Page 14 of 15 FirstFirst ... 49101112131415 LastLast
Results 261 to 280 of 289
  1. #261  
    same issue as above but on a pixi+
  2. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #262  
    Just submitted today:
    - special version for O2 Pre users. I can't test it; you'll have to.

    Submitted yesterday:
    - update to main USCL patch that should fix problems for Verizon Pixi+ users.

    Can't wait for dbsooner to post them to webos-patches?
    Use this link to view/download the .patch files.
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  3. #263  
    dsevil I looked at the help file and read the thread but I don't see how to add something to the .json file. Is there a step by step somewhere?
  4. #264  
    Quote Originally Posted by mamouton View Post
    dsevil I looked at the help file and read the thread but I don't see how to add something to the .json file. Is there a step by step somewhere?
    check out this thread..has lots of good examples

    EDIT: oops..here is the link: http://forums.precentral.net/webos-p...ine-patch.html

    also, per post #109 from dsevil
    As for user-defined commands, I've decided to just have it be a file called uscl.json on the USB drive's root directory for now.
    - Syntax is JSON; remember: no comments, trailing commas, functions, or unquoted object property strings.
    - Because of that, it's limited to web site searches for now.
    - Example file is available.
    - After copying/modifying/deleting uscl.json and unmounting the device, use the .update command. If the file doesn't exist or contains a syntax error, you'll get a warning.
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  5. #265  
    Thanks I tried to use the .gr command to make a grocery list and it never would go through what am I doing wrong?
  6. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #266  
    There are actually two mechanisms, and there exists official documentation for both.

    Newer API, for web searches and custom JavaScript code:
    User-Defined Commands — Universal Search Command Line

    Older uscl.json API, for web searches only:
    User-Defined Web Site Searches and Command Aliases — Universal Search Command Line
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  7. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #267  
    Check /var/log/messages on the device and see if you have any syntax errors.
    Remember, strict JSON on uscl.json or sources.json.
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  8. #268  
    Quote Originally Posted by govotsos View Post
    Is this 1.4.5 compatible? It wasn't on the list of patches to remove so I left it installed when I updated to 1.4.5 last night. Now it doesn't work. In Preware, it says there's an update. It fails the install and won't remove it. I can post the IPKG log if that will help. I have a US Verizon Wireless Palm Pre Plus with OS 1.4.5.

    Thanks
    Any ideas how to address this issue that peperdanky & I are having?
  9. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #269  
    The fixes for Verizon and O2 are not yet available in the webos-patches feed.

    The O2 fix will be available as a separate patch you install instead of the regular "Command Line" patch. I don't remember what I specified for the title but it will be something like "Command Line for O2".

    The Verizon fix will be part of the regular patch. The current version number of the regular patch on webos-patches is 1.4.5-62; you'll see a higher version number when it does become available.

    The patch files are available for download if you want to install via webOS Quick Install. Scroll up and look for post #262 in this thread for that.
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  10. #270  
    It's been added to the feed, but i'm still having issues installing. E-Mailed you and included the ipkg log.
    Verizon Pixi Plus on 1.4.5 w/ Preware
  11. #271  
    anyone still having issues with verizon? I am.
    Verizon Pixi Plus on 1.4.5 w/ Preware
  12. #272  
    Quote Originally Posted by SuzukiGS750EZ View Post
    anyone still having issues with verizon? I am.
    I still am. It still refuses to install or remove. I've gotten so used to this patch that I'm actually considering doctoring just to get it back.

    Would it help if I sent the logs from removal & install attempts?
  13. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #273  
    Sorry, haven't had the time to look at this until now. Looks like the patch that got posted on webos-patches still has the problem even though I submitted a fix. I resubmitted, making sure this time to let them know what's going on. Glad you're still interested in my patch.... I'm trying with what little time I have, I swear.
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  14. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #274  
    Also it looks like the O2 Pre version of the patch is out now. How's it working out for those of you who've tried to install it? Please, oh pretty please, say it's working.
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  15. #275  
    I just found out about the O2-specific version.
    It installed and Luna-restarted, but it still doesn't quite work. There is no additional entry in Universal Search, just google, wikpedia, google maps and twitter (so it doesn't look like your screenshot on page 1). However, it doesn't break keyboard input anymore.

    I'm on a german Pre, 1.4.5 and some patches. If you need more information, let me know. I won't uninstall this time (as I can still use my Pre ;-) )
    Best webOS-mod ever: have a look
  16. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #276  
    Does the "cmd:" item still show up when you type something beginning with a dot?
    If so, then ".show" *should* cause the items to show up.
    If not, then are there any hackers with an O2 Pre that want to look into this?
    I maintain the Universal Search Command Line, Hide App Vendors, and Poor Man's Twitter Client patches; the palm-rsync utility; and the rot13 web-distributed app.

    I also have a twitter feed and a web site.
  17. #277  
    this patch was working for me on a sprint pixi when it was a version prior to 1.4.5-62 (I don't remember the specifics though)

    The upgrade to 1.4.5-62 broke it for me but it did let me uninstall the old version successfully.

    I still can't get 1.4.5-67 installed. I get the following in the ipkg.log file

    Code:
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    52 31918 52 16861 0 0 15173 0 0:00:02 0:00:01 0:00:01 31051
    100 31918 100 31918 0 0 25375 0 0:00:01 0:00:01 --:--:-- 46257
    identify
    org.webosinternals.patches.universal-search-command-line
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":8, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":8 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":8 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":8 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":8 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":8 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.universal-search-command-line.postinst 2>&1
    1 out of 2 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-applauncher/sources.json.rej
    remove
    Removing package org.webosinternals.patches.universal-search-command-line from root...
    (offline root mode: not running org.webosinternals.patches.universal-search-command-line.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    I do have the "Add IMDB to universal search" patch also installed but USCL failed on a freshly doctored pixi with just 'preware' and 'free music ringtones' installed.

    Any ideas what the issue is or how to troubleshoot further?

    Also, is the version before 1.4.5-62 available to download anywhere?
  18. #278  
    Quote Originally Posted by dsevil View Post
    Does the "cmd:" item still show up when you type something beginning with a dot?
    If so, then ".show" *should* cause the items to show up.
    If not, then are there any hackers with an O2 Pre that want to look into this?
    No, it does not. I'll have it tested on some other devices within the week just to be certain.
    Best webOS-mod ever: have a look
  19. #279  
    thanks - just to say i was miffed when the orgional patch didn't work on UK O2 - but your new patch fixes that - congrats on being picked up bywebos 2.0
  20. bluedonut's Avatar
    Posts
    43 Posts
    Global Posts
    54 Global Posts
    #280  
    I see version 1.4.5-72 showed up in my Preware, but when I try to install it, it fails. Here is the log message.

    failed
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.universal-search-command-line.prerm 2>&1
    ERROR: /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.universal-search-command-line is not a directory or does not exist!

Tags for this Thread

Posting Permissions