Page 3 of 46 FirstFirst 1234567813 ... LastLast
Results 41 to 60 of 913
Like Tree8Likes
  1.    #41  
    Quote Originally Posted by Jason Robitaille View Post
    I've been getting "ERROR: This is not Palm webOS 1.1.0" on the emulator. Anything you can do about that? The emulator is my primary way of testing (I have no device myself).
    The emulator isn't really an emulator. It doesn't actually run the same binaries as the Pre (it runs on an x86 CPU whereas the Pre runs on an ARM CPU) so binary patches that work on the Pre won't work on the emulator.
  2. spepi's Avatar
    Posts
    17 Posts
    Global Posts
    124 Global Posts
    #42  
    Quote Originally Posted by spepi View Post
    i'll be trying this monday....thats one of my pet peeves...whe browser is horrible
    I dont have Novaterm in the Palm\sdk\bin I only have novacom.....any way to get the novaterm
  3.    #43  
    Quote Originally Posted by spepi View Post
    I dont have Novaterm in the Palm\sdk\bin I only have novacom.....any way to get the novaterm
    Check out the link in the first post for instructions how to get to a command line.
  4. #44  
    Quote Originally Posted by Jason Robitaille View Post
    I'll be adding this to 2.04 of WeboS Quick Install's Tweaks

    @clipcarl, what files does your script install?
    Quote Originally Posted by Jason Robitaille View Post
    I've been getting "ERROR: This is not Palm webOS 1.1.0" on the emulator. Anything you can do about that? The emulator is my primary way of testing (I have no device myself).
    Carl and Jason,

    What is the progress for fixing this error and getting this into webOS Quick Installer 2.04?

    - Craig
  5. #45  
    Quote Originally Posted by jbg7474 View Post
    So, just wondering out loud, could there not be another way to do this? You know how the browser will display these pages correctly if you go to a working mobile site (such as m.precentral.net) and rotate to landscape and back before visiting the site? Can this a patch automatically set the browser to that state on opening instead of identifying itself as an iPhone? I don't want to mess up all the ad trackers out there by having them think there's yet another iPhone out there.
    OK, so this changes the information the Pre sends to the website.

    Can we find out what that new info is and set the patch to keep forcing that information all of the time?

    - Craig
  6. #46  
    Quote Originally Posted by Milominderbinder View Post
    Carl and Jason,

    What is the progress for fixing this error and getting this into webOS Quick Installer 2.04?

    - Craig
    Well, I've got it implemented in what will be the 2.03 release. No way to test, but in theory it should work properly, lol. We'll see the outcome when I release it (hopefully) later tonight
  7. ericUT's Avatar
    Posts
    71 Posts
    Global Posts
    228 Global Posts
    #47  
    THANK YOU THANK YOU THANK YOU! I've been hypothesizing this for a long time. Both phones have the same resolution, same browser, same streaming functionality, THEY SHOULD LOAD THE SAME SITES!!!

    Mega props to you sir
  8. #48  
    I was excited to find this thread, but then disappointed when I found it doesn't work like I'd hoped. Specifically it does not work at www dot zinio dot com/iphone, which provides special, free access to many full magazines to iPhone users.

    I was hoping this hack would generate a complete iPhone user agent string. This is the one I use without problem in Firefox with the UserAgent plugin is:
    Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419 (United States)

    However, this plugin produces:
    Mozilla/5.0 (webOS/1.1; U; en-US) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/1.0 Safari/525.27.1 iPhone

    So, even though it has iPhone in the string, it's not enough to make zinio dot com display it's iphone only content. Is it possible, or would you be willing to provide a hack that delivers a true iPhone user-agent string?

    Thanks for your efforts so far regardless. I found this thread while thinking I was going to have to try finding out how to do this hack myself. Seeing that it required a binary patch, this would have definitely been more than I could have done myself.

    Thanks,
    Tim

    P.S. Sorry for the link-less message. I'm apparently too new to put links in my posts.
  9. sandrshe's Avatar
    Posts
    46 Posts
    Global Posts
    57 Global Posts
    #49  
    Quote Originally Posted by jrstinkfish View Post
    Works fine, but I've run a weird glitch, maybe someone else who has installed it can try it out and see if it's just me. Walmart.com won't load after I installed the patch -- the Pre gives me an error "Cannot find an application that can load this file." Not a dealbreaker, and it may be unrelated since I haven't tried it in a while before this. But it did load fine last time I tried before this.

    Walmart is doing the same for me. uninstalled the patch and it is working again. Also eBay - New & used electronics, cars, apparel, collectibles, sporting goods & more at low prices, m.ebay.com, and iphone.ebay.com did not work properly with the patch.

    This is a no go for me. I'll wait for palm. this only works with a few sites, not most.
  10. bdubbx's Avatar
    Posts
    133 Posts
    Global Posts
    136 Global Posts
    #50  
    Ok...i felt like a retard for a while trying to do this patch...but I figured out why I was getting the "not found error". You said to put the file in the "root" directory, and I use WinSCP...so I put the file in the very first file. After I realized you were talking about putting the file in the root directory while in USB mode, I put the change-user-agent file in the "media/interal" folder. After running the code it installed.

    Unfortuntely, the only site I was hoping this would work for is m.snapmylife.com...which it doesn't...thanks anyways!
  11. #51  
    Quote Originally Posted by sandrshe View Post
    Walmart is doing the same for me. uninstalled the patch and it is working again. Also eBay - New & used electronics, cars, apparel, collectibles, sporting goods & more at low prices, m.ebay.com, and iphone.ebay.com did not work properly with the patch.

    This is a no go for me. I'll wait for palm. this only works with a few sites, not most.
    Yeah, I started to post that eBay was messing up -- the site would appear pinched into a corner after initially displaying fine. As I was typing the post, I went back and re-checked, and the eBay was back to normal, so I erased that part of my post thinking it was unrelated. I don't use Walmart.com or eBay much on my phone, so I'm willing to do without if the problem is eventually fixed.
  12. #52  
    FYI, WebOS Quick Install 2.03 has just been released, with this patch added to the Tweaks section
    http://forums.precentral.net/showthread.php?p=1860851
  13.    #53  
    @jrstinkfish, @sandrshe, @bdubbx and @wtgreen:

    The attached version creates a more complete iPhone user agent string and Walmart, eBay, SnapMyLife, and zinio.com (?) all seem to work fine...

    ...but this version breaks Google Maps (Sprint Navigation works fine though). Unfortunately, you have to pick your poison. If you want more universal compatibility with web sites you have to give up Google Maps.
    Attached Files Attached Files
  14. gage006's Avatar
    Posts
    543 Posts
    Global Posts
    576 Global Posts
    #54  
    Quote Originally Posted by clipcarl View Post
    @jrstinkfish, @sandrshe, @bdubbx and @wtgreen:

    The attached version creates a more complete iPhone user agent string and Walmart, eBay, SnapMyLife, and zinio.com (?) all seem to work fine...

    ...but this version breaks Google Maps (Sprint Navigation works fine though). Unfortunately, you have to pick your poison. If you want more universal compatibility with web sites you have to give up Google Maps.
    Thanks! Decided I'd rather have the sites work better than Google Maps. Sprint Nav provides the same info, at least for my needs.
  15. #55  
    Quote Originally Posted by clipcarl View Post
    @jrstinkfish, @sandrshe, @bdubbx and @wtgreen:

    The attached version creates a more complete iPhone user agent string and Walmart, eBay, SnapMyLife, and zinio.com (?) all seem to work fine...

    ...but this version breaks Google Maps (Sprint Navigation works fine though). Unfortunately, you have to pick your poison. If you want more universal compatibility with web sites you have to give up Google Maps.
    Thanks for the quick response but *ouch*... that's a tough choice. That darn google maps is just so useful.

    Thank you for your efforts. I know binary patches are more limited and difficult than just changing some javascript, and it's great that you've been willing to share your efforts.
  16. #56  
    And just for the record, that's a really clever install script. I haven't worked in the unix world or programmed shells scripts in more than a decade so maybe I'm just behind the times, but that's a clever way of distributing and installing a binary file.
  17. #57  
    I love hacking a system as much as anyone else and I hate apple, but can we not just go to the iphone URL for many websites. It's not as much fun but for some less technical users may work. Sorry to play devil's advocate.
  18. scobb's Avatar
    Posts
    56 Posts
    Global Posts
    95 Global Posts
    #58  
    Can someone post the user agent strings for both the original Pre and the one for the iPhone?

    I'd like to suggest an e-mail campaign to the webmasters of sites where this "hack" works. I mean "hack" in the best possible way - it works well and is rather clever.

    I'm thinking that we should have a simple e-mail (to copy and paste) with all of the correct terms and information so that webmasters can make the changes to go down the same display path when they see a Pre that they do when they see an iPhone.

    The benefit is two-fold. One - it keeps the adsense numbers accurate, and two it will make all Pre users web experience better.

    Cheers,
    Steve
  19. #59  
    Quote Originally Posted by mvpilot172 View Post
    I love hacking a system as much as anyone else and I hate apple, but can we not just go to the iphone URL for many websites. It's not as much fun but for some less technical users may work. Sorry to play devil's advocate.
    Yes, for many you can. But many others do something special only when they detect the iPhone browser and that's what this patch addresses. With it, the website won't know your Pre is not an iphone.
  20. sumitk's Avatar
    Posts
    48 Posts
    Global Posts
    55 Global Posts
    #60  
    Ultimately this has to be a button or so on the browser app, switching the user agent in and out.
Page 3 of 46 FirstFirst 1234567813 ... LastLast

Posting Permissions