Page 23 of 46 FirstFirst ... 13181920212223242526272833 ... LastLast
Results 441 to 460 of 913
Like Tree8Likes
  1.    #441  
    Quote Originally Posted by larryflynt2k View Post
    the negative side effect of switching the user agent is that web developers will be encouraged to code only for IPHONES

    ...
    No, not really. Web sites use two different methods to determine the user's browser. When you actually hit the web site and it sends you a page it is doing a simple and fast string search on the fly to determine your browser. In this case, usually the web site is simply looking for the substring "iPhone" in the user agent string. However, when web sites analyze their traffic to determine what browsers users are using they use much more sophisticated log analyzers that would see this unique user agent string and easily know that it's not an iPhone. After all, this user agent string still prominently contains the substrings "Pre" and "webOS."

    Also, this is the way it's always been done throughout the history of web browsers and the World Wide Web. Heck, even today Firefox, Safari, Internet Explorer, webOS, iPhone and nearly every other web browser you could care to name still have the substring "Mozilla" in their user agent strings to show web sites they are compatible with the ancient Netscape web browser. If you don't think the way this is done is correct then what you really need to do is invent a time machine and change the last 15 years of history!

    Hopefully this response will put this issue to rest once and for all.
  2. #442  
    Quote Originally Posted by dingwall1 View Post
    Just a heads up, although I have completely no idea whether its related or not, after I did the user agent spoof tweak, my phone instantly got stuck on the boot screen, and I read that maybe one or two others did as well. I tried the suggested remedy with no luck, but did stumble across this:

    http://discussion.treocentral.com/pa...ml#post1956427

    and it worked great. again, I have no idea if its related, as I mean NO disrespect to Jason.
    I experienced the same exact problem. Stuck on palm logo screen, Pre had been working great for the past 3 months, no issues whatsoever until I installed the Iphone spoof patch from WOSQI......I can only say that it is 100% related to applying this patch.....Now its on to try the Recovery tool, and if that fails, WebOS Doctor it is......
  3. #443  
    just a note:
    /sbin/shutdown -r now

    will work more reliably than 'reboot'
  4. twiktor's Avatar
    Posts
    151 Posts
    Global Posts
    169 Global Posts
    #444  
    Yeah this monster just took a bite outta my **** as well. Luckily the phone wasn't bricked as I thought as the links above were bang on perfect (in a very annoying weird step kinda way).

    All i can say is that it was when trying to add the iphone user tweak that i saw an error pop up thus resulting in a frozen phone.
  5. #445  
    yeah this is the easiest not-on-preware patch i ever installed. and this is coming from a guy who didn't know what a command line was 2 months ago. hella easy, yo.
  6.    #446  
    Quote Originally Posted by xaiki View Post
    just a note:
    /sbin/shutdown -r now

    will work more reliably than 'reboot'
    In what case does /sbin/reboot not work?
  7. #447  
    This hosed my phone up as well. Trying very hard not to have to visit the Doctor, but WebOS Repair Utility keeps giving me "Error 5".
  8. twiktor's Avatar
    Posts
    151 Posts
    Global Posts
    169 Global Posts
    #448  
    The Doctor only hurts for an hour or two while you reinstall all your patches etc. I had been under the impression that I'd lose my usb files from the Dr but I in fact did not when using the above forced usb dr fix volume press while doing jumping jacks on a marble covered floor with the lights out fix thing :P

    Now I am suffering the incredible urge to try and reinstall the iphone tweak again even though I know the outcome last time. MUST RESIST THE URGE!
  9. #449  
    Caused a boot hangup for me as well. I can still connect using WOSQI, but I never get into Luna. Tried manually stopping and starting it from the command line in WOSQI, but to no avail. About to try the repair utility after I get the newest doctor downloaded.
  10. #450  
    Caused a boot hangup for me as it has for others (stuck on palm screen). I can still connect using WOSQI, but I never get into Luna. Tried manually stopping and starting it from the command line in WOSQI, but to no avail. Repair utility gives me error 5 when I agree to replace a file.
  11. #451  
    Quote Originally Posted by DefinedByClass13 View Post
    Weird, this is still not working for me. I've tried with Terminal and WOSQI. All I get is "folder not found."
    i had same exact problem so what i did was - when in USB mode, i put the change-user-agent file into any SUBfolder (i used DCIM... random choice). then disconnected and used INTERNALZ to move the file from /media/internal/DCIM to /media/internal/ and ran the command in the phone's terminal app. worked beautifully!

    i hope this will help :-)
  12. #452  
    Any chance this lands on Preware?
  13. #453  
    i noticed that when the 'spoof' is applied i am unable to download anything: apps from catalog, utube videos, streaming/downloading audio from sites...

    when uninstall the spoof everything works nicely again. i've done the install/uninstall a couple of times so im 100% confident its caused by the change-user-agent patch.

    any1 else having this issue?

    thanx
  14. #454  
    Not sure if this was mentioned, but the iPhone spoof is not 100%. For example, going to Zinio Labs | iPhone should allow you to view all the magazines on the site free, if you are using an iPhone. Spoofing the user agent on Safari works with this site, but the spoof for WebOS does not work. Is there any reason why this might be?
  15.    #455  
    Quote Originally Posted by jedwardmiller View Post
    Not sure if this was mentioned, but the iPhone spoof is not 100%. For example, going to Zinio Labs | iPhone should allow you to view all the magazines on the site free, if you are using an iPhone. Spoofing the user agent on Safari works with this site, but the spoof for WebOS does not work. Is there any reason why this might be?
    If I make the Pre's user agent closer to that of the iPhone in order to make sites like this one work it breaks Google Maps on the Pre. This version works on almost every site but keeps Google Maps working.
  16. #456  
    Quote Originally Posted by clipcarl View Post
    If I make the Pre's user agent closer to that of the iPhone in order to make sites like this one work it breaks Google Maps on the Pre. This version works on almost every site but keeps Google Maps working.
    Is there a reason why this does that? Is it an issue with the Pre itself or limitations with the coding?
  17. #457  
    clipcarl, I notice when I go to m.radioreference.com with the patch applied I get an error trying to stream the police scanner file is this happening because of the same reason you reference above? When I unapply the patch it streams but it just takes a long time to stream, with the patch applied I get the unable to stream immediately message. Great patch if there is nothing that can be done that is fine, I use the patch way more than listen to police scanners just thought you might want to know.
  18. glenada's Avatar
    Posts
    777 Posts
    Global Posts
    829 Global Posts
    #458  
    Is this installed in Preware for download?
    Current Phone(s): HTC Inspire "4G" & Pre 2
  19. #459  
    Well it worked good for me but removing it not so easy I seem not able to remove it
  20. #460  
    I'm still using this...not one problem.

Posting Permissions