Page 19 of 46 FirstFirst ... 9141516171819202122232429 ... LastLast
Results 361 to 380 of 913
Like Tree8Likes
  1.    #361  
    Quote Originally Posted by Ramer84015 View Post
    It was available via WebOS Quick Install previously. Wonder why Preware doesn't want to include such a useful patch.
    Because this patch modifies a binary library file and not an HTML or Javascript file. Also, until just about 1 minute ago the patch required a binary patch file and a binary executable to apply the patch which made it hard to audit. This has now been changed so that it is a single simple shell script and binary files are not required. This makes it much more transparent and easy to understand what the patch is doing which hopefully will be enough to get it into Preware.
  2. #362  
    Quote Originally Posted by clipcarl View Post
    Yes, follow the instructions in the first post. The last time I checked, the Preware author (Rod Whitby) didn't want to add this type of patch to Preware, but maybe he'll change his mind if you bug him enough!
    We *do* want to add this patch to Preware, but want to do it in a way which does not open the floodgates to more complex binary patches that cannot be reviewed for security aspects (there is absolutely no problem with this patch, it's the general principle we're concerned about).

    And at the moment we're a bit busy with this 1.3.1 update, so working out a safe, general, binary patching architecture for Preware has had to take a back seat for a while.

    Keep bugging us until we work out how to do it.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3. #363  
    Quote Originally Posted by clipcarl View Post
    Because this patch modifies a binary library file and not an HTML or Javascript file. Also, until just about 1 minute ago the patch required a binary patch file and a binary executable to apply the patch which made it hard to audit. This has now been changed so that it is a single simple shell script and binary files are not required. This makes it much more transparent and easy to understand what the patch is doing which hopefully will be enough to get it into Preware.
    Thanks, that will make it easier.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. #364  
    Do we need to uninstall the one from this morning and install the latest one?
  5.    #365  
    Quote Originally Posted by mamouton View Post
    Do we need to uninstall the one from this morning and install the latest one?
    No. The end result is the same.
  6. #366  
    Ok thanks, really missed this patch for the few hours it wasn't available. Google wave only works with this spoof.
  7. #367  
    Quote Originally Posted by heberman View Post
    I changed the user agent following these instructions, but it doesn't seem to make any difference.
    After a bit more testing - let me clarify:

    Thanks for posting clear instructions. The user agent change worked fine. The problem I have is that the spoof works on some sites, but not on a specific site I need the spoof for work purposes. I don't know why. I've asked the work-related site to update their site to treat the Pre the same as the iphone and the programmer said he would. Hopefully that will fix my problem.
    Palm V-->Visor Deluxe-->Visor Prism-->Visorphone-->Treo 180-->Treo 600-->Treo 650 on Sprint-->Treo 700p-->Centro-->Diamond-->Pre-->HTC EVO 4g???!
  8. #368  
    How do you install via the emulator, since it is not available in quickinstall yet?
  9. Stihl's Avatar
    Posts
    741 Posts
    Global Posts
    747 Global Posts
    #369  
    Really wish this spoof worked on newyorker.com. It does, technically, but the site is so far engorged between Steve Job's buttox that it is unusable. The navigation TOO articles and blogs is fantastic, but once you actually get there, you find yourself unable to actually read anything due to both the tiny font and the entire article width matching the width of the screen. Sure, you can zoom in, but then you would be reading 7 words, scrolling to the right, reading another 7, scrolling to the right, reading to the end of the paragraph, scrolling to the beginning...

    I tried to check out some podcasts figuring I could download them easily with the multimod patch, but all links are itunes only.

    Several other sites work well enough, but the bugs and, more influentially, constant reminder that I have to kowtow to the mighty behemoth that is Apple is going to make me have to pass on this patch, if on principle alone.

    It is a monumental effort though. I just look forward to the day when websites make all their websites Touch instead of Mobile or iPhone.
  10.    #370  
    Quote Originally Posted by mamouton View Post
    How do you install via the emulator, since it is not available in quickinstall yet?
    If you are asking for a version that works in the emulator, there isn't one.
  11. #371  
    oh ok just wondering. I thought at one time it was available with quickinstall. That is how I used to try them out so as to not bork my pre.
  12. #372  
    Quote Originally Posted by mamouton View Post
    oh ok just wondering. I thought at one time it was available with quickinstall. That is how I used to try them out so as to not bork my pre.
    Well you can use the linux command line tool in quick install to run the patch. You just need to get the patch on the phone first. There are instructions in the last page or two of this thread.
  13. #373  
    My sites are displaying like they did when I had the iphone patch after the update and I have not installed it, anyone else?
    Check out my Light Blue theme and if you like please hit the thanks button or even better, donate.
  14.    #374  
    The latest version (change-user-agent_universal-2.1.zip) should now work on any webOS device running any recent version of webOS on any mobile network. Yes, this means the patch should (hopefully) work for GSM Pre users as well as Pixi owners! Please test this and let me know if it works for everyone as I do not have a GSM Pre or a Pixi. Heck, it should even work on the emulator now.

    This version should work on future versions of webOS too as long as Palm does not change the user agent.

    The way uninstallation works has been changed. Now the patch reverses the patching process in order to uninstall. This way the patch can be uninstalled even if the backup file has been lost and the patch plays nice with anything else that might in the future patch the same library. To get the previous behavior of simply restoring the backup file please use the new "restore-backup" option.

    People that have already installed a previous working version of the patch do not need to upgrade (the end result is still the same). However, if you'd like to try the new patch anyway to see if you can help find any bugs then that would be appreciated. (As usual, though, I think it's pretty solid and bug free but who knows...)
  15. #375  
    Nice update Carl. Thanks for all your hard work on this.

    FYI, you really don't need to give me any credit on the install... you did all the work.

    Thanks again!
  16. #376  
    I don't understand that part you said the uninstall system change, what that mean?
    pd: I love this patch , thanks again!


    Quote Originally Posted by clipcarl View Post
    The latest version (change-user-agent_universal-2.1.zip) should now work on any webOS device running any recent version of webOS on any mobile network. Yes, this means the patch should (hopefully) work for GSM Pre users as well as Pixi owners! Please test this and let me know if it works for everyone as I do not have a GSM Pre or a Pixi. Heck, it should even work on the emulator now.

    This version should work on future versions of webOS too as long as Palm does not change the user agent.

    The way uninstallation works has been changed. Now the patch reverses the patching process in order to uninstall. This way the patch can be uninstalled even if the backup file has been lost and the patch plays nice with anything else that might in the future patch the same library. To get the previous behavior of simply restoring the backup file please use the new "restore-backup" option.

    People that have already installed a previous working version of the patch do not need to upgrade (the end result is still the same). However, if you'd like to try the new patch anyway to see if you can help find any bugs then that would be appreciated. (As usual, though, I think it's pretty solid and bug free but who knows...)
  17. hofs1's Avatar
    Posts
    460 Posts
    Global Posts
    473 Global Posts
    #377  
    Hey Carl I saw u put my name in the install confirmation thankyou line too.

    Its also not necessary all i did was play with some user agent strings. YOU created the whole concept of modding the user agent.

    Thanks for such a great patch!!!!!!!!!!!!! And for the future proof version too.
    T300 - T600 - T650 - T700p - T755p - T800w - Pre
  18. #378  
    Hmm i'm having trouble with this. I unzipped the folder, dragged the "change-user-agent" file to my Pre while on USB Drive mode. Proceeded to WOSQI's Linux Commandline, typed "/media/internal/change-user-agent" and I get a "not found" error. The steps for this process are a lot simpler compared to other things i've done to my phone, so i'm perplexed as to why I can't get this to work.
  19.    #379  
    Quote Originally Posted by DefinedByClass13 View Post
    Hmm i'm having trouble with this. I unzipped the folder, dragged the "change-user-agent" file to my Pre while on USB Drive mode. Proceeded to WOSQI's Linux Commandline, typed "/media/internal/change-user-agent" and I get a "not found" error. The steps for this process are a lot simpler compared to other things i've done to my phone, so i'm perplexed as to why I can't get this to work.
    That should work. When you dragged the file to your Pre are you sure you dragged it to the root of the USB Drive (which ends up being /media/internal) and didn't accidentally drag into one of the folders there?

    Do you have access to any other command line besides WOSQI such as Novacom / Navaterm or the Terminal app?
  20.    #380  
    @hofs1: You came up with a key idea to make things work even better so I give you credit to show that I appreciate it.

    @wtgreen: You helped people solve their problems with the patch and created a new version when I wasn't around so I give you credit to show that I appreciate it.

    (BTW, if either of you would actually prefer not to have your name mentioned let me know and I'll remove it.)

Posting Permissions