Page 14 of 46 FirstFirst ... 491011121314151617181924 ... LastLast
Results 261 to 280 of 913
Like Tree8Likes
  1. #261  
    Quote Originally Posted by clipcarl View Post
    Here's the part where I'm guessing but it's the only thing I can think of to cause your problem. I suspect that WOSQI makes its own backup of the library when it installs the patch. Then when you uninstall the patch it blindly restores the backup without checking to see if the WebOS version matches the backup which is very, very bad. This would break lots of stuff on the Pre.
    You are correct I made my own backup. I've stated countless times to disable tweaks before updating the OS, so didn't consider this issue at the time. Thankfully my Repair Utility can fix the issue in a jiffy, no harm no foul. An updated v2.82, reliant on the script for backup, will be out momentarily.
    Last edited by Jason Robitaille; 10/14/2009 at 12:08 PM.
  2.    #262  
    Quote Originally Posted by Jason Robitaille View Post
    You are correct I made my own backup. I've stated countless times to disable tweaks before updating the OS, so didn't consider this issue at the time. Thankfully my Repair Utility can fix the issue in a jiffy, no harm no foul. An updated v2.82, reliant on the script for backup, will be out momentarily.
    Yes, the first rule when writing software is to understand that users never read or follow instructions and code should never depend on them doing so in order to not mess up the system. Code should be audited and tested to be as "*****-proof" and as "malicious-user-proof" as possible.
  3. #263  
    Quote Originally Posted by clipcarl View Post
    Yes, the first rule when writing software is to understand that users never read or follow instructions and code should never depend on them doing so in order to not mess up the system. Code should be audited and tested to be as "*****-proof" and as "malicious-user-proof" as possible.
    I realize that, which is one reason why I made Repair Utility, to do any cleanup needed. Plus, iPhone spoof was one of only 3 tweaks that still used my old backup method (the other 2 being improved autocorrect dictionary and the adblocker).

    Anyway, WOSQI v2.82 is released.
    http://forums.precentral.net/canuck-...ml#post1975855
  4. #264  
    Quote Originally Posted by rwhitby View Post
    Agreed.

    We're looking at the wider picture - it's crystal clear that this particular patch is perfectly safe, but if we add a generic way to do binary patches to Preware, then it could be a problem.

    -- Rod
    I think I understand. This patch is obviously not an issue, but how can you know that all future binary patches will not be malicious?

    Maybe treat this one as just another regular patch until you can develop a binary patch procedure?

    And, Carl, it is good to have you back!

    - Craig
    Last edited by Milominderbinder; 10/14/2009 at 03:56 PM.
  5. loftwyr's Avatar
    Posts
    38 Posts
    Global Posts
    43 Global Posts
    #265  
    I've got a Bell (Canadian) Pre (1.2.1) and the patch abends with "This is not a Nova-Sprint-Castle device"

    Can a patch version be made that works on Bell devices?
    PalmPilot Pro --> Palm III --> Palm V --> Palm 505 --> Treo 700p --> Palm Pre
  6.    #266  
    Quote Originally Posted by loftwyr View Post
    I've got a Bell (Canadian) Pre (1.2.1) and the patch abends with "This is not a Nova-Sprint-Castle device"

    Can a patch version be made that works on Bell devices?
    Yes. Can you post the output of the following commands:
    md5sum /usr/lib/libWebKitLuna.so

    cat /etc/palm-build-info
  7. #267  
    Quote Originally Posted by clipcarl View Post
    Yes. Can you post the output of the following commands:
    md5sum /usr/lib/libWebKitLuna.so

    cat /etc/palm-build-info
    Based off the 1.2.1 Bell WebOSDoctor:

    md5sum: 2c5a6563dfefbe1bbd7a5d9a19d5e141

    build info:
    Code:
    PRODUCT_VERSION_STRING=Palm webOS 1.2.1
    BUILDNAME=Nova-BellMo-Castle
    BUILDNUMBER=112
    BUILDTIME=20090929173044
    BUILDMARK=206508
  8.    #268  
    The patch should now work on Bell Canada devices. Redownload the 1.2.1 version and give it a try.
  9. #269  
    Jason,

    I'm seeing some weird behavior with this patch related to WOSQI versions 2.8, 2.81 and 2.82. As I posted yesterday in the WOSQI thread, I had some problems that caused me to run webos doctor, so I started from a clean slate yesterday.

    I installed the patch via WOSQI 2.8 yesterday on my clean install of webos 1.2.1. Tonight, I went to remove it and update to the WOSQI 2.82 version of the patch. I opened WOSQI 2.81 (probably should have used 2.8, but messed that up) and unchecked the patch. Restarted luna, and verified via the browser that the patch was uninstalled. Then I opened WOSQI 2.82, and it showed the patch already installed (via the check block next to it in tweaks). I closed 2.82 and tried to reinstall and then uninstall again via WOSQI 2.8, and this is how my Pre sits as of now (I have restarted it multiple times to verify changes):

    The patch is unchecked (does not show installed) in WOSQI 2.8 and 2.81.
    The patch is checked in WOSQI 2.82.
    The patch is working on my browser (I see iPhone web content when browsing).
    I only viewed but never checked or unchecked the patch in WOSQI 2.82.

    I may of made things worse with everything I tried, but I don't think I should have seen the patch as installed in WOSQI 2.82 after removing it in 2.81. Does this sound like something that needs troubleshooting/addressing, or just a case of operator error?
  10. loftwyr's Avatar
    Posts
    38 Posts
    Global Posts
    43 Global Posts
    #270  
    Worked perfectly on my Bell pre! Thank you!
    PalmPilot Pro --> Palm III --> Palm V --> Palm 505 --> Treo 700p --> Palm Pre
  11. #271  
    Well, as of this morning the patch is no longer working. Guess I'll chalk this up to operator error and start over lol.
  12.    #272  
    Quote Originally Posted by stflush View Post
    Well, as of this morning the patch is no longer working. Guess I'll chalk this up to operator error and start over lol.
    Please try to install manually without WOSQI and post your results. Thanks!
  13. #273  
    hey guys , one simple question this tweak is working again with webos q.i 2.82 ? i was trying to install yesterday tru webos q.i and nothing happen and the i uninstall it because doesnt work for me .
    Or i have to root to work fine as the first page say !
    thanks and great job!
  14. #274  
    Quote Originally Posted by clipcarl View Post
    Please try to install manually without WOSQI and post your results. Thanks!
    The patch still shows as checked (installed) in WOSQI 2.82. Should I do anything else first or just install it?
  15.    #275  
    Quote Originally Posted by SISGO View Post
    hey guys , one simple question this tweak is working again with webos q.i 2.82 ? i was trying to install yesterday tru webos q.i and nothing happen and the i uninstall it because doesnt work for me .
    Or i have to root to work fine as the first page say !
    thanks and great job!
    I don't know. You should ask on the WebOS QuickInstall thread.
  16.    #276  
    Quote Originally Posted by stflush View Post
    The patch still shows as checked (installed) in WOSQI 2.82. Should I do anything else first or just install it?
    Just try installing it manually without WOSQI. Any error messages it prints will tell us if there's a problem.
  17. #277  
    I've got 1.1.3, can you update it?
    Have u got screens?
  18. #278  
    just installed with WOSQI 2.82. works flawlessly. Thanks for the hard work.
  19.    #279  
    Quote Originally Posted by rondera View Post
    I've got 1.1.3, can you update it?
    Have u got screens?
    What's 1.1.3?
  20.    #280  
    Quote Originally Posted by rondera View Post
    I've got 1.1.3, can you update it?
    Have u got screens?
    What's 1.1.3?

Posting Permissions