Page 104 of 152 FirstFirst ... 4549499100101102103104105106107108109114 ... LastLast
Results 2,061 to 2,080 of 3039
  1. mk3
    mk3 is offline
    mk3's Avatar
    Posts
    575 Posts
    Global Posts
    622 Global Posts
    #2061  
    Quote Originally Posted by previti View Post
    I've got virtual box & palm SDK loaded & working. I'm just not sure what to type in to the command prompt once I'm rooted.

    the prompt says:
    root@castle:/# <-[J
    after rooting

    ...

    I spent hours trying to read about this online, but I'm not getting a clear answer. If one of you could please lend me some of your expertise; I'd truly appreciate it. Specifically, what do I type into novaterm in order to delete these files & have VK uninstalled.

    Thanks so much guys.
    Here ---> http://forums.precentral.net/webos-i...ml#post1990148

    This worked for me.
  2. #2062  
    no new updates?
  3. #2063  
    Some files from a failed keyboard installation still exsist on my Pre causing install to fail. You mention a script to clear the files. Can you tell me where I can find this and how to execute?? Thanks Jeff
  4. #2064  
    hey emoney...im getting an ipkg error when installing the keyboard....this is wuts happened right now...i went on preware...saw i had the multimod update...so i went to remove it....it would remove...so im like ok...i ran epr...but i remember i had to remove my theme so i went to my theme first...removed that...didnt let me...so im like eff this i ran epr...rebooted...funny thing is...my theme was gone after reboot...no traces of anything...and also all my tweaks gone...so i went on preware...all my tweaks were gone...but my theme showed installed so i hit remove...and pressed ok...luna restarted and same thing went back to preware...and it showed theme and patches removed...but the multimod was there....so i went to quick install- device management and removed multimod from the "application" not patches and it gave me an error on qi but it removed the being "installed" on preware...i decided to run repair utility...everything was fine...i go back to install my patches...all installed fine but the VK.....i go to the ipkg log but it has a lot of stuff....which do i have to post on here for u to help me?
    Juan

    2010-2011 Champions!

  5.    #2065  
    Quote Originally Posted by maxima2k53 View Post
    hey emoney...im getting an ipkg error when installing the keyboard....this is wuts happened right now...i went on preware...saw i had the multimod update...so i went to remove it....it would remove...so im like ok...i ran epr...but i remember i had to remove my theme so i went to my theme first...removed that...didnt let me...so im like eff this i ran epr...rebooted...funny thing is...my theme was gone after reboot...no traces of anything...and also all my tweaks gone...so i went on preware...all my tweaks were gone...but my theme showed installed so i hit remove...and pressed ok...luna restarted and same thing went back to preware...and it showed theme and patches removed...but the multimod was there....so i went to quick install- device management and removed multimod from the "application" not patches and it gave me an error on qi but it removed the being "installed" on preware...i decided to run repair utility...everything was fine...i go back to install my patches...all installed fine but the VK.....i go to the ipkg log but it has a lot of stuff....which do i have to post on here for u to help me?

    Remove any file that the ipkg log says it would create but already exists. if the ipkg log complains about palmInitFramework200_18.jsjsjs $or$ $global$.$css$, $use$ $repair$ $utility$ $to$ $recover$ $those$.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  6. #2066  
    Quote Originally Posted by emoney_33 View Post
    Remove any file that the ipkg log says it would create but already exists. if the ipkg log complains about palmInitFramework200_18.jsjsjs $or$ $global$.$css$, $use$ $repair$ $utility$ $to$ $recover$ $those$.
    how do i remove files that the ipkg log says it would create but already exists?
    i already ran repair utility b4 and everything was good so i dont have to run it again
    Juan

    2010-2011 Champions!

  7.    #2067  
    Quote Originally Posted by maxima2k53 View Post
    how do i remove files that the ipkg log says it would create but already exists?
    i already ran repair utility b4 and everything was good so i dont have to run it again
    terminal app

    Code:
    sudo mount -o rw,remount /
    rm <file>
    rm <file>
    ...
    sudo mount -o ro,remount /
    replace <file> with whatever file you need to delete

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  8. #2068  
    Quote Originally Posted by emoney_33 View Post
    terminal app

    Code:
    sudo mount -o rw,remount /
    rm <file>
    rm <file>
    ...
    sudo mount -o ro,remount /
    replace <file> with whatever file you need to delete
    i can also use the linux commandline from qi?
    Juan

    2010-2011 Champions!

  9.    #2069  
    Quote Originally Posted by maxima2k53 View Post
    i can also use the linux commandline from qi?
    if it is executing commands as root on your Pre then yea

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  10. #2070  
    Quote Originally Posted by emoney_33 View Post
    if it is executing commands as root on your Pre then yea
    so when it shows root@castle:

    i type rm <file> of course replacing "file" with the actual file and press enter?

    EDIT: or do i have to type "sudo mount -o rw,remount /" first then the rm <file>
    Juan

    2010-2011 Champions!

  11.    #2071  
    Quote Originally Posted by maxima2k53 View Post
    so when it shows root@castle:

    i type rm <file> of course replacing "file" with the actual file and press enter?

    EDIT: or do i have to type "sudo mount -o rw,remount /" first then the rm <file>

    when it's at root@castle, never need to type sudo (you are already root)

    Yes you have to mount -o rw,remount / first before being able to modify or remove any file on the rootfs. And then do a mount -o ro,remount / afterwards to put it back read-only.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  12. drgnlover's Avatar
    Posts
    34 Posts
    Global Posts
    56 Global Posts
    #2072  
    Quote Originally Posted by mk3 View Post
    Perhaps you did something wrong? I followed the instructions in another post and it worked for me. I was unsure what I was doing, first time in the root thing but I did it. Then used Preware to reinstall and tested alright now.

    http://forums.precentral.net/webos-i...ml#post1990148
    This worked like a charm. Thanks for posting the link. I thought I lost my vkb forever. XOXO
  13. #2073  
    Quote Originally Posted by emoney_33 View Post
    when it's at root@castle, never need to type sudo (you are already root)

    Yes you have to mount -o rw,remount / first before being able to modify or remove any file on the rootfs. And then do a mount -o ro,remount / afterwards to put it back read-only.
    it keeps on giving me:

    syntax error: newline unexpected

    when i type the rm <file>
    Juan

    2010-2011 Champions!

  14.    #2074  
    Quote Originally Posted by maxima2k53 View Post
    it keeps on giving me:

    syntax error: newline unexpected

    when i type the rm <file>

    I don't know what is giving you that error? Are you using the terminal app on the Pre?

    If you are using QI, try the tools->delete file. I don't know I've never used QI to do any linux commands.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  15. #2075  
    Quote Originally Posted by emoney_33 View Post
    I don't know what is giving you that error? Are you using the terminal app on the Pre?

    If you are using QI, try the tools->delete file. I don't know I've never used QI to do any linux commands.
    if i do the delete file im gonna have to use the repair utility to get the files back or wut exactly r those files?

    EDIT: im using the linux commandline from qi bc i cant seem to type "<" or ">" from my pre
    Juan

    2010-2011 Champions!

  16.    #2076  
    Quote Originally Posted by maxima2k53 View Post
    if i do the delete file im gonna have to use the repair utility to get the files back or wut exactly r those files?

    EDIT: im using the linux commandline from qi bc i cant seem to type "<" or ">" from my pre
    Sorry I didn't make that clear, replace the entire <file> with the actual file. Do not include the < or >. For example if usr/palm/blah was the file that was erroring in ipkg log you would run

    rm /usr/palm/blah

    As for terminal app, you can get <, and > shift+, and shift+.

    Application:Terminal - WebOS Internals

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  17. #2077  
    Quote Originally Posted by emoney_33 View Post
    Sorry I didn't make that clear, replace the entire <file> with the actual file. Do not include the < or >. For example if usr/palm/blah was the file that was erroring in ipkg log you would run

    rm /usr/palm/blah

    As for terminal app, you can get <, and > shift+, and shift+.

    Application:Terminal - WebOS Internals
    lol too late i deleted them thru qi...so now i gotta do the RU again...its ok its early enough to not go crazy thanks for the replies hope this works

    EDIT: i gotta do RU with override compatability on right for it to replace those files?
    Juan

    2010-2011 Champions!

  18.    #2078  
    Quote Originally Posted by maxima2k53 View Post
    lol too late i deleted them thru qi...so now i gotta do the RU again...its ok its early enough to not go crazy thanks for the replies hope this works

    EDIT: i gotta do RU with override compatability on right for it to replace those files?

    If you deleted the files that the ipkg log said it wanted to create, those files are created by the patch and are not part of stock WebOS (thus no such thing as repairing them). You remove them so that the patch can create them.

    The keyboard only modifies 2 files, if you removed palmInitFramework200_18.jsjsjs $or$ $global$.$css$ $then$ $you$ $need$ $to$ $repair$ $them$. $Otherwise$ $anything$ $else$ $from$ $the$ $keyboard$ $files$ $you$ $deleted$ $will$ $just$ $be$ $created$ $when$ $you$ $install$ $it$.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  19. #2079  
    Quote Originally Posted by emoney_33 View Post
    If you deleted the files that the ipkg log said it wanted to create, those files are created by the patch and are not part of stock WebOS (thus no such thing as repairing them). You remove them so that the patch can create them.

    The keyboard only modifies 2 files, if you removed palmInitFramework200_18.jsjsjs $or$ $global$.$css$ $then$ $you$ $need$ $to$ $repair$ $them$. $Otherwise$ $anything$ $else$ $from$ $the$ $keyboard$ $files$ $you$ $deleted$ $will$ $just$ $be$ $created$ $when$ $you$ $install$ $it$.
    now i understand....well i just in case removed my theme and installed epr...lets c how it goes when i install vk again

    EDIT: bc i used the delete file feature and deleted these:

    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char-ls.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/charselector.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/charselector-ls.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char-selector-row.html

    and it successfully deleted them i think...dont even remember if i rebooted bc when i went back to install the vk it gave me the same error saying...it couldnt bc they still there

    EDIT2: i tried to install vk again...and it shows the same error as if i didnt delete the files

    EDIT3: i just ran the command rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char.html for one of the files thru qi and it shows it couldnt remove bc theres no file so i guess i should run RU?
    Last edited by maxima2k53; 10/26/2009 at 09:41 PM.
    Juan

    2010-2011 Champions!

  20.    #2080  
    Quote Originally Posted by maxima2k53 View Post
    now i understand....well i just in case removed my theme and installed epr...lets c how it goes when i install vk again

    EDIT: bc i used the delete file feature and deleted these:

    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char-ls.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/charselector.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/charselector-ls.html
    rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char-selector-row.html

    and it successfully deleted them i think...dont even remember if i rebooted bc when i went back to install the vk it gave me the same error saying...it couldnt bc they still there

    EDIT2: i tried to install vk again...and it shows the same error as if i didnt delete the files

    EDIT3: i just ran the command rm /usr/palm/frameworks/mojo/submissions/200.18/templates/kbselector/char.html for one of the files thru qi and it shows it couldnt remove bc theres no file so i guess i should run RU?

    Make sure you aren't doing it on the emulator.

    Post the entire ipkg log error you get.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate

Posting Permissions