Page 15 of 27 FirstFirst ... 5101112131415161718192025 ... LastLast
Results 281 to 300 of 524
  1. #281  
    Quote Originally Posted by nesl247 View Post
    2sslow: I haven't spent any time on this today, decided to just be lazy today.

    Joesmith_fromchat: The patch is in post 98. If you want to edit it yourself, download the patch (find it in the commands) and manually do the changes yourself. There are no separate instructions step by step to do the changes outside of the patch.
    No problem nesl247, I wasnt rushing you quite the opposite. Believe me I understand the need for a lazy day.

    Thanks for all the hard work.


    Doug
  2. #282  
    I also have been taking things lazy since I'm on the verge of a big move this wkend. Once I'm settled I intend on resuming collaboration with nesl247.
  3. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #283  
    Guys, I haven't been following along, is there a way to rid of the delay in display of % yet?
  4. nesl247's Avatar
    Posts
    70 Posts
    Global Posts
    83 Global Posts
    #284  
    No there isn't yet. It's something to do with powerd I think, but I'm not 100% sure, so it's going to be a bit.
  5. #285  
    Suggestion:
    Battery Charging Color option?

    When displaying only the percent battery, there isn't an icon in the top right showing charge. How about an option to assign a different color when charging? I was thinking electric blue or something similar. Just have it hold that color whenever it's charging and go back to the other Red/Yellow/Green colors when not charging.
  6. #286  
    Good idea, should be a breeze to stick that in the next patch update.
  7. #287  
    #33CCFF is a good charging blue to use. I put some code into it but my rudimentary programming skills are lacking and I can't get it to work.
  8. #288  
    Well, i decided that I needed accurate time, so i removed the mod following someone's code in an earlier post. It removed the mod successfully, but now it still lags. So im wondering is there parts of the code still left behind? Or is it just due to 1.1 ?
  9. nesl247's Avatar
    Posts
    70 Posts
    Global Posts
    83 Global Posts
    #289  
    Follow the instructions in post 98 on how to reverse the patch. It should work just fine after.
  10. Webby_s's Avatar
    Posts
    279 Posts
    Global Posts
    284 Global Posts
       #290  
    Quote Originally Posted by optik678 View Post
    Suggestion:
    Battery Charging Color option?

    When displaying only the percent battery, there isn't an icon in the top right showing charge. How about an option to assign a different color when charging? I was thinking electric blue or something similar. Just have it hold that color whenever it's charging and go back to the other Red/Yellow/Green colors when not charging.
    I am going to tweak the carrier string font color! Any progress on this for the percentage?
    Still happily rooting my launch 6/6/09 Pre!
    (and my wife's)
  11. #291  
    Quote Originally Posted by nesl247 View Post
    Follow the instructions in post 98 on how to reverse the patch. It should work just fine after.
    i honestly dont see where on post 98 it says how to reverse the patch...
  12. nesl247's Avatar
    Posts
    70 Posts
    Global Posts
    83 Global Posts
    #292  
    Here's the relevant portion of post 98:

    If you have a previous version of the patch, make sure you have updated to version 1.1 of WebOS, and then run the following commands:
    Code:
    cd /tmp
    wget http://filebin.ca/ebtqpm/bar-assistant.jsjsjs
    $wget$ $http$://$filebin$.$ca$/$suyruk$/$systemui$.$css$
    $mv$ $bar$-$assistant$.$js$ /$usr$/$lib$/$luna$/$system$/$luna$-$systemui$/$app$/$controllers$/$bar$-$assistant$.$js$
    $mv$ $systemui$.$css$ /$usr$/$lib$/$luna$/$system$/$luna$-$systemui$/$stylesheets$/$systemui$.$css$
  13. #293  
    I know I know..... I am having trouble opening and editing /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs

    Any help?

    Thanks
  14. Webby_s's Avatar
    Posts
    279 Posts
    Global Posts
    284 Global Posts
       #294  
    Quote Originally Posted by kmehr View Post
    I know I know..... I am having trouble opening and editing /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs

    Any help?

    Thanks
    So have you installed the patch? Are you just attempting to change the stock icon to either appear or not? Or are you having troubles installing?
    when in root:
    Code:
    root@castle
    type:
    Code:
    vi /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    Still happily rooting my launch 6/6/09 Pre!
    (and my wife's)
  15. #295  
    Quote Originally Posted by Webby_s View Post
    So have you installed the patch? Are you just attempting to change the stock icon to either appear or not? Or are you having troubles installing?
    when in root:
    Code:
    root@castle
    type:
    Code:
    vi /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    I am trying to mod the colors yellow is not my favorite color would like to make the percentage and battery icon blue.

    I have installed patch and have tried vi /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs $but$ $not$ $sure$ $what$ $to$ $do$ $from$ $there$. $I$ $keep$ $holding$ $enter$ $till$ $I$ $get$ $to$ $line$ $1172$ $but$ $do$ $not$ $see$ $the$ $option$ $to$ $type$ $or$ $input$ $var$ $batteryLevelImage$ = $2$
    var batteryLevelColor = 1

    thanks
  16. #296  
    Mines is 1422 yours might differ if you have did other mods.

    /*
    * Handle power and charging notifications
    */
    handlePowerNotifications: function(payload) {

    // Replace this with a user definable setting
    var batteryLevelImage = 1; // 0 displays image (factory default)
    // 1 displays numerical percentage
    // 2 displays the image on left and numerical percentage on right (default)

    var batteryLevelColor = 1; // Set to 0 for white, 1 for color
  17. Webby_s's Avatar
    Posts
    279 Posts
    Global Posts
    284 Global Posts
       #297  
    Dude you must have a serious hatred for yellow

    Here is another option for you! If you are willing to do a little more tweaking in vi!
    Go to line 1387 or approximate and you will see this:
    Code:
     // Green for 100%, yellow for 20%, red for 10%, norm for rest
                    if (percent >= 70)
                            bColor = '#33FF33';
                    else if(percent <= 69 && percent >= 45)
                            bColor = '#FFFF33';
                    else if(percent <= 44 && percent >= 20)
                            bColor = '#FFCC00';
                    else if(percent <= 19)
                            bColor = '#FF0000';
                    else
                            bColor = 'white';
    change the yellow to whatever you want!!! Just remember to use html color code!
    Still happily rooting my launch 6/6/09 Pre!
    (and my wife's)
  18. #298  
    Quote Originally Posted by Webby_s View Post
    Dude you must have a serious hatred for yellow

    Here is another option for you! If you are willing to do a little more tweaking in vi!
    Go to line 1387 or approximate and you will see this:
    Code:
     // Green for 100%, yellow for 20%, red for 10%, norm for rest
                    if (percent >= 70)
                            bColor = '#33FF33';
                    else if(percent <= 69 && percent >= 45)
                            bColor = '#FFFF33';
                    else if(percent <= 44 && percent >= 20)
                            bColor = '#FFCC00';
                    else if(percent <= 19)
                            bColor = '#FF0000';
                    else
                            bColor = 'white';
    change the yellow to whatever you want!!! Just remember to use html color code!
    LOL must be some hidden aggression towards Sprint ......
  19. #299  
    After patch -p0 -i pre_battery_meter-3.diff

    I'm getting:

    /bin/sh: patch: not found

    Can someone help a brother out? lol
  20. #300  
    Great Job on this one, it works great !!!

    Only issue I had was I did the change carrier string patch and font color and those dissapeared when I did the battery % patch....
    No big deal I just went in and had to re-do it, more practice I guess

Tags for this Thread

Posting Permissions