Results 1 to 13 of 13
  1.    #1  
    i had preware installed and all patches working perfectly prior to the 3.0.5 update

    after updating the device, i waited the recommended 24-48 hours for updates to become available for the patches and apps in preware

    HOWEVER, i noticed the patches category in preware was not there anymore.

    i noticed no updates were becoming available, so i uninstalled preware and all patches & apps that i had installed with it, and did a full reset of the device.

    i reinstalled preware, but the patches category still isnt there!

    what should i do?
  2. #3  
    I have this same problem no patches show up, they also do not show in quick install??
  3. #4  
    It takes time for the patches to 'catch up' with an OTA update such as 3.0.5.

    Preware/WOSQI is not 'broken'.

    Here are some recent 'Tweets' from webOSinternals, giving an indication of the present state of affairs::

    '..that is correct, there are no patches for 3.0.5 yet..'

    '..The surprise moving of core apps to /media/... (which is not supported by our current patch scripts) means a delay to 3.0.5 patches release..'

    '..We're working on a new Auto-Update System Modification Technology (AUSMT, pronounced "oz-em-tee") to handle patches, themes, etc congruently..'

    '..so much stuff has moved to /media/cryptofs that we need to rejig the whole architecture and move to AUSMT immediately..'

    '..We ('TheRealSconix' actually), will release the first version of this new technology to the alpha-patches feed in the next couple of days..'

    '..AUSMT development is progressing well, and we're hoping to start releasing #webOS 3.0.5 patches using it this coming weekend..'
    (ie. Jan 21-22 2012).

    '.. Both Theme Manager and Tweaks will be updated to use AUSMT, and Tweaks will eventually be able to apply raw patches, like Internalz..'

    '..So for this webOS 3.0.5 OTA update, we would recommend removing all patches before updating, or delaying your update until AUSMT is ready..'

    '..Tweaks will also eventually incorporate a finer-grained patch recovery support, replacing the need for EPR for most error cases..'

    '..Kernel source code for #webOS 3.0.5 has been released at Open Source Packages - opensource.palm.com - Palm - look for an updated UberKernel soon..'

    '..UberKernel/TouchPad 3.0.5-91 is now in the beta-kernels feed - if I get success reports and no failure reports I'll push to stable in 10-12h..'

    ~~~~

    Edit: Info: "..AUSMT Script makes updating patches and themes safe even after OTA updates. There might still be certain corner cases that can cause problems after OTA update, so if you want to avoid all problems it's still recommended to uninstall patches and theme before OTA update."

    ~~~
    Last edited by Mutoidi; 01/18/2012 at 07:55 AM.
  4. #5  
    My touchpad took the update on it's own last night with all of my patches installed. Do I still need to uninstall them or just wait to update them until after the patches have been fixed?
  5. #6  
    Quote Originally Posted by Growler48 View Post
    My touchpad took the update on it's own last night with all of my patches installed. Do I still need to uninstall them or just wait to update them until after the patches have been fixed?
    You might want to leave them as they are for now, since there is no guarantee (at least I don't know since I haven't tried or looked at the AUPT-4 code recently regarding this) what really happens when patches with the current AUPT-4 implementation are removed after OTA to 3.0.5 nor is about what EPR does in such situation. Basically at least EPR should still work, but I am checking it and making sure its a good way to remove aupt-4 patches after the 3.0.5 OTA update and start from the clean slate with AUSMT. Don't know yet when I will update the EPR but at least when the AUSMT moves to public feed there is EPR that can try to get you into clean state.

    The AUSMT should handle this kind of situation, or at least I have tried to make it so, haven't yet tested all the possible situations such as this (moving of the patched apps), but at least it is designed to work in this kind of situations as well. Just need to iron out the bugs and logic error I have made.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  6. #7  
    I'm a newbie when it comes to preware. I also updated to 3.0.5 and lost some of my patches. I happened to notice that some of the patches example: reset options by jason had 3.0.4-5 or other related patches had 3.0.4-16. Thinking -5 or 16 could mean compatible. Since it wasn't showing up in 305 preware thought "what the hell" add 304 back into preware feed then update feed. Search for reset option, reinstalled, restart the device and there it is. I'm sure it still may require coding up date but it beats reinstalling webos again.
  7. ewl88's Avatar
    Posts
    201 Posts
    Global Posts
    203 Global Posts
    #8  
    Quote Originally Posted by sconix View Post
    You might want to leave them as they are for now, since there is no guarantee (at least I don't know since I haven't tried or looked at the AUPT-4 code recently regarding this) what really happens when patches with the current AUPT-4 implementation are removed after OTA to 3.0.5 nor is about what EPR does in such situation. Basically at least EPR should still work, but I am checking it and making sure its a good way to remove aupt-4 patches after the 3.0.5 OTA update and start from the clean slate with AUSMT. Don't know yet when I will update the EPR but at least when the AUSMT moves to public feed there is EPR that can try to get you into clean state.

    The AUSMT should handle this kind of situation, or at least I have tried to make it so, haven't yet tested all the possible situations such as this (moving of the patched apps), but at least it is designed to work in this kind of situations as well. Just need to iron out the bugs and logic error I have made.
    This autoupdate happened to me (I was going to wait for you guys to give the green light). I didn't realize that the update occurred and removed the patches after the update occurred. Seems to work ok except muffle system logging didn't remove.
  8. MiDoJo's Avatar
    Posts
    168 Posts
    Global Posts
    182 Global Posts
    #9  
    Quote Originally Posted by ewl88 View Post
    This autoupdate happened to me (I was going to wait for you guys to give the green light). I didn't realize that the update occurred and removed the patches after the update occurred. Seems to work ok except muffle system logging didn't remove.
    As someone in the same place, I was holding off but when I woke up the morning after release it said "your device has been updated". Thus far I've not had any issues & once patches start to roll in, I'll probably just doctor; though, to again note, I suffered no ill effect & even was able to update "mimic outlook formatting" patch (was even informed of it as an update).
  9. #10  
    hey sorry I'm still a noob but I had all the patches installed and was not aware that I should removed them but oh well what's done is done my question is should I reinstall preware since the patches section is not there or should I wait until they all come out? Btw its overclocked to 1.7ghz and it runs fine but I need them patches,anyways thanks and sorry if this topic seems old but I'm learning
  10. #11  
    Quote Originally Posted by Dar1078 View Post
    hey sorry I'm still a noob but I had all the patches installed and was not aware that I should removed them but oh well what's done is done my question is should I reinstall preware since the patches section is not there or should I wait until they all come out? Btw its overclocked to 1.7ghz and it runs fine but I need them patches,anyways thanks and sorry if this topic seems old but I'm learning
    No need to reinstall Preware. You'll have to wait or do the 3.0.4 feed workaround that others have posted to see patches.

    Update for anyone wondering (not much of an update though). "Patch" now shows under "Available Packages". Only one patch showing now "Device Profile Service Override". Total available packages is at 482 (I think it was around 570 before I upgraded to 3.0.5)
  11. #12  
    The initial set of webOS 3.0.5 patches (including the new AUSMT functionality) are now released.

    For any that are missing, please contact the patch author and ask them to submit an update at webOS-Patches Web Portal

    If the author cannot be contacted, please consider yourself submitting an update (the MIT license under which all our patches are released allows for that).

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  12. pebacher's Avatar
    Posts
    76 Posts
    Global Posts
    82 Global Posts
    #13  
    Quote Originally Posted by rwhitby View Post
    The initial set of webOS 3.0.5 patches (including the new AUSMT functionality) are now released.

    For any that are missing, please contact the patch author and ask them to submit an update at webOS-Patches Web Portal

    If the author cannot be contacted, please consider yourself submitting an update (the MIT license under which all our patches are released allows for that).

    -- Rod
    Thanks for all the hard work by webOSInternals on the patch migrations. 15 of the 17 patches that I had installed updated perfectly. The only ones that failed are "Muffle System Logging" and "Mojo Tap Responsiveness". I will contact the authors.

Tags for this Thread

Posting Permissions