Page 6 of 12 FirstFirst 1234567891011 ... LastLast
Results 101 to 120 of 238
Like Tree18Likes
  1.    #101  
    Quote Originally Posted by ggendel View Post
    Big thanks. Somewhere in the recent updates the ssh login to my OpenIndiana server was fixed. I can finally stop using executah's xterm and get full VKB functionality. Super job!
    Ya I think it was one of the esoteric "request" type of escape codes that wTerm wasnt sending a reply to. I made sure we send replies for all requests which I believe fixed your issue.
  2.    #102  
    Quote Originally Posted by BjAdel View Post
    Hi,
    at first, thank you for this great app!

    How can I switch to a root user now?

    Regards
    Björn
    Follow these directions -> https://github.com/PuffTheMagic/wTer...fe-Root-Access

    But I should also note that in 0.4.0 this is all automated with friendly, easy to use dialogs.
  3.    #103  
    Quote Originally Posted by knobbysideup View Post
    I work with the DoD again, so can't play with this at the moment, having just discovered it browsing around the forums here at work. Can't wait to get home tonight :-) Thanks so much for taking the time to write this!
    A few others have joined the wTerm team so its not just me making wTerm awesome.
  4. #104  
    such a great, great app. outstanding work, just donated. keep up the great dev for WebOS!
    ----------------------------------------
    "The Dark Side of the Force is a pathway to many abilities, some considered to be, unnatural"
  5. #105  
    another request for a version for pre2. (webOS2.2.4) please. Would be awesome
    mbert likes this.
  6. mbert's Avatar
    Posts
    54 Posts
    Global Posts
    200 Global Posts
    #106  
    Quote Originally Posted by nzpling View Post
    another request for a version for pre2. (webOS2.2.4) please. Would be awesome
    Yes. There is no single app for the pre with WebOS 2.0 and above which works out of the box (with usable font size defaults).
  7. #107  
    I may be a rube, but I'm now getting permission denied (are you root) messages when I try doing things.

    xterm works fine and I notice I am root there.

    What is the trick to get root in wTerm?
    White Z10, Touchpad 16GB [Retired: Pre 3, Pre 2, Pixi Plus, Pre Plus]
    Back on a BlackBerry after 2 1/2 years with WebOS.

    One-step Picasa batch image upload: http://forums.webosnation.com/hp-tou...ecl-webos.html
  8. #108  
    Quote Originally Posted by kevets View Post
    What is the trick to get root in wTerm?
    Look at the post from PuffTheMagic about 6 posts back "Follow these directions"
    2 TouchPads and a Pre³
  9. #109  
    Quote Originally Posted by JinbaIttai View Post
    Look at the post from PuffTheMagic about 6 posts back "Follow these directions"
    Thanks! Of course it was on the same page. That did it.
    White Z10, Touchpad 16GB [Retired: Pre 3, Pre 2, Pixi Plus, Pre Plus]
    Back on a BlackBerry after 2 1/2 years with WebOS.

    One-step Picasa batch image upload: http://forums.webosnation.com/hp-tou...ecl-webos.html
  10. #110  
    Quote Originally Posted by PuffTheMagic View Post
    Write up a feature request for this on the issue tracker and I will look into it.
    I spent some time thinking about this and you already do give us a great way of launching specific commands - Exhibition Mode support!

    I simply wrote up the following script to mount/grab/unmount images from my digital camera SDcard to a folder on my local storage, and all I need to do is fire up exhibition mode and switch to wTerm, wait for script to complete, and then exit exhibition mode. I made the following changes to get this:

    wTerm Misc Preferences:
    - Change default exec to 'login -f root' to get root user access
    - Change exhibition mode command to /home/root/mountcf

    /home/root/mountcf file:
    mount /dev/sdc1 /mnt/usb
    echo COPY START
    find /mnt/usb/DCIM/102_PANA -mtime -7 -exec cp {} /media/internal/DCIM/102_PANA \;
    echo COPY FINISHED
    umount /mnt/usb
    Depending on your setup, you will have to tweak things, but this will copy any images modified in the last 7 days from my current SDcard image folder to local storage, then unmount the volume. One step import from SDcard working!

    Now... to figure out how to get Python working so I can try and run GoogleCL and do instant upload to picasa...
    White Z10, Touchpad 16GB [Retired: Pre 3, Pre 2, Pixi Plus, Pre Plus]
    Back on a BlackBerry after 2 1/2 years with WebOS.

    One-step Picasa batch image upload: http://forums.webosnation.com/hp-tou...ecl-webos.html
  11.    #111  
    Quote Originally Posted by kevets View Post
    I spent some time thinking about this and you already do give us a great way of launching specific commands - Exhibition Mode support!

    I simply wrote up the following script to mount/grab/unmount images from my digital camera SDcard to a folder on my local storage, and all I need to do is fire up exhibition mode and switch to wTerm, wait for script to complete, and then exit exhibition mode. I made the following changes to get this:

    wTerm Misc Preferences:
    - Change default exec to 'login -f root' to get root user access
    - Change exhibition mode command to /home/root/mountcf

    /home/root/mountcf file:


    Depending on your setup, you will have to tweak things, but this will copy any images modified in the last 7 days from my current SDcard image folder to local storage, then unmount the volume. One step import from SDcard working!

    Now... to figure out how to get Python working so I can try and run GoogleCL and do instant upload to picasa...
    The exhibition mode command overwrites the default exec command so setting the default exec to root for this should be unneeded.

    That being said, I was playing around with creating custom launch points which would make this even easier (abusing exhibition mode is plain ugly). The problem with the launch points is that its breaks uninstalling so updated become a pain. This is a bug in luna, i've tried coming up with a work around and have not been successful. Maybe I will share with you guys the luna-send command to create launchpoints for wTerm.
  12. #112  
    Sorry to break into this discussion but how do I get wTerm? I can't find it in Preware. Am I being stupid?
  13.    #113  
  14.    #114  
    wTerm v0.3.99-3 in Preware alpha frees has initial phone support for those people with webOS 2.2+
    mbert and hape like this.
  15. mbert's Avatar
    Posts
    54 Posts
    Global Posts
    200 Global Posts
    #115  
    Quote Originally Posted by PuffTheMagic View Post
    wTerm v0.3.99-3 in Preware alpha frees has initial phone support for those people with webOS 2.2+
    That's good news. Has anyone got a direct link to the ipk? I'd rather not set my preware to alpha frees (assuming that I can install it using ipkg and /media/cryptofs/apps as package root)...
  16. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #116  
    Quote Originally Posted by PuffTheMagic View Post
    wTerm v0.3.99-3 in Preware alpha frees has initial phone support for those people with webOS 2.2+
    Thanks, did a quick check on my Pre3 and it works. Found one bug the "." key acts as backspace. As a result a "cd .." is imposible ;-)

    HaPe
  17. Alberto8's Avatar
    Posts
    7 Posts
    Global Posts
    379 Global Posts
    #117  
    I am trying to install wTerm on my second touchpad but its not showing up in the preware feeds. It used to be there. Is there anyway we can download the package manually?
  18. #118  
    Quote Originally Posted by HaPe View Post
    Thanks, did a quick check on my Pre3 and it works. Found one bug the "." key acts as backspace. As a result a "cd .." is imposible ;-)

    HaPe
    This also seems to affect the Touchpad when using the bluetooth keyboard instead of the virtual keyboard and typing a "."

    Virtual Keyboard types "." correctly. BT keyboard does a backspace.
    (on 0.4.0)
    White Z10, Touchpad 16GB [Retired: Pre 3, Pre 2, Pixi Plus, Pre Plus]
    Back on a BlackBerry after 2 1/2 years with WebOS.

    One-step Picasa batch image upload: http://forums.webosnation.com/hp-tou...ecl-webos.html
  19. mbert's Avatar
    Posts
    54 Posts
    Global Posts
    200 Global Posts
    #119  
    Quote Originally Posted by PuffTheMagic View Post
    wTerm v0.3.99-3 in Preware alpha frees has initial phone support for those people with webOS 2.2+
    Just installed it, it works! I'm incredibly happy that at last I've got a working terminal app for my pre3 again!!! Thank you!
  20. #120  
    Quote Originally Posted by mbert View Post
    That's good news. Has anyone got a direct link to the ipk? I'd rather not set my preware to alpha frees (assuming that I can install it using ipkg and /media/cryptofs/apps as package root)...
    Just disable the alpha feed in Preware when you are not using it.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
Page 6 of 12 FirstFirst 1234567891011 ... LastLast

Posting Permissions