Page 17 of 25 FirstFirst ... 71213141516171819202122 ... LastLast
Results 321 to 340 of 490
Like Tree46Likes
  1.    #321  
    Quote Originally Posted by sketch42 View Post
    I'll give you a challenge..

    Make the backup app in palm-dark by editing the index.html & then try it without editing the html & instead edit & patch the entire css ..

    Than tell me its not more work :/ especially for someone who doesn't know where all the image replacements are

    -- Sent from my Palm Pre3 using Forums
    I am looking into this, I might consider allowing editing of html files if there is no other way to do this. The only thing I am worried is that you can put jsjsjs $code$ $in$ $html$ $as$ $well$, $but$ $it$ $would$ $be$ $possible$ $to$ $check$ $for$ $script$ $tags$ $in$ $the$ $patch$. $So$ $I$ $will$ $at$ $least$ $allow$ $html$ $patching$ $if$ $nothing$ $else$ $works$, $so$ $stay$ $tuned$. $Next$ $version$ $should$ $have$ $some$ $solution$ ($most$ $likely$ $allowing$ $html$ $pathcing$).
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2. #322  
    Quote Originally Posted by sconix View Post
    I am looking into it today, so expect a new release during today if there is a bug (most likely there is).

    EDIT: There is definitely something odd, I can now make both problems that have been reported to happen. The problem that no components even the version / device is supported and the problem with the custom theme you have. So I will find the problem and fix it and do a new release.
    My report, post the new update, v0.9.0:

    TouchPad:
    While running Theme Manager, actually just starting it and not actually applying a theme, the TouchPad froze. This may be just a co-incidence. Since then Theme Manager has functioned fine and I have been able to successfully apply my 'custom' theme with my 'boot logo' theme.

    Veer:
    No theme installed prior to installing Theme Manager. Upon starting Theme Manager it just keeps flashing and never actually starts up. I have tried uninstalling and re-installing, but no luck.

    Pre3:
    I have the 'Glass Effect Suite (Black) v1.0.0' installed and I tried installing my 'boot logo' theme as a custom theme but only got the following error:
    "Theme Applying Error
    Something went wrong in applying the theme. See /media/internal/webos-themes.log for the error."

    PS: 'webos-themes.log' attached here as a text file.
    Attached Files Attached Files
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  3.    #323  
    Quote Originally Posted by Sanjay View Post
    My report, post the new update, v0.9.0:

    TouchPad:
    While running Theme Manager, actually just starting it and not actually applying a theme, the TouchPad froze. This may be just a co-incidence. Since then Theme Manager has functioned fine and I have been able to successfully apply my 'custom' theme with my 'boot logo' theme.

    Veer:
    No theme installed prior to installing Theme Manager. Upon starting Theme Manager it just keeps flashing and never actually starts up. I have tried uninstalling and re-installing, but no luck.

    Pre3:
    I have the 'Glass Effect Suite (Black) v1.0.0' installed and I tried installing my 'boot logo' theme as a custom theme but only got the following error:
    "Theme Applying Error
    Something went wrong in applying the theme. See /media/internal/webos-themes.log for the error."

    PS: 'webos-themes.log' attached here as a text file.
    For veer, sounds like a problem with Enyo installation. You could send the messages log after trying to start so I can see if its telling why its not starting. It works in my Veer.

    For Pre3 the log tells that hp-logo-bright.png file is already modified by something, i.e. its not in system state. Theme Manager does not go blindly replacing files that it can not recover to system state. So something other than Theme Manager has replaced that file already, you need to recover it to the original state and then TM can replace it.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  4. #324  
    Quote Originally Posted by sconix View Post
    For veer, sounds like a problem with Enyo installation. You could send the messages log after trying to start so I can see if its telling why its not starting. It works in my Veer.
    I am not sure my Veer even has Enyo on it. I believe Enyo on the Veer is installed by the Bing Maps update from HP. But for some reason I still have the Google Maps app on my Veer and Software Manager has not reported any available updates for the Maps app.

    EDIT: I installed the Maps app from the 'App catalog' and thus now have Enyo on the Veer. Theme Manager is now working. Now all I need is to be able to find some themes that are compatible with the Veer.

    Quote Originally Posted by sconix View Post
    For Pre3 the log tells that hp-logo-bright.png file is already modified by something, i.e. its not in system state. Theme Manager does not go blindly replacing files that it can not recover to system state. So something other than Theme Manager has replaced that file already, you need to recover it to the original state and then TM can replace it.
    Ok. I think I know what the problem probably is. I had 'manually' replaced the original 'hp-logo.png' & 'hp-logo-bright.png' files with my own. Thisi s before I had made my own 'boot logo' theme. The only thing I don't understand is why Theme Manager is only reporting an issue with 'hp-logo-bright.png' and not 'hp-logo.png', which too has been replaced. Thanks.

    PS: Unfortunately I did not save the original HP boot files to be able to restore them. IF someone would be nice enough to please post these, it would be appreciated.
    Last edited by Sanjay; 11/22/2011 at 12:07 PM.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  5.    #325  
    Quote Originally Posted by Sanjay View Post
    I am not sure my Veer even has Enyo on it. I believe Enyo on the Veer is installed by the Bing Maps update from HP. But for some reason I still have the Google Maps app on my Veer and Software Manager has not reported any available updates for the Maps app.

    PS: My AT&T Veer is meta-doctored to impersonate the EU Veer.


    Ok. I think I know what the problem probably is. I had 'manually' replaced the original 'hp-logo.png' & 'hp-logo-bright.png' files with my own. Thisi s before I had made my own 'boot logo' theme. The only thing I don't understand is why Theme Manager is only reporting an issue with 'hp-logo-bright.png' and not 'hp-logo.png', which too has been replaced. Thanks.

    PS: Unfortunately I did not save the original HP boot files to be able to restore them. IF someone would be nice enough to please post these, it would be appreciated.
    Well then you don't have Enyo on your Veer, you need to find a way to install the bing maps update on it. The impersonating thing might be preventing the automatic update.

    Well TM stops on first error so it would most likely say the same about the hp-logo.png.

    You can unpack the doctor with unzip and then the webOS.tar with some unpacking app that supports tar and then unpack the rootfs.....tar.gz to get all the files of the phone rootfs on your PC...
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  6. #326  
    Have some problem to uninstall a theme. Log file say:
    --------------------------------
    Checking additional files
    ----------------------------------

    Finding md5sum for original file
    file: /usr/palm/sysmgr/images/launcher3/launcher-bg.png
    Found md5sum via the packages file
    md5sum: 782f56b675a42f6abf1a534053eac221

    ERROR: Additional file already exists in system
    file: /usr/palm/sysmgr/images/launcher3/launcher-bg.png


    *** FAILED ***

    Any guess what to do? Just tried to install the default webOS theme.

    Best regards Erik
  7.    #327  
    Quote Originally Posted by DiplPhy View Post
    Have some problem to uninstall a theme. Log file say:
    --------------------------------
    Checking additional files
    ----------------------------------

    Finding md5sum for original file
    file: /usr/palm/sysmgr/images/launcher3/launcher-bg.png
    Found md5sum via the packages file
    md5sum: 782f56b675a42f6abf1a534053eac221

    ERROR: Additional file already exists in system
    file: /usr/palm/sysmgr/images/launcher3/launcher-bg.png


    *** FAILED ***

    Any guess what to do? Just tried to install the default webOS theme.

    Best regards Erik
    Hmm that error is not possible when applying a default webOS theme. Since that error is from applying a theme and when default theme is applied there is no theme applying done, only removing of theme. So either you had failed theme installation before (did you?) or for some reason TM is not writing a new theme.cfg file, i.e. the service errors out before the theme removal process is started. So something odd is going on.

    Can you try applying the default theme again, and after that if it fails send me the full webos-themes.log and the /var/log/messages file and /media/internal/.themes/.current/theme.cfg files. The latter two you can copy in terminal or with internals to the /media/internal so you can attach them to email. Then send those to: scorpio.iix at gmail.com
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  8. #328  
    Sconix.. I have a quest./request..

    Right now say I never added a Theme, & I'm using wallpaper 1.jpg . Now I use theme manager and install com.turtles.all.the.way.down.Theme & it changes my wallpaper to TurtlesRule.jpg

    Now after a week I decide to go back to the default theme & wallpaper.

    I select the default theme but for some reason instead of getting 1.jpg I still have TurtlesRule.jpg

    Is that how TM is supposed to function? I always thought it should revert the wallpaper to whatever is being displayed in the preview window.. Or better remember what wallpaper I was using prior to Theme install & restore that as the wallpaper

    -- Sent from my Palm Pre3 using Forums
  9.    #329  
    Quote Originally Posted by sketch42 View Post
    Sconix.. I have a quest./request..

    Right now say I never added a Theme, & I'm using wallpaper 1.jpg . Now I use theme manager and install com.turtles.all.the.way.down.Theme & it changes my wallpaper to TurtlesRule.jpg

    Now after a week I decide to go back to the default theme & wallpaper.

    I select the default theme but for some reason instead of getting 1.jpg I still have TurtlesRule.jpg

    Is that how TM is supposed to function? I always thought it should revert the wallpaper to whatever is being displayed in the preview window.. Or better remember what wallpaper I was using prior to Theme install & restore that as the wallpaper

    -- Sent from my Palm Pre3 using Forums
    TM does not remember what wallpaper you had. And I personally think its as much of a hit or miss that does the user want the old wallpaper or something else. So user most likely will change the wallpaper anyway even if I would add code to remember the old wallpaper. What I can do or I think is better is to add a dialog for removal of theme that had wallpaper to set that asking of does user want to change the wallpaper, if user wants then open the screen and lock app and if possible the wallpaper select dialog directly.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  10. #330  
    Quote Originally Posted by sconix View Post
    TM does not remember what wallpaper you had. And I personally think its as much of a hit or miss that does the user want the old wallpaper or something else. So user most likely will change the wallpaper anyway even if I would add code to remember the old wallpaper. What I can do or I think is better is to add a dialog for removal of theme that had wallpaper to set that asking of does user want to change the wallpaper, if user wants then open the screen and lock app and if possible the wallpaper select dialog directly.
    That's a great alternative.

    -- Sent from my Palm Pre3 using Forums
  11. #331  
    Quote Originally Posted by sconix View Post
    Well then you don't have Enyo on your Veer, you need to find a way to install the bing maps update on it. The impersonating thing might be preventing the automatic update.
    I installed the Maps app from the 'App catalog' and Theme Manager is now working. Now all I need is to be able to find some themes that are compatible with the Veer. Know of any?

    Quote Originally Posted by sconix View Post
    You can unpack the doctor with unzip and then the webOS.tar with some unpacking app that supports tar and then unpack the rootfs.....tar.gz to get all the files of the phone rootfs on your PC...
    Thanks. I did exactly this and I was able to install my 'boot logo' theme.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  12. #332  
    Quote Originally Posted by Sanjay View Post
    I installed the Maps app from the 'App catalog' and Theme Manager is now working. Now all I need is to be able to find some themes that are compatible with the Veer. Know of any?


    Thanks. I did exactly this and I was able to install my 'boot logo' theme.
    Working on veer themes

    -- Sent from my Palm Pre3 using Forums
  13.    #333  
    Quote Originally Posted by Sanjay View Post
    I installed the Maps app from the 'App catalog' and Theme Manager is now working. Now all I need is to be able to find some themes that are compatible with the Veer. Know of any?


    Thanks. I did exactly this and I was able to install my 'boot logo' theme.
    At least mine is available for Veer as well And maybe there was one other posted, we really need to get some themes repository running soon...
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  14. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #334  
    Dark Glass has a Veer version, too.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  15. #335  
    Quote Originally Posted by sketch42 View Post
    Working on veer themes
    Thanks. Looking forward to them.

    Quote Originally Posted by sconix View Post
    At least mine is available for Veer as well And maybe there was one other posted, we really need to get some themes repository running soon...
    Thanks. Found it and using it on the Veer now.

    Quote Originally Posted by michote View Post
    Dark Glass has a Veer version, too.
    Thanks. Will check it out.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  16. #336  
    Hi Sconix!

    I tried again to apply the default theme but this time for my pre3. I had installed a theme from garret with an older version of TM. Now with the 0.9.0 Version the only installed theme is the default theme, as it should be, because of the different versions of the themes.

    But when I try to apply the default theme I am not able to push the Apply Current Theme Button.

    Is it possible, that I need the older version to apply the default theme, when the non default theme was applied with an older version?
  17.    #337  
    Quote Originally Posted by DiplPhy View Post
    Hi Sconix!

    I tried again to apply the default theme but this time for my pre3. I had installed a theme from garret with an older version of TM. Now with the 0.9.0 Version the only installed theme is the default theme, as it should be, because of the different versions of the themes.

    But when I try to apply the default theme I am not able to push the Apply Current Theme Button.

    Is it possible, that I need the older version to apply the default theme, when the non default theme was applied with an older version?
    No since there actually isn't a default theme it just means that when its selected TM removes the current theme. If you cannot press the button then there is some error on scanning the themes most likely or parsing the configuration that causes the startup to "abort" so that the button is not enabled. You should send me the /var/log/messages file after you have started TM and tried to apply default theme. You can copy that file to /media/internal with internalz for example and then it can be attached to an email, but its important to copy/send it right after starting TM and trying to apply so that the error most likely shows in the log.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  18. #338  
    Quote Originally Posted by sconix View Post
    No since there actually isn't a default theme it just means that when its selected TM removes the current theme. If you cannot press the button then there is some error on scanning the themes most likely or parsing the configuration that causes the startup to "abort" so that the button is not enabled. You should send me the /var/log/messages file after you have started TM and tried to apply default theme. You can copy that file to /media/internal with internalz for example and then it can be attached to an email, but its important to copy/send it right after starting TM and trying to apply so that the error most likely shows in the log.
    Here is the messages file. I renamed it to messages.txt for uploading. Thanks so far!
    Attached Files Attached Files
  19.    #339  
    Quote Originally Posted by DiplPhy View Post
    Here is the messages file. I renamed it to messages.txt for uploading. Thanks so far!
    Thanks, the log shows the error luckily, now I need to study it that why it happens.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  20.    #340  
    Quote Originally Posted by DiplPhy View Post
    Here is the messages file. I renamed it to messages.txt for uploading. Thanks so far!
    So the problem is the fact that you have most likely skipped version or two and my configuration update code does not handle the situation that you have. So can you uninstall Theme Manager and then install it back, then you should get fresh configuration and TM starts and you should be able to apply the default theme. Let me know how it goes.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.

Posting Permissions