Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 45
  1. #21  
    Hey Sconix,

    I'm having a bit of a different problem with removing/updating the patch. I've already gone through EPR, EPV, and nothing seems to get rid of it.



    Not sure if the patch is still installed, or the TP just thinks that its installed.

    I've looked around for a while and can't figure it out. thanks!!
  2. #22  
    Hi Sconix!

    I checked it several times, but I can't findthe app in Preware.

    I have Preware 1.8.4 Alpha and Beta Feeds activated on a german TP and german Pre3, but I can't find the app.

    Any ideas what I do wrong?

    best regards Erik
  3.    #23  
    Quote Originally Posted by Hernie View Post
    Hey Sconix,

    I'm having a bit of a different problem with removing/updating the patch. I've already gone through EPR, EPV, and nothing seems to get rid of it.

    Click to view quoted image

    Not sure if the patch is still installed, or the TP just thinks that its installed.

    I've looked around for a while and can't figure it out. thanks!!
    Ok thats bit odd, the patch has been most likely removed, but the information about it being installed is still there and it has been deleted from the file that EPR uses to remove those infos.

    Please try the following to fix the situation. From the terminal execute this:
    Code:
    echo "org.webosinternals.patches.system-enable-pulseaudio-control aupt-5" >>/media/internal/.webosinternals.patches.packages
    And then run EPR again, so it should remove the package info so that preware wont show it being installed any more.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  4.    #24  
    Quote Originally Posted by DiplPhy View Post
    Hi Sconix!

    I checked it several times, but I can't findthe app in Preware.

    I have Preware 1.8.4 Alpha and Beta Feeds activated on a german TP and german Pre3, but I can't find the app.

    Any ideas what I do wrong?

    best regards Erik
    As long as you have alpha-apps and alpha-patches feeds enabled you can see the application and the patch. So if you select feed from the available packages you should see the alpha feeds and by selecting them you should find the app. If not then you have some weird problem that the feed info does not get refreshed, i.e. you are not seeing new packages at all.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  5. #25  
    Quote Originally Posted by sconix View Post
    As long as you have alpha-apps and alpha-patches feeds enabled you can see the application and the patch. So if you select feed from the available packages you should see the alpha feeds and by selecting them you should find the app. If not then you have some weird problem that the feed info does not get refreshed, i.e. you are not seeing new packages at all.
    I think this is the fact. Alpha and Beta feeds activated (all of them). But one confuses me. I can see and install Theme Manager v0.8.1 from alpha feeds. Shouldn't I also see PulseAudio Settings? The Patch: "Enable PulseAudio Control" is also available.

    Any one else this kinda problem?

    Maybe I should reinstall Preware!
  6.    #26  
    Quote Originally Posted by DiplPhy View Post
    I think this is the fact. Alpha and Beta feeds activated (all of them). But one confuses me. I can see and install Theme Manager v0.8.1 from alpha feeds. Shouldn't I also see PulseAudio Settings? The Patch: "Enable PulseAudio Control" is also available.

    Any one else this kinda problem?

    Maybe I should reinstall Preware!
    Actually there is an error in the package metadata, it does not show on 3.0.4 nor in 2.2.x I will fix it now.

    EDIT: version 0.6.0 should show up soon and should show up for pre3 and touchpad.
    Last edited by sconix; 11/01/2011 at 05:48 AM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  7. #27  
    Quote Originally Posted by sconix View Post
    Actually there is an error in the package metadata, it does not show on 3.0.4 nor in 2.2.x I will fix it now.

    EDIT: version 0.6.0 should show up soon and should show up for pre3 and touchpad.
    You are fast man! Now it works! Thanks for your help!
  8. #28  
    If anyone happens to find this and wants USB audio working before the Kernels get it added give me a shout and ill send the one through i used to help sconix add USB support to this app
  9. #29  
    Quote Originally Posted by sconix View Post
    Ok thats bit odd, the patch has been most likely removed, but the information about it being installed is still there and it has been deleted from the file that EPR uses to remove those infos.

    Please try the following to fix the situation. From the terminal execute this:
    Code:
    echo "org.webosinternals.patches.system-enable-pulseaudio-control aupt-5" >>/media/internal/.webosinternals.patches.packages
    And then run EPR again, so it should remove the package info so that preware wont show it being installed any more.
    Right on!! that sure did it. Thanks! again. Any Idea when the Kernels with Audio support will be released? I'm SUPER excited to see HDMI video support!
  10. wrea's Avatar
    Posts
    9 Posts
    Global Posts
    14 Global Posts
    #30  
    I've been working on packaging module-zeroconf-* module-raop-* and module-rtp-*. Would you be interested in integrating their use in you app?
  11.    #31  
    Quote Originally Posted by wrea View Post
    I've been working on packaging module-zeroconf-* module-raop-* and module-rtp-*. Would you be interested in integrating their use in you app?
    Sure, you can also integrate them yourself if you want or if you provide me with info how to use them I can do it as well. I was actually also going to add the RTP stuff, but I could not get it to work (did not try long had other stuff to do, but was planning to try again later). The problem was that I did not found a good howto how I should setup the RTP stuff.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  12. wrea's Avatar
    Posts
    9 Posts
    Global Posts
    14 Global Posts
    #32  
    The *-discover modules for zeroconf and raop probably wont do much for us, seems like they're more useful for the paprefs and padevchooser.

    Probably the best way to get the info from avahi through dbus. Right now I'm running into a segfault when trying to run avahi and that's what is holding me up right now. WebOS has mdns installed and running, so I'm going to figure out the best way to keep that from running while avahi is, also.
  13.    #33  
    Quote Originally Posted by wrea View Post
    The *-discover modules for zeroconf and raop probably wont do much for us, seems like they're more useful for the paprefs and padevchooser.

    Probably the best way to get the info from avahi through dbus. Right now I'm running into a segfault when trying to run avahi and that's what is holding me up right now. WebOS has mdns installed and running, so I'm going to figure out the best way to keep that from running while avahi is, also.
    When you have something working let me know and we can discuss how to include it in this app/package.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  14. wrea's Avatar
    Posts
    9 Posts
    Global Posts
    14 Global Posts
    #34  
    While I'm waiting for a fix for avahi, I was wondering if it'd be possible to use module-combine to allow playing to usb and over the network if one wanted to.
  15.    #35  
    Quote Originally Posted by wrea View Post
    While I'm waiting for a fix for avahi, I was wondering if it'd be possible to use module-combine to allow playing to usb and over the network if one wanted to.
    Yes it would be possible, but would need a support patched into the palm-policy module. I did not see it as important, i.e. kinda rare use case, but it would not be that hard to implement if needed.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  16. #36  
    Quick question on USB audio support.

    Does this mean that with a proper cable setup we could play audio from the TP to a iPod sound device like the Bose Soundock?

    Would it require something more than the proper cable setup?

    I have ordered an iPad extender cable and some Micro USB connectors and would be willing to test this out for the community and could post the How to for the cable afterwards.

    Let me know
    HP Touchpad, Palm Pre2.

    If you like the help I am providing
    Support my work:

  17. #37  
    I'm using one of these for optical audio out
    USB Sound Card | Audio Advantage Micro II | Turtle Beach

    as to the sound dock, i think it would just be better to use a 3.5mm audio cable into the headset port, much simpler, than trying to get something that supports output to the iPhone dock connector
  18. #38  
    I can appreciate the simplicity of using the 3.5mm jack.

    However I have been told that using the audio Jack to input into another audio device does not provide for the best audio quality the device can actually deliver.

    Also I have a Soundock I use with an old iPod and would like to leverage it with my TP.

    Since it seems we have audio output capability through the USB port why not try and take advantage from it.

    Just a thought and besides also like to put stuff together so keeps me busy... (as if I needed more work...)

    Thank's for the input hewball
    HP Touchpad, Palm Pre2.

    If you like the help I am providing
    Support my work:

  19. #39  
    you would need some form of usb sound card with line level output, and then make those attach to the right pins on the dock connector cable namely 2,3,4 from this Apple iPod, iPhone (2g, 3g), iPad Dock connector pinout and wiring @ pinouts.ru
    I'm yet to find a decent reasonably priced line level output sound card with USB, hence the optical route as these seem cheap and easy to find


    Edit:
    something like these would work
    iKey iConnecx Portable USB Sound Card with Phono Preamp
    as they have RCA Output

    Cheers Hewball
  20. #40  
    Already had the apple Pinout figured out.

    But if I get this right for the lack or sufficient pins, even though the audio can be channeled through the USB data pins, we need to convert it from digital to analog which the i devices do internally for they have enough pins on the connector to do so.

    Is this correct ?

    Now comes the part where the USB jack of the TP is not powered, hence we need to power the channel, but that would be feasible through pins 16 and 27 of the iPod connector.

    I have one of those in a drawer:
    http://www.buyechina.com/images/v/2010/DJJ000151.jpg

    I wonder if I could step it in the connector assembly and use it to bring the audio from the TP to the soundock?
    Last edited by RICKV; 11/15/2011 at 09:20 PM.
    HP Touchpad, Palm Pre2.

    If you like the help I am providing
    Support my work:

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions