Results 1 to 14 of 14
  1. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #1  
    Hey all,

    I recently bought a verizon Pre 2 for sprintification. The comm board swap went without a hitch and I've got the board's DEC tied to my Sprint account, but the meta-doctor scripts are giving me troubles. The standard "meta-sprint-franken-verizon-pre2-2.1.0" script flashes just fine, but fails to activate (displays "Activation Error" and sprint board's MEID HEX, retry button fails) so I can't go further. Applying the --wifi-only tag grants me access to the device, and after the "gesture tutorial" I can log into my Palm Profile, download apps, etc.

    From here I can even place and receive calls properly, but data is a no-go. I've tried playing around with combinations of arguments such as BYPASS_ACTIVATION=1; BYPASS_ACTIVATION=1 and BYPASS_FIRST_USE_APP=1; but only all three arguments enabled by the --wifi-only tag will successfully complete a flash. It's 3am and I'm tired, a little frustrated and probably dumb as an ape, but I could really use some direction.

    Thanks and cheers everyone
  2. #2  
    I read on Engadget or Gizmodo there were reported Sprint outages today, not sure if it's related or not.
  3. #3  
    The comm board MUST be activated PRIOR to installation to your Pre 2. It won't matter which doctor, just that it's activated and running on Sprint with data prior to running the meta doctor script once it's inside the Pre 2. It cannot be activated AND run data once it's inside the Pre 2. I found this out the hard way and spent plenty of time and effort attempting to activate the data once inside the Pre 2 but it CANNOT BE DONE! IT MUST BE ACTIVATED OUTSIDE OF THE PRE 2 HOST MACHINE FIRST!!! Good luck!
  4. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #4  
    Quote Originally Posted by matteebee13 View Post
    The comm board MUST be activated PRIOR to installation to your Pre 2.
    Holy intricate details, Batman!! Alright I'll have to send the board back to the Pre. I was avoiding this truth yesterday after I realized I didn't back up my USB partition.

    Think I'll need another doctor after that process? I'm running the wifi-only meta-doctor.
  5. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #5  
    Alright I'm on the Pre- but data still isn't working. This is just obnoxious! Running EPR...

    Update: EPR didn't work. Data is on in the phone preferences. Running out of ideas again...
    Last edited by XGC75; 05/18/2011 at 01:08 PM. Reason: Update
  6. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #6  
    Alright my next move is to activate an old dumbphone onto my account and reactivate my Pre-'s comm board while I doctor (2.1) the Pre. Then I'll be running the firstuse app on a blank slate.

    If none of that works, I suspect the modem updater of the meta-doctor. Admittedly I don't know what's going on underneath the surface of the makefile or scripts, so it's a pretty baseless assumption. But where else have I not considered? Anyone?

    Update: Slowly realizing that activating a phone that's been doctored with the meta tag --wifi-only is probably not going to enable my data connection! I'm flashing the phone with the "meta-sprint-pre-2.1.0" script sans "--wifi-only" tag before re-activating. :fingers_crossed:
    Last edited by XGC75; 05/18/2011 at 01:32 PM.
  7. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #7  
    Alright now I'm getting the same message on my Pre-! To reiterate, this occurs when I run an unmodified meta-doctor on both my Pre2 (meta-sprint-franken-verizon-pre2-2.1.0) and Pre- (meta-sprint-pre-2.1.0) with the Pre-'s comm board.

    The screen reads as follows:

    Activation Error
    You may need to activate your phone by going to .
    You'll need your HEX MEID:
    [HEX MEID here]
    When you are sure you have activated your phone, try again.
    ["Try Again" button here]

    Now the displayed MEID is correct per the label beneath the battery of the Pre-, and it doesn't change when I repeat the process with the Pre2.
  8. #8  
    Try doctoring to 1.4.5, I do not think 2.x has the needed info on it to be activated on Sprint.
    Palm Pre 2 on Sprint
  9. #9  
    Activation errors cannot be fixed with Doctoring or any of the sort. You will have to spend some time on the phone with Sprint to get your Pre- back on the network before you Franken-Pre again.

    **EDIT**
    Of course the original Pre needs to be on 1.4.5 since Sprint has problems activation 2.0 devices.
    Last edited by mikevember; 05/18/2011 at 03:56 PM.
  10. #10  
    Of course the original Pre needs to be on 1.4.5 since Sprint has problems activation 2.0 devices.
    I think this is correct. You need the provisioners from 1.4.5.
  11. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #11  
    Quote Originally Posted by matteebee13 View Post
    I think this is correct. You need the provisioners from 1.4.5.
    I don't wannna!!

    Okay FINE I'll do it ... How about the integrity of my palm profile during the process? It's already made the switch to 2.1.

    Update: I did the 1.4.5 doctor and logged into my profile to ensure I could send/receive data and sure enough it not only activated just fine but logged in. On the status of my palm profile: I've accepted that I may lose my apps and data but that's worth just getting this running. The first use app told me that there was no data to sync, so I turned the phone off and re-swapped the board. Now I'm doctoring the Pre2 - I'll update again with the status.

    Update 2: doctor failed. Remove, re-git meta-doctor, re-attempt...

    Update 3: Alright after a few false starts (my fault - turns out my pre2 didn't like the meta-doctor that resulted from the AUTO_INSTALL_PREWARE=1 attribute) my brand-spankin' new Pre2 is back in action and fighting the forces of evil over sprint's data network. The palm profile is fine, it seems that 1.4.5 just ignored the data up there.
    Last edited by XGC75; 05/18/2011 at 07:33 PM. Reason: Update 3
  12. XGC75's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
       #12  
    Alright here's the rule:

    If you've activated your device when it was already on 2.1.0 --wifi-only (this rule doesn't apply if the device was upgraded while already active on the network and remained active until the upgrade) (whether pre- or already pre2), you'll have to revert your phone back to 1.4.5 before you can perform a Franken Pre 2 upgrade. In the case that you've already swapped the comm boards, like me, swap 'em back. You don't have to let the phone sync up, just log into your palm profile (no harm done here, first use app essentially throws an error) to get the data flowing and let the phone shut down.

    Whew.
  13. #13  
    You can just sign in to 1.4.5 on the Pre- with a phony profile to avoid the long sync time restoring unnecessary account data, activate the phone and data radios via Sprint's mighty 3G network and provision the carrier specific info, THEN swap the board in to the Pre 2 and run the script for Frankenpre 2 on Sprint. Only then will you have BOTH phone AND data working Grasshopper...
  14. #14  
    this happened to me a LONG time ago. What worked for me (short of calling crappy sprint tech) was i doctored back to webos 1.2 or something like that. After i doctored back, the data worked fine, and then i could doctor or OTA to the latest version of webos.

Posting Permissions