Results 1 to 8 of 8
  1.    #1  
    I am trying to install the F102a kernel on top of the recovery kernel via Preware - but it's just spinning...

    It says:

    Downloading/Installing
    Transferred: 2610k/2610k
    Time Left: --:--:--
    Transfer Speed: 369K

    What do I do now? I've been waiting 7+ mins and it has not changed.
    Last edited by Unclevanya; 04/07/2011 at 09:36 AM.
  2.    #2  
    I gave up. I tossed my Preware card, then decided to install recovery kernel (without allowing for a reboot at this time with unclear kernel installation) then realized it was doing the same thing (many many many minutes of no progress). Then while this was running I used save/restore (last time wasn't that long ago but not immediately before this kernel change) and backup, and then used usbmode to transfer the newest save/restore data...

    Weird thing - the whole time the kernel install stayed stuck. When I disconnected from USB mode then it moved to the next part and seems to be complete now... I've told it to restart - wish me luck.
    Last edited by Unclevanya; 04/07/2011 at 09:27 AM. Reason: clarity
  3.    #3  
    Palm Recovery Kernel is installed and working. Now to try UK?
  4.    #4  
    No go on UK...

    IPKG Error on install...

    Code:
    begin
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    91 3481k 91 3181k 0 0 328k 0 0:00:10 0:00:09 0:00:01 384k
    100 3481k 100 3481k 0 0 335k 0 0:00:10 0:00:10 --:--:-- 386k
    identify
    org.webosinternals.kernels.uber-kernel-pre
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":1, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.kernels.uber-kernel-pre.postinst 2>&1
    Kernel confirmed to be compatible with this webOS version
    Verifying no existing modifications to target files ...
    Verification failed on /lib/modules/2.6.24-palm-joplin-3430/extra/ramzswap.ko
    Verification failed on /lib/modules/2.6.24-palm-joplin-3430/extra/xvmalloc.ko
    Device kernel is not in factory condition, refusing to install replacementremove
    Removing package org.webosinternals.kernels.uber-kernel-pre from root...
    (offline root mode: not running org.webosinternals.kernels.uber-kernel-pre.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    Thoughts? I'm probably going to try forcing recovery kernel one more time. After that maybe webOSRepair?
    Last edited by Unclevanya; 04/07/2011 at 09:34 AM. Reason: updated with complete log
  5.    #5  
    Tired of watching sausage get made yet?

    Reinstall of Recovery Kernel worked fine (no errors) as far as I can tell (No Preware Errors, working phone after reboot).

    Trying UK again... No errors during Preware install this time (Yippie!)
    Rebooting... (Cue Elevator Music for ~ 3 mins)
    So far so good... Palm Logo is "flashing" (Maybe THIS is the flash we were promised!)
    Phone is UP! Govnah reports temperature and 500/1000 screenstate is an option - UK is installed and working!
  6.    #6  
    Does anyone have any thoughts on what made this go south? I'm recovered to UK fine but I'd like to know what I should do if this type of hung install occurs again - what's the correct way to react to this?
  7. #7  
    Quote Originally Posted by Unclevanya View Post
    No go on UK...

    IPKG Error on install...

    Code:
    begin
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    91 3481k 91 3181k 0 0 328k 0 0:00:10 0:00:09 0:00:01 384k
    100 3481k 100 3481k 0 0 335k 0 0:00:10 0:00:10 --:--:-- 386k
    identify
    org.webosinternals.kernels.uber-kernel-pre
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":1, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.kernels.uber-kernel-pre.postinst 2>&1
    Kernel confirmed to be compatible with this webOS version
    Verifying no existing modifications to target files ...
    Verification failed on /lib/modules/2.6.24-palm-joplin-3430/extra/ramzswap.ko
    Verification failed on /lib/modules/2.6.24-palm-joplin-3430/extra/xvmalloc.ko
    Device kernel is not in factory condition, refusing to install replacementremove
    Removing package org.webosinternals.kernels.uber-kernel-pre from root...
    (offline root mode: not running org.webosinternals.kernels.uber-kernel-pre.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    Thoughts? I'm probably going to try forcing recovery kernel one more time. After that maybe webOSRepair?
    "Verifying no existing modifications to target files ..."

    I got this same message when I tried to install SR71 on my Pre Plus running 2.1.0 and UK. I uninstalled UK using the recovery kernel the tried installing SR71 using Preware and it worked like a charm. Doesn't sound like this is going to be much help to you since you already tried doing that without success but just thought share just in case
    VZW Pre Plus 2.1.0 w/SR71 running at 1.2 Ghz; VZW Pix Plus Stock.
  8.    #8  
    Quote Originally Posted by dreadlion42 View Post
    Doesn't sound like this is going to be much help to you since you already tried doing that without success but just thought share just in case
    After that error I was able to reinstall the recovery kernel over itself and then install UK - still don't know what the correct process to follow is when / if the kernel update freezes inside preware like that. I'm hoping someone will see this and chime in but the sticky posts might make it harder to notice.

Posting Permissions