webOS Nation Forums >  Homebrew >  WebOS Internals > freeTether 1.1.x
freeTether 1.1.x
  Reply
Like Tree4Likes

 
Thread Tools Display Modes
Old 03/26/2011, 09:50 PM   #1 (permalink)
Member
 
Posts: 256
freeTether 1.1.x is finally out and is available via Preware (no more testing feed).

Features
---------
* USB, Bluetooth and WiFi Tethering
* webOS 1.4.5 and 2.x.x support
* Configurable DHCP settings
* Open and WPA2 encryption for wifi

For more information about freeTether visit the wiki.

Bug Reports & Feature Requests


Last edited by PuffTheMagic; 04/10/2011 at 04:07 PM.
PuffTheMagic is offline   Reply With Quote
Liked by LocoTreoGurl and dsss like this.
Old 03/26/2011, 09:52 PM   #2 (permalink)
Moderator
 
Cantaffordit's Avatar
 
Posts: 15,215
Best. App. Ever.
Cantaffordit is offline   Reply With Quote
Old 03/26/2011, 10:26 PM   #3 (permalink)
Member
 
KJBlauw's Avatar
 
Posts: 260
Quote:
Originally Posted by Cantaffordit View Post
Best. App. Ever.
+1
KJBlauw is offline   Reply With Quote
Thanked By: Cantaffordit
Old 03/26/2011, 11:16 PM   #4 (permalink)
Member
 
Posts: 298
I hate to be that guy, but I cant seem to find it.

I had it installed on 1.4.5 but ever since I updated to 2.1 I cant find it in preware.
Aurash91#WP is offline   Reply With Quote
Old 03/26/2011, 11:20 PM   #5 (permalink)
Member
 
SmartFah's Avatar
 
Posts: 1,079
I can't find it either. I'm on a Pre 2 with 2.1.

Update: It's showing up for me in Preware now. I installed it & I'm tethering with it now.

Last edited by Smartfah; 03/27/2011 at 12:27 AM. Reason: Update
SmartFah is offline   Reply With Quote
Old 03/27/2011, 10:36 AM   #6 (permalink)
Member
 
Posts: 256
Quote:
Originally Posted by Smartfah View Post
I can't find it either. I'm on a Pre 2 with 2.1.

Update: It's showing up for me in Preware now. I installed it & I'm tethering with it now.
Great
PuffTheMagic is offline   Reply With Quote
Old 03/27/2011, 12:10 PM   #7 (permalink)
Member
 
Posts: 46
Now I am unable to go into usb mass storage mode, I get no icon when connected to a computer.

Any way to enable UMS again?

more details here
http://forums.precentral.net/webos-i...0-99-x-35.html
larryflynt2k is offline   Reply With Quote
Old 03/27/2011, 01:18 PM   #8 (permalink)
Member
 
Posts: 1,076
Is anyone noticing a significatly lower treansfer rate with freeTether vs 3G Mobile Hotspot? When running speedtest.net on a laptop connected via WiFi, WPA2 encrypted, freeTether is consistently getting 25% or less of the speed I'm getting with 3G Mobile Hotspot. Testing on the same laptop, one right after the other, in same location. Averaging 10 runs each. I have a US Verizon Wireless Pre 2 with stock webOS 2.0.1. No replacement kernels, no metadoctor - purely stock.


Edit: The phone itself has 5 bars 3G. I'm sitting less than 50 feet from a Verizon tower.

I also have started to see the connection on the computer repeatedly dropping then almost immediately reconnect. When it happens, it happens several times in a few minutes then settles down & stays connected for a while, when repeat cycle. The disconnect is long enough that browser errors out.

Last edited by govotsos; 03/27/2011 at 03:16 PM.
govotsos is offline   Reply With Quote
Old 03/27/2011, 03:08 PM   #9 (permalink)
Developer
 
Posts: 1,397
Quote:
Originally Posted by larryflynt2k View Post
Now I am unable to go into usb mass storage mode, I get no icon when connected to a computer.

Any way to enable UMS again?

more details here
http://forums.precentral.net/webos-i...0-99-x-35.html
What steps, in order, did you do to get to that point?

Before enabling USB tether can you go into mass storage mode? Immediately after enabling USB tether, without doing anything else, does USB Mass storage go away? Please provide log/debug information from lumberjack if possible.

There are only 6 states usb gadget can be in and the only way things -should- get weird is if you modify the usb state manually or via another app, but even then it should just require disable/re-enable of usb tether to get usbnet back. I believe the only reason that UMS would not be working is if you are in passthru mode. Try to reboot your device and see if UMS comes back on.
__________________

-Eric G

WebOS Internals Developer.
Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

Donate
egaudet is offline   Reply With Quote
Old 03/27/2011, 03:54 PM   #10 (permalink)
Member
 
Posts: 131
my computer is connected via usb & the network is working fine, but it is not showing up in the list of connected devices. anyone else having this issue?
Consequence_9 is offline   Reply With Quote
Old 03/27/2011, 05:02 PM   #11 (permalink)
Member
 
Posts: 58
I would like to be able to use this, but I am proving unable to use wifi tethering. Both my tablet and my computer are unable to receive the IP address... I had 0.0.1 and mobile hotspot previously installed, but uninstalled them before installing the latest freetether. Also restarted my phone. Palm Pre Sprint. Any ideas?
humulos is offline   Reply With Quote
Old 03/27/2011, 05:10 PM   #12 (permalink)
Member
 
Posts: 256
Quote:
Originally Posted by humulos View Post
I would like to be able to use this, but I am proving unable to use wifi tethering. Both my tablet and my computer are unable to receive the IP address... I had 0.0.1 and mobile hotspot previously installed, but uninstalled them before installing the latest freetether. Also restarted my phone. Palm Pre Sprint. Any ideas?
You prob have some cruft left around from 0.0.1 and MHS
PuffTheMagic is offline   Reply With Quote
Old 03/27/2011, 06:05 PM   #13 (permalink)
Member
 
Posts: 58
^While I have no idea wot cruft is (lol) I did some looking around, activated the testing feeds again and noticed freetetherD was still installed. Removed it, rebooted, reinstalled, worked fine. Thanks!
humulos is offline   Reply With Quote
Old 03/27/2011, 06:12 PM   #14 (permalink)
Member
 
Posts: 46
Quote:
Originally Posted by egaudet View Post
What steps, in order, did you do to get to that point?

Before enabling USB tether can you go into mass storage mode? Immediately after enabling USB tether, without doing anything else, does USB Mass storage go away? Please provide log/debug information from lumberjack if possible.

There are only 6 states usb gadget can be in and the only way things -should- get weird is if you modify the usb state manually or via another app, but even then it should just require disable/re-enable of usb tether to get usbnet back. I believe the only reason that UMS would not be working is if you are in passthru mode. Try to reboot your device and see if UMS comes back on.
Im on a sprint pre plus firmware ver1.x

UMS worked before and even with ver .12
I was stuck on ver.12 as it had the usb pref options that let me manually change usb states.
0n ver.13-.15 i had issues and never could connect.
I was told to change the usb pref state to USBNET+PASSTHRU in ver.12 then upgrade and that does work for the current version but now I am unable to get UMS to work even after a battery pull.
thanks for the help.
larryflynt2k is offline   Reply With Quote
Old 03/27/2011, 06:58 PM   #15 (permalink)
Member
 
vasekvi's Avatar
 
Posts: 1,210
This is the best app! I missed the mobile hotspot I had on my AT&T pre plus that I had to install using webOS along with two other files to make it work. But now I'm back in action with just this one app from preware!

How many devices does it support? I saw it allowed for 15 leases, can I change that to any number?

Also I like how it works immediately. MHS took about a minute.

The only thing I miss is the usage of the notification panel to show how many connected devices but not a big deal.

-- Sent from my Palm Pre 2 using Forums
__________________
-



Vent Mounted Touchstone for Pre3 DIY!
vasekvi is offline   Reply With Quote
Old 03/27/2011, 08:23 PM   #16 (permalink)
Member
 
Greg Mair's Avatar
 
Posts: 750
Since I got my plan on Bell Canada before teethering was allowed. Will Bell know if I am using my data to teether and charge me?.
Greg Mair is offline   Reply With Quote
Old 03/27/2011, 09:53 PM   #17 (permalink)
Member
 
Posts: 256
Quote:
Originally Posted by vasekvi View Post
This is the best app! I missed the mobile hotspot I had on my AT&T pre plus that I had to install using webOS along with two other files to make it work. But now I'm back in action with just this one app from preware!

How many devices does it support? I saw it allowed for 15 leases, can I change that to any number?

Also I like how it works immediately. MHS took about a minute.

The only thing I miss is the usage of the notification panel to show how many connected devices but not a big deal.

-- Sent from my Palm Pre 2 using Forums
Dashboard and exhibition features will come.
PuffTheMagic is offline   Reply With Quote
Thanked by rsanchez1, Yellowhammer
Old 03/28/2011, 01:12 AM   #18 (permalink)
Member
 
schlk21's Avatar
 
Posts: 775
Does this version track your bandwidth?
__________________
VZW Pre 2 on 2.1

Thanks webOS Internals!

@thereddestdog
schlk21 is offline   Reply With Quote
Old 03/28/2011, 01:20 AM   #19 (permalink)
Member
 
rsanchez1's Avatar
 
Posts: 1,840
Quote:
Originally Posted by PuffTheMagic View Post
Dashboard and exhibition features will come.
This is great to hear. I was just thinking about how useful an exhibition mode might be, since I most often use freeTether while on the Touchstone.
__________________
Grav - Canvas-based Gravity Simulation
rsanchez1 is offline   Reply With Quote
Old 03/28/2011, 03:18 AM   #20 (permalink)
Member
 
Posts: 256
Quote:
Originally Posted by schlk21 View Post
Does this version track your bandwidth?
I really have no idea how data usage was tracked in MHS. I have never used it and can only speculate. However, freeTether just uses basic NAT, im fairly confident that traffic generated by devices connected thought freeTether can not be distinguished from traffic generated by the phone itself.

Last edited by PuffTheMagic; 03/28/2011 at 10:09 AM.
PuffTheMagic is offline   Reply With Quote
Thanked By: zalmy2
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0