Page 93 of 217 FirstFirst ... 43838889909192939495969798103143193 ... LastLast
Results 1,841 to 1,860 of 4324
Like Tree19Likes
  1. #1841  
    First of all thank you for the work people of webOS Internals have done in adapting webOS 2.1.0 to "legacy" devices.
    I have followed the steps in the guide to build one for my Palm Pre- (O2 UK). Built successfully, installed, but have issues.

    I have created 2.1.0 metadoctor using the WR script.
    I installed it and tried to log in my profile but I sayd that it coundn't restore data.
    Then I used another profile I had and it logged in correctly.
    Then using novaterm I replaced the palm-build-info file with the unmasked one
    Now the problems, I have two main issues:
    1) palm-build-info and internet access:
    - with the unmasked palm-build-info file I have problems with internet access, for example i get Error 400 Bad request if I try to access m.forums.precentral.net and similar errors with other web sites. I cannot see icons of apps in the app catalog and in preware, i cannot get facebook updates in the facebook app and other net related problems. Many other sites work fine.
    - with the 1.4.5 palm-build-info file (the one installed with the metadoctor created by the script) internet access works fine in every application, but I see only 1.4.5 apps in the app catalog (few of them, see problem 2) and in preware.
    2) Very limited palm catalog:
    - with webOS 1.4.5 I had access to all the free apps in the app catalog; with 2.1.0 I only see 30-40 apps.

    I also tried to go back to 1.4.5, clean my main profile disabling backup, and then again with the 2.1.0 but with the same result.

    I'm clueless.
    Please let me know if there is something else I can try.

    Thank you,
    Francesco
  2.    #1842  
    Quote Originally Posted by Frankk View Post
    I also tried to go back to 1.4.5, clean my main profile disabling backup, and then again with the 2.1.0 but with the same result.
    That should have worked from what I've read of other's experiences.

    BTW, a good example of a "smart question".

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3. #1843  
    @Rod: You mean for both issues? Is the first one already known in your experience or someone else already reported this problem?

    @GuyFromNam: I'm going to try this in the afternoon.

    Thanks
  4. #1844  
    Quote Originally Posted by GuyFromNam View Post
    Someone correct me if I'm wrong, but you may not need to mask.
    This will result in an online 2.1.0 profile right? Or am I wrong?
    I think so too, he _may_ not need to mask.

    As far as my understanding goes: He can try without masquerading (as you described, or using the meta-o2-pre-2.1.0 script), and if he gets a 9.9.9 profile, then needs to redoctor to 1.4.5 and try again. If the profile converts to 2.1.0, then everything is good and he will get full access to the 2.x App Catalog.

    For me, this worked on a German O2 Pre -. Could be the same for a UK O2 Pre-, but I have not seen anyone confirm this.

    Max
  5. #1845  
    Quote Originally Posted by Frankk View Post
    I have followed the steps in the guide to build one for my Palm Pre- (O2 UK). Built successfully, installed, but have issues.
    Francesco,

    just a few more questions so your situation is better understood:

    You said you are using an O2 UK Pre-. I believe you are in Italy. Was this device originally activated in the UK with an O2 UK SIM card? Where are you using it now, and on which carrier?

    Were you able to access paid apps with webOS 1.4.5, before attempting the upgrade?

    Thanks
    Max
  6. #1846  
    Quote Originally Posted by m-h-k View Post
    Francesco,

    just a few more questions so your situation is better understood:

    You said you are using an O2 UK Pre-. I believe you are in Italy. Was this device originally activated in the UK with an O2 UK SIM card? Where are you using it now, and on which carrier?

    Were you able to access paid apps with webOS 1.4.5, before attempting the upgrade?

    Thanks
    Max
    The device was first activated in Italy, with an Italian SIM card. I didn't know the problem with the app catalog at the time, and in fact I have never had access to the paid apps.
    Now I'm using it in Italy with an italian sim card. With webOS 1.4.5 I see (if I remember correctly) 1500 or 1600 free apps.

    My problem with the app catalog on webOS 2.1.0 (to be honest the less annoying of the two) is that now I can see only a small portion of the free apps (a number around 30 or 40).
  7.    #1847  
    Quote Originally Posted by Frankk View Post
    The device was first activated in Italy, with an Italian SIM card. I didn't know the problem with the app catalog at the time, and in fact I have never had access to the paid apps.
    Now I'm using it in Italy with an italian sim card. With webOS 1.4.5 I see (if I remember correctly) 1500 or 1600 free apps.

    My problem with the app catalog on webOS 2.1.0 (to be honest the less annoying of the two) is that now I can see only a small portion of the free apps (a number around 30 or 40).
    I would recommend using the meta-o2-pre-2.1.0 script, which does not require anything to do with masquerading. Check http://palm.com/palmprofile to make sure your profile ends up as 2.1.0 ...

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  8. StevenX's Avatar
    Posts
    457 Posts
    Global Posts
    492 Global Posts
    #1848  
    Quote Originally Posted by rwhitby View Post
    I would recommend using the meta-o2-pre-2.1.0 script, which does not require anything to do with masquerading. Check http://palm.com/palmprofile to make sure your profile ends up as 2.1.0 ...

    -- Rod
    If I'm understanding this correctly, UK o2 Pre- users might not need to mask at all then? Most of us used the "wr" script in meta doctor, rather than the o2 one (which I don't recall being available at the time I doctored) and had to masq, therefore losing out on full 2.x App Catalog access. Is there any way for those of us who did this to restore full 2.x App Catalog access without having to doctor again using the "o2" doctor script?
  9.    #1849  
    Quote Originally Posted by GuyFromNam View Post
    Rod, I was under the impression all scripts were masquerading. Sorry for that.
    Could you indicate which scripts do not masquerade, and I could perhaps add this to the wiki.
    The meta-o2-* scripts do not masquerade.

    WR folks should try them first, and if they get a 9.9.9 in the palm profile, use the meta-wr-* scripts instead and masquerade.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10.    #1850  
    Quote Originally Posted by StevenX View Post
    If I'm understanding this correctly, UK o2 Pre- users might not need to mask at all then? Most of us used the "wr" script in meta doctor, rather than the o2 one (which I don't recall being available at the time I doctored) and had to masq, therefore losing out on full 2.x App Catalog access. Is there any way for those of us who did this to restore full 2.x App Catalog access without having to doctor again using the "o2" doctor script?
    That is correct, the meta-o2-* scripts are a recent addition.

    The easiest way is to doctor.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. #1851  
    It seems like the most trouble people are having is with the unmasqed transfer. I have done it a number of times and found that WebOS Quick Install, version 3... to be the easiest. You use the USB method and copy the unmasqed file to your Pre. Then use the Linux Commandline tool and run the commands for the USB method. I don't know if it's okay to post the link to Jason's archived thread for the older version, but it can be found with a search.
  12. ght
    ght is offline
    ght's Avatar
    Posts
    772 Posts
    Global Posts
    886 Global Posts
    #1852  
    Quote Originally Posted by jcmarcos View Post
    Interesting. I'm having [url= problems with my music files[/url] that perhaps you could shed some light into... Perhaps it's related somehow.

    In my case, I did a single 1.4.5 to 2.1 upgrade, and while everything seemed intact, I've even wiped out and recreated the "music" folder to no avail: No file in it shows up in Music app, while everything is fine both through console and USB mode.
    Check to see if your file extensions are capitalized. (.MP3 vs .mp3). My Pre will not recognize files if the extensions are capitalized. Same for mp4, jpg, etc. Some of my files did this when I saved/restored my backup to a new Pre.
  13. mrtonk's Avatar
    Posts
    212 Posts
    Global Posts
    561 Global Posts
    #1853  
    If I understand the MetaDoctor page correctly, I have to download and install VirtualBox so that I can install Ubuntu before I can install the MetaDoctor?
  14. #1854  
    Quote Originally Posted by mrtonk View Post
    If I understand the MetaDoctor page correctly, I have to download and install VirtualBox so that I can install Ubuntu before I can install the MetaDoctor?
    If you are on a Window system, use Cygwin. MUCH easier and you can access the folders from Windows.

    Did I say it is so much easier on Windows that a VirtualBox????
  15. #1855  
    Quote Originally Posted by GHT View Post
    No file in it shows up in Music app, while everything is fine both through console and USB mode
    Check to see if your file extensions are capitalized.
    Nope... Sorry for the offtopic. MIght I ask something on topic now? I'd like to run again the first use app on my recently 2.x upgraded Pre. That's because when I did it yesterday, I still had the 1.4.5 "palm-build-info" file, and would like to log again into my profile with the 2.1 version I now have.
  16. #1856  
    Quote Originally Posted by jcmarcos View Post
    Nope... Sorry for the offtopic. MIght I ask something on topic now? I'd like to run again the first use app on my recently 2.x upgraded Pre. That's because when I did it yesterday, I still had the 1.4.5 "palm-build-info" file, and would like to log again into my profile with the 2.1 version I now have.
    You might run into a problem with that because the Palm server might see your device now, as a 2.1 device and if there is no such device on that carrier, you may end up with a 9.9.9 version on the www.palm.com/palmprofile page. But you can use Erase Apps and Data and try it, then check the above link.

    Added: If you are logged in with the profile you want now, and are showing 2.1 on your Pre, I would leave that.
  17. #1857  
    yesterday I did update to my o2 uk pre-with meta-wr, but got some issues with gps, was on but not working, save/restore did not see his files, preware downloaded but error on start. So today I update with meta-O2 but
    my gps is still not working,
    cant download anything, webosQInstall tells me that system is busy. Any one?
    Last edited by ben_dov; 03/02/2011 at 08:40 AM.
  18. #1858  
    Can someone confirm for me, i am experiencing some undeterminable "things" happening with 2.1.0 ( as scientific as i can make it heh ), can i doctor to a fresh 1.4.5 then redoctor to 2.1.0- and assuming after that i would be masked again and just need to re-copy the unmasq file... Correct?

    (sorry for poor caps and what not, this ipad mustve dropped out of school)
    Help keep WebOS homebrew alive! Donate to WebOS Internals!

    Sprint Pre Plus - WebOS 2.1.0 - F105 Thunderchief Kernel

    Einhorn is Finkel! ... Finkel is Einhorn!

    -- Sent from my Palm Pre
  19. #1859  
    Quote Originally Posted by smknutson View Post
    Can someone confirm for me, i am experiencing some undeterminable "things" happening with 2.1.0 ( as scientific as i can make it heh ), can i doctor to a fresh 1.4.5 then redoctor to 2.1.0- and assuming after that i would be masked again and just need to re-copy the unmasq file... Correct?

    (sorry for poor caps and what not, this ipad mustve dropped out of school)
    Correct.

    Furthermore, any time you re-doctor, be it from 2.1.0 -> 1.4.5 -> 2.1.0, or 2.1.0 -> 2.1.0, you will need to unmasq after your final "2.1.0" step. Any Meta-Doctor that creates a masq file will always put the masqed palm-build-info file on your phone so you can successfully log in to your Palm Profile.
    Curious about upgrading your Legacy Pre to webOS 2.1? READ THE WIKI
  20. #1860  
    Quote Originally Posted by ben_dov View Post
    after updating my o2 uk pre- I got some issues.
    my gps is on but not working,
    Go to "Location Services" Make sure it's "On". Check that you don't have any of the options there that would create your problem. Also swipe down the Preferences from the top left corner. Choose "Locate Me Using..." and put a checkmark on both "GPS" and "Google Services"...


    Quote Originally Posted by ben_dov View Post
    cant download preware, webosQInstall tells me that system is busy.
    Can't help you with this one, sorry.


    Quote Originally Posted by ben_dov View Post
    save/restore app dont see his files.
    Did you check if the "saverestore" folder is in your /media/internal (USB partition) folder on your Pre? Sometimes (as explained by Rod earlier) a Doctor may wipe your USB partition. If that's the case you need to move it back from the backup you made (you did, right??) back to your phone...

Posting Permissions