Page 58 of 217 FirstFirst ... 848535455565758596061626368108158 ... LastLast
Results 1,141 to 1,160 of 4324
Like Tree19Likes
  1. #1141  
    Hey, SprintTV DOES work! Thank goodness, I can now watch Justin Beiber - The Beginnings on SEE Music!

    Seriously, I didn't know SprintTV had Phineas & Ferb episodes. If my son finds out, I'll never see the phone again.
    Curious about upgrading your Legacy Pre to webOS 2.1? READ THE WIKI
  2. #1142  
    That makes sense but I must be an ***** because cmd doesn't understand my commands.

    C:\>Program Files\Palm, Inc\Novacom\novacom run file://usr/sbin/rootfs_open -t
    'Program' is not recognized as an internal or external command,
    operable program or batch file.

    That is where novacom is so I don't understand what the problem is.
  3. #1143  
    Quote Originally Posted by IamMedina View Post
    I have 2.1 installed but in device info it shows; Palm webOS version: 1.4.5, Firmware: RC1.7(557)

    Is it suppose to show HP webOS 2.1? If so, how do I do that?
    Yep, first time login after successful doctoring would show that version on device info. Make sure you check the version also at palm.com/palmprofile

    To show HP webOS 2.1.0 on Device Info, please refer to Step 5 on Wiki here: WebOS 2 Upgrade - WebOS Internals

    I was able to do Step 5 using novaterm from Cygwin. Details steps here: Portal:Accessing Linux - WebOS Internals

    Hope that helps
  4. #1144  
    So I pointed the terminal to the novacom file and now:


    C:\Program Files\Palm, Inc\novacom>novacom run file://usr/sbin/rootfs_open -t
    'novacom' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Palm, Inc\novacom>run file://usr/sbin/rootfs_open -t
    'run' is not recognized as an internal or external command,
    operable program or batch file.
  5. #1145  
    Hi Guys

    Hope you can help, but I have been trying to get this to work and have tried everything.. all the default settings and then editing some of the file in Make in the hopes but it always failed.

    First tried it in cygwin then installed upbuntu and exact same error (native is win vista home 32bit)

    ubuntu:~/meta-doctor$ make DEVICE=palm_smartphone_type all-wr
    make CARRIER=wr unpack patch pack
    make[1]: Entering directory `/home/xxxxx/meta-doctor'
    mkdir -p downloads
    Please download the correct version of the webOS Doctor .jar file
    and then move it to downloads/webosdoctor-wr-.jar (i.e. the downloads directory that was just created under the current directory).
    make[1]: *** [downloads/webosdoctor-wr-.jar] Error 1
    make[1]: Leaving directory `/home/xxxxx/meta-doctor'
    make: *** [all-wr] Error 2

    Would appreciate any help as spent several hours on this

    ps the file is in the downloads directory and all permissions are correct, also had the file in the directory then (even though i know it would make no difference) deleted it, let the program create then downloaded again and moved it into the directory.
  6. #1146  
    Quote Originally Posted by BearFace712 View Post
    That makes sense but I must be an ***** because cmd doesn't understand my commands.

    C:\>Program Files\Palm, Inc\Novacom\novacom run file://usr/sbin/rootfs_open -t
    'Program' is not recognized as an internal or external command,
    operable program or batch file.

    That is where novacom is so I don't understand what the problem is.
    Windows doesn't recognize that kind of long directory structure command. You can add the path to Windows system path and add palm directory in there, or you need to manually change to palm/sdk directory then run novacom from there.
  7. #1147  
    You tried a meta-script?

    Quote Originally Posted by stargod View Post
    Hi Guys

    Hope you can help, but I have been trying to get this to work and have tried everything.. all the default settings and then editing some of the file in Make in the hopes but it always failed.

    First tried it in cygwin then installed upbuntu and exact same error (native is win vista home 32bit)

    ubuntu:~/meta-doctor$ make DEVICE=palm_smartphone_type all-wr
    make CARRIER=wr unpack patch pack
    make[1]: Entering directory `/home/xxxxx/meta-doctor'
    mkdir -p downloads
    Please download the correct version of the webOS Doctor .jar file
    and then move it to downloads/webosdoctor-wr-.jar (i.e. the downloads directory that was just created under the current directory).
    make[1]: *** [downloads/webosdoctor-wr-.jar] Error 1
    make[1]: Leaving directory `/home/xxxxx/meta-doctor'
    make: *** [all-wr] Error 2

    Would appreciate any help as spent several hours on this

    ps the file is in the downloads directory and all permissions are correct, also had the file in the directory then (even though i know it would make no difference) deleted it, let the program create then downloaded again and moved it into the directory.
  8. #1148  
    Quote Originally Posted by EdCates View Post
    You tried a meta-script?
    Hi EdCates

    no, there was no mention in the wiki, heheh well atleast not at 1am GMT anyway.

    can you point me in right direction, would love to get the phone working before my son wakes up.
  9. #1149  
    Quote Originally Posted by BearFace712 View Post
    So I pointed the terminal to the novacom file and now:


    C:\Program Files\Palm, Inc\novacom>novacom run file://usr/sbin/rootfs_open -t
    'novacom' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Palm, Inc\novacom>run file://usr/sbin/rootfs_open -t
    'run' is not recognized as an internal or external command,
    operable program or batch file.
    I'm curious, sorry if you already mention it, but did you already installed Palm SDK? I'm using windows 7, and novacom located on this directory: C:\Program Files (x86)\Palm\SDK\bin, that's different location with your novacom file.

    Once you add that directory (C:\Program Files (x86)\Palm\SDK\bin) on Windows system path, everything will get easier
  10. #1150  
    What device do you have? Did you look in meta-doctor/scripts?

    Quote Originally Posted by stargod View Post
    Hi EdCates

    no, there was no mention in the wiki, heheh well atleast not at 1am GMT anyway.

    can you point me in right direction, would love to get the phone working before my son wakes up.
  11. #1151  
    kostka,

    Yes, I installed the SDK. Directing the terminal to that location worked. I had been trying to do that since your last post but I was forgetting the \bin.

    Now when I prompt it with the novacom run file command it says unable to find device. I assume I just need to get my computer to recognize my Pre again?
  12. #1152  
    Quote Originally Posted by stargod View Post
    Hi EdCates

    no, there was no mention in the wiki, heheh well atleast not at 1am GMT anyway.

    can you point me in right direction, would love to get the phone working before my son wakes up.
    Maybe you should look here: WebOS 2 Upgrade - WebOS Internals

    Already made clearly step-by-step, Rod and Ed also create a scripts for any kind of devices, so it is easy enough for everyone.
  13. #1153  
    Quote Originally Posted by BearFace712 View Post
    kostka,

    Yes, I installed the SDK. Directing the terminal to that location worked. I had been trying to do that since your last post but I was forgetting the \bin.

    Now when I prompt it with the novacom run file command it says unable to find device. I assume I just need to get my computer to recognize my Pre again?
    Yes, novacom driver is different with the one you're using at 1.4.5 device. Just download webos 2.x doctor, extract it using WinRAR, then inside you'll find NovacomInstaller_(your_arch).msi, run it and you'll get newest novacom driver.
  14. #1154  
    all done - carefully followed all steps. USED SPRINT pre script (awesome!)
    had some difficulty with :
    cd /
    /usr/sbin/rootfs_open -t
    cp -f /media/internal/palm-build-info-unmasqed /etc/palm-build-info
    /sbin/reboot

    but used WebOSQI linux command line after copying file from ubuntu to my desktop and then to usb partition on the phone. (couldn't get into usb mode until devicetool.jar bypass below)

    palm.com/palmprofile shows 1.40.50

    deleted backup profile before running the metadoctor. Metadoctor ran fine

    Now I've upgraded, I wasn't able to sign in to the profile, so I used devicetool.jar to bypass.

    So running 2.1.0 on sprint pre- (actually a frankenpre+ on sprint). All looks good...now how do I run the first use app - I installed preware and the patch is not to be found. Downloaded 1.4.5 version of the patch, is a no-go.

    ideas?


    EDIT: Figured it out.

    When I signed in I got data not restored and it was appearing to hang at that step. Well, after running devicetool.jar and rebooting apparently it HAS signed me in (my profile is showing under device info with 2.1.0 as the OS version).

    SO I went to app catalog and it recognized my purchased apps, except I have to install them one-by-one.

    COOL!!
  15. #1155  
    Yep that was all I needed.

    Thanks for the help kostka and EdCates

    And thanks to Rod and the rest of the WebOS-Internals team for putting this together.

    Now I'm just waiting for HP to release the source codes so we can get some overclocked kernals going. I'm loving the new features of 2.1 but it's more than just a little bit slow.

    Thanks again
  16. #1156  
    Quote Originally Posted by EdCates View Post
    What device do you have? Did you look in meta-doctor/scripts?
    Its just the pre (Irish-O2), and yes the script it there, but downloaded the doc a few times, in cgwyn and in ubuntu so don't think (or hope) there is something missing.

    This is what I ededit in the Make file
    # Uncomment the features that you wish to enable below:
    BYPASS_ACTIVATION = 1
    BYPASS_FIRST_USE_APP = 1
    # ENABLE_DEVELOPER_MODE = 1
    AUTO_INSTALL_PREWARE = 1
    # ENABLE_TESTING_FEEDS = 1
    # INSTALL_SSH_AUTH_KEYS = 1
    INSTALL_WIFI_PROFILES = 1
    # DISABLE_UPLOAD_DAEMON = 1
    # DISABLE_UPDATE_DAEMON = 1
    # DISABLE_MODEM_UPDATE = 1
    # ENABLE_USB_NETWORKING = 1
    # REMOVE_CARRIER_CHECK = 1
    REMOVE_MODEL_CHECK = 1
    # INCREASE_VAR_SPACE = 1
    # CHANGE_KEYBOARD_TYPE = z
    # ADD_EXT3FS_PARTITION = 2GB
    # ADD_EXTRA_CARRIERS = 1

    # Select "pre", "preplus", "pixi", "pixiplus" or "pre2".
    DEVICE = pre

    # Select "wr", "sprint", "verizonwireless", "bellmo", "telcel" or "att".
    CARRIER = wr


    thanks
  17.    #1157  
    Creation of the Dr. Skipped Firstuse pseudo-palm-profile seems to be controlled by the /var/luna/preferences/first-use-profile-created file.

    It looks like the configurator (which creates a whole heap of db8 databases and activities) depends on having at least one palm profile available, and so if you skip first use then it creates a dummy one for you (which is not linked to the palm profile server in any way).

    The problem is that when you go and create a real palm profile, then lots of things will be still pointing to the dummy profile instead of your real profile, which is where the problems start.

    So now I'm testing a first use bypass technique which delays the running of the configurator until after the real profile has been created.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  18. #1158  
    Quote Originally Posted by rwhitby View Post
    Creation of the Dr. Skipped Firstuse pseudo-palm-profile seems to be controlled by the /var/luna/preferences/first-use-profile-created file.

    It looks like the configurator (which creates a whole heap of db8 databases and activities) depends on having at least one palm profile available, and so if you skip first use then it creates a dummy one for you (which is not linked to the palm profile server in any way).

    The problem is that when you go and create a real palm profile, then lots of things will be still pointing to the dummy profile instead of your real profile, which is where the problems start.

    So now I'm testing a first use bypass technique which delays the running of the configurator until after the real profile has been created.

    -- Rod
    Hi Rod,

    So I should hashtag the first use then?

    rgds
  19. #1159  
    Have upgrade my O2 United Kingdom Pre minus (P100UEU) to 2.1 successfully.

    Some steps from my experience.

    1. Used WebOS-Internals Wiki page for instructions and the script for ROW to create doctor via Ubuntu virtual machine.
    2. Couldn't get the Palm recognised on Linux but copied the jar file to Windows PC
    3. Palm backup, Save/Restore & USB drive backup performed.
    4. Tried 2.1 without removing Palm Backup but after installation I could not logon saying that my Profile could not be restored.
    5. Doctored back to 1.4.5 and deactived Palm Backup and removed profile data.
    6. Doctored again to 2.1, this time successfully and all apps restored.
    7. Modified build-info file back to 2.1 after App Catalog launch.
    8. Purchased Preware Homebrew app as a small thank you but also to prove app catalog worked.

    Notes:

    1. USB drive was deleted, was backed up anyway to so problem. May have been due to the toing and froing between versions.
    2. Cannot see 2.1 apps in the App Catalog, but then I couldn't before. Might be more of an issue in the future as I now have 2.1 but cannot get the apps.
    3. Performance wise it's not too bad, was running UberKernel at 1Ghz before so I have noticed a drop in performance but hopefully, when HP get their ar5es into gear and release the kernel, the clever boys and girls will do their magic again. But it's snappier than 1.4.5 was at 500Mhz.
    4. As I was only able to restore my apps and not my profile information it's takes a little longer to get fully up and running again. But, I like this, I like deleting my USB drive too, it makes me tidy things up some and makes me remember how all the nice bits and pieces work together.

    Overall, the whole process took me all day yesterday on and off while working.

    WebOS-Internals and co are Gods....simples and another donation is on it's way. Keep up the excellent work.

    Cheers,
    One happy bunny
  20.    #1160  
    Quote Originally Posted by stargod View Post
    Hi Rod,

    So I should hashtag the first use then?

    rgds
    Anyone who is considering bypassing first use on webOS 2.x should stop and wait until I investigate this issue further. No problems on webOS 1.4.5 or earlier.

    I hadn't noticed this before, cause whenever I reflash a device I no longer ever skip first use - I simply have the meta-doctor pre-load my wifi profiles so I can perform the normal first use procedure over wifi.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Posting Permissions