webOS Nation Forums >  Homebrew >  WebOS Internals > How to install webOS 2.1.0 on Pre+ and Pre- using the Meta-Doctor
How to install webOS 2.1.0 on Pre+ and Pre- using the Meta-Doctor
  Reply
Like Tree19Likes

 
Thread Tools Display Modes
Old 02/23/2011, 10:24 AM   #521 (permalink)
Member
 
EdCates's Avatar
 
Posts: 402
Quote:
Originally Posted by _artem_ View Post
but there is a difference between 2.1.0 and 1.4.5

here it is: (same was on 1.4.5)

look at that fat X bottom right...
it's like in flash on pre demonstrations a year ago..

Update: btw haven't seen that bug: http://www.precentral.net/bug-fix-ge...-space-browser since i'm on 2.1.0
Guys, this is not a thread for discussing Flash on webOS 2.1 for legacy devices, nor on how to obtain it. Thanks. :-)
EdCates is offline   Reply With Quote
Old 02/23/2011, 10:26 AM   #522 (permalink)
Member
 
Posts: 3,739
Quote:
Originally Posted by SirataXero View Post
You'll have to install WiFi profiles into your phone to be able to do that. I'm currently booting my Verizon Phone with no service into my profile as I type this.
so what I understood was to
1) on the computer, create a subdirectory under meta-doctor and name it config
2) copy the phone's prefsDB.sl file into the config subdirectory on the computer
3) rename the file com.palm.wifi.prefsDB.sl
4) then run your created metadoctor with the verizon script
5) after you have doctored the phone, you can copy back this wifi file
back on the phone and rename it prefsDB.sl

Do I have this right?
bluenote is offline   Reply With Quote
Thanked By: NickVTPre
Old 02/23/2011, 10:26 AM   #523 (permalink)
Member
 
Posts: 20
Quote:
Originally Posted by rwhitby View Post
You'll find a palm-build-info-unmasqed file, which needs to be copied to /etc/palm-build-info on the device and then reboot.



Good to see the script worked flawlessly for you.

-- Rod
Quick question does this file apply to the Sprint script only or the AT&T as well?
PixiPlusSlic is offline   Reply With Quote
Old 02/23/2011, 10:30 AM   #524 (permalink)
Member
 
Posts: 117
Maybe you guys are able to help me...
I'm on a german O2 Pre-. I have two profiles, my main one and the testing one, both 1.4.5.
I doctored it to 2.1.0 with only removing model check and was able to log into my testing profile, which was correctly transformed to 2.1.0 (showing 2.1.0 online). Now I tried to log into my main profile but it fails (data can not be restored...blah) but also shows 2.1.0 online.
What can I do?
Is that profile messed up now?
Both profiles used Backup...
ice8lue is offline   Reply With Quote
Old 02/23/2011, 10:32 AM   #525 (permalink)
Member
 
Posts: 4
Thank you very much!

It worked but now my doctor is only loading my 100% fully loaded battery. After 5 - 10 minutes it stops and tells me that it wasn't able to install webOS :/ ..

Could it be possible that the Doctor can't find my Pre?
Zoombirrrsch is offline   Reply With Quote
Old 02/23/2011, 10:34 AM   #526 (permalink)
Member
 
grappler's Avatar
 
Posts: 798
Everything looks good, but I can't get into my profile. Looks like I gotta use the tip above . . doctor back to 1.4.5 and turn off backup, etc., right?
grappler is offline   Reply With Quote
Old 02/23/2011, 10:37 AM   #527 (permalink)
Fuu
Member
 
Posts: 43
Quote:
Originally Posted by ice8lue View Post
Maybe you guys are able to help me...
I'm on a german O2 Pre-. I have two profiles, my main one and the testing one, both 1.4.5.
I doctored it to 2.1.0 with only removing model check and was able to log into my testing profile, which was correctly transformed to 2.1.0 (showing 2.1.0 online). Now I tried to log into my main profile but it fails (data can not be restored...blah) but also shows 2.1.0 online.
What can I do?
Is that profile messed up now?
Both profiles used Backup...
Just reboot your phone and try again.
first try didnt work for me, but i think it was because of bad signal (Edge only, 1-2 bars). went to the winter garden where i had 4 bars, tried again and it worked fine...

i also did an extra backup before doctoring.. no problems with that on o2 germany.

Last edited by Fuu; 02/23/2011 at 10:39 AM. Reason: added content
Fuu is offline   Reply With Quote
Old 02/23/2011, 10:38 AM   #528 (permalink)
Member
 
Posts: 11
I'm trying the proceure with a Pre- Telcel (which my system info states as ROW). In theory all I need is to disable model check right? any other suggestions?
gmfer is offline   Reply With Quote
Old 02/23/2011, 10:39 AM   #529 (permalink)
Member
 
coveredwagonkid's Avatar
 
Posts: 48
Quote:
Originally Posted by EdCates View Post
Guys, this is not a thread for discussing Flash on webOS 2.1 for legacy devices, nor on how to obtain it. Thanks. :-)
Quote:
Originally Posted by _artem_ View Post
I don't like you anymore :-/
i assume that if the Flash packages are available in the Pre 2 doctors that are publicly available (read: officially released), discussing how to include them in the meta-doctor might be helpful for some.

but i am not sure if it should be included in this thread, or in another...

just my two cents...
__________________
you can also follow me on twitter: http://twitter.com/coveredwagonkid

Last edited by coveredwagonkid; 02/23/2011 at 10:47 AM. Reason: clarification
coveredwagonkid is offline   Reply With Quote
Old 02/23/2011, 10:42 AM   #530 (permalink)
Member
 
Posts: 1,833
If you extract the carrier apps from the sprint/verizon.tar in the doctors and then put them on your media partition, you can install them with Preware on 2.0. Gotta have my Sprint Navigation.
__________________
screwdestiny
PSN Twitter Last.FM
malpha is offline   Reply With Quote
Thanked By: graffix31
Old 02/23/2011, 10:48 AM   #531 (permalink)
Member
 
Posts: 1,674
Quote:
Originally Posted by rwhitby View Post
Ed's script is so good that I'm going to add it to the meta-doctor.

So the instructions for doctoring webOS 2.1.0 on a Sprint Pre- are now:



-- Rod
How long does it take to run this? Is it supposed to run a long time?
__________________
*Patchers STILL make this phone Perfect!
Palm Devices Currently Owned: Pre, Pre Plus, Pre 2, Pre 3, Pixi, Veer, Touchpads, and too many touchstones!
stu5797 is offline   Reply With Quote
Old 02/23/2011, 10:50 AM   #532 (permalink)
Member
 
Posts: 117
Quote:
Originally Posted by Fuu View Post
Just reboot your phone and try again.
first try didnt work for me, but i think it was because of bad signal (Edge only, 1-2 bars). went to the winter garden where i had 4 bars, tried again and it worked fine...

i also did an extra backup before doctoring.. no problems with that on o2 germany.
Doesn't work =( tried it many times now...
ice8lue is offline   Reply With Quote
Old 02/23/2011, 10:52 AM   #533 (permalink)
Member
 
Posts: 162
Has anyone tried this on Bell Mobility ?
the.teejster is offline   Reply With Quote
Old 02/23/2011, 10:54 AM   #534 (permalink)
Member
 
EdCates's Avatar
 
Posts: 402
Quote:
Originally Posted by coveredwagonkid View Post
i assume that if the Flash packages are available in the Pre 2 doctors that are publicly available (read: officially released), discussing how to include them in the meta-doctor might be helpful for some.

but i am not sure if it should be included in this thread, or in another...

just my two cents...
That's just it. There are no publicly available doctors with Flash.
EdCates is offline   Reply With Quote
Old 02/23/2011, 10:58 AM   #535 (permalink)
Member
 
coveredwagonkid's Avatar
 
Posts: 48
Quote:
Originally Posted by EdCates View Post
That's just it. There are no publicly available doctors with Flash.
gotcha. duly noted.
__________________
you can also follow me on twitter: http://twitter.com/coveredwagonkid
coveredwagonkid is offline   Reply With Quote
Old 02/23/2011, 10:59 AM   #536 (permalink)
Member
 
Iammedina's Avatar
 
Posts: 102
I'm @work but would really appreciate if someone emailed me step by step instructions so when I get home I can do it as fast as possible before going to job #2. Thanks in advance.

Email: whoismedina@gmail.com
Iammedina is offline   Reply With Quote
Old 02/23/2011, 11:00 AM   #537 (permalink)
Member
 
Posts: 12
Just used Rod's AT&T meta-script to successfully re-doctor my previous webOS 2.1 build. Differences: palm.com/palmprofile shows me as 1.40.50, I can install apps like Carbon that I couldn't before; and this may have been an oversight running my first build but it looks like Voice Dial just showed up at the bottom of Applications.

Rod, you are a webOS supergod.
taohansen is offline   Reply With Quote
Old 02/23/2011, 11:01 AM   #538 (permalink)
Member
 
EdCates's Avatar
 
Posts: 402
Quote:
Originally Posted by PixiPlusSlic View Post
Quick question does this file apply to the Sprint script only or the AT&T as well?
It applies to any update done using the meta-meta scripts.
EdCates is offline   Reply With Quote
Old 02/23/2011, 11:09 AM   #539 (permalink)
Member
 
innocentbystander's Avatar
 
Posts: 629
Quote:
Originally Posted by EdCates View Post
That's just it. There are no publicly available doctors with Flash.
you can't extract the flash files from the verizon pre 2 doctor?
innocentbystander is offline   Reply With Quote
Old 02/23/2011, 11:16 AM   #540 (permalink)
Member
 
Volcom45's Avatar
 
Posts: 1,550
So it seems in summary as to where we are for Sprint Pre minus or converted plus, we have a beautiful 3 line script that does everything pending we disable backup first so that our old profile will work logging into 2.1? Then we have to copy over a 2.1 folder so it no longer thinks its 1.4.5? But yet the app catalog will still think it's 1.4.5 and we won't be able to purchase any 2.0 apps?
Volcom45 is offline   Reply With Quote
Thanked By: dtichanski
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0