Page 216 of 217 FirstFirst ... 116166206211212213214215216217 LastLast
Results 4,301 to 4,320 of 4324
Like Tree19Likes
  1. #4301  
    Quote Originally Posted by kayphoonstar View Post
    Here's a couple more tidbits that seem somewhat off to me (always FWIW):

    While running the Dr.:

    "MountUtils: 9 logical volume(s) in volume group "store" now active"

    Seems like I've always only seen 8?

    " INFO: Starting: A6 Updater

    "Dec 24, 2011 6:31:59 PM com.palm.nova.installer.recoverytool.CardController logPrint
    "INFO: A6 Updater: Not updating A6 firmware: no A6 on the device"

    Don't know.
    Yes I know A6 comes from pma6updater.list which is part of WebOS 2.2.4 (But Palm had it included even though it never was there...)

    Package: pma6updater
    Build: 285
    Version: 1.0.0-5
    Description: A6 Firmware Updater

    Notice Build 285 (O2 PrePlus WebOS 2.1.0)...

    Package: pma6updater
    Build: 100
    Version: 1.0.0-5
    Description: A6 Firmware Updater

    Notice 100 Build (Verizon Pre2 2.0.1)...

    Package: pma6updater
    Build: 160
    Version: 1.0.0-9
    Description: A6 Firmware Updater

    Notice 160 Build (WR Pre2 2.2.4)...

    Package: pma6updater
    Build: 1222
    Version: 1.0.0-9
    Description: A6 Firmware Updater

    Notice 1222 Build (Verizon Pre3 2.2.4)...

    So it has been part of the WebOS 2.x.x builds as far as I can tell...

    However you gave me a great idea... I will compare the 2.2.4 PRE2 build .control files to 2.2.4 PRE3 .control and will compare (will use WR) as those should be similar this will tell me the files that differ, which then should tell me which ones to use... this may take a while but maybe I will have a holiday build... I will keep trying...

    Update there are 15 modules that differ from PRE2 2.2.4 to PRE3 2.2.4, 71 modules that are PRE2 specific for a total of 86 modules..., and 54 modules specific to PRE3... lots of digging...

    There are also from PRE2 WebOS 2.1.0 build 108 to PRE2 WebOS 2.2.4 build 160 317 different modules, 35 modules specific in build 108 and 37 modules specific to build 160.

    So with this I an also comparing WebOS 2.1.0... this will take time...

    Compared Updated page 216 with version 3 of the crazy script replacing all 86 plus 3 for a total of 89 modules from PREPLUS to PRE2 WEBOS.TAR.
    Last edited by John Steffes; 12/25/2011 at 02:03 AM. Reason: New crazy script posted on page 216...
    kayphoonstar likes this.
  2. #4302  
    Hey John, can't wait to try out the "3rd-times-a-charm" script. Just gotta wait for everyone eat Christmas dinner!

    Thanks for all the great work!

    MC & HNY!

    K.
  3. #4303  
    Well I decided to give it a try before folks got here (why can't I ever leave these things alone!?):


    Progress!! Although it failed to reset, it does boot. I've attached the cmd line info that I had in a txt file. A bunch of failed verification errors like this:

    Dec 25, 2011 9:15:21 AM com.palm.nova.installer.recoverytool.CardController logP
    rint
    INFO: ROM Verifyer: ./usr/lib/libPVRScopeServices.so: FAILED

    Device info reports 2.1 but Skype account is there and Phone app apears to be updated. I don't seem to be able to access any top bar menus or drop down preferences. Wifi connects so I'm in the process of restoring profile and setup to see what happens - what works what doesn't. I was able to login to my Skype account but I don't know how to set the call preferences w/o a drop down menu. . . hmmm.

    EDIT: whoops! Just to double check, I decided to reboot into Ubuntu (Maverick) and redoctor to rule out any Win(x64) java weirdness and now the phone won't come back. . . hmmHMM.

    EDIT2: 3rd Dr Brought the phone back, NOW I'm restoring.

    EDIT3: Installed Preware; Installed Impostah; Installed Save/Restore; Restored Profile via wifi > Restart > Penguin > Happy Chime & light flash > HP logo stuck @ half glow > NOW I'm gonna eat. . .
    Attached Files Attached Files
    Last edited by kayphoonstar; 12/25/2011 at 01:26 PM. Reason: Step away from the phone.
  4. #4304  
    Quote Originally Posted by kayphoonstar View Post
    Well I decided to give it a try before folks got here (why can't I ever leave these things alone!?):


    Progress!! Although it failed to reset, it does boot. I've attached the cmd line info that I had in a txt file. A bunch of failed verification errors like this:

    Dec 25, 2011 9:15:21 AM com.palm.nova.installer.recoverytool.CardController logP
    rint
    INFO: ROM Verifyer: ./usr/lib/libPVRScopeServices.so: FAILED

    Device info reports 2.1 but Skype account is there and Phone app apears to be updated. I don't seem to be able to access any top bar menus or drop down preferences. Wifi connects so I'm in the process of restoring profile and setup to see what happens - what works what doesn't. I was able to login to my Skype account but I don't know how to set the call preferences w/o a drop down menu. . . hmmm.

    EDIT: whoops! Just to double check, I decided to reboot into Ubuntu (Maverick) and redoctor to rule out any Win(x64) java weirdness and now the phone won't come back. . . hmmHMM.

    EDIT2: 3rd Dr Brought the phone back, NOW I'm restoring.

    EDIT3: Installed Preware; Installed Impostah; Installed Save/Restore; Restored Profile via wifi > Restart > Penguin > Happy Chime & light flash > HP logo stuck @ half glow > NOW I'm gonna eat. . .
    Great... Ok know why the rom verify failed... the PRE2 modules
    pmmultitouchlib camd-omap36xx camsrc-omap36xx pmmedia-omap36xx tisgxgfx-roadrunner
    need to be deleted...
    the PREPLUS ones are
    cypress-multitouch camd-omap34xx camsrc-omap34xx pmmedia-omap34xx tisgxgfx...

    So a few things I can try one is rename the existing module files from PREPLUS to PRE2, which would allow the verify to work... or I can see if the Makefile process will prune the files so that the PRE2 go away, and the PREPLUS stay...

    First one I will try is the Makefile prune
    Second will be the rename...

    I am happy we boot... Progress... indeed...

    Script Updated on Page 216 (4th version) to fix ROM verification, Makefile can not prune files... Rod maybe you can add a DELETE_EXTRA or something to prune files (would be a .list format that the script can supply?)
    Last edited by John Steffes; 12/25/2011 at 02:18 PM. Reason: 4th version of crazy script post on page 216 to fix rom verification issues...
  5. #4305  
    Awesome - ready to try 4th version after guests depart. . .!
  6. #4306  
    So I've run the last script and while it failed to reset, the error codes look somewhat more positive like this:
    INFO: ROM Verifyer: Starting Check of ROM

    Dec 25, 2011 7:50:09 PM com.palm.nova.installer.recoverytool.CardController logPrint
    INFO: ROM Verifyer: ./etc/camd/vx6953-load-firmware: ADDED

    (More Attached.)

    'ADDED' sounds better than 'FAILED'

    The phone starts up faster than the previous tries but there still is no response from the topbar and no way to access preferences on any apps. That renders it pretty much unusable for any length of time. This seems like the main impediment to success from a user point of view.

    The GUI just isn't functional as is since there is total lack of access to the configuration screens of all apps without a top bar drop down menu. So even though it boots after a battery pull when the doctor fails, I can't get into any configurations, e.g., preferences in Preware. No camera either, btw, it won't open.

    A couple other things I noticed: the timestamps report being "in the future" often when the doctor is running, and when I was poking around in the webos.tar file of the doctor, the files in the ./boot/ directory were duplicated - I'm not really sure I know how that's even possible - in other words, there are two "config-2.6.24-palm-joplin-3430" files etc. - this is true of each of the files in the ./boot/ directory of the "nova-cust-image-castle.rootfs.tar.gz" inside the webos.tar file inside of the doctor file.

    Seems so close. . . .

    Attached Files Attached Files
  7. #4307  
    Quote Originally Posted by kayphoonstar View Post
    So I've run the last script and while it failed to reset, the error codes look somewhat more positive like this:
    INFO: ROM Verifyer: Starting Check of ROM

    Dec 25, 2011 7:50:09 PM com.palm.nova.installer.recoverytool.CardController logPrint
    INFO: ROM Verifyer: ./etc/camd/vx6953-load-firmware: ADDED

    (More Attached.)

    'ADDED' sounds better than 'FAILED'

    The phone starts up faster than the previous tries but there still is no response from the topbar and no way to access preferences on any apps. That renders it pretty much unusable for any length of time. This seems like the main impediment to success from a user point of view.

    The GUI just isn't functional as is since there is total lack of access to the configuration screens of all apps without a top bar drop down menu. So even though it boots after a battery pull when the doctor fails, I can't get into any configurations, e.g., preferences in Preware. No camera either, btw, it won't open.

    A couple other things I noticed: the timestamps report being "in the future" often when the doctor is running, and when I was poking around in the webos.tar file of the doctor, the files in the ./boot/ directory were duplicated - I'm not really sure I know how that's even possible - in other words, there are two "config-2.6.24-palm-joplin-3430" files etc. - this is true of each of the files in the ./boot/ directory of the "nova-cust-image-castle.rootfs.tar.gz" inside the webos.tar file inside of the doctor file.

    Seems so close. . . .

    Ok 5th attempt to fix ROM verification issues, added compcache module now 6th... posted on page 216...
    Last edited by John Steffes; 12/26/2011 at 08:30 AM. Reason: Updated from 5th to 6th...
  8. #4308  
    Quote Originally Posted by John Steffes View Post
    Ok 5th attempt to fix ROM verification issues, added compcache module now 6th... posted on page 216...
    This looks good:

    INFO: Flash End time (Success)1324921019668

    Boots up fine but NO touchscreen response at all! Keyboard brings response input is recognized.

    I'll drop back it back to another version just to be sure it isn't something in the hardware. Another issue I've noticed is that, on a completely empty USB drive it was only reporting 4.6 GB free.

    UPDATE: Touchscreen fine - Device info still reporting 4.6 GB.
    Last edited by kayphoonstar; 12/26/2011 at 12:32 PM.
  9. #4309  
    Quote Originally Posted by kayphoonstar View Post
    This looks good:

    INFO: Flash End time (Success)1324921019668

    Boots up fine but NO touchscreen response at all! Keyboard brings response input is recognized.

    I'll drop back it back to another version just to be sure it isn't something in the hardware. Another issue I've noticed is that, on a completely empty USB drive it was only reporting 4.6 GB free.

    UPDATE: Touchscreen fine - Device info still reporting 4.6 GB.
    Ok the next phase, now we got it to boot, we got some functionality... now it is time to remove modules... There were a 86 modules plus 4 added for functionality... So in the build there are 90 modules that are extracted from the PREPLUS and put into the PRE2 TAR. These are too many... need to have help here...

    Need to have someone remove a module from the PREPLUS extract, and remove that same module from PRE2 side. leaving the the rest... Build a doctor, and slam device... which modules are needed? Which are not... I have some notes I will attach (page 216) with which modules differ, which are the same and which ones are different because of hardware differences...

    I am assuming (similar hardware) some of the PRE2 modules will work on the PREPLUS...

    This is where more people need to get involved... as it will take a long time for someone to remove a module and slam and test...

    Once we come up with which modules we need to go from PREPLUS to PRE2 and which modules can stay at PRE2, I think we will get full functionality...

    I am assuming any modules that is kernel related, or that has device drivers or kernel modules (.ko) will have to stay... But we need to test each and every module one at a time... Also if removing a module which we prune files, a remark needs to be put in front of the remove from the custom WEBOS tar.

    Anyone who has the time, let me know we can put together another thread dedicated just to this phase...
    Last edited by John Steffes; 12/26/2011 at 06:51 PM.
  10. #4310  
    My Pre+ seems to have quite a bit of life left in it - if just for the sake of turning it into a wifi only Skype phone, 2.2.4 seems worth the effort!
  11.    #4311  
    Quote Originally Posted by John Steffes View Post
    OK.... I have gone crazy...
    Was playing with WEBOS 2.2.4 Kernel, copied it to WEBOS 2.1.0 PRE2 worked... thought try something else...
    Copied WEBOS 2.1.0 Kernel to WEBOS 2.2.4 PRE2 worked...

    All of this untested to a palm profile, just wanted to see if it would boot... it did...

    Now what if I take WEBOS.TAR, remove the WEBOS 2.2.4 Kernel PRE2, and put WEBOS 2.1.0 Kernel PRE+ in instead would it work....

    Ok not for faint at heart.... please no real phones, only a developer phone that can be re-doctored many times....

    Here is a script that does this... Does it work.... HAVE NOT TESTED on Pre+... But it builds a doctor with no errors... Does anyone want to try.... (PLEASE do not do this on your only device)... Have heard you can not BRICK a PRE+ but... this script might... Any test Verizon Pre+ devices anyone has to test this CRAZY script?

    Any Developers out there who can look at the script and tell me if it would work, or what I could do to make it work?

    First test yeilded trenchcoat issues, included new version to include older trenchcoat in the build.

    Second test yielded issues with booting beyond Kernel...

    Third times a charm? Compared 86 modules between PRE2 and PRE3 (2.2.4) and back ported to script... Assuming if there are 86 modules different between PRE2 and PRE3 then modifying those from PRE2 to PREPLUS should yield?

    Third time was a charm, we have boot... we had rom verification issues fourth update should fix that...

    Fifth Update to fixed rom verification added issues...
    Sixth Updated added CompCache...

    Sixth Script works, builds PRE+ with WebOS 2.2.4, but not all functionality is there...

    Added modules.txt.zip so that anyone who wants to assist in finding which modules need to be copied...
    I have moved the Meta-Doctor to GitHub so that your prodigious contributions can be incorporated more easily by sending me a pull request.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  12. #4312  
    Quote Originally Posted by rwhitby View Post
    I have moved the Meta-Doctor to GitHub so that your prodigious contributions can be incorporated more easily by sending me a pull request.

    -- Rod
    Thanks for that, I also created a new thread under pre/pre+ called

    WebOS 2.2.4 on Palm Pre+ or Pre...

    Time to stop hi-jacking your thread and create a new one...
    Last edited by John Steffes; 12/26/2011 at 06:23 PM. Reason: Added URL for new thread...
  13. #4313  
    Can you share manual instructions for recreating the function of the getbt script? Unfortunately it looks like the git server for metadoctor is down, so I can't install it at the moment.

    UPDATE: I see it's now hosted on github, though the wiki needs to be updated to reflect the new URL.
    Last edited by onlinespending; 01/10/2012 at 11:42 AM.
  14.    #4314  
    Quote Originally Posted by onlinespending View Post
    Can you share manual instructions for recreating the function of the getbt script? Unfortunately it looks like the git server for metadoctor is down, so I can't install it at the moment.

    UPDATE: I see it's now hosted on github, though the wiki needs to be updated to reflect the new URL.
    Which wiki page needs updating?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  15. #4315  
    Quote Originally Posted by rwhitby View Post
    Which wiki page needs updating?

    -- Rod
    I think this might need to be changed (not sure how to change it and also not sure if I am correct about the need for a change) bellow is from the webos 2 upgrade wiki

    Sprint Franken Unlocked Pre 2
    Be aware that there is no publicly available solution for Sprint Navigation or Sprint PRL Update for this procedure. If you depend on either of those things, you should not upgrade to webOS 2.x
    NOTE: Tokens are no longer needed to create a Sprint Franken Unlocked Pre 2. You only need to run the script below. However, it is still a good idea to capture and store the tokens from each phone for potential future use.
    ./scripts/meta-sprint-franken-unlocked-pre2-2.2.4
    You will end up with version 2.2.4 listed in your palm profile, and version 2.2.4 listed in the Device Info application.
    You should be able to purchase apps that require a minimum webOS 2.x version (depending upon geo-restrictions and country of first activation).
    The "Voice Dial" app may not work. Please see the Voice Dialing section below to remedy this.
    Sprint Franken Verizon Pre 2
    Be aware that there is no publicly available solution for Sprint Navigation or Sprint PRL Update for this procedure. If you depend on either of those things, you should not upgrade to webOS 2.x
    NOTE: Tokens are no longer needed to create a Sprint Franken Verizon Pre 2. You only need to run the script below. However, it is still a good idea to capture and store the tokens from each phone for potential future use.
    ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
    You will end up with version 2.2.4 listed in your palm profile, and version 2.2.4 listed in the Device Info application.
    You should be able to purchase apps that require a minimum webOS 2.x version (depending upon geo-restrictions and country of first activation).


    it shows to type in ./scripts/meta-sprint-franken-unlocked-pre2-2.2.4 or ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
    this does not work for me.

    when I type in ls ./scripts/ this is listed meta-sprint-franken-unlocked-pre2-2.1.0 or meta-sprint-franken-verizon-pre2-2.2.1.0
    What does this button do?


    crappy phones -->treo 600--> 700p--> 755p--> Pre--->Pre- 2.1 F104-----Franken Pre+ 2.1 f105 ---> Franken pre2 2.2.4
    touchpad 16gig uberkernel woop woop!!!
  16.    #4316  
    Quote Originally Posted by loopytee View Post
    I think this might need to be changed (not sure how to change it and also not sure if I am correct about the need for a change) bellow is from the webos 2 upgrade wiki

    Sprint Franken Unlocked Pre 2
    Be aware that there is no publicly available solution for Sprint Navigation or Sprint PRL Update for this procedure. If you depend on either of those things, you should not upgrade to webOS 2.x
    NOTE: Tokens are no longer needed to create a Sprint Franken Unlocked Pre 2. You only need to run the script below. However, it is still a good idea to capture and store the tokens from each phone for potential future use.
    ./scripts/meta-sprint-franken-unlocked-pre2-2.2.4
    You will end up with version 2.2.4 listed in your palm profile, and version 2.2.4 listed in the Device Info application.
    You should be able to purchase apps that require a minimum webOS 2.x version (depending upon geo-restrictions and country of first activation).
    The "Voice Dial" app may not work. Please see the Voice Dialing section below to remedy this.
    Sprint Franken Verizon Pre 2
    Be aware that there is no publicly available solution for Sprint Navigation or Sprint PRL Update for this procedure. If you depend on either of those things, you should not upgrade to webOS 2.x
    NOTE: Tokens are no longer needed to create a Sprint Franken Verizon Pre 2. You only need to run the script below. However, it is still a good idea to capture and store the tokens from each phone for potential future use.
    ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
    You will end up with version 2.2.4 listed in your palm profile, and version 2.2.4 listed in the Device Info application.
    You should be able to purchase apps that require a minimum webOS 2.x version (depending upon geo-restrictions and country of first activation).


    it shows to type in ./scripts/meta-sprint-franken-unlocked-pre2-2.2.4 or ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
    this does not work for me.

    when I type in ls ./scripts/ this is listed meta-sprint-franken-unlocked-pre2-2.1.0 or meta-sprint-franken-verizon-pre2-2.2.1.0
    Make sure you have the latest version of the meta-doctor. You probably need to git pull, or perhaps migrate from the old clone location to the new clone location on github.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. #4317  
    Quote Originally Posted by rwhitby View Post
    Make sure you have the latest version of the meta-doctor. You probably need to git pull, or perhaps migrate from the old clone location to the new clone location on github.

    -- Rod

    git pull does not seem to work for me I get this error returned
    fatal: The remote end hung up unexpectedly

    mac os 10.5.8 and github is not available for mac 10.5.8 only 10.6 and above
    What does this button do?


    crappy phones -->treo 600--> 700p--> 755p--> Pre--->Pre- 2.1 F104-----Franken Pre+ 2.1 f105 ---> Franken pre2 2.2.4
    touchpad 16gig uberkernel woop woop!!!
  18. #4318  
    I'm actually trying to franken pre2 a verizon pre2 I just bought today off a guy.
    What does this button do?


    crappy phones -->treo 600--> 700p--> 755p--> Pre--->Pre- 2.1 F104-----Franken Pre+ 2.1 f105 ---> Franken pre2 2.2.4
    touchpad 16gig uberkernel woop woop!!!
  19. #4319  
    when I type in ./scripts/meta-sprint-franken-unlocked-pre2-2.1.0

    It will build the doctor
    What does this button do?


    crappy phones -->treo 600--> 700p--> 755p--> Pre--->Pre- 2.1 F104-----Franken Pre+ 2.1 f105 ---> Franken pre2 2.2.4
    touchpad 16gig uberkernel woop woop!!!
  20.    #4320  
    Quote Originally Posted by loopytee View Post
    git pull does not seem to work for me I get this error returned
    fatal: The remote end hung up unexpectedly

    mac os 10.5.8 and github is not available for mac 10.5.8 only 10.6 and above
    Github is a site, not an app.

    -- Rod

Posting Permissions