Page 212 of 217 FirstFirst ... 112162202207208209210211212213214215216217 LastLast
Results 4,221 to 4,240 of 4324
Like Tree19Likes
  1. #4221  
    Not that good with Ubuntu but generally techy !

    However when I try to follow the commands for installing MetaDoctor I just get

    E:Malformed line 61 in source list /etc/apt/sources.list (dist parse)
    E:The list of sources could not be read.

    I am running as administrator - but then I'm not sure how to add another user or run as another use.

    I think I have checked spelling and everything is OK so can't see what else to do.

    I think I have the 64 bit version and got the latest version from the ubuntu web site.
  2. #4222  
    guys,
    i'm from india and i have a unlocked version of ATT pre plus..
    so can i install webos 2.0 on my pre plus with the meta doctor thing?
    please guide me !
  3. #4223  
    Quote Originally Posted by John Steffes View Post
    So took the PRE2 build from Verizon, adds the new version of Voice Dial from ATT (2.1.2), new flash from Touchpad (3.0.2) with portions updated from ATT (2.1.2), and ENYO framework from PRE3 (2.2.0).

    Thanks
    So is adding possible to Pre2 2.1 unlocked also, perhaps even adding Skype from Pre3 2.2 unlocked?

    Quote Originally Posted by schlk21 View Post
    With the recent Pre 3 doctors now available, is getting v2.2 on a Pre+ or Pre 2 possible?
    well this would be even better, but perhaps more difficult.
  4. #4224  
    Looking at the 2.2.x Dr. the entire phone app is upgraded to Enyo with Skype integrated. Copying the Skype ipk from 2.2.x does not add Skype to Webos 2.1.0 that is the reason I used the Verizon Skype for Verizon devices. One can copy the Verizon Dr., metadoctor it to work on a non-Verizon device (unlocked pre2/pre plus). I have a Pre2 and a Pre+ and both are Verizon devices and Skype works on both. I can not say if just having the Verizon dr. with the 2.1 Skype will work, but it is worth the try. FYI the maps released in the app catalog also now included Enyo (did not validate if the framework changed from webos 3.0.0, or 3.0.2, or 2.2.0, or 2.2.3 (att or Verizon) assume all are same 1.0 version. To keep Google Maps and Bing Maps, once I installed maps from catalog, use internalz pro to change the appinfo.json under /media/crypto/.../app../com.palm.app.maps change the name from Maps to Bing Maps and the app id to something like com.palm.app.bingmaps and restart luna and you will see both Google Maps and Bing Maps. Now I can't say this will work with the standard Dr. (without Enyo) as I have my meta Dr. installed on my PRE2 and PRE+ (which already include Enyo), but when I installed maps it did not require a reboot and worked just fine.
  5. #4225  
    I just got my VZW Palm Pre+ metadoctored to WebOS 2.1.0.

    Everything seems to be working. I'm able to download/purchase applications from the App Catalog. I've installed Preware and loaded Uberkernel.

    I was able to download Angry Birds out of the App Catalog as I already owned it. However I'm not seeing Angry Birds Seasons or Rio in the App Catalog. I see the *free* versions, but not the full versions that I've already paid for.

    Is this a profile issue?

    I've tried searching for the App Catalog links via Google, but when I try to open them it says that it's not available for my model..
  6. #4226  
    Quote Originally Posted by eXceLon View Post
    I just got my VZW Palm Pre+ metadoctored to WebOS 2.1.0.

    Everything seems to be working. I'm able to download/purchase applications from the App Catalog. I've installed Preware and loaded Uberkernel.

    I was able to download Angry Birds out of the App Catalog as I already owned it. However I'm not seeing Angry Birds Seasons or Rio in the App Catalog. I see the *free* versions, but not the full versions that I've already paid for.

    Is this a profile issue?

    I've tried searching for the App Catalog links via Google, but when I try to open them it says that it's not available for my model..
    No Rovio updated them to PRE2, VEER, PRE3 status... so unless you have a device ID of one of those you will not see it in the catalog, however, if one has a device that meets the download device requirement one can copy the ipk (or the extracted) to the Pre+ with 2.1.0 and it will work just fine...

    Seems Rovio thinks 2.1.0 is only for EU (as it really is) and as those of us who are in the US have 2.1.0 (metadoctored) they don't count us.

    So the new updated games were designed around 2.1.0, as no US carrier will release 2.X for legacy Palm devices (even though they have the code and could if they wanted to) but then who would buy the latest smartphone, if the one you bought last year is updated to the latest OS... Seems to be a stand off, the developer could state 2.1.0 (instead of 1.4.5) and could offer on PRE line (as it does work)...

    But then some developers are ok with metadoctored devices, and some only want to do things by the book.... no US WEBOS 2.X on legacy Pre devices, so no angry birds update...
  7. #4227  
    Thanks for the information. I guess I didn't do my research well enough.

    I thought that this would get me the version of WebOS that was running on the VZW Pre2. Looking around a bit, I guess the US Pre2 is still officially on 2.0 rather than 2.1?

    That's disappointing, since the primary reason that I wanted to do this was because new applications and app updates weren't being released for the 1.4.5.1 version. Most notably I couldn't get anymore updates for Angry Birds Rio and Angry Birds Seasons. Now I can't get them at all...

    Are there meta-doctor scripts to get whatever version the VZW Pre2 is running onto my Pre Plus? What actual difference in functionality is there between WebOS 2.0.x and 2.1.x?
  8. #4228  
    Quote Originally Posted by eXceLon View Post
    Thanks for the information. I guess I didn't do my research well enough.

    I thought that this would get me the version of WebOS that was running on the VZW Pre2. Looking around a bit, I guess the US Pre2 is still officially on 2.0 rather than 2.1?

    That's disappointing, since the primary reason that I wanted to do this was because new applications and app updates weren't being released for the 1.4.5.1 version. Most notably I couldn't get anymore updates for Angry Birds Rio and Angry Birds Seasons. Now I can't get them at all...

    Are there meta-doctor scripts to get whatever version the VZW Pre2 is running onto my Pre Plus? What actual difference in functionality is there between WebOS 2.0.x and 2.1.x?
    The Verizon Palm Pre+ is stuck at 1.4.5.1 (although, Verizon has 2.1.0 they will not release it, I was told because they wanted people to upgrade to the PRE2, seems silly to give someone a two year contract, then drop support after a year..., assuming someone would add a PRE2 to get the latest version before their contract was up).

    The Verizon Palm Pre2 is currently at 2.1.0 (although, I have heard rumors they were to support 2.2.X but now that we are is this unknown situation, who knows...)

    Now although WebOS 2.1.0 is the same version it is not the same binary bits, there are differences in the kernels and the palm application files... So a PRE2 WebOS 2.1.0 is not the same as a PRE+ WebOS 2.1.0, even though they are the same version.

    But this is not what is stopping you from getting the updated version of the games you want, that is because the developer decided when selecting which devices the games would work on they choose PRE2, VEER, and PRE3, ignoring the fact that someone could have metadoctored WebOS 2.1.0 onto their US PRE+.

    To fix this the developer would have to select PRE as a device with WebOS 2.1.0. This would allow the game to work and would prevent the 1.4.5.1 users from getting it. However, as they seem to be playing by the book, as no US carriers release WebOS 2.1.0 (even thought we know it works, not as good as a PRE2, VEER, or PRE3, but it still works).

    The last reason I had heard why they (Rovio) were not releasing updates, was that Palm was not releasing an updated firmware (WebOS 2.1.0) to the US market, which was nothing to do with Palm but the carriers (Sprint, Verizon, & ATT), that seemed to drop support from their customers. So when the VEER on ATT and the non-supported carriers PRE3 (on Verizon and ATT) had WebOS 2.1.2 and 2.2.3, they could then release the updated games.

    So to fix this we could all contact Verizon, Sprint, and ATT and complain to the highest rep that we demand them to support WebOS 2.1.0 on the Pre+/Pre (that is not going to happen), or we all contact Rovio to update their software to work on the PRE line with WebOS 2.1.0 knowing that the US market did not release it....

    Again, I think that will not happen either... then the best I can suggest, is with a PRE2, VEER, and PRE3 owner who owns the game, can then copy the game to their PRE as you own the phone and the game and by all legal rights (DMCA) for fair use, as with the touchpad on the same account it also had the same games...

    Sorry to confuse you on this, hope that clears this, it is because of the device lock on the game not the version of WebOS.
    Last edited by John Steffes; 10/15/2011 at 03:26 PM.
  9. #4229  
    Thanks for the clarification. I take it that no one has come up with a way to spoof the device type for the App Catalog? Make it think I'm running a Pre2 w/ WebOS 2.1.0?

    It's unfortunate that HP/Palm has abandoned so many users such that we're forced to jump through so many hoops to make our devices reasonably functional.
  10. #4230  
    Quote Originally Posted by fremen567 View Post
    I also thought this would be an issue with my German O2 pre- that is being used on non-supported carrier.
    I can confirm for you that you can change/input settings manually. Sign in with ur profile and wait for it to "see" that you don't have active data and it'll give you option to enter setting for ur carrier. It accepted settings for my carrier, and it wouldn't do that on 1.4.5.
    Hope this helps.


    Sent from my Galaxy S using Tapatalk
    Hi, I have the issue but in Spain with the Virtual Mobile Operator (VMO) SIMYO and YOIGO. I cant connect to access my profile as the carriers are not in the DB but on the second attempt to check my profile email, I am given the option of entering the carrier details manually.
    However, when I enter those for SIMYO apn="gprs-service.com", User="", Password= "" o "1234" I get the error "APN invalid" but the response time is so quick I suspect it not resolving the URL or something.
    Can someone pls advise what "BYPASS_ACTIVATION" and "BYPASS_FIRST_USE_APP" in the O2 script do specifically?
    I’m hoping that if set "BYPASS_FIRST_USE_APP=1", setup WiFi/WEP and run the gesture tutorial, I should be able to create/ recover my profile over WiFi..
    One other issue is that the phone has the “R” for roaming even though the network MCC is the same as the SIM (214). So the Pre doesn’t check the network, rather it must have the O2/UK country code set in a script somewhere. Can this be set to detect the SIM value or changed to Spain 214?

    WORK AROUND: entered DEVMODE and after luna reset could bypass the activation page. I then added the carrier manually to the database and did a full erase to get back to the activation page. This time I could use the 3G data service..
    Last edited by palmprespain; 10/28/2011 at 09:54 AM.
  11. #4231  
    How well-tested is the meta-verizon-franken-unlocked-pre2-2.1.0 script lately? I have made many builds of this using Ubuntu 11.04 and from it, I keep getting a phone that restarts too often to finish the sync and sometimes loses its login settings requiring me to sign in again. This is both with my main profile and with a new empty palm profile.

    Of course, it could be that I have a lemon pre2 (I had no sim card to test it beforehand), but the franken procedure seemingly went well on my end.
    Last edited by PickleFart9; 10/25/2011 at 06:29 AM. Reason: Stuck comm board back in the original pre, works. Could still be a lemon pre2, but it isn't the comm board at least.
  12. #4232  
    hello i'm running webos 2.1.0 currently on my palm pre plus, and i was just wondering if it is at all possible to get the unlocked version of 2.1 on my pre plus?
  13. #4233  
    Today webOS 2.2.4 for Pre 2 came out. Is it possible to install this version on a Pre- with this method?

    EDIT: Twitter account @webosinternals just answered my question: "Updates for Pre 2 will not work as-is on Pre or Pre+, due to kernel differences."
    Last edited by Seddy; 12/09/2011 at 05:15 AM.
  14. #4234  
    I have asked this before, as linux is linux...

    If one were to take the doctor (which is not yet released) for 2.2.4 and were to have the source code for the kernel, which it would (as WEBOSINTERNALS makes kernels available in PREWARE), Let just ask the question (I have asked before and nobody wanted to try)...

    Compile a meta-doctor which would start with the PRE2, remove the PRE2 kernel, swap out a re-compiled (from PRE2 source) PRE+/PRE kernel - (which then would have all the right hooks), and put that in the new meta-doctor... I have not tested this, but in theory it should work... as the uber-kernel works with PRE2 and a uber-kernel works with PRE+/PRE, assuming the kernel had all the same things as the PRE2 but compiled for the PRE+/PRE. Now this is just a theory, and I have suggested this before, but nobody wanted to test it... I have built many linux boxes, from Intel 286 to Intel XEON, from AMD 386 to AMD Turion, once you have the right hooks, all GNU tools worked (provided they were compiled on the right CPU chip)...

    Assuming WEBOS does get full open-sourced, what harm would it bring to test this theory? I assume the reason to not test is NDA and if it was not released on one device then it should not be developed, but from the PIXI, VEER, and now HTC, seems that a few have tried and succeeded in some way to get it to boot.

    Sorry for the long post, but want to know what Rod and others think, would this work, or better yet, tell me why it won't work...

    Check this out:

    WebOS 2.2.4 on Palm Pre+ or Pre...
    Last edited by John Steffes; 01/06/2012 at 02:41 PM. Reason: Added URL... for Pre2 image to work on a Pre/PrePlus
  15. #4235  
    For those of us who have Skype Mobile (Pre+/Pre2 with webOS2.1.0) and are on Verizon Wireless...
    I also created a getbt script (this script requires the meta-doctor Application:MetaDoctor - WebOS Internals)... this script will create a tar called bt.tar... extract this tar and copy it to /media/internal/bt...

    Use novaterm, if you do not know how to do this then don't.
    Make sure BlueTooth is not enabled, this process will remove the existing BlueTooth profile database...
    Then make sure your file system is read/write and be at the root (/)...

    mount -o remount,rw /
    mv /usr/bin/BluetoothMonitor /usr/bin/BluetoothMonitor.old
    mv /usr/bin/PmBtStack /usr/bin/PmBtStack.old
    mv /var/preferences/com.palm.bluetooth/prefsDB.sl /var/preferences/com.palm.bluetooth/prefsDB.sl.old
    rm -rf /usr/palm/applications/com.palm.app.bluetooth/resources/en/ie
    cp -r /media/internal/bt/* ./
    reboot

    Go back into novaterm as these files are no longer needed:

    mount -o remount,rw /
    rm -rf /usr/bin/BluetoothMonitor.old /usr/bin/PmBtStack.old /var/preferences/com.palm.bluetooth/prefsDB.sl.old
    exit

    Start BlueTooth it will take a long time the first time...
    Stop BlueTooth - my phone locked up...
    Reboot (had to pull the battery)...
    Start BlueTooth... sync with touchpad... MAP works on 2.1.0 on Pre+ and Pre2....

    If you see the unable to connect messaging (MAP) profile then there might be a profile issue on both devices, deleting both preference files (on touchpad and phone) and re-setting up both BlueTooth profiles might fix this, use novaterm on both devices and type:

    mount -o remount,rw /
    mv /var/preferences/com.palm.bluetooth/prefsDB.sl /var/preferences/com.palm.bluetooth/prefsDB.sl.old
    exit

    Once both devices are re-setup, go to the BlueTooth preferences for the Touchpad device on the Phone, select off (turn off) for Mirror SMS, exit preferences, then go back into preferences for the Touchpad device on the Phone, select on (turn on) Mirror SMS.

    If this fixes your issue you can then use novaterm on both devices and remove the .old files:

    mount -o remount,rw /
    rm -rf /var/preferences/com.palm.bluetooth/prefsDB.sl.old
    exit

    To revert to original BlueTooth files use the following scripts below and use the previous procedure with the bt.tar created:
    getbt-vzw2.1.0 - script to pull WebOS 2.1.0 Bluetooth files for restore to original files... (non-MAP Stock Verizon Build 124)
    getbt-o22.1.0 - script to pull WebOS 2.1.0 Bluetooth files for restore to original files... (non-MAP Stock O2 Build 285)
    Attached Files Attached Files
    Last edited by John Steffes; 07/14/2012 at 09:20 PM. Reason: Updated Scripts HP/Palm changed the Source URL
  16.    #4236  
    Quote Originally Posted by John Steffes View Post
    I created a Verizon Pre 2 2.2.4 Script... Have not tested it, so would like some one to test it, or Rod if you want you can add it to the meta-doctor list...
    mv: rename build/test-verizon-pre2-2.2.4/rootfs/usr/lib/ipkg/info/com.motionapps.rom.classic.md5sums to build/test-veri\
    zon-pre2-2.2.4/rootfs/usr/lib/ipkg/info/com.motionapps.rom.classic.md5sums.old: No such file or directory
    cat: ./usr/lib/ipkg/info/com.motionapps.rom.classic.list: No such file or directory

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17.    #4237  
    Added the updated test-verizon-pre2-2.2.4 script to the meta-doctor.

    https://twitter.com/webosinternals/s...11361963876353

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  18. ght
    ght is offline
    ght's Avatar
    Posts
    772 Posts
    Global Posts
    886 Global Posts
    #4238  
    Quote Originally Posted by John Steffes View Post
    I created a Verizon Pre 2 2.2.4 Script... Have not tested it, so would like some one to test it, or Rod if you want you can add it to the meta-doctor list...

    For those of us who have Skype (Pre+/Pre2 and 2.1.0) and are on Verizon...
    I also created a getbt script... this script will create a tar called bt.tar... extract this tar and copy it to /media/internal/bt...

    Use Novaterm, if you do not know how to do this then don't.
    Make sure bluetooth is not enabled...
    Then make sure your file system is read/write and be at the root (/)...
    mv /usr/bin/BluetoothMonitor /usr/bin/BluetoothMonitor.old
    mv /usr/bin/PmBtStack.old /usr/bin/PmBtStack.old
    cp -r /media/internal/bt/* ./
    reboot phone
    go back into Novaterm and rm -rf /usr/bin/BluetoothMonitor.old /usr/bin/PmBtStack.old
    exit Novaterm
    Start BlueTooth it will take a long time the first time...
    Stop BlueTooth - my phone locked up...
    Reboot (had to pull the battery)...
    Start BlueTooth... sync with touchpad... MAP works on 2.1.0 on Pre+ and Pre2....
    Trying to run the getbt script, but I must be missing something. I've run metadoctor scripts before, but I'm still a linux newb. Here's what I'm seeing in terminal:

    tintigab@ubuntu:~/meta-doctor$ ./scripts/getbt
    [ -d build/pre2-p224pre2-wr-2.2.4/rootfs/usr/lib/ipkg/info ]
    make: *** [extract-rootfs-ipkgs] Error 1

    What am I missing (or doing wrong)?
  19. #4239  
    Quote Originally Posted by John Steffes View Post
    I created a Verizon Pre 2 2.2.4 Script... Have not tested it, so would like some one to test it, or Rod if you want you can add it to the meta-doctor list...

    For those of us who have Skype (Pre+/Pre2 and 2.1.0) and are on Verizon...
    I also created a getbt script... this script will create a tar called bt.tar... extract this tar and copy it to /media/internal/bt...

    Use Novaterm, if you do not know how to do this then don't.
    Make sure bluetooth is not enabled...
    Then make sure your file system is read/write and be at the root (/)...
    mv /usr/bin/BluetoothMonitor /usr/bin/BluetoothMonitor.old
    mv /usr/bin/PmBtStack.old /usr/bin/PmBtStack.old
    cp -r /media/internal/bt/* ./
    reboot phone
    go back into Novaterm and rm -rf /usr/bin/BluetoothMonitor.old /usr/bin/PmBtStack.old
    exit Novaterm
    Start BlueTooth it will take a long time the first time...
    Stop BlueTooth - my phone locked up...
    Reboot (had to pull the battery)...
    Start BlueTooth... sync with touchpad... MAP works on 2.1.0 on Pre+ and Pre2....
    I want to try this but I just want be sure I'm clear on what I'm doing.

    Should this line "mv /usr/bin/PmBtStack.old /usr/bin/PmBtStack.old"
    be "mv /usr/bin/PmBtStack /usr/bin/PmBtStack.old" ?
  20. #4240  
    Quote Originally Posted by GHT View Post
    Trying to run the getbt script, but I must be missing something. I've run metadoctor scripts before, but I'm still a linux newb. Here's what I'm seeing in terminal:

    tintigab@ubuntu:~/meta-doctor$ ./scripts/getbt
    [ -d build/pre2-p224pre2-wr-2.2.4/rootfs/usr/lib/ipkg/info ]
    make: *** [extract-rootfs-ipkgs] Error 1

    What am I missing (or doing wrong)?
    I think you need to run the other script first - "test-verizon-pre2-2.2.4", then the getbt script can extract just the bt files from the jar that's created in /builds.

Posting Permissions