Page 18 of 217 FirstFirst ... 813141516171819202122232868118 ... LastLast
Results 341 to 360 of 4324
Like Tree19Likes
  1. #341  
    Quote Originally Posted by rwhitby View Post
    Leathal (and others using the masquerade method):

    We have determined by experiment that you can replace the /etc/palm-build-info with the correct contents for 2.1.0 after you log into your profile. Do this on the running device and then reboot.

    This allows Preware and other apps to know they are running on 2.x, and allows access to everything in the app catalog except for applications marked "minimum version 2.0". Still thinking about what we do for those.

    -- Rod
    About doing this Rod, what would be the best way?

    Internalz does not work on webOS 2.0 currently due to the NDA. Does the OpenSSH app in Preware install on 2.x? or is there another way to set up SSH?
    screwdestiny
    PSN Twitter Last.FM
  2. drvon#AC's Avatar
    Posts
    67 Posts
    Global Posts
    72 Global Posts
    #342  
    Quote Originally Posted by idontwan2know View Post
    2) Someone in the thread has mentioned possibly writing a script, which if it were specific enough, would make it *relatively* simple but would probably only work for one specific carrier/device/webOS version configuration. A script would have to be written for each instance, so it would be a question of whether anybody with the necessary skills felt it was worth their time.

    3) Yes. It is illegal to redistribute modified doctor versions. All webOS Internals can do is give you instructions on how to modify the doctor for your particular configuration.

    4) Probably at some point. However, a lot of things need to be tested before it gets to that stage and Rod has already mentioned the possibility of making some changes to the metadoctor that would have to be completed before a final guide could be created.

    Note: I'm not a member of webOS Internals and don't speak for them. Just trying to answer some of the more basic questions.
    Thanks so much for the reply!
  3. #343  
    Hey guys.

    One quick question, I'm trying to install this on a Sprint Pre, which doctor is the one we are supposed to metaDoctor, the O2 or Vodafone?

    Oh and does any one has a link on how to flash the Verizon pre2 modem? or any general guide?

    Thanks in advance
  4. Kujila's Avatar
    Posts
    400 Posts
    Global Posts
    401 Global Posts
    #344  
    I've read through the thread, but I'm a bit confused - Will the Sprint Pre- get phone service without including CMDA firmware, or can I Meta Doctor without scavenging VZW files?
  5. #345  
    Quote Originally Posted by Kujila View Post
    I've read through the thread, but I'm a bit confused - Will the Sprint Pre- get phone service without including CMDA firmware, or can I Meta Doctor without scavenging VZW files?
    You will get phone service, but you won't get texts to work and you'll get a popup claiming "Call was dropped" every time you end a call...
  6. #346  
    Rod,

    Is it possible for you to update the OP with a list of where you're at? What works, what doesn't on Sprint Pre Minus? I (and I'm sure I'm not alone), haven't been able to sit here hitting F5 for the past 5 or so hours and am now kinda lost. :-\


    M.
  7. Kujila's Avatar
    Posts
    400 Posts
    Global Posts
    401 Global Posts
    #347  
    Thanks for the reply; I'll hold off until we find a workaround, then, since I actually need to use the phone.
  8. #348  
    Quote Originally Posted by Kujila View Post
    I've read through the thread, but I'm a bit confused - Will the Sprint Pre- get phone service without including CMDA firmware, or can I Meta Doctor without scavenging VZW files?
    No. You need the updated CDMA firmware from the VZW Pre2/webOS 2.0.x doctor so that webOS 2 can talk to the modem. There is a "CDMA" package in the 2.1.x doctor, but it's an empty placeholder file. Not much use. ;-)
  9.    #349  
    Quote Originally Posted by malpha View Post
    About doing this Rod, what would be the best way?

    Internalz does not work on webOS 2.0 currently due to the NDA. Does the OpenSSH app in Preware install on 2.x? or is there another way to set up SSH?
    Use novacom put.

    I always use the Palm SDK tools (palm-install, novacom, novaterm, etc) for doing stuff like this, cause you *know* it will always work when a new webOS version is released.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10. v3
    v3 is offline
    v3's Avatar
    Posts
    10 Posts
    #350  
    HI all, in addition to the pictures I posted earlier of the Pre Minus running 2.1, here is a video of the OS running:

    Tried to do some reasonably demanding things and have more than a few cards open... all ran fine.
  11. #351  
    To update your Pre-, you're going to have to peck around the metadoctor jar file anyway, so there's reason not to get your hands dirty hunting around the VZW jar file.
    screwdestiny
    PSN Twitter Last.FM
  12.    #352  
    Quote Originally Posted by Xanadu73 View Post
    Rod,

    Is it possible for you to update the OP with a list of where you're at? What works, what doesn't on Sprint Pre Minus? I (and I'm sure I'm not alone), haven't been able to sit here hitting F5 for the past 5 or so hours and am now kinda lost. :-\


    M.
    Yep, if folks want to wordsmith text that they think should be added to the OP, please do so and I'll add it later. Remember I work during my day.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  13. Kujila's Avatar
    Posts
    400 Posts
    Global Posts
    401 Global Posts
    #353  
    I've got
    Code:
    roadrunnercdma_fw.tar
    from the VZW Pre 2 Doc; do I just rename it
    Code:
    castlecdmafw.tar
    and overwrite the original one?

    I'm not even quite sure I'm doing this correctly, and I extracted the Doctors, webOS.tar, etc with WinRAR :/ I'm definitely going to have to look through the other Meta Doctor threads to see if I'm going about this the right way.
  14. #354  
    Quote Originally Posted by rwhitby View Post
    Yep, if folks want to wordsmith text that they think should be added to the OP, please do so and I'll add it later. Remember I work during my day.

    -- Rod

    I didn't mean *now*.

    Thank you Rod.


    M.
  15. #355  
    Quote Originally Posted by v3 View Post

    Posted to Sprint's Facebook Page. I'll keep spreading it.




    M.
  16. #356  
    Waiting for Xcode to download so I can try this out. By the way, have we noticed any differences with the updated version of the O2 doctor?
  17. #357  
    Okay, I am so close to install. The last step I have is to change the tokens. I've got the tokens from my device using the Show Properties app, emailed them to myself, put them in the relevant section in the castle.xml file in the webOS.tar.

    But when I try to move this xml file into the webOS.tar, I get a message saying "An error occurred when trying to add this file" that I didn't get when I put in the VZW firmware files. Any ideas as to why? This on an Ubuntu machine using the default Archive Manager...does it have anything to do with it being a /./ folder?
    screwdestiny
    PSN Twitter Last.FM
  18. #358  
    Quote Originally Posted by Leathal View Post
    Got my original Palm Profile (with paid apps) working! Hooray for novacom showing me errors related to the backup server.

    1) Doctor back to 1.4.5
    2) Disable Backup and select Delete Backups from Server when asked
    3) Metadoctor back to 2.1

    I'm still unable to purchase new paid apps, but I'm 100% logged in to my 1.4.5 profile, no 9.9.9 problems, and have Angry Birds and all that stuff.
    Ah-HA! That did it. THANK you, Leathal!
  19. #359  
    I now have 2.1.0 working on my O2 GSM Pre which I am using in Australia. My Palm profile was restored and I have access to free apps from the App Catalog as before. I used the following command

    make DEVICE=preplus CARRIER=wr clobber all
    with REMOVE_MODEL_CHECK=1 in the makefile.

    It took me two tries because when I bypassed the First Use application it didn't appear in the launcher and so I couldn't set up my Palm profile. The second time Preware wasn't installed despite me setting AUTO_INSTALL_PREWARE=1 in the makefile. I can install it using WOSQI but soon after the icon becomes faded and it sends me to the App Catalog for an update that doesn't exist.
  20. gabe2gg's Avatar
    Posts
    150 Posts
    Global Posts
    165 Global Posts
    #360  
    Quote Originally Posted by malpha View Post
    Okay, I am so close to install. The last step I have is to change the tokens. I've got the tokens from my device using the Show Properties app, emailed them to myself, put them in the relevant section in the castle.xml file in the webOS.tar.

    But when I try to move this xml file into the webOS.tar, I get a message saying "An error occurred when trying to add this file" that I didn't get when I put in the VZW firmware files. Any ideas as to why? This on an Ubuntu machine using the default Archive Manager...does it have anything to do with it being a /./ folder?
    I think the castle.xml you are supposted to edit is located in:
    /meta-doctor/build/preplus-p101ueude-wr-2.1.0/webOS

Posting Permissions