Page 169 of 217 FirstFirst ... 69119159164165166167168169170171172173174179 ... LastLast
Results 3,361 to 3,380 of 4324
Like Tree19Likes
  1. #3361  
    Quote Originally Posted by liggy View Post
    Hello,

    I just run the MetaDoctor "./scripts/meta-sprint-pre-2.1.0" script (Step Nr.3). Everything appeared to work fine. At the very end of the process I noticed a bunch of Permission denied errors.

    Is this cause for concern or can i keep going with step 4??

    Log file attached!

    Thanks!
    Here is some added information, specifically the last few lines of the meta-doctor scripts run. BTW I ran this three times with the same result. Also Windows Vista 32-bit (if that makes a difference). Again, this is just the llast few lines. For the rest see attached TXT file. Thanks so much for your help!!!

    rm -f build/meta-sprint-pre-2.1.0/.patched
    [ -d patches/webos-2.1.0 ]
    if [ -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz ] ; then \
    gunzip -c < build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz > build/meta-sprint-pre-2.1.0/rootfs/md5sums ; \
    fi
    mv build/meta-sprint-pre-2.1.0/rootfs/md5sums build/meta-sprint-pre-2.1.0/rootfs/md5sums.old
    mkdir -p build/meta-sprint-pre-2.1.0/rootfs/var/gadget
    touch build/meta-sprint-pre-2.1.0/rootfs/var/gadget/novacom_enabled
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/UpdateDaemon
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/uploadd
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/contextupload
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/rdxd
    for app in com.palm.app.firstuse ; do \
    ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    find ./usr/palm/applications/$app -type f | xargs md5sum ) \
    > build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new ; \
    ./scripts/replace-md5sums.py \
    build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.old build/meta-sprint-pre-2.1.0/rootfs/usr
    /lib/ipkg/info/$app.md5sums.new \
    > build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums ; \
    rm -f build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.old build/meta-sprint-pre-2.1.0/rootfs
    /usr/lib/ipkg/info/$app.md5sums.new ; \
    done
    ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    find ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/module
    s ./etc/palm-build-info -type f | xargs md5sum ) \
    > build/meta-sprint-pre-2.1.0/rootfs/md5sums.new
    md5sum: ./usr/bin/awk: Permission denied
    md5sum: ./usr/bin/chvt: Permission denied
    md5sum: ./usr/bin/cmp: Permission denied
    md5sum: ./usr/bin/cryptpw: Permission denied
    md5sum: ./usr/bin/cut: Permission denied
    md5sum: ./usr/bin/env: Permission denied
    md5sum: ./usr/bin/expr: Permission denied
    md5sum: ./usr/bin/ftpput: Permission denied
    md5sum: ./usr/bin/hexdump: Permission denied
    md5sum: ./usr/bin/install: Permission denied
    md5sum: ./usr/bin/less: Permission denied
    md5sum: ./usr/bin/md5sum: Permission denied
    md5sum: ./usr/bin/mkpasswd: Permission denied
    md5sum: ./usr/bin/nmeter: Permission denied
    md5sum: ./usr/bin/passwd: Permission denied
    md5sum: ./usr/bin/printf: Permission denied
    md5sum: ./usr/bin/renice: Permission denied
    md5sum: ./usr/bin/resize: Permission denied
    md5sum: ./usr/bin/seq: Permission denied
    md5sum: ./usr/bin/split: Permission denied
    md5sum: ./usr/bin/tail: Permission denied
    md5sum: ./usr/bin/tee: Permission denied
    md5sum: ./usr/bin/time: Permission denied
    md5sum: ./usr/bin/ttysize: Permission denied
    md5sum: ./usr/bin/uniq: Permission denied
    md5sum: ./usr/bin/wget: Permission denied
    md5sum: ./usr/bin/who: Permission denied
    md5sum: ./usr/bin/yes: Permission denied
    make[1]: *** [build/meta-sprint-pre-2.1.0/.patched] Error 123
    make[1]: Leaving directory `/home/Valued Customer/meta-doctor'
    make: *** [all] Error 2

    Valued Customer@Laptop01 ~/meta-doctor
    $
    Attached Files Attached Files
  2. 86ipods's Avatar
    Posts
    2 Posts
    Global Posts
    11 Global Posts
    #3362  
    Hello everyone,

    I am a first time poster and recent convert to WebOS from Android. I bought a roughed up Sprint Pre and a near perfect Verizon Pre Plus and created a Sprint FrankenPre+. I initially installed 1.4.5 and everything worked perfectly but after upgrading to 2.1.0 I am having two problems. I cannot receive texts at all and when I send a text it shows on the receivers phone as completely random symbols and letters. Also when I make a call, after I hang up I get a message saying the call was dropped. Maybe there is something specific I need to meta-doctor into my build to fix the issue? I have a feeling there is a fix for this and I just can't find it. Please help me out or link me to a forum if one already exists. Thank you everyone in advance. This already seems like an excellent community just from reading through the postings.

    Just a couple of details just in case:

    Sprint FrankenPre+, Palm profile does sync, data connects, calls can be made, Version shows up as HP WebOS 2.1.0 in device information, and the operating system is butter smooth. That sums it up. Thank you

    -86ipods
  3. gelobter's Avatar
    Posts
    16 Posts
    Global Posts
    19 Global Posts
    #3363  
    my problem, first posted earlier today, has been repeated by 3 others since I filed it. Any thoughts?
    thanks!
  4. #3364  
    Hi all,

    Just moved to WebOS after my Droid 1's charger port decided to give up the ghost. Found a guy with a refurb replacement Verizon Pre + on Craigslist, never even been turned on. Knowing what the trusty OMAP 3430 can do (I OC'd the Droid to 1GHz for most of its life), I immediately patched it with UberKernel.

    I've since made the leap to 2.1, though not without difficulty. After compiling the Doctor with Cygwin on Vista Ultimate (on the Windows side of a Mac Pro), the phone kept getting stuck on the "charging"/0% screen. I solved it by killing novacomd, reinstalling it, killing it again when it didn't work, and reinstalling until it did. Not sure if it's a foible of my particular system, but if anyone else is having the same problem on an outdated version of Windows on a Mac, that might help.

    2.1 is great, but my location services are COMPLETELY broken (with the exception of WiFi location). No GPS, no network location. Starting VZ Nav doesn't help either, like it did with 1.4.5. I just can't get any location data at all. ##GPS# always fails, as well. Should I recompile the Doctor and run it again? Doctor back to 1.4.5 and complain to Verizon? Run ebag333's QPST hack (I've heard that Verizon phones all use 000000 for their MSL... Any truth to this?)? Any suggestions would be great. Unfortunately all I've read is that GPS is BETTER on 2.1, so I feel like something went wrong making the Doctor JAR.

    For the record, I didn't mess with my Palm Profile when I upgraded, and it carried over perfectly. I figured I'd just make a new profile on 2.1 if it broke (having had the phone for all of two days before that point), but it was just fine without messing with backups and deleting my data.
  5. kuoirad's Avatar
    Posts
    204 Posts
    Global Posts
    340 Global Posts
    #3365  
    Have you checked to make sure Location Services is correctly (and fully) turned on? There's an entry about that in the wiki...
  6. #3366  
    Quote Originally Posted by kuoirad View Post
    Have you checked to make sure Location Services is correctly (and fully) turned on? There's an entry about that in the wiki...
    Of course—tried it with every combination of GPS/Google Services checked and unchecked just to see, too, with no success.
  7. #3367  
    Just a quick question. i have my sprint pre with 2.1. it was a the newer script a while back where no masking was needed and the penguin was the boot logo. anyway i need to go back to 1.4.5 to get some prl info and want to know if anything has changed with the script where maybe i should create a new dr. thanks a lot in advance
  8. #3368  
    Ok trying to update my Sprint Pre- from 1.4.5 to 2.1.0 using meta-sprint-pre-2.1.0 doctor and it gets to 82% then says it cant restart the device. I have tried rebooting the phone and the computer several times. I get the following output log of webosdoctor.

    I am currently running the 1.4.5 doctor to try to get my phone back to a working state.
    Attached Files Attached Files
  9. #3369  
    Quote Originally Posted by zarGon View Post
    Ah, thanks. After installing 2.1 the phone doesn't boot further than the boot image.

    Of course.

    My problem is that my phone doesn't boot correctly.

    I have followed the instructions on WebOS 2 Upgrade - WebOS Internals.
    - Copied all the files from the USB drive
    - Installed Cygwin and MetaDoctor on my laptop (Windows 7)
    - Installed the Palm SDK
    - (Also installed webOS Quick Install to make sure I had the Novacom drivers)
    - [It took a very long time to turn backups off, so I cancelled that] (So, if I'm correct, my Palm profile is not erased)
    - I ran "./scripts/meta-o2-pre-2.1.0" in Cygwin
    - After a while, webOSDoctor was launched. I installed 2.1 with the doctor.
    - Afer finising installing 2.1, the phone boots up webOS 2.1 and from that moment on it reboots.

    The result:


    Installing 2.1 ends up in a boot loop. And, it won't stop till I pull out the battery.


    I have doctored it back to 1.4.5. That works, the phone boots up and I get to choose a language and log in to my Palm profile. Installing 2.1 after a doctored 1.4.5 has yet again resulted in a boot loop.
    I don't know if the Zargon solved his problem, but I'm having the same problem here. Exactly the same problem when I try go from 1.4.5 to 2.1.

    Some suggestions?


    Best regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  10.    #3370  
    Quote Originally Posted by Stickboy46 View Post
    Ok trying to update my Sprint Pre- from 1.4.5 to 2.1.0 using meta-sprint-pre-2.1.0 doctor and it gets to 82% then says it cant restart the device. I have tried rebooting the phone and the computer several times. I get the following output log of webosdoctor.
    INFO: ROM Verifyer: ./usr/bin/traceroute: ADDED

    That's the error. You need to show the log of how you build your custom doctor to determine why that error occurs.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11.    #3371  
    Quote Originally Posted by NADLER View Post
    After successfully doctored the Pre2 to 2.1.0, I took apart both Pres again and reFrankenPred.

    I did a clean install of the Meta-doctor. However, once again WebOS doctor failed at 12-13% exactly the same place as before.

    I then decided to just Doctor from the jar file in the build subdirectory pre-p103ueuna-wr-2.1.0 which I believe is the directory and the file that the script uses. Again it failed at 12-13%.

    I then went to the meta-sprint-franken-unlocked-pre2-2.1.0 subdirectory and tried webosdoctorp103ueuna-wr-2.1.0.jar and IT WORKED!!

    I now have a frankenPre.

    Two questions:
    1. Is there a bug in the frankenpre script?
    2. Do I have the correct version installed?

    Thanks again!!!
    pre-p103ueuna-wr-2.1.0 is the unmodified doctor.

    meta-sprint-franken-unlocked-pre2-2.1.0 is the custom doctor.

    The former will stop at 12-13%, and if you look at the doctor console log output, it will tell you why (token mismatch).

    The latter will work, as you experienced.

    Note that both the wiki instructions and the actual output of the script tell you to run the latter, so I have no idea why you were trying to run the former and expecting it to work.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  12.    #3372  
    Quote Originally Posted by gelobter View Post
    my problem, first posted earlier today, has been repeated by 3 others since I filed it. Any thoughts?
    thanks!
    Run the meta-doctor on Linux instead.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  13. #3373  
    Quote Originally Posted by rwhitby View Post
    pre-p103ueuna-wr-2.1.0 is the unmodified doctor.

    meta-sprint-franken-unlocked-pre2-2.1.0 is the custom doctor.

    The former will stop at 12-13%, and if you look at the doctor console log output, it will tell you why (token mismatch).

    The latter will work, as you experienced.

    Note that both the wiki instructions and the actual output of the script tell you to run the latter, so I have no idea why you were trying to run the former and expecting it to work.

    -- Rod
    I ran the script indicated in the Wiki each time ./scripts/meta-sprint-franken-unlocked-pre2-2.1.0. It ran the webOS doctor automatically. I didn't change anything.

    It was not until the last couple of tries that I found the correct file and ran the jar file manually. Perhaps the script is pointing to an incorrect file or an incorrect subdirectory?

    In any event, my frankenPre is up an running and I am happy.

    Thanks.
    Last edited by NADLER; 04/01/2011 at 08:26 AM.
  14. TimBoch's Avatar
    Posts
    312 Posts
    Global Posts
    318 Global Posts
    #3374  
    Quote Originally Posted by gelobter View Post
    Hi! I religiously followed the Internals instructions and ran the make-doctor script in Cygwin.

    The .jar is definitely generated, but the script ends with the a series of "permission denied" notices for md5sum commands and overall error 123 and error 2.

    I've attached the log of the cygwin window. Any ideas? thanks!
    I finally had hoped to make the meta-doctor plunge on my Verizon Pre+. Installed Cygwin and went through the steps as described in the Wiki. All seemed to progress very well but at the end, I too received the messages in this quote. The new meta-doctor didn't auto launch as the Wiki stated and I have not wanted to run the .jar file created until I knew if anyone that had these messages had found out an answer.
    Thanks for your help and for the amazing work you do to make the impossible, possible.
    Tim Boche

    Palm IIIe, IIIx, IIIxe, IIIc, ClieT615, ClieTJ25, ClieTJ37(2), Treo600, Treo650, Centro(AT&T & Verizon),
    Pre Plus(6 replacements), TouchPads(1-16gb,2-32gb), Pre2 (and a spare)
  15. #3375  
    Quote Originally Posted by rwhitby View Post
    INFO: ROM Verifyer: ./usr/bin/traceroute: ADDED

    That's the error. You need to show the log of how you build your custom doctor to determine why that error occurs.

    -- Rod
    Thanks, but i didnt realize that the new boot image was the linux penguin. My phone actually boots just fine on 2.1 now. 82% is apparently a full install. I thought it was in an error screen when it brought up that penguin. My phone is working fine now
  16. #3376  
    @TimBoch: Read post #3417. Rod said you need to run Linux!
    Last edited by liggy; 04/01/2011 at 01:07 PM. Reason: added reference.
  17. #3377  
    Using patched webos 2.1.0 is disabled the "Update" application?
  18.    #3378  
    Quote Originally Posted by Stickboy46 View Post
    Thanks, but i didnt realize that the new boot image was the linux penguin. My phone actually boots just fine on 2.1 now. 82% is apparently a full install. I thought it was in an error screen when it brought up that penguin. My phone is working fine now
    That is correct. Even though the file verification fails, the phone is still flashed and should operate correctly (as long as the failing verification is not a serious one).

    It would be good to know why it's failing on traceroute for you and no-one else, but it's not a serious error so you should be fine.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  19. #3379  
    Please, a little help: how can I have the log using meta-doctor in cygwin.

    Sorry, but I confess that I'm a newbie!!

    Thanks since now...


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  20. #3380  
    If I shut off my sprint 1.4.5, put 2.1 on a spare device with the same profile, if I now turn back on my old device w/ that profile will that cause any conflict? Or will it just work like a wifi device and all my old apps still or will it not even log in since it was the same profile?

    P.S. rwhitby i plan to donate soon, it wont be a huge amount since I cant afford it, but surely everything helps Thanks again!

Posting Permissions