Page 148 of 217 FirstFirst ... 4898138143144145146147148149150151152153158198 ... LastLast
Results 2,941 to 2,960 of 4324
Like Tree19Likes
  1.    #2941  
    Quote Originally Posted by EddieDFW View Post
    Do we lose access to anything by upgrading? Someone mentioned earlier not being able to access Sprint Navigation.
    What does the wiki page say? Prove you've read that by telling us what it says, and we'll fill in the blanks.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. #2942  
    Hi all! I searched the threads before asking this, but only found this one post, which didn't appear to be answered. I'm using a MAC with OS X and have successfully installed everything I need to run the Meta-doctor. I'm trying to get webOS 2.1 on a wifi only Sprint Pre -.

    Upon running the webosdoctorp101ueude-wr-2.1.0.jar file (either through Finder or through Terminal), I get the same error dvron got:

    Here's my terminal output:

    Code:
    name-macbook:meta-doctor soccerbudd_22$ ./scripts/meta-sprint-pre-2.1.0
    DEVICE = preplus
    CARRIER = wr
    VERSION = 2.1.0
    ENABLE_DEVELOPER_MODE = 1
    DISABLE_UPLOAD_DAEMON = 1
    DISABLE_UPDATE_DAEMON = 1
    CUSTOM_WEBOS_TARBALL = webOS.tar
    CUSTOM_CARRIER_TARBALL = carrier.tar
    CUSTOM_MODEL_LIST = P100EWW
    CUSTOM_CARRIER_LIST = Sprint
    CUSTOM_BOOTLOGO = scripts/WebOS-Internals.tga
    
    Your custom doctor file will be created at build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    
    make: Nothing to be done for `unpack'.
    make: Nothing to be done for `unpack'.
    make: Nothing to be done for `unpack'.
    dmtree-sprint_1.0.0-1_armv7.ipk
    com.handson.app.nascar_1.0-46_armv7.ipk
    com.handson.app.nfl_1.0-38_armv7.ipk
    com.palm.app.sprintportal_1.0-7_armv7.ipk
    mobitv-sprint-rtspsrc_1.0.0-20.1_armv7.ipk
    com.mobitv.app.sprinttv_1.0-65_armv7.ipk
    crotest-images_1.0-2_armv7.ipk
    audiod-config-cdma_1.0-4_castle.ipk
    installer.xml
    palmcustomizationinfo-wr-castle-plus_1.0-284_all.ipk
    sweatshop-wr-castle_1.0-72_armv7.ipk
    pmvoicecommand_1.4-5.30_armv7.ipk
    contacts.plugin.pmvoicecommand_1.0-2_all.ipk
    pmvoicecommand-dede_1.0-5.30_armv7.ipk
    pmvoicecommand-engb_1.0-5.30_armv7.ipk
    pmvoicecommand-enus_1.0-5.30_armv7.ipk
    pmvoicecommand-eses_1.0-5.30_armv7.ipk
    pmvoicecommand-esmx_1.0-5.30_armv7.ipk
    pmvoicecommand-frca_1.0-5.30_armv7.ipk
    pmvoicecommand-frfr_1.0-5.30_armv7.ipk
    pmvoicecommand-itit_1.0-5.30_armv7.ipk
    rm -rf build/meta-sprint-pre-2.1.0
    make unpack patch pack
    rm -rf build/meta-sprint-pre-2.1.0
    mkdir -p build/meta-sprint-pre-2.1.0
    cp downloads/webosdoctorp101ueude-wr-2.1.0.jar build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		unzip -q webosdoctorp101ueude-wr-2.1.0.jar META-INF/MANIFEST.MF com/* \
    			resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		unzip -q webosdoctorp101ueude-wr-2.1.0.jar resources/wr-castle-plus.tar )
    cp webOS.tar build/meta-sprint-pre-2.1.0/resources/webOS.tar
    cp carrier.tar build/meta-sprint-pre-2.1.0/resources/wr-castle-plus.tar
    mkdir -p build/meta-sprint-pre-2.1.0/webOS
    gnutar -C build/meta-sprint-pre-2.1.0/webOS \
    		-f build/meta-sprint-pre-2.1.0/resources/webOS.tar -x
    cp scripts/WebOS-Internals.tga build/meta-sprint-pre-2.1.0/webOS/BootLogo.tga
    mkdir -p build/meta-sprint-pre-2.1.0/carrier
    gnutar -f build/meta-sprint-pre-2.1.0/resources/wr-castle-plus.tar -t \
    		> build/meta-sprint-pre-2.1.0/carrier/carrier-file-list.txt
    gnutar -C build/meta-sprint-pre-2.1.0/carrier \
    		-f build/meta-sprint-pre-2.1.0/resources/wr-castle-plus.tar -x
    gunzip -f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar.gz
    mkdir -p build/meta-sprint-pre-2.1.0/rootfs
    gnutar -C build/meta-sprint-pre-2.1.0/rootfs --wildcards \
    		-f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar \
    		-x ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    touch build/meta-sprint-pre-2.1.0/.unpacked
    rm -f build/meta-sprint-pre-2.1.0/.patched
    [ -d patches/webos-2.1.0 ]
    if [ -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz ] ; then \
    	  gunzip -c < build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz > build/meta-sprint-pre-2.1.0/rootfs/md5sums ; \
    	fi
    mv build/meta-sprint-pre-2.1.0/rootfs/md5sums build/meta-sprint-pre-2.1.0/rootfs/md5sums.old
    mkdir -p build/meta-sprint-pre-2.1.0/rootfs/var/gadget
    touch build/meta-sprint-pre-2.1.0/rootfs/var/gadget/novacom_enabled
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/UpdateDaemon
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/uploadd
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/contextupload
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/rdxd
    for app in com.palm.app.firstuse ; do \
    	  ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    	    find ./usr/palm/applications/$app -type f | xargs md5sum ) \
    	      > build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new ; \
    	  ./scripts/replace-md5sums.py \
    	    build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.old build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new \
    	      > build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums ; \
    	  rm -f build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.old build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new ; \
    	done
    ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    	  find ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info -type f | xargs md5sum ) \
    	    > build/meta-sprint-pre-2.1.0/rootfs/md5sums.new
    ./scripts/replace-md5sums.py build/meta-sprint-pre-2.1.0/rootfs/md5sums.old build/meta-sprint-pre-2.1.0/rootfs/md5sums.new > \
    				     build/meta-sprint-pre-2.1.0/rootfs/md5sums
    rm -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.old build/meta-sprint-pre-2.1.0/rootfs/md5sums.new
    [ -f hashes/Sprint ]
    sed -i.orig -e '/ApprovalCharlieHash/d' \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    rm -f build/meta-sprint-pre-2.1.0/resources/recoverytool.config.orig
    echo "ApprovalCharlieHash=`cat hashes/Sprint`" >> \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    [ -f hashes/P100EWW ]
    sed -i.orig -e '/ApprovalMikeHash/d' \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    rm -f build/meta-sprint-pre-2.1.0/resources/recoverytool.config.orig
    echo "ApprovalMikeHash=`cat hashes/P100EWW`" >> \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    touch build/meta-sprint-pre-2.1.0/.patched
    rm -f build/meta-sprint-pre-2.1.0/.packed
    gnutar -C build/meta-sprint-pre-2.1.0/rootfs --wildcards \
    		-f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar \
    		--delete ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    ( cd build/meta-sprint-pre-2.1.0/rootfs ; mkdir -p ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./var/luna/preferences ./var/gadget ./var/home/root ./var/preferences ./var/palm/data )
    if [ -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz ] ; then \
    	  gzip -f build/meta-sprint-pre-2.1.0/rootfs/md5sums ; \
    	  ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    		gnutar -f ../webOS/nova-cust-image-castle.rootfs.tar \
    			--numeric-owner --owner=0 --group=0 \
    			--append ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./var/luna/preferences ./var/gadget ./var/home/root ./var/preferences ./var/palm/data ./etc/palm-build-info ./md5sums.gz ) ; \
    	else \
    	  ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    		gnutar -f ../webOS/nova-cust-image-castle.rootfs.tar \
    			--numeric-owner --owner=0 --group=0 \
    			--append ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./var/luna/preferences ./var/gadget ./var/home/root ./var/preferences ./var/palm/data ./etc/palm-build-info ./md5sums ) ; \
    	fi
    gzip -f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar
    ( cd build/meta-sprint-pre-2.1.0/webOS ; \
    		gnutar -f ../resources/webOS.tar \
    			--numeric-owner --owner=0 --group=0 -h \
    			-c . )
    sed -i.orig -e '/^Name: /d' -e '/^SHA1-Digest: /d' -e '/^ /d' -e '/^\n$/d' \
    		build/meta-sprint-pre-2.1.0/META-INF/MANIFEST.MF
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q -d webosdoctorp101ueude-wr-2.1.0.jar META-INF/MANIFEST.MF META-INF/JARKEY.*  \
    			resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q webosdoctorp101ueude-wr-2.1.0.jar META-INF/MANIFEST.MF  \
    			resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-pre-2.1.0/carrier ; \
    		gnutar -f ../resources/wr-castle-plus.tar \
    			--numeric-owner --owner=0 --group=0 -h \
    			-c -T carrier-file-list.txt )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q -d webosdoctorp101ueude-wr-2.1.0.jar resources/wr-castle-plus.tar )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q webosdoctorp101ueude-wr-2.1.0.jar resources/wr-castle-plus.tar )
    touch build/meta-sprint-pre-2.1.0/.packed
    Invalid or corrupt jarfile build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    What am I doing wrong? Any help is appreciated!

    Thank you!
    Karla


    Quote Originally Posted by drvon View Post
    so I have tried running the script a few times and still get this message:


    touch build/preplus-p101ueude-wr-2.1.0/.packed
    Invalid or corrupt jarfile build/preplus-p101ueude-wr-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    ryan-carlsons-macbook-4:meta-doctor ryancarlson$

    I need help please.

    Also this was using the bell mobility script
  3.    #2943  
    Quote Originally Posted by soccerbudd View Post
    Hi all! I searched the threads before asking this, but only found this one post, which didn't appear to be answered. I'm using a MAC with OS X and have successfully installed everything I need to run the Meta-doctor. I'm trying to get webOS 2.1 on a wifi only Sprint Pre -.

    Upon running the webosdoctorp101ueude-wr-2.1.0.jar file (either through Finder or through Terminal), I get the same error dvron got:

    Here's my terminal output:

    Code:
    name-macbook:meta-doctor soccerbudd_22$ ./scripts/meta-sprint-pre-2.1.0
    DEVICE = preplus
    CARRIER = wr
    VERSION = 2.1.0
    ENABLE_DEVELOPER_MODE = 1
    DISABLE_UPLOAD_DAEMON = 1
    DISABLE_UPDATE_DAEMON = 1
    CUSTOM_WEBOS_TARBALL = webOS.tar
    CUSTOM_CARRIER_TARBALL = carrier.tar
    CUSTOM_MODEL_LIST = P100EWW
    CUSTOM_CARRIER_LIST = Sprint
    CUSTOM_BOOTLOGO = scripts/WebOS-Internals.tga
    
    Your custom doctor file will be created at build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    
    make: Nothing to be done for `unpack'.
    make: Nothing to be done for `unpack'.
    make: Nothing to be done for `unpack'.
    dmtree-sprint_1.0.0-1_armv7.ipk
    com.handson.app.nascar_1.0-46_armv7.ipk
    com.handson.app.nfl_1.0-38_armv7.ipk
    com.palm.app.sprintportal_1.0-7_armv7.ipk
    mobitv-sprint-rtspsrc_1.0.0-20.1_armv7.ipk
    com.mobitv.app.sprinttv_1.0-65_armv7.ipk
    crotest-images_1.0-2_armv7.ipk
    audiod-config-cdma_1.0-4_castle.ipk
    installer.xml
    palmcustomizationinfo-wr-castle-plus_1.0-284_all.ipk
    sweatshop-wr-castle_1.0-72_armv7.ipk
    pmvoicecommand_1.4-5.30_armv7.ipk
    contacts.plugin.pmvoicecommand_1.0-2_all.ipk
    pmvoicecommand-dede_1.0-5.30_armv7.ipk
    pmvoicecommand-engb_1.0-5.30_armv7.ipk
    pmvoicecommand-enus_1.0-5.30_armv7.ipk
    pmvoicecommand-eses_1.0-5.30_armv7.ipk
    pmvoicecommand-esmx_1.0-5.30_armv7.ipk
    pmvoicecommand-frca_1.0-5.30_armv7.ipk
    pmvoicecommand-frfr_1.0-5.30_armv7.ipk
    pmvoicecommand-itit_1.0-5.30_armv7.ipk
    rm -rf build/meta-sprint-pre-2.1.0
    make unpack patch pack
    rm -rf build/meta-sprint-pre-2.1.0
    mkdir -p build/meta-sprint-pre-2.1.0
    cp downloads/webosdoctorp101ueude-wr-2.1.0.jar build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		unzip -q webosdoctorp101ueude-wr-2.1.0.jar META-INF/MANIFEST.MF com/* \
    			resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		unzip -q webosdoctorp101ueude-wr-2.1.0.jar resources/wr-castle-plus.tar )
    cp webOS.tar build/meta-sprint-pre-2.1.0/resources/webOS.tar
    cp carrier.tar build/meta-sprint-pre-2.1.0/resources/wr-castle-plus.tar
    mkdir -p build/meta-sprint-pre-2.1.0/webOS
    gnutar -C build/meta-sprint-pre-2.1.0/webOS \
    		-f build/meta-sprint-pre-2.1.0/resources/webOS.tar -x
    cp scripts/WebOS-Internals.tga build/meta-sprint-pre-2.1.0/webOS/BootLogo.tga
    mkdir -p build/meta-sprint-pre-2.1.0/carrier
    gnutar -f build/meta-sprint-pre-2.1.0/resources/wr-castle-plus.tar -t \
    		> build/meta-sprint-pre-2.1.0/carrier/carrier-file-list.txt
    gnutar -C build/meta-sprint-pre-2.1.0/carrier \
    		-f build/meta-sprint-pre-2.1.0/resources/wr-castle-plus.tar -x
    gunzip -f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar.gz
    mkdir -p build/meta-sprint-pre-2.1.0/rootfs
    gnutar -C build/meta-sprint-pre-2.1.0/rootfs --wildcards \
    		-f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar \
    		-x ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    touch build/meta-sprint-pre-2.1.0/.unpacked
    rm -f build/meta-sprint-pre-2.1.0/.patched
    [ -d patches/webos-2.1.0 ]
    if [ -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz ] ; then \
    	  gunzip -c < build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz > build/meta-sprint-pre-2.1.0/rootfs/md5sums ; \
    	fi
    mv build/meta-sprint-pre-2.1.0/rootfs/md5sums build/meta-sprint-pre-2.1.0/rootfs/md5sums.old
    mkdir -p build/meta-sprint-pre-2.1.0/rootfs/var/gadget
    touch build/meta-sprint-pre-2.1.0/rootfs/var/gadget/novacom_enabled
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/UpdateDaemon
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/uploadd
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/contextupload
    chmod -x build/meta-sprint-pre-2.1.0/rootfs/usr/bin/rdxd
    for app in com.palm.app.firstuse ; do \
    	  ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    	    find ./usr/palm/applications/$app -type f | xargs md5sum ) \
    	      > build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new ; \
    	  ./scripts/replace-md5sums.py \
    	    build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.old build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new \
    	      > build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums ; \
    	  rm -f build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.old build/meta-sprint-pre-2.1.0/rootfs/usr/lib/ipkg/info/$app.md5sums.new ; \
    	done
    ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    	  find ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info -type f | xargs md5sum ) \
    	    > build/meta-sprint-pre-2.1.0/rootfs/md5sums.new
    ./scripts/replace-md5sums.py build/meta-sprint-pre-2.1.0/rootfs/md5sums.old build/meta-sprint-pre-2.1.0/rootfs/md5sums.new > \
    				     build/meta-sprint-pre-2.1.0/rootfs/md5sums
    rm -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.old build/meta-sprint-pre-2.1.0/rootfs/md5sums.new
    [ -f hashes/Sprint ]
    sed -i.orig -e '/ApprovalCharlieHash/d' \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    rm -f build/meta-sprint-pre-2.1.0/resources/recoverytool.config.orig
    echo "ApprovalCharlieHash=`cat hashes/Sprint`" >> \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    [ -f hashes/P100EWW ]
    sed -i.orig -e '/ApprovalMikeHash/d' \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    rm -f build/meta-sprint-pre-2.1.0/resources/recoverytool.config.orig
    echo "ApprovalMikeHash=`cat hashes/P100EWW`" >> \
    		build/meta-sprint-pre-2.1.0/resources/recoverytool.config
    touch build/meta-sprint-pre-2.1.0/.patched
    rm -f build/meta-sprint-pre-2.1.0/.packed
    gnutar -C build/meta-sprint-pre-2.1.0/rootfs --wildcards \
    		-f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar \
    		--delete ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    ( cd build/meta-sprint-pre-2.1.0/rootfs ; mkdir -p ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./var/luna/preferences ./var/gadget ./var/home/root ./var/preferences ./var/palm/data )
    if [ -f build/meta-sprint-pre-2.1.0/rootfs/md5sums.gz ] ; then \
    	  gzip -f build/meta-sprint-pre-2.1.0/rootfs/md5sums ; \
    	  ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    		gnutar -f ../webOS/nova-cust-image-castle.rootfs.tar \
    			--numeric-owner --owner=0 --group=0 \
    			--append ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./var/luna/preferences ./var/gadget ./var/home/root ./var/preferences ./var/palm/data ./etc/palm-build-info ./md5sums.gz ) ; \
    	else \
    	  ( cd build/meta-sprint-pre-2.1.0/rootfs ; \
    		gnutar -f ../webOS/nova-cust-image-castle.rootfs.tar \
    			--numeric-owner --owner=0 --group=0 \
    			--append ./usr/palm/applications/com.palm.app.firstuse ./usr/lib/ipkg/info ./etc/ssl ./usr/bin ./boot ./lib/modules ./var/luna/preferences ./var/gadget ./var/home/root ./var/preferences ./var/palm/data ./etc/palm-build-info ./md5sums ) ; \
    	fi
    gzip -f build/meta-sprint-pre-2.1.0/webOS/nova-cust-image-castle.rootfs.tar
    ( cd build/meta-sprint-pre-2.1.0/webOS ; \
    		gnutar -f ../resources/webOS.tar \
    			--numeric-owner --owner=0 --group=0 -h \
    			-c . )
    sed -i.orig -e '/^Name: /d' -e '/^SHA1-Digest: /d' -e '/^ /d' -e '/^\n$/d' \
    		build/meta-sprint-pre-2.1.0/META-INF/MANIFEST.MF
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q -d webosdoctorp101ueude-wr-2.1.0.jar META-INF/MANIFEST.MF META-INF/JARKEY.*  \
    			resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q webosdoctorp101ueude-wr-2.1.0.jar META-INF/MANIFEST.MF  \
    			resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-pre-2.1.0/carrier ; \
    		gnutar -f ../resources/wr-castle-plus.tar \
    			--numeric-owner --owner=0 --group=0 -h \
    			-c -T carrier-file-list.txt )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q -d webosdoctorp101ueude-wr-2.1.0.jar resources/wr-castle-plus.tar )
    ( cd build/meta-sprint-pre-2.1.0 ; \
    		zip -q webosdoctorp101ueude-wr-2.1.0.jar resources/wr-castle-plus.tar )
    touch build/meta-sprint-pre-2.1.0/.packed
    Invalid or corrupt jarfile build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar
    What am I doing wrong? Any help is appreciated!

    Thank you!
    Karla
    Note sure what the problem is there. I develop the MetaDoctor on OSX.

    What version are you running (I run Snow Leopard). Did you install the MacPorts dependencies correctly? Do you have the latest Java updates installed?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. #2944  
    Just finished installing 2.1 on my Verizon Pre Plus, and I only have 1 thing to say....

    THANK YOU THANK YOU THANK YOU!!!

    I'm generally an internet moocher and rarely contribute...but for this I am DEFINITELY donating to webOS internals. Fantastic work.

    Everything seems to be working just fine right now...I'm just waiting for apps to finish installing. Things are running pretty fast, too.

    The only downside is that I lost all my texts....it's worth it though, especially since it was made clear that there was a good chance this would happen. I had trouble finding a way to back up text messages and got impatient before doing the upgrade...someone should put a link to detailed instructions on the wiki page. But maybe I'm the only one who cares. Or the only one dumb enough to not be able to figure it out.
  5. phaeton's Avatar
    Posts
    5 Posts
    Global Posts
    23 Global Posts
    #2945  
    Ok, no scolding. I've read the wiki, run the meta-doctor and everything seems to work just fine.

    Here's my problem: my Sprint pre- is no longer activated on the Sprint network so I can't get past the setup screen and either login to my palm profile or create a new one. Is there a way to either (a) bypass setup (b) backload my wifi profile so that it starts up and connects directly to that?

    Worst comes to worst I can just swap my Evo for my Pre and swap them back after activation.

    And no judgement for the Evo, please. My Pre is rode hard and the Evo is just to see me through until the Pre 3 is released.
  6.    #2946  
    Quote Originally Posted by phaeton View Post
    Ok, no scolding. I've read the wiki, run the meta-doctor and everything seems to work just fine.

    Here's my problem: my Sprint pre- is no longer activated on the Sprint network so I can't get past the setup screen and either login to my palm profile or create a new one. Is there a way to either (a) bypass setup (b) backload my wifi profile so that it starts up and connects directly to that?

    Worst comes to worst I can just swap my Evo for my Pre and swap them back after activation.

    And no judgement for the Evo, please. My Pre is rode hard and the Evo is just to see me through until the Pre 3 is released.
    This seems to happen to some people, and we don't know why.

    The solution seems to be to doctor back to webOS 1.4.5, activate on Sprint, then meta-doctor forward again.

    If that works for you, you are then obligated to add that information to the wiki page for the next person to read.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  7. phaeton's Avatar
    Posts
    5 Posts
    Global Posts
    23 Global Posts
    #2947  
    Quote Originally Posted by rwhitby View Post
    This seems to happen to some people, and we don't know why.

    The solution seems to be to doctor back to webOS 1.4.5, activate on Sprint, then meta-doctor forward again.

    If that works for you, you are then obligated to add that information to the wiki page for the next person to read.

    -- Rod
    I know why it's happened. It's happened because I deactivated my Sprint pre a few weeks ago to switch (temporarily) to the Evo and have been using my pre as a wifi only device.

    I can understand having to re-activate my pre on my Sprint account but why should I have to doctor back to 1.4.5?

    Not being argumentative. Just ensuring I understand before I re/un/doctor.

    Thanks!
  8.    #2948  
    Quote Originally Posted by phaeton View Post
    I know why it's happened. It's happened because I deactivated my Sprint pre a few weeks ago to switch (temporarily) to the Evo and have been using my pre as a wifi only device.

    I can understand having to re-activate my pre on my Sprint account but why should I have to doctor back to 1.4.5?

    Not being argumentative. Just ensuring I understand before I re/un/doctor.

    Thanks!
    There is no provisioner binary that is compatible with webOS 2.1.0 - the only one we have is for 1.4.5, so that is what you must use to activate the device.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  9. #2949  
    Just upgraded my Pre+ to 2.1. All in all pretty smooth. I had some issues with Novacom, and had to hunt a bit to find out how to enable wifi profiles. I added detail to the Meta-Doc wiki, and the Webos-2.1 upgrade wiki about these things.

    2.1 is fast...
  10. #2950  
    Hi,

    I'm wondering if the spanish Simyo carrier is already included in 2.1 (it is not in 1.4.5); otherwise I could end with no 3G.

    In 1.4.5 I've got 3G support by following the instructions found here...

    Could any of you check wether spanish Simyo is supported by default -or send me the file /usr/lib/luna/CarrierNetworkSettings.db3-?? Or maybe there's other way of extracting that file from the 2.1 fw?

    TIA
  11.    #2951  
    Quote Originally Posted by quini View Post
    Hi,

    I'm wondering if the spanish Simyo carrier is already included in 2.1 (it is not in 1.4.5); otherwise I could end with no 3G.

    In 1.4.5 I've got 3G support by following the instructions found here...

    Could any of you check wether spanish Simyo is supported by default -or send me the file /usr/lib/luna/CarrierNetworkSettings.db3-?? Or maybe there's other way of extracting that file from the 2.1 fw?

    TIA
    Just unpack a 2.1 doctor and look..

    metadoctor has a ./scripts/unpack-doctor script.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  12. #2952  
    Quote Originally Posted by rwhitby View Post
    Just unpack a 2.1 doctor and look..

    metadoctor has a ./scripts/unpack-doctor script.
    Thanks.

    I forgot to mention that there's no CarrierNetworkSettings.db3 file in the 2.1.0 firmware (german O2 for Pre+ found here (neither in /usr/lib/luna/ nor in /var/luna/data/)... O8-)

    Has it changed its name? Or it's dinamically created when installing? 8-?

    Any other hint?

    Thanks!
  13.    #2953  
    Quote Originally Posted by quini View Post
    Thanks.

    I forgot to mention that there's no CarrierNetworkSettings.db3 file in the 2.1.0 firmware (german O2 for Pre+ found here (neither in /usr/lib/luna/ nor in /var/luna/data/)... O8-)

    Has it changed its name? Or it's dinamically created when installing? 8-?

    Any other hint?

    Thanks!
    Look in /etc/carrierdb/carrierdb.json (you could find that path in the meta-doctor Makefile).

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  14. #2954  
    Quote Originally Posted by rwhitby View Post
    Note sure what the problem is there. I develop the MetaDoctor on OSX.

    What version are you running (I run Snow Leopard). Did you install the MacPorts dependencies correctly? Do you have the latest Java updates installed?

    -- Rod
    Hi Rod! Sorry for the delayed response, but I had been downloading applications and running scripts for 5 hours and needed a break.

    I'm running OS X Version 10.5.8 (which I think is Leopard? I'm relatively new to Macs). I downloaded Xtools for Leopard and MacPorts. I ran all of the scripts/installs listed on the wiki page for the Meta-Doctor, downloaded the SDK/PDK and checked for Java updates. I'll try the software updates again to see if I have any success.

    Gracias!

    UPDATE: Okay, I ran the Mac Software Update again, which did have a Java update to install. I installed, rebooted and re-ran ./scripts/meta-sprint-pre-2.1.0 --wifi-only script. It re-built all of the custom OS doctors, but errored on the one I need again:

    Invalid or corrupt jarfile build/meta-sprint-pre-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar

    I think I read someone had a similar issue and moved their .jar file to a PC, where it worked. Perhaps I should try that?

    I wonder if it could also be a versioning issue since the wiki shows the update for OS X 10.6, which is a newer version than what I have.

    Karla
    Last edited by soccerbudd; 03/12/2011 at 07:58 AM.
  15. #2955  
    This appears to be a problem with Leopard then. Snow Leopard works just fine. Maybe you should consider an update ( 29 Dollar ), it's worth it imho as long as you don't have a PPC Mac.

    €dith: Otherwise install virtualbox (freeware) and run Ubuntu in it. That's how I created the *.jar and the doctor worked fine on my MacBook running Snow Leopard.
  16. #2956  
    Quote Originally Posted by FischOderAal View Post
    This appears to be a problem with Leopard then. Snow Leopard works just fine. Maybe you should consider an update ( 29 Dollar ), it's worth it imho as long as you don't have a PPC Mac.

    €dith: Otherwise install virtualbox (freeware) and run Ubuntu in it. That's how I created the *.jar and the doctor worked fine on my MacBook running Snow Leopard.
    I have an Intel Mac, so I'm good there. I guess I *could* update, but I'm feeling sort of lazy in that regard.

    I already have VirtualBox, so maybe I'll try downloading Ubuntu. I know a lot of people had issues with that, so I may go this route if the PC copy doesn't work.

    Thanks!
    Karla
  17. #2957  
    Quote Originally Posted by soccerbudd View Post
    I have an Intel Mac, so I'm good there. I guess I *could* update, but I'm feeling sort of lazy in that regard.

    I already have VirtualBox, so maybe I'll try downloading Ubuntu. I know a lot of people had issues with that, so I may go this route if the PC copy doesn't work.

    Thanks!
    Karla
    Karla, if you are new to mac, upgrading to snow leopard is well worth it. Rod's scripts will run easily and flawlessly after that, no mucking around (I did it for sprint, vzw, and wireless).
    At $29 for the upgrade, it could save you those 5 hours you talked about before, unless your time is worth less than $6/hr, you are gravy.
  18. h-cubed's Avatar
    Posts
    463 Posts
    Global Posts
    518 Global Posts
    #2958  
    I have got the GPS working now but what happened to the Always Allow for GPS option? Kinda annoying having to accept GPS access all the time...

    But if I absolutely have to I guess I can just live with it! :-)
    Ħ╬čųβ£Δ
    Sent from my HTC Evo 4G
  19. #2959  
    Hum? Imho it's at the same place as before. "Standortbasierte Dienste" it says on my phone. It's the icon with the compass and the second option from the top. The way I see it the only difference here is that they differentiate between apps and websites as well as adding the option to add Geotags to your photos.
  20. h-cubed's Avatar
    Posts
    463 Posts
    Global Posts
    518 Global Posts
    #2960  
    Oh wow nevermind I feel like a dunce!

Posting Permissions