Page 123 of 217 FirstFirst ... 2373113118119120121122123124125126127128133173 ... LastLast
Results 2,441 to 2,460 of 4324
Like Tree19Likes
  1. #2441  
    Quote Originally Posted by nethan View Post
    Sprint Pre -

    Remembered to git the newest script this time (thanks Ed).

    Meta and Doctored.

    Profile AND phone say 2.1 and apps are reinstalling as I type.

    Ya'll rock.

    Did you turn off backups to delete your Palm Profile? I'm not sure if we're still doing that step. I'm reading both things here.


    M.
    Last edited by Xanadu73; 03/05/2011 at 12:47 PM.
  2. #2442  
    Quote Originally Posted by rwhitby View Post
    I've pushed some minor changes to the MetaDoctor and the Sprint and Verizon scripts. It's an internal implementation change, which is not intended to have any impact on the functionality or result. You do not need to do anything as a result of this change.

    Just letting you know in case I stuffed anything up, then you'll know what to point at.

    The change means that the MetaDoctor now automatically retains the ordering of the files in the carrier tarball, ensuring that any inter-package dependencies are maintained. In doing so, it allows customised usage of the MetaDoctor to support inclusion of other ipkg files into the carrier tarball in the future, including the correct dependency ordering.

    -- Rod

    now Rod do you think you should implement the Flash plugin in the metadoctor script for the Plus variants? I have installed 2.1 on a sprint plus, as well as a AT&T plus and after installing flash on each, both work effectly in the browser. Of course as well as applying the preference patch to be able to enable and disable it.
  3. #2443  
    Quote Originally Posted by wellwellwell11 View Post
    now Rod do you think you should implement the Flash plugin in the metadoctor script for the Plus variants? I have installed 2.1 on a sprint plus, as well as a AT&T plus and after installing flash on each, both work effectly in the browser.
    Did you try the new test script on the AT&T Pre+?
  4. #2444  
    Installation of 2.1 on a Sprint Pre- went perfectly for me. Many thanks to the webos internals team!

    The only issue I ran into was that my VM ran out of drive space while the meta-doctor was workings its magic and I had to use cygwin. Adding the amount of drive space the meta-doctor needs for each script might be useful. The Sprint Pre- script needed 3.47GB for me.
  5. #2445  
    Quote Originally Posted by richardfrank View Post
    Yup, it's actually starting to reboot (back into 1.4.5) around 4% (i.e. the disconnection noise happens then) and then the process gets stuck at the ramdisk point (8%)...

    I've tried disconnecting and reconnecting, but to no avail.

    I found it mentioned on the "how to recover" page of the Internals Wiki that said:



    Anyone else come across this issue??
    Actually yes. i am having the exact same issue. i completely deleted my meta-doctor folder. redid everything. ran the script no problem. moved everything over into a share folder and ran the dr. everything looks like it is fine but i hit 4% and i get the the palm screen and cant do anything.
  6. #2446  
    Quote Originally Posted by graffix31 View Post
    Actually yes. i am having the exact same issue. i completely deleted my meta-doctor folder. redid everything. ran the script no problem. moved everything over into a share folder and ran the dr. everything looks like it is fine but i hit 4% and i get the the palm screen and cant do anything.
    Rather relieved to hear it's not just me!

    It's clearly not a "UK O2 Pre-" issue, since your location implies USA (unless you're in Boston, UK??)...

    Anyone out there able to shed some light on this, or do I need to go reading up how to use Novaterm and try the Internals Wiki solution... though I can't say I understand what it's doing?! And my USB partition seems fine...
  7. #2447  
    Quote Originally Posted by EdCates View Post
    AT&T Users:

    I just checked in a new test-meta-att-preplus-2.1.0 script. Need some folks to test it and see if you get a 2.1.0 device and online profile, please.

    Thanks,
    Ed
    I was just looking into this myself. It looks like a fairly standard meta Doctor list of params no hacking before running meta Doctor.

    I too tried this and found the GSM radio wasn't finding AT&T. I think you need the CUSTOM_CARRIER_DMSET=560 and CUSTOM_WEBOS_DMSET=556 parameters so it connects to AT&T as the source 2.1 image is also UTMS.

    My profile went 9.9.9, so I'm getting it back to 1.4.5 and am going to delete backups to see if that helps. (I should have just stuck with my test profile, but I got greedy and tried my primary one. ugh!)
  8. #2448  
    Quote Originally Posted by Xanadu73 View Post
    Did you turn off backups to delete your Palm Profile? I'm not sure if we're still doing that step. I'm reading both things here.
    profile-after-cleaned.png

    Another success story!

    I did not delete my backups. It had a hard time getting going, but worked in the end. The first try belly'ed up at 4%, the second at 8%. The third time went all the way through.

    Yes, I did step 6.




    M.

    #######
    # EDIT:

    Sorry. Sprint Pre- (Silver Button)
    #######
  9. #2449  
    Quote Originally Posted by rwcash View Post
    I was just looking into this myself. It looks like a fairly standard meta Doctor list of params no hacking before running meta Doctor.

    I too tried this and found the GSM radio wasn't finding AT&T. I think you need the CUSTOM_CARRIER_DMSET=560 and CUSTOM_WEBOS_DMSET=556 parameters so it connects to AT&T as the source 2.1 image is also UTMS.

    My profile went 9.9.9, so I'm getting it back to 1.4.5 and am going to delete backups to see if that helps. (I should have just stuck with my test profile, but I got greedy and tried my primary one. ugh!)
    Thanks for testing this. I don't have an AT&T *anything*, and as a life-long Sprint customer the GSM world is alien to me. ;-)

    I updated the test-meta-att script to add the DMSET values back in, per your suggestion.
    Last edited by EdCates; 03/05/2011 at 02:31 PM. Reason: Reality changed.
  10. #2450  
    Quote Originally Posted by rwcash View Post
    I was just looking into this myself. It looks like a fairly standard meta Doctor list of params no hacking before running meta Doctor.

    I too tried this and found the GSM radio wasn't finding AT&T. I think you need the CUSTOM_CARRIER_DMSET=560 and CUSTOM_WEBOS_DMSET=556 parameters so it connects to AT&T as the source 2.1 image is also UTMS.

    My profile went 9.9.9, so I'm getting it back to 1.4.5 and am going to delete backups to see if that helps. (I should have just stuck with my test profile, but I got greedy and tried my primary one. ugh!)
    I'm still getting 9.9.9 even after a deletion of the backups. Anyone else trying this with any luck? Could be HPalm's servers aren't showing any AT&T love...
  11. #2451  
    Quote Originally Posted by rwhitby View Post
    Here's the deal with step 5:

    For Sprint/Verizon:
    --------------------

    Sometime in the last week, Sprint Pre 2's started to get correct version numbers on the palm profile.

    We noticed this, and modified the sprint and verizon scripts to do the right thing to take advantage of that. Seems that it worked.

    For other carriers:
    --------------------

    We now create a custom conglomeration of parts of the 1.4.5 palm-build-info and parts of the 2.1.0 palm-build-info to create one that says one thing to the palm profile login process, and something else to Mojo when it asks what version of webOS is running.

    -- Rod
    Sprint pre minus: I'm running fine with the original scripts 1 week out that included step 5. Palm.com/palmprofile shows 1.40.50 and device shows HP WebOS 2.1.0

    Would there be any advantage to re-metadoctoring? I mean would I get a palm.com/palmprofile to show 2.1.0 and would that allow me to buy 2.x only apps from the catalog like music player remix.

    So those of us who did the old step 5...any reason for us to re-metadoctor (looked and did not see an answer to this). Thanks!
  12. #2452  
    Quote Originally Posted by cyberprashant View Post
    Sprint pre minus: I'm running fine with the original scripts 1 week out that included step 5. Palm.com/palmprofile shows 1.40.50 and device shows HP WebOS 2.1.0

    Would there be any advantage to re-metadoctoring? I mean would I get a palm.com/palmprofile to show 2.1.0 and would that allow me to buy 2.x only apps from the catalog like music player remix.

    So those of us who did the old step 5...any reason for us to re-metadoctor (looked and did not see an answer to this). Thanks!
    It's not been answered explicitly, but yes, there are numerous people now getting the correct OS version in their profiles, and the ability to get 2.X apps.

    I recommend re-doctoring. It can only help going forward.
  13. #2453  
    Quote Originally Posted by EdCates View Post
    It's not been answered explicitly, but yes, there are numerous people now getting the correct OS version in their profiles, and the ability to get 2.X apps.

    I recommend re-doctoring. It can only help going forward.
    OK I will re-metadoctor and see what happens. Not sure if I should use the --wifi-only switch. I did the second time and that allowed me to bypass actvation, connect to wifi access point and run gesture first use (cell service reception flaky in here)...but what's wierd is my cell service works fine afterwards (which is NOT what otther folks are reporting namely that cell service is permanently disabled by wifi-only)
  14.    #2454  
    Quote Originally Posted by richardfrank View Post
    Rather relieved to hear it's not just me!

    It's clearly not a "UK O2 Pre-" issue, since your location implies USA (unless you're in Boston, UK??)...

    Anyone out there able to shed some light on this, or do I need to go reading up how to use Novaterm and try the Internals Wiki solution... though I can't say I understand what it's doing?! And my USB partition seems fine...
    Your issue is novacom drivers and your computer, not a corrupt USB drive on the Pre.

    -- Rod
  15. #2455  
    "FIX" is in quotes for a reason...

    I was digging through my Pre- while still on 1.4.5 and found:

    /var/lib/software/ModemFiles

    In here I found my PRL file and some other modem related files/dirs. I saved them before I wiped my phone for webOS 2.1 and just copied the whole /var/lib/software/* kit-and-kaboodle into my webOS 2.1 install. I have full bars (which I only had after an update 3 or so ago) and full 3g. Device Info also reads that file just fine. I do not see any reason why this would be "illegal" as these files came off MY phone and they were put there by Sprint for "me" to use, so...


    Quote Originally Posted by ash
    root@My Pre:/var/lib/software# ls -lt
    -rw-r--r-- 1 root root 35 Mar 5 15:53 system_settings.info
    -rwxr-xr-x 1 root root 299782 Mar 5 15:36 DmTree.backup.xml
    -rwxr-xr-x 1 root root 299782 Mar 5 15:36 DmTree.xml
    drwxr-xr-x 2 root root 4096 Mar 5 15:36 ModemFiles
    drwxr-xr-x 2 root root 4096 Mar 5 15:36 SessionFiles
    -rwxr-xr-x 1 root root 0 Mar 5 15:36 booted
    -rwxr-xr-x 1 root root 14 Mar 5 15:36 domain
    -rwxr-xr-x 1 root root 1 Mar 5 15:36 state
    -rwxr-xr-x 1 root root 0 Mar 5 15:36 version
    -rw-r--r-- 1 root root 9 Mar 5 15:28 ware
    drwxr-xr-x 2 root root 4096 Feb 1 12:41 tmp

    root@My Pre:/var/lib/software# ls -lt ModemFiles/
    -rwxr-xr-x 1 root root 7649 Mar 5 15:36 prefroamlist

    root@My Pre:/var/lib/software#




    The update button still isn't there, so it's not update-able, but, at least it's not a year+ old PRL...

    If this is known, I'm sorry for wasting your time.




    M.
  16. fubka's Avatar
    Posts
    36 Posts
    Global Posts
    40 Global Posts
    #2456  
    are there any videos of webos2.0 on a pre-? I have seen them on pre+ and want to see it in motion before a take the plunge. Thanks.
  17. #2457  
    I tried searching in this thread but can't seem to find an answer.

    I'm trying this (Sprint Pre-) in Cygwin, and when I pulled down the meta-doctor, noticed I did not get a Palm-Build-Info or masqued file (watched the video posted) in my meta-doctor folder. Other than that, I started the process and it made the meta-doctor, however, I am now stuck at

    cp: cannot stat 'build/pre2-p102eww-verizonwireless-2.1.1/webOS/roadrunnercdma_fw.tar': no such file or directory
    tar: ./castlecdmafw.tar: Cannot stat: no such file or director
    tar: Exiting with failure status due to previous errors
  18. #2458  
    Quote Originally Posted by jboucicaut View Post
    I tried searching in this thread but can't seem to find an answer.

    I'm trying this (Sprint Pre-) in Cygwin, and when I pulled down the meta-doctor, noticed I did not get a Palm-Build-Info or masqued file (watched the video posted) in my meta-doctor folder. Other than that, I started the process and it made the meta-doctor, however, I am now stuck at

    cp: cannot stat 'build/pre2-p102eww-verizonwireless-2.1.1/webOS/roadrunnercdma_fw.tar': no such file or directory
    tar: ./castlecdmafw.tar: Cannot stat: no such file or director
    tar: Exiting with failure status due to previous errors
    You're not running the meta-sprint-pre-2.1.0 script, are you?
  19. nethan's Avatar
    Posts
    96 Posts
    Global Posts
    97 Global Posts
    #2459  
    Quote Originally Posted by fubka View Post
    are there any videos of webos2.0 on a pre-? I have seen them on pre+ and want to see it in motion before a take the plunge. Thanks.
    I don't have a video of my phone in operation but I can say it runs just about as smoothly as 1.4.5 did. The only thing that seems to chug in the camera app. I've been able to take pictures, but it is very slow. I haven't tried video yet. When you first update and it is re installing all your apps it is VERY slow, but once that is done, it speeds up considerably.
  20. fubka's Avatar
    Posts
    36 Posts
    Global Posts
    40 Global Posts
    #2460  
    nethan: see are there any advantages for 2.1 over 1.45 on a pre-. The lesser amount of ram is what worries me.

Posting Permissions