Page 100 of 217 FirstFirst ... 50909596979899100101102103104105110150200 ... LastLast
Results 1,981 to 2,000 of 4324
Like Tree19Likes
  1. d.moss's Avatar
    Posts
    541 Posts
    Global Posts
    582 Global Posts
    #1981  
    ok.. i've gotten a little further.. i saw what my issue was.. i was missing the git clone step so there was indeed "no such file".. i entered the git clone command then ./scripts/ command, and the terminal said "your custom doctor will be created at....." it began to build, then i got another error.. below
    Attached Images Attached Images
  2. #1982  
    Quote Originally Posted by d.moss View Post
    ok.. i've gotten a little further.. i saw what my issue was.. i was missing the git clone step so there was indeed "no such file".. i entered the git clone command then ./scripts/ command, and the terminal said "your custom doctor will be created at....." it began to build, then i got another error.. below
    It looks like one or more of your webOS Doctor .JAR files didn't download properly. Remove the contents of ./meta-doctor/downloads/ and run the script again.
    Curious about upgrading your Legacy Pre to webOS 2.1? READ THE WIKI
  3. #1983  
    Fantastic work as always!

    I've actually read every post in this thread, have been through the Webos 2 Upgrade Wiki several times, as well as the Metadoctor Application Wiki, and have been using Metadoctor for at least a year.

    I haven't seen this addressed anywhere, so here's my question:

    I've got 2 Sprint Pre-'s on separate Palm Profiles one running a meta-doctored 1.4.5 and one running 2.1.0 (new-sprint-pre script, modified to add wifi profiles, testing feeds, the varspace mod). Both run well.

    What I'd like to do is have both of them be ready to be my primary phone, so that I can switch back and forth quickly when necessary.

    For a while I had my 2.1.0 activated on Sprint, 3G, text messaging and phone worked fine. I then activated my 1.4.5 Pre- (with a fresh doctor) and 3G worked on that phone. However, when I re-activated the 2.1.0 device, I get the phone and text messaging to work, but had no 3G and an occasional "Your device could not establish a data connection (67)" error. I know that one solution (from the 9min video in the wiki and my own experience) is to re-doctor to 1.4.5 while activated, then doctor back to 2.1.0.
    However, this is far from the quick switch that I'm looking for. I've reproduced this problem basically every time I activate a (previously-activated) phone that is running a meta-doctor.

    Am wondering if anyone has any insight into this, and what settings you would recommend for each device. I know that bypassing activation is not a viable option. Bypassing First Use apparently causes profile version issues or Dr. Firstuse skipped issues. Neither of these are selected in either my 2.1.0 or 1.4.5 meta-doctors.

    How would you recommend setting up two devices that will be sometimes full-phone, and sometimes wifi-only? It seems that there's an issue with the phone fully activating and allowing 3G if the phone becomes deactivated at some point.

    Please let me know if any of you need more details to help. Much appreciated!
  4. #1984  
    Quote Originally Posted by Frankk View Post
    This solved my problem N.1 with net connection, but I still see few apps (47 to be precise) in the app catalog.
    All the apps I previously installed in 1.4.5 got reinstalled correctly. My palm profile now says i'm on 2.1.0 (was 1.4.5 before).

    I'm afraid I have to install my apps downloading the IPKs manually with IPK fetcher.....
    I was wrong, I see many more apps (don't know how many exactly), it's only that you can't see the count in the new app catalog (at least I don't know how).

    Btw I still can't install "Voice Memos" or "Voices". If I try to install them from preware the app catalog launches saying that the apps are not available in my country.

    **
    I get some too many cards problems (even with compcache set to 32MB). Today I'm going to try a custom kernel UberKernel of F105, I will decide later.
  5.    #1985  
    Quote Originally Posted by DaDueler View Post
    I've got 2 Sprint Pre-'s on separate Palm Profiles one running a meta-doctored 1.4.5 and one running 2.1.0 (new-sprint-pre script, modified to add wifi profiles, testing feeds, the varspace mod). Both run well.

    What I'd like to do is have both of them be ready to be my primary phone, so that I can switch back and forth quickly when necessary.

    For a while I had my 2.1.0 activated on Sprint, 3G, text messaging and phone worked fine. I then activated my 1.4.5 Pre- (with a fresh doctor) and 3G worked on that phone. However, when I re-activated the 2.1.0 device, I get the phone and text messaging to work, but had no 3G and an occasional "Your device could not establish a data connection (67)" error. I know that one solution (from the 9min video in the wiki and my own experience) is to re-doctor to 1.4.5 while activated, then doctor back to 2.1.0.
    However, this is far from the quick switch that I'm looking for. I've reproduced this problem basically every time I activate a (previously-activated) phone that is running a meta-doctor.
    Sorry, but I know nothing about the Sprint CDMA phone activation process (living in a country that only has GSM networks).

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6. #1986  
    I've checked this twice.
    If I manually edit the Makefile instead of running the WR script, voicedial is not available.
  7. #1987  
    Quote Originally Posted by rwhitby View Post
    I have updated both the first post in this thread, and the WebOS 2 Upgrade wiki page to make it clear that you should not go further than the end of Step 1: Setting up Meta-Doctor on the MetaDoctor wiki page before returning to the WebOS 2 Upgrade wiki page and continuing there.

    I think that might answer your question.

    -- Rod
    Before I saw your post I saw those instructions and found them a bit misleading based on my experience, so I took it upon myself to refine them a bit. I see no need for anyone to go past the 8th step of setting up meta-doctor (or step 11 on the mac instrucitons).
    I'm sure that if you want the instructions back the way you had them you won't be shy about reverting my changes.
  8.    #1988  
    Quote Originally Posted by johnsonx42 View Post
    Before I saw your post I saw those instructions and found them a bit misleading based on my experience, so I took it upon myself to refine them a bit. I see no need for anyone to go past the 8th step of setting up meta-doctor (or step 11 on the mac instrucitons).
    I'm sure that if you want the instructions back the way you had them you won't be shy about reverting my changes.
    No, what you've done is good.

    I actually think we need to restructure the MetaDoctor page so that the setup stuff is separate, and then all the running stuff is separate. Then we really could just point to section 1 only.

    Anyone who wants to take a crack at that, feel free.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  9. #1989  
    If anyone thinks it would be helpful I might see about making a windows-only instruction page. It seems alot of the windows users are getting confused by all the different instructions, and are wasting hours setting up ubuntu in a vm, or running wubsi or whatever it's called (yes, it might be good for them, but hardly necessary). it's SO much simpler to just run the whole thing from Cygwin. starting from nothing a simple set of steps ought to have a windows user running the meta-script within 15 minutes, and running the dr 15 minutes after that.
  10. #1990  
    This may prove to be helpful for someone:

    I spent all of yesterday night trying to install 2.1 on my O2-DE Pre Minus using the meta-doctor script, and only got error messages to the tune of my phone being the wrong model.

    Around 1 AM, I decided to try one last hail mary before going to sleep - I had previously set my system language to en-us in order to be able to install a few patches that would not work with de-de. So I had the idea of switching the system language back to German. And bingo, instead of going to bed, my phone finally doctored. Only made it to bed by 3am.

    So if you're running a non-"standard" language on your phone, that may bork your 2.1 upgrade. (The Doctor asks you to select a language; I tried both German and English, and neither would work before I finally reset my phone's language to German).
  11.    #1991  
    Got some new test scripts to try. These are designed to eliminate the need for step 5 (since that is the step everyone is having problems with).

    Need some brave souls to test them. ./scripts/test-*

    If you're on Sprint, you may get an extra special treat ...

    -- Rod
  12. #1992  
    This is non-technical and lengthy, I hope it doesn't disturb you. It's a chat I've just had with a Palm support employee, to whom I ask if they can upgrade my 1.4.5 profile to the 2.1 I have on my original Movistar Spain Pre. Long story short: Unsupported, go back to 1.4.5. Helpful anyway:

    12:15 Christian R.: Thank you for contacting Palm Technical Support. My name is Christian. The chat session ID is 83859859. As far as I understand you are having issues with your profile.
    12:15 Juan Carlos Marcos Rodríguez: Hello Christian. Yes, I have problems with my profile. But actually, I created the problems myself. Want to know?
    12:16 Christian R.: Of course sir.
    12:17 Juan Carlos Marcos Rodríguez: Well, I've updated my original Movistar Spain Pre to WebOS 2.1, through an unofficial procedure. The phone seems to work fine, but I'd like to know if HP agrees with that, and if you would update my profile to 2.1.
    12:18 Christian R.: Let me check a few things, can I have your serial number please?
    12:19 Christian R.: You can find it in the Device Info app.
    12:21 Juan Carlos Marcos Rodríguez: Well, if you assure me that you are not going to kick me out of the profile... I'm worried, because my update is unoficial, and perhaps HP would ban me out.
    12:23 Christian R.: Don't worry sir, it is only a procedure that we do not recommend.
    12:24 Juan Carlos Marcos Rodríguez: OK fine. My serial number is ************.
    12:24 Christian R.: Thank you very much.
    12:25 Christian R.: Well, actually the profile is still with the old operative system.
    12:26 Juan Carlos Marcos Rodríguez: Yes. I'd like to know if you can update it to 2.1 version, and what consequences that might have, related mostly to the App catalog.
    12:27 Christian R.: Unfortunately not sir, we do not provide support at that specific situations.
    12:28 Juan Carlos Marcos Rodríguez: Oh, thanks. Perhaps I could try to log in again into my profile from the phone, but that function is only availble once, and I no longer can. Is there a procedure to do it afterwards?
    12:31 Christian R.: You could try to do a WebOS Doctor to get back to the 1.4.5 and use again the profile.
    12:31 Christian R.: And erase the 2.1 that you have now.
    12:32 Juan Carlos Marcos Rodríguez: I see. So you recommend going back to 1.4.5, that's understandable. Thankyou very much Christian. One more question: Will I be able to buy apps from the catalog in my current sittuation?
    12:33 Christian R.: Actually we cannot really determine that... That's why we don't recommend it. It could happen that you can use it... But it also can happen the other way round.
    12:34 Juan Carlos Marcos Rodríguez: Fine, I understand my sittuation better now. Thankyou very much for your help Christian.
    12:34 Christian R.: Is there anything else I can do for you today?
    12:35 Juan Carlos Marcos Rodríguez: That was all, thanks.
    12:35 Christian R.: Remember that at the end of this session you might be getting a Customer Satisfaction survey. We will very much appreciate your feedback.
    Thank you very much for contacting Palm Technical Support. Have a nice day!
  13. #1993  
    Quote Originally Posted by h2onions View Post
    No, I didn't do step 5. I was just wondering if I have to/should do it?
    Now there is a reason why Step 5 exists.
    Please, follow the Wiki, each and every step.

    You cannot expect things to work correctly if you are skipping steps.

    In other words: if you leave it out you will have a confused, non-standard Pre where some things will not work correctly.

    Max
  14. #1994  
    Quote Originally Posted by rwhitby View Post
    Got some new test scripts to try. These are designed to eliminate the need for step 5 (since that is the step everyone is having problems with).

    Need some brave souls to test them. ./scripts/test-*

    If you're on Sprint, you may get an extra special treat ...

    -- Rod
    Tested the new sprint script, confirmed that my palm profile now shows 2.1.0, and that i can now see the "Voices" app in the app catalog.

    Nice update :-)
  15. #1995  
    Quote Originally Posted by jcmarcos View Post
    This is non-technical and lengthy, I hope it doesn't disturb you. It's a chat I've just had with a Palm support employee, to whom I ask if they can upgrade my 1.4.5 profile to the 2.1 I have on my original Movistar Spain Pre. Long story short: Unsupported, go back to 1.4.5.
    Quite understandable. They would open a can of worms if they started trying to support unofficial upgrades.

    Max
  16. #1996  
    Quote Originally Posted by d.moss View Post
    ok.. i've gotten a little further.. i saw what my issue was.. i was missing the git clone step so there was indeed "no such file".. i entered the git clone command then ./scripts/ command, and the terminal said "your custom doctor will be created at....." it began to build, then i got another error.. below
    Looks like a bad download to me. I'd suggest to whack the Doctor files out of ./downloads, and let the script pull them in again. It looks like it's the Sprint one that's bonked, but, unless you're on dial-up, you might as well whack them all.


    M.
  17. #1997  
    Quote Originally Posted by johnsonx42 View Post
    If anyone thinks it would be helpful I might see about making a windows-only instruction page. It seems alot of the windows users are getting confused by all the different instructions, and are wasting hours setting up ubuntu in a vm, or running wubsi or whatever it's called (yes, it might be good for them, but hardly necessary). it's SO much simpler to just run the whole thing from Cygwin. starting from nothing a simple set of steps ought to have a windows user running the meta-script within 15 minutes, and running the dr 15 minutes after that.
    Please do!!!
  18. #1998  
    Quote Originally Posted by zinge View Post
    Tested the new sprint script, confirmed that my palm profile now shows 2.1.0, and that i can now see the "Voices" app in the app catalog.

    Nice update :-)
    I can't seem to find the test script. What exactly did you type in? (I'm also on a Sprint Pre)
  19. #1999  
    Quote Originally Posted by DaDueler View Post
    However, when I re-activated the 2.1.0 device, I get the phone and text messaging to work, but had no 3G and an occasional "Your device could not establish a data connection (67)" error.

    After having been with Sprint since early 2002, I'll say this is due to the old PRL that gets flashed to our phones in this meta-doctor process. There's (currently) no way to update the PRL to get a new list of towers. This is why not having an update-able PRL is a Show Stopper™
    for me with updating to 2.1 right now. I *know* that I will be running into this issue since only the last couple PRL updates have kept me above 3 bars and a constant 3G in my area.


    M.
  20. #2000  
    Quote Originally Posted by StuntmanMark View Post
    I can't seem to find the test script. What exactly did you type in? (I'm also on a Sprint Pre)

    git pull


    M.

Posting Permissions