Page 18 of 22 FirstFirst ... 813141516171819202122 LastLast
Results 341 to 360 of 431
Like Tree16Likes
  1. #341  
    Quote Originally Posted by MartinH@webos View Post
    GREAT ! Thanks!
    This version finally works on my Pre3 !
    I can talk in both directions; I can use Audio Switch to switch the Pre3 speakers; I can receive and place calls.
    Good to hear!

    Quote Originally Posted by MartinH@webos View Post
    This version does display "RegistrationOK" (instead of RegOK).
    This is because linphone 3.5.2 uses different states than 3.3.2. See here for technical info about this particular change.

    Quote Originally Posted by MartinH@webos View Post
    If I receive a call on the Pre3 I can not really end the call on the Pre3. (there is no active button to press). I can close the app and next time I open it the previous call gets canceled.
    Oops, this is a bug from the upgrade to 3.5.2. Will be fixed soon.

    Quote Originally Posted by MartinH@webos View Post
    Also it always displays "unknown caller" instead of the phone/SIP Number.
    This is also due to upgrade to 3.5.2, will need a bit more work as the caller id is no longer passed as "message" along with a new call notification, you now need to go obtain it afterwards. Will be fixed soon too.

    Quote Originally Posted by MartinH@webos View Post
    I could not hear any DTMF tones when using keypad.
    You can typically never "hear" any DTMF tones unless it's feedback from the remote party(and even then it only works while they are sending some sound of their own). Do DTMF work for accessing menu in a voicemail box for example? They should.

    Quote Originally Posted by MartinH@webos View Post
    I had a bit of a problem with installing this version at the first try.
    First I did uninstall the previous linphone 0.1.18 version and install the new one. (This failed to register)
    Then I installed the previous 0.1.18 version (without uninstall) and again installed the new version over the installed one. Now the new version did register and works as described above.
    This is weird and I cannot reproduce it. Might be that your phone was in a weird state... If you can reliably reproduce it we could check some logs I guess...

    In the meantime people should be warned that 0.1.15-nm1 has the issues mentionned by Martin and maybe others, so install at your own risk.
  2. #342  
    Quote Originally Posted by Lazar Dobrescu View Post
    This is because linphone 3.5.2 uses different states than 3.3.2. See here for technical info about this particular change.
    No problem. This just an indicator in the app that tells me that I have the "new" 0.1.15 version installed.
    Else the app has no display of it's version. I need to run Preware or Application Manager to look up the installed version and this just tells me "0.1.15".

    Looking forward to test more future versions.

    Thanks for the great progress !!

    ---
    BTW - I installed the same "pre" version on my TouchPad 3.0.5 and still do not get it to register : "still waiting for .."
  3. #343  
    Alright I got a new version working, with the two bug fixes:
    - Disconnect button is now enabled when an incoming call gets connected
    - Caller ID is retrieved correctly

    Here it is:
    linphone-0.1.15-nm2-pre
    linphone-0.1.15-nm2-pixi

    As always, if you try it and find problems please report them.
  4. #344  
    Quote Originally Posted by MartinH@webos View Post
    Else the app has no display of it's version. I need to run Preware or Application Manager to look up the installed version and this just tells me "0.1.15".
    You can orange-click on an app's launcher icon to see its version. There was a bug in 0.1.15.1, it didn't show the last 1. It should be ok in 0.1.15.2.
    Last edited by Lazar Dobrescu; 05/04/2012 at 12:13 AM.
  5. #345  
    Quote Originally Posted by Lazar Dobrescu View Post
    Alright I got a new version working, with the two bug fixes:
    - Disconnect button is now enabled when an incoming call gets connected
    - Caller ID is retrieved correctly

    Here it is:
    linphone-0.1.15-nm2-pre
    linphone-0.1.15-nm2-pixi

    As always, if you try it and find problems please report them.
    Great! As with the previous version I ha to manually load the file 'service'. It seems to be missing in the dbus directory, isn't it?
  6. #346  
    Quote Originally Posted by Dick99999 View Post
    Great! As with the previous version I ha to manually load the file 'service'. It seems to be missing in the dbus directory, isn't it?
    Damn, it indeed was an error in the packaging process... I updated the files they should now be fine. Thanks for the heads up!
  7. #347  
    Quote Originally Posted by Lazar Dobrescu View Post
    Alright I got a new version working, with the two bug fixes:
    - Disconnect button is now enabled when an incoming call gets connected
    - Caller ID is retrieved correctly

    Here it is: linphone-0.1.15-nm2-pre
    As always, if you try it and find problems please report them.
    Thanks again !!!
    I installed the new version 2 on my Pre3 and it is better than ever ! Thanks !
    Disconnect button is there and works ok.
    But on my Pre3 the caller ID does not display at all. now the field between Green and Red button is just blank all the time when I receive a call. (with the old 0.1.8 version it displayed "unkown caller or some actual number".)

    I did try the same version on TouchPad - but no change at all. Still "waiting for service ..."
    Did anyone ever get a Registration OK on a TouchPad 3.0.5 device ??
    --
    Now, I need to look at a way to launch linphone whenever my Wifi is active.
    Still need to test if linphone does register when I switch Wifi off and on again ..
    ---
    Still need to test other older devices: PrePlus 1.4.5 and Pre2 on 2.2.4
  8. #348  
    Quote Originally Posted by MartinH@webos View Post
    But on my Pre3 the caller ID does not display at all. now the field between Green and Red button is just blank all the time when I receive a call. (with the old 0.1.8 version it displayed "unkown caller or some actual number".)
    Thanks a lot for your testing and feedback MartinH!

    That issue is strange, are you able to setup lumberjack on your pre 3 and "follow" linphone logs while it is receiving a call? Then you can from the menu Log->copy and hopefully show me interesting stuff? I cannot see your problem at all on my phone everything seems fine on the caller ID side...
  9. #349  
    Quote Originally Posted by MartinH@webos View Post
    Now, I need to look at a way to launch linphone whenever my Wifi is active.
    Not sure if it's overkill for you but I usually manage all that using the awesome Mode Switcher app..
  10. #350  
    Quote Originally Posted by Lazar Dobrescu View Post
    That issue is strange, are you able to setup lumberjack on your pre 3 and "follow" linphone logs while it is receiving a call?
    Ok. Here is part of my log. (I replaced my private numbers in here)

    Quote Originally Posted by my log
    [2012-05-07 21:57:23] (Linphone) Warning: document had scroll top set, resetting.
    [2012-05-07 21:57:23] (Linphone) Info: Linphone: DialpadAssistant#setup
    [2012-05-07 21:57:23] (Linphone) Info: Linphone: DialpadAssistant#setup: screenHeight = 800
    [2012-05-07 21:57:23] (Linphone) Info: Linphone: DialpadAssistant#setup: dialpad.class = dialpad-scene pre
    ...
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: DialpadAssistant#gstateUpdate [ CallIncomingReceived , ( Incoming call )]
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: DialpadAssistant#handleAny
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: DialpadAssistant#handleCallIn
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: DialpadAssistant#handleCallIn: RINGIN
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: LinphoneService#callInfo
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: DialpadAssistant#buttonEmptyON true
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: TelephonyCommands#setAudioScenario failure
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: DialpadAssistant#incomingCallPopup
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: IncomingcallAssistant#initialize <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:00] (Linphone) Warning: document had scroll top set, resetting.
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: IncomingcallAssistant#setup <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:00] (Linphone) Error: An exception occurred in the 'incomingcall' scene's setup() method.
    [2012-05-07 22:06:00] (Linphone) Error: Error: Cannot call method 'replace' of undefined, line undefined, file undefined
    [2012-05-07 22:06:00] (Linphone) Info: About to activate scene incomingcall
    [2012-05-07 22:06:00] (Linphone) Info: Linphone: IncomingcallAssistant#activate <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:00] (Linphone) Info: Transition ended.
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: DialpadAssistant#gstateUpdate [ CallEnd , ( Call ended )]
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: DialpadAssistant#handleAny
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: IncomingcallAssistant#onMissed <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: IncomingcallAssistant#closeWindow <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: DialpadAssistant#handleCall
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: DialpadAssistant#handleCall: IDLE or ENDED
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: DialpadAssistant#buttonDialON true
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: TelephonyCommands#setAudioScenario failure
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: IncomingcallAssistant#deactivate <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:07] (Linphone) Info: Linphone: IncomingcallAssistant#cleanup <sip:0123498765@fritz.fonwlan.box>
    [2012-05-07 22:06:12] (Linphone) Info: Linphone: DialpadAssistant#gstateUpdate [ CallEnd , ( Call released )]
    [2012-05-07 22:06:12] (Linphone) Info: Linphone: DialpadAssistant#handleAny
    [2012-05-07 22:06:12] (Linphone) Info: Linphone: DialpadAssistant#handleCall
    [2012-05-07 22:06:12] (Linphone) Info: Linphone: DialpadAssistant#handleCall: IDLE or ENDED
    [2012-05-07 22:06:12] (Linphone) Info: Linphone: DialpadAssistant#buttonDialON true
    [2012-05-07 22:06:12] (Linphone) Info: Linphone: TelephonyCommands#setAudioScenario failure
    I assume here something goes wrong in my case:
    [2012-05-07 22:06:00] (Linphone) Error: An exception occurred in the 'incomingcall' scene's setup() method.
    [2012-05-07 22:06:00] (Linphone) Error: Error: Cannot call method 'replace' of undefined, line undefined, file undefined
  11. #351  
    Quote Originally Posted by MartinH@webos View Post
    Ok. Here is part of my log. (I replaced my private numbers in here)
    Yeah ok that was just bad testing on my part... I was sure I had covered that case. Anyhow here's what hopefully the final fix on that issue:

    linphone-0.1.15-nm3-pre
    linphone-0.1.15-nm3-pixi

    If that still fails for some reason, let me know and I'll be happy to fix it again...
  12. #352  
    Quote Originally Posted by Lazar Dobrescu View Post
    here's what hopefully the final fix on that issue:

    linphone-0.1.15-nm3-pre
    Thanks again !
    This version 0.1.15.3 works better than every other version. (audioswitch app works fine)
    Yes, now on my Pre3 (2.2.4) the caller ID does display as: "Unknown Caller" and the 2nd line displays the actual number.
    I don't know why "Unknown Caller" is displayed. My local Fritzbox (SIP server) has names configured for these "IP-phones" and numbers are related to names in the local phonelist. But does not provide that information to the called phone device.

    ---
    I installed 0.1.15.3 on Touchpad (3.0.5) without any change. "Still waiting for service to come up ..."
    If someone can tell me where to find the linphone logs on TouchPad then I can have a look.

    I installed 0.1.15.3 on PrePlus (1.4.5) without issues.
    I was able to call and talk with my Pre3 in both directions without issues.

    The only minor issue is that the current call is not terminated when you close the linphone app. Then the speaker is still active and the connection is still ongoing.
    Once you restart the Pre3 linphone app then the previous connection is terminated and registration is started ok.
    On PrePlus it needed a reset in the linphone app to terminate the previous talk and for getting registered again.

    Can you or someone put this 0.1.15.3 version in the preware catalog for phones at some time?

    Thanks, Martin
  13. #353  
    Quote Originally Posted by MartinH@webos View Post
    I don't know why "Unknown Caller" is displayed. My local Fritzbox (SIP server) has names configured for these "IP-phones" and numbers are related to names in the local phonelist. But does not provide that information to the called phone device.
    As far as I know in the SIP world the actual calling point is the one providing its Caller ID, not the server. There might be a configuration on your phones to setup a name, but some devices don't. If the calling party is another webos phone, there is no way yet to give it a name to send as caller id.

    Quote Originally Posted by MartinH@webos View Post
    The only minor issue is that the current call is not terminated when you close the linphone app. Then the speaker is still active and the connection is still ongoing.
    Once you restart the Pre3 linphone app then the previous connection is terminated and registration is started ok.
    On PrePlus it needed a reset in the linphone app to terminate the previous talk and for getting registered again.
    I'll take a look at this and see if it's fixable easily...

    Quote Originally Posted by MartinH@webos View Post
    Can you or someone put this 0.1.15.3 version in the preware catalog for phones at some time?
    No idea how that works and I don't know if there are other plans for this app either. I guess someone would need to talk to the guys at webos-internals...
    MartinH@webos likes this.
  14. #354  
    Quote Originally Posted by Lazar Dobrescu View Post
    I updated my post with the new link for pixi. Obviously untested as I don't own a pixi. Let me know how it goes.

    My SIP provider is voip.ms.
    Thanks Lazar, your version is sooo much better than any other release..is working great on my Pixi+...im using a sip2sip.info account...and calling to an Inum ( provided by callcentric ), works fine....

    Since im using very large Inums numbers ( if you used them before you know what im talking about ) would be great the addition of a simple contact list, or allow copy paste, or any other method so i dont have to type/memorize every number

    Thanks for your great work.
  15. #355  
    Quote Originally Posted by MartinH@webos View Post
    I installed 0.1.15.3 on Touchpad (3.0.5) without any change. "Still waiting for service to come up ..."
    If someone can tell me where to find the linphone logs on TouchPad then I can have a look.
    Well, now I found mojo - Lumberjack for TouchPad (on Preware) and it works ok.
    Below please read where the Error occurs during first start up:

    Quote Originally Posted by MartinH@TouchPad
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: AppAssistant#onFocus
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: TelephonyCommands#lockVolumeKeys: true
    [2012-05-09 19:19:27] (Linphone) Info: Transition ended.
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: TelephonyCommands#setAudioScenario failure
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: TelephonyCommands#proxSet: failure (enable=false)
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: DialpadAssistant#gstateUpdate [ , ( . )]
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: AppAssistant#onFocus
    [2012-05-09 19:19:27] (Linphone) Info: Linphone: TelephonyCommands#lockVolumeKeys: true
    [2012-05-09 19:19:30] (Linphone) Error: Linphone: LinphoneService#quit failure: Message status unknown.
    [2012-05-09 19:19:30] (Linphone) Error: Linphone: LinphoneService#firewall failure: Message status unknown.
    [2012-05-09 19:19:30] (Linphone) Error: Linphone: LinphoneService#dtmfMethod failure: Message status unknown.
    [2012-05-09 19:19:31] (Linphone) Info: Linphone: AppAssistant#onBlur
    The exact same log entry occurs when I use the "Reset Service (soft)" menu:
    Error: Linphone: LinphoneService#quit failure: Message status unknown.

    A similar log entry occurs when I use the "Reset Service (hard)" menu:
    Error: Linphone: LinphoneService#abort failure: Message status unknown.

    Perhaps this helps to indentify the issue?

    Quote Originally Posted by Lazar
    I usually manage all that using the awesome Mode Switcher app.
    Yes, thanks. I have MS installed on my Pre3 - but I have not really used so far.
    Now I did configure it for linphone and it works ok. linphone is smart enough to re-register as soon as the Wifi gets connected.

    Regards, Martin
  16. #356  
    Quote Originally Posted by MartinH@webos View Post
    *snip touchpad logs*
    Perhaps this helps to indentify the issue?
    Looks like this could be that the service is just not able to start, or doesn't answer to any queries. If you are comfortable with shell access to your device we can try to find out if that is indeed the case and why...The upstart file is /var/palm/event.d/org.webosinternals/linphone.service. In it is the launching of the actual service executable, which you can try to launch from the command line(after exporting LD_LIBRARY_PATH as in the upstart file).

    First check if it's actually already running:
    ps xua | grep linphone
    if you see a line containing /var/usr/sbin/org.webosinternals.linphone.service like so:
    root 15923 0.2 0.7 50240 3548 ? SLsl 22:34 0:00 /var/usr/sbin/org.webosinternals.linphone.service -N
    , it is already running and you need to stop it first:
    stop org.webosinternals.linphone.service
    Then start it with debugging logs, something like:
    export LD_LIBRARY_PATH=/var/usr/lib/org.webosinternals.linphone
    /var/usr/sbin/org.webosinternals.linphone.service -N -d 9
    If you are able to do this and show me what happens, maybe we can find a solution...
  17. #357  
    Quote Originally Posted by Lazar Dobrescu View Post
    , it is already running and you need to stop it first:
    I've used wterm and found that linphone service is running on my TouchPad.
    As root I've tried to kill the process. (kill <id>)
    But same process is restarted automatically.

    I can not execute "stop" on my TouchPad - because there is no "stop" command installed.
    Where to find "stop" or what package does it install? How else I can stop this service and restart it manually?
  18. #358  
    Quote Originally Posted by MartinH@webos View Post
    I've used wterm and found that linphone service is running on my TouchPad.
    As root I've tried to kill the process. (kill <id>)
    But same process is restarted automatically.

    I can not execute "stop" on my TouchPad - because there is no "stop" command installed.
    Where to find "stop" or what package does it install? How else I can stop this service and restart it manually?
    stop is normally in /sbin, maybe it's just not on your path... Otherwise it will restart automatically because its upstart script tells it to do so.

    I guess it would be simpler for me to provide another package:
    linphone-0.1.15-nm3-logs-pre
    That will enable logs all the time to /media/internal/linphone.log.

    If we can have a look at those at the same time as the ones from Lumberjack hopefully we can figure out what goes wrong...
  19. #359  
    Quote Originally Posted by Lazar Dobrescu View Post
    stop is normally in /sbin, maybe it's just not on your path...
    thanks!

    here is the log - including std error output at the very begining.

    /var/usr/sbin/org.webosinternals.linphone.service: /usr/lib/libpulse.so.0: no version information available (required by /var/usr/lib/org.webosinternals.linphone/libmediastreamer.so.1)
    Linphone Service (0.2.4)
    Activating Linphone...
    ortp-message-oRTP-0.20.0 initialized.
    ortp-message-assigning PCMU/8000 payload type number 0
    ortp-message-assigning GSM/8000 payload type number 3
    ortp-message-assigning PCMA/8000 payload type number 8
    ortp-message-assigning speex/8000 payload type number 110
    ortp-message-assigning speex/16000 payload type number 111
    ortp-message-assigning speex/32000 payload type number 112
    ortp-message-assigning telephone-event/8000 payload type number 101
    ortp-message-assigning G722/8000 payload type number 9
    ortp-message-assigning iLBC/8000 payload type number 96
    ortp-message-assigning AMR/8000 payload type number 97
    ortp-message-assigning AMR-WB/16000 payload type number 98
    ortp-message-assigning 1015/8000 payload type number 99
    ortp-message-assigning G726-16/8000 payload type number 100
    ortp-message-assigning G726-24/8000 payload type number 102
    ortp-message-assigning G726-32/8000 payload type number 103
    ortp-message-assigning G726-40/8000 payload type number 104
    ortp-message-assigning AAL2-G726-16/8000 payload type number 105
    ortp-message-assigning AAL2-G726-24/8000 payload type number 106
    ortp-message-assigning AAL2-G726-32/8000 payload type number 107
    ortp-message-assigning AAL2-G726-40/8000 payload type number 108
    ortp-message-assigning SILK/8000 payload type number 109
    ortp-message-assigning SILK/12000 payload type number 113
    ortp-message-assigning SILK/16000 payload type number 114
    ortp-message-assigning SILK/24000 payload type number 115
    ortp-message-assigning G729/8000 payload type number 18
    ortp-message-Mediastreamer2 2.8.2 (git: 2.8.1-5-g7114083) starting.
    ortp-message-Registering all soundcard handlers
    ortp-message-Card 'PulseAudio: default' added
    ortp-message-New PulseAudio context state: PA_CONTEXT_CONNECTING
    ortp-message-Loading ms plugins fron [/usr/local/lib/mediastreamer/plugins]
    ortp-message-Cannot open directory /usr/local/lib/mediastreamer/plugins: No such file or directory
    ortp-message-ms_init() done
    ortp-message-Cannot open directory /usr/local/lib/liblinphone/plugins: No such file or directory
    ortp-warning-/usr/local/share/sounds/linphone/rings/oldphone.wav does not exist
    ortp-message-linphone_core_set_playback_gain_db(): no active call.
    ortp-message-Adding new codec PCMU/8000 with fmtp
    ortp-message-Adding new codec GSM/8000 with fmtp
    ortp-message-Adding new codec PCMA/8000 with fmtp
    ortp-message-Adding new codec G722/8000 with fmtp
    ortp-message-Adding new codec L16/44100 with fmtp
    ortp-message-Adding new codec L16/44100 with fmtp
    ortp-message-Adding new codec speex/8000 with fmtp vbr=on
    ortp-message-Adding new codec speex/16000 with fmtp vbr=on
    ortp-message-Adding new codec speex/32000 with fmtp vbr=on
    ortp-message-getaddrinfo returned the following addresses:
    ortp-message-0.0.0.0 port 5060
    Ready
    ortp-message-New PulseAudio context state: PA_CONTEXT_AUTHORIZING
    ortp-message-New PulseAudio context state: PA_CONTEXT_SETTING_NAME
    ortp-message-New PulseAudio context state: PA_CONTEXT_READY
    ortp-message-New local ip address is 192.168.178.22
    ortp-message-Network state is now [UP]
    ortp-message-eXosip: Reseting timer to 10s before waking up!
    ortp-message-getaddrinfo returned the following addresses:
    ortp-message-0.0.0.0 port 5060
    ortp-message-eXosip: Reseting timer to 10s before waking up!
    ortp-message-keep alive: 0
    ortp-message-eXosip: Reseting timer to 10s before waking up!
    ortp-message-keep alive: 0
    ortp-message-eXosip: Reseting timer to 10s before waking up!
    ortp-message-keep alive: 0
    ortp-message-eXosip: Reseting timer to 10s before waking up!
    hope that helps ..

    there is no such dir on TouchPad: directory /usr/local/lib/liblinphone
  20. #360  
    Quote Originally Posted by MartinH@webos View Post
    thanks!

    here is the log - including std error output at the very begining.



    hope that helps ..

    there is no such dir on TouchPad: directory /usr/local/lib/liblinphone
    Doesn't help much unfortunately . That directory is just for plugins it's not relevant. Everything seems fine on the service side, yet the app cannot talk to it. I'm not sure if something works differently on the Touchpad, but I have no idea where to get info on what went wrong...

    Until I get my hands on a Touchpad one day(HA!), or unless someone knowledgeable about communication with services on the Touchpad recognizes that issue, I'm not sure there's much I can do...

Posting Permissions