Results 1 to 12 of 12
  1.    #1  
    I'm wondering if you guys can help me diagnose an issue with the Palm Pre and Pre 2?

    I can connect perfectly to my network (uses WPA2-Personal) and it always shows full bars, but getting actual web data is very spotty (it frequently will claim there's no web connection even though it shows full wifi bars and sometimes just throws an error saying it cannot connect).

    This issue started showing up on my palm pre in 1.4 (never happened in 1.3) and now I'm also getting it on a Pre 2.

    You can see more about this issue here: wifi broken after the 1.4 update! - Palm Support Community

    I'm wondering how to diagnose what's actually going on with the wifi connection and see if I can patch/fix it.

    Some more info:
    * Happens on Sprint Pre with 1.4.5
    * Happens on AT&T Pre 2 with 2.0
    * My network uses WPA-Personal
    * My network is a non-broadcast SSID
    * I have ZERO issues with my netbook, an iPod touch and a Pre with 1.3.1.
    * I have a linksys router that previously had the linksys OS (got the problem then with 1.4.x) and now has dd-wrt and I'm still getting the issue

    Thanks!
  2. #2  
    If you go into wifi preferences and tap on your network, does it have the right ip addresses showing up? I did not read the other thread.
  3.    #3  
    Quote Originally Posted by frantid View Post
    If you go into wifi preferences and tap on your network, does it have the right ip addresses showing up? I did not read the other thread.
    Yep. The ip, gateway, etc are all correct. And even if I try setting it manually with a static ip, I get the same issue.

    It always connects. The problem is when I'm surfing the web or using an app that needs data, the actual data connections are intermittent and frequently just drop or don't connect despite the wifi bars always being full.

    If I switch (on my 1.4.5 Pre) to EvDO, it all connects perfectly. It's only on wifi.
  4. #4  
    Just gonna throw this out there even though you said you have no connection issues with other devices/webOS versions, but do you have anything else in place that might be using the same frequency as wireless-g? I was experiencing really crappy wifi and had forgotten I recently got some wireless headphones. Once I disconnected the base for the headphones my wifi was back to normal.
  5.    #5  
    Quote Originally Posted by NachoB View Post
    Just gonna throw this out there even though you said you have no connection issues with other devices/webOS versions, but do you have anything else in place that might be using the same frequency as wireless-g? I was experiencing really crappy wifi and had forgotten I recently got some wireless headphones. Once I disconnected the base for the headphones my wifi was back to normal.
    hmmm...i'll look at my router's dhcp server and see what's connected and if that "fixes" it, but if so, that's still a webos problem. No other device has had this problem and even webos 1.3 did not have this issue, so some change in 1.4 caused this.
  6. #6  
    Do you have any idea what your mtu setting is on your router? Try 1490 for adsl.

    Also if you have the terminal app you can try to ping a site like yahoo.com to see if it has problems. Use sym c to break the ping.
  7. #7  
    Quote Originally Posted by thesilversurfer View Post
    hmmm...i'll look at my router's dhcp server and see what's connected and if that "fixes" it, but if so, that's still a webos problem. No other device has had this problem and even webos 1.3 did not have this issue, so some change in 1.4 caused this.
    The wireless headphones I was referring to are standalone, like a cordless phone, you would not see them connected to your router, but do cause interference to other wireless devices.

    Like I said, probably not your problem since other devices work just fine, so I thought I'd just throw it out there as something to consider.
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  8.    #8  
    Quote Originally Posted by NachoB View Post
    The wireless headphones I was referring to are standalone, like a cordless phone, you would not see them connected to your router, but do cause interference to other wireless devices.

    Like I said, probably not your problem since other devices work just fine, so I thought I'd just throw it out there as something to consider.
    ah, I understand. In that case, no. I use a dect 6 phone and don't have a microwave and the router's not near anything.
  9. #9  
    Having both bluetooth and wifi enabled has also been known to cause wifi problems. If you have bluetooth on, turn it off and see what happens.
  10. #10  
    Another setting to check on your router is the dhcp lease renew time. Unless you use a lot of temporary machines, there's no problem in setting the lease time to 7 days.
  11.    #11  
    Don't have any bluetooth being used and the lease time is 3 days, so that shouldn't be a problem.

    What I need to know is how to diagnose this issue. So actually finding and looking at the logs, what things to check for to see what the wifi radio is doing, commands to use at the command line, etc.
  12. #12  
    Do you have the terminal app?

    run "ifconfig"

    here's what it looks like on the Pre emulator:

    Code:
    root@qemux86:/# ifconfig
    eth0      Link encap:Ethernet  HWaddr 08:00:27:75:87:82
              inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:8415 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8390 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:526182 (513.8 KiB)  TX bytes:530438 (518.0 KiB)
              Interrupt:10 Base address:0xd020
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:146 errors:0 dropped:0 overruns:0 frame:0
              TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:15635 (15.2 KiB)  TX bytes:15635 (15.2 KiB)
    compare it to running the same on a desktop. If you are using windows, open a cmd box run "ipconfig /all"
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch

Posting Permissions