Results 1 to 3 of 3
  1.    #1  
    Hi,

    I'm quite new to this all cross compiling issue and linux.
    I'm running windows 7 and using the virtualbox to run a Ubuntu 9.10 OS.
    I'm trying to compile ScummVM to webos and for that reason I need to install Scratchbox2 cross compiling environment according to this WebOS Internals PDK - WebOS Internals

    after running make stage
    i get ibtool: Version mismatch error. This is libtool 2.2.6b, but the libtool: definition of this LT_INIT comes from libtool 2.2.6. libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b

    can someone assist?
  2. #2  
    Quote Originally Posted by Equilibrium View Post
    Hi,

    I'm quite new to this all cross compiling issue and linux.
    I'm running windows 7 and using the virtualbox to run a Ubuntu 9.10 OS.
    I'm trying to compile ScummVM to webos and for that reason I need to install Scratchbox2 cross compiling environment according to this WebOS Internals PDK - WebOS Internals

    after running make stage
    i get ibtool: Version mismatch error. This is libtool 2.2.6b, but the libtool: definition of this LT_INIT comes from libtool 2.2.6. libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b

    can someone assist?
    Ubuntu 9.10 is shipped with libtool 2.2.6a-4, hence the error message.

    Simply upgrade libtool to 2.2.6b-2 (backported to 9.10, see libtool @ Linux App Finder)
    Palm Pilot Pro -> M505 -> T|X -> (franken) Pre & Pixi -> Pre2 2.2.4 & TP
    Linphone port to webOS (1.4.x -> ...), lately working on NAVIT
  3. #3  
    I have the same problem when the script is trying to build pidgin:

    libtool: Version mismatch error. This is libtool 2.2.6 Debian-2.2.6a-4, but the
    libtool: definition of this LT_INIT comes from libtool 2.2.6b.
    libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6 Debian-2.2.6a-4
    libtool: and run autoconf again.

    I've already upgraded the host libtool to 2.2.6b, but it still appears as 2.2.6 when I try to build this.

    /srv/preware/cross-compile$ libtool --version
    ltmain.sh (GNU libtool) 2.2.6b

    ---- SOLVED (But I don't know if it's the right approach) ---
    Turns out that the pidgin source had the Debian-2.2.6a-4 definition in its ltmail.sh file.
    I changed:

    VERSION="2.2.6 Debian-2.2.6a-4"
    TIMESTAMP=""
    package_revision=1.3013

    for

    VERSION="2.2.6b"
    TIMESTAMP=""
    package_revision=1.3017

    And it compiled...
    Last edited by NuttyBunny; 03/23/2011 at 01:58 PM.
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg

Posting Permissions