Results 1 to 17 of 17
  1.    #1  
    I've tried looking all over the forums and broader web search, so sorry if I managed to miss something anyway.

    Anyway, after updating my Sprint Pre to 1.4.5, I found myself wanting to reapply patches. However, all are blocked by lsdiff and patch. Incidentally, as this was happening, I tried to install another package. All of them failed with errors like:

    # ipkg -o /media/cryptofs/apps in
    stall /media/internal/.developer/org.webosinternals.patch_2.5.9-4_armv7.ipk
    Clearing state_want and state_flag for pkg=org.webosinternals.patch (arch_priority=0 flag=16 want=2)
    An error ocurred, return value: 4.
    Collected errors:
    Cannot find package org.webosinternals.patch.
    Check the spelling or perhaps run 'ipkg update'


    # ipkg -o /media/cryptofs/apps in
    stall /media/internal/.developer/org.webosinternals.visualboyadvance_1.2.4_armv7
    .ipk
    Clearing state_want and state_flag for pkg=org.webosinternals.visualboyadvance (arch_priority=0 flag=16 want=2)
    An error ocurred, return value: 4.
    Collected errors:
    Cannot find package org.webosinternals.visualboyadvance.
    Check the spelling or perhaps run 'ipkg update'


    Realizing that some worked and some didn't even from the same feed, I realized that all the ones that worked were generically 'arm' architecture and the failing ones are all armv7. Is there some configuration file somewhere I need to update for ipkg to work with armv7 arch packages? Never reinstalled my phone firmware, would rather not start now...
  2. #2  
    Have you updated the feeds in Preware or tried to install lsdiff and patch from webosqi?
  3. #3  
    We determined in IRC that the OP's device had been manually modified and the /etc/ipkg and /media/cryptofs/apps/etc/ipkg directories were missing, meaning that the arch.conf file which controls architecture-specific installations was missing.

    Once the OP reverted those manual modifications to his device, everything started working as normal.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. #4  
    Same problem here. Don't know how to fix it. Don't understand Rod's response
  5. #5  
    Quote Originally Posted by firemandave View Post
    Same problem here. Don't know how to fix it. Don't understand Rod's response
    Please post your IPKG Log from Preware.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6. #6  
    here ya go
    Attached Images Attached Images
  7. #7  
    Rod, I noticed it started after I updated my Glass Effect Suite Alternate Theme. It didn't do it all the time, but most the time Preware would give me this error. I unistalled the theme, updated feeds, did a luna restart, and it still did it. I have done a full restart now (no theme installed) and Preware has loaded properly 3 times.
  8. #8  
    Quote Originally Posted by firemandave View Post
    Rod, I noticed it started after I updated my Glass Effect Suite Alternate Theme. It didn't do it all the time, but most the time Preware would give me this error. I unistalled the theme, updated feeds, did a luna restart, and it still did it. I have done a full restart now (no theme installed) and Preware has loaded properly 3 times.
    That error message just means there was a problem at www.prethemer.com - you should talk to the owners of that site for such problems. It is not a problem with Preware, and is definitely not the same problem as anything in this thread (none of which have actually been a problem with Preware).

    The unreliability of that site is one reason why themes are turned off by default.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  9. #9  
    Lesson learned. Thanks Rod!
  10. #10  
    Posted the same thing in the other thread...

    I hope this is the same for everyone, but I've noticed a couple changes with this issue.

    First, I stopped getting the error (same as the screenshot from firemandave), but noticed that the Prethemer feed wasn't downloading anything (only a couple hundred themes to choose from in Preware), now I just loaded it up to check and saw that Precentral themes and Prethemer are downloading like normal. Hope you're seeing the same thing, firemandave.

    My guess is that Rod was right (surprising, I know...) and Prethemer had some issues and got them worked out.
    "...human sacrifices, dogs and cats living together! MASS HYSTERIA!"

    -Ghostbusters
  11. #11  
    Hello, I recently had to use Doctor to restore my Pre Plus due to windows live contacts being unable to become deleted. Long story short, I am trying to install a few patches and apps from preware that I had before [such as music remix player 2.0 beta] and it's giving me a strange looking error. Can anyone help? :[
    I already tried installing them using webOS quick install and it gives me a jave.net redirected too many times error? Help?

    begin
    Nothing Interesting.
    failed
    -1: Unable to run command: /usr/bin/curl --create-dirs --insecure --location --fail --show-error --output /media/internal/.developer/com.palm_.app_.mprbeta_1.99.34_all.ipk http://media.precentral.net/resource....99.34_all.ipk 2>&1
    % Total % Received % Xferd Average Speed Time Time Time Current
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0
    curl: (22) The requested URL returned error: 403
  12. Chris_B's Avatar
    Posts
    15 Posts
    Global Posts
    21 Global Posts
    #12  
    Hi Rod,

    I am having trouble installing Preware after my phone crashed overnight. I reconnected to my Palm Profile and all seemed to load back up, save for a ton of apps. I was able to install Preware at first and was doing manual app installation, but had issues in QI saying I may need to do a "IPKG Update". Searching the forums, I came across a post that said uninstalling Preware and then re-installing it would clear up that issue. Now, I can't get Preware installed again.

    Here is the error in QI:

    ERROR: An error occurred while attempting to install .org.webosinternals.preware_1.5.7_686.ipk

    Clearing state_want and state_flag for pkg=org.webosinternals.preware (arch_priority=0 flag=16 want=2)
    An error ocurred, return value 4.
    Collected errors:
    Cannot find package org.webosinternals.preware.
    Check the spelling or perhaps run 'ipkg update'

    Any clues here?

    Other knowns: Windows 7 64-bit, WebOS 3.14, Pre "minus", PalmOS 14.5

    Thanks,

    Chris
  13. #13  
    Quote Originally Posted by Chris_B View Post
    Here is the error in QI:

    ERROR: An error occurred while attempting to install .org.webosinternals.preware_1.5.7_686.ipk
    _i686 is the package for the emulator, not the Pre.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  14. Chris_B's Avatar
    Posts
    15 Posts
    Global Posts
    21 Global Posts
    #14  
    Quote Originally Posted by rwhitby View Post
    _i686 is the package for the emulator, not the Pre.

    -- Rod
    Somehow that was all I was getting QI to download. Rebooted both and tried again... all good now! Thanks!
  15. #15  
    Ive been having a problem with Preware as well. I just installed it this morning after doing a doctor last night. I am running 2.1 on my Pre Plus. I installed Preware and at first everything was normal. I downloaded some applications but no patches. After doing some luna restarts from doing some theming of my own, I tried Preware again and now it wont load any of the feeds. There is nothing under available packages. I get an error before preware is done loading. I have tried doing a full restart, uninstalling and reinstalling preware and I still have the same problem. Again, I havent added any patches or anything that would change the way the phone works.
  16. GigaS27's Avatar
    Posts
    286 Posts
    Global Posts
    389 Global Posts
    #16  
    Quote Originally Posted by jsgraphicart View Post
    Ive been having a problem with Preware as well. I just installed it this morning after doing a doctor last night. I am running 2.1 on my Pre Plus. I installed Preware and at first everything was normal. I downloaded some applications but no patches. After doing some luna restarts from doing some theming of my own, I tried Preware again and now it wont load any of the feeds. There is nothing under available packages. I get an error before preware is done loading. I have tried doing a full restart, uninstalling and reinstalling preware and I still have the same problem. Again, I havent added any patches or anything that would change the way the phone works.
    The feeds are down. I also am trying to restore my apps/patches and now cannot due to the feeds being down. I hope they get it back up shortly.
    Sprint Palm Pre-
  17. #17  
    Quote Originally Posted by GigaS27 View Post
    The feeds are down. I also am trying to restore my apps/patches and now cannot due to the feeds being down. I hope they get it back up shortly.
    Ok. I was thinking it was just me. Good to know. Thanks.

Posting Permissions