webOS Nation Forums >  Homebrew >  WebOS Internals > Speech Dispatcher
Speech Dispatcher
  Reply
Like Tree2Likes

 
Thread Tools Display Modes
Old 11/01/2012, 08:13 AM   #61 (permalink)
Member
 
60RH's Avatar
 
Posts: 401
Quote:
Originally Posted by HaPe View Post
Hi all,


Be aware that you need to change the language in line 29 of the patch before install!


HaPe
...and line 27 that says "Anruf von" so it should be "call from" translated in your preferred language.

Last edited by BoRn; 11/01/2012 at 08:47 AM.
60RH is offline   Reply With Quote
Thanked By: HaPe
Old 11/08/2012, 11:15 AM   #62 (permalink)
Member
 
60RH's Avatar
 
Posts: 401
Any way to change the voices settings in navit or for this nice patch?
60RH is offline   Reply With Quote
Old 12/20/2012, 06:03 PM   #63 (permalink)
Member
 
Posts: 298
Quote:
Originally Posted by hape View Post
Hi all,

beginning with version 0.7.1-14 (which is currently in the alpha feed) I added a javascript service.
Good - but to which alpha feed did you add these changes?
I use a TP 3.0.5 and in preware I have "alpha-apps" fields enabled - but I don't see tis version 0.7.1-14 .
I'm still on v.0.7.1-10.2
MartinH@webos is offline   Reply With Quote
Old 02/15/2013, 09:48 AM   #64 (permalink)
Member
 
60RH's Avatar
 
Posts: 401
Quote:
Originally Posted by hape View Post
Hi all,

beginning with version 0.7.1-14 (which is currently in the alpha feed) I added a javascript service. I updated the documentaion in the WIKI with the details: Application:SpeechDispatcher - WebOS Internals

The Mojo app now shows you the default audio channel and you can set is with the icon in the lower right corner. There is also a test button to test the selected audio channel and the service.

The attached patch can be used with this version to speak the incoming caller name.
Be aware that you need to change the language in line 29 of the patch before install!
You will get the best results if you use a ring tone with a little bit of silence at the beginning, because the speak output starts with the ringtone in the same volume. I diden't find a way to output it before the ringtone starts.
You need to set the ringtone to a audio file with silence if you only want to have the name spoken.

HaPe
Modified patch for english and all is good but I wanted to play with different voices and added "type":"female1"
to the service call but it still speaks with the default voice.
even messed with speechhd.conf in /var/etc/speech-dispatcher and changed the DefaultVoiceType in the global conf for espeak.
What am I doing wrong?
60RH is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0