Page 1 of 3 123 LastLast
Results 1 to 20 of 45
  1.    #1  
    Please report all wIRC >=0.1.0 bugs in this thread!

    Unique Bugs:
    [ ] http://forums.precentral.net/2449790-post2.html
    [ ] http://forums.precentral.net/2450698-post10.html
    Last edited by PuffTheMagic; 05/16/2010 at 10:10 AM.
  2. #2  
    when i close a card with a channel open it
    don't leave the channel... after I close the connection in
    main window it still don't quit instead it's giving ping
    timeout... in wirc 0.1.0
  3. #3  
    After upgrading to 0.1.0 this morning when I opened wIRC and tried to join a server I got a big red icon and the server messages I see "~~~wIRCd is not running!"

    I imagine restarting my phone might fix it, but I'm waiting to try that later.
  4. #4  
    Quote Originally Posted by RagingMind View Post
    After upgrading to 0.1.0 this morning when I opened wIRC and tried to join a server I got a big red icon and the server messages I see "~~~wIRCd is not running!"

    I imagine restarting my phone might fix it, but I'm waiting to try that later.
    Did you also update the service, wIRCd?

    The new app requires changes that are in the new service.
  5. #5  
    I updated wIRCd at the same time I updated wIRC
  6. punzada's Avatar
    Posts
    137 Posts
    Global Posts
    161 Global Posts
    #6  
    Quote Originally Posted by RagingMind View Post
    I updated wIRCd at the same time I updated wIRC
    Same thing happened while installing with me, just go into Preware and uninstall both the wirc application and wircd service and reinstall it - works fine after that.

    May be something a bit wonky with one of the pre/post install scripts.
  7. #7  
    rebooting the phone also fixed it... now I can connect to stuff again
  8. #8  
    I did not have upgrade trouble - I used 'update' and then I rebooted and no problems connecting.

    I love the improvements, esp the time stamp, but I'm having a harder time than before knowing when I've disconnected, especially since 'ping' is gone. It seems that even name changes appear to 'process' with the server while disconnected?

    I turned on the lag meter, perhaps that will get the job done.

    What I'd love, is something that actually put some text in the backlog when disconnects happen.

    (I'm an IRC noob, so hopefully this isn't a foolish concern.)
  9. punzada's Avatar
    Posts
    137 Posts
    Global Posts
    161 Global Posts
    #9  
    Quote Originally Posted by notcalvin View Post
    I did not have upgrade trouble - I used 'update' and then I rebooted and no problems connecting.

    I love the improvements, esp the time stamp, but I'm having a harder time than before knowing when I've disconnected, especially since 'ping' is gone. It seems that even name changes appear to 'process' with the server while disconnected?

    I turned on the lag meter, perhaps that will get the job done.

    What I'd love, is something that actually put some text in the backlog when disconnects happen.

    (I'm an IRC noob, so hopefully this isn't a foolish concern.)
    No, It's a valid concern I as well would like some indication of when a disconnect happens (doesn't have to be a notification or anything but a simple ***disconnected in the current active channel/conversation as well as the server log window would be appreciated - with timestamp as well).

    So far I've been able to remain connected to networks longer without disconnects as frequently over wifi, loving the timestamps (done in a very nice unobstrusive way). Glad to see progress with WIRC I just thought yesterday actually "I wonder if development is still progressing with wirc" - I must of been channeling the developers brainwaves.
  10. #10  
    I get a constant error on wIRCd when I do a channel list as soon as its done, wIRCd dies and comes back with a wircd not running... and then I have to reconnect but somehow the other session is still connected so I cant get back my username until like 15mins pass.
    I am Pain, I am Real, I'm not a dream! (Ayreon)
  11.    #11  
    Quote Originally Posted by clyfton View Post
    I get a constant error on wIRCd when I do a channel list as soon as its done, wIRCd dies and comes back with a wircd not running... and then I have to reconnect but somehow the other session is still connected so I cant get back my username until like 15mins pass.
    hmmm, I wil look into this, I havent used the channel listing on an IRC server since I was 12
  12. #12  
    In regard to losing the connection (on quakenet) I find two things happen...
    1) sometimes it reconnects automatically, which is great
    2) other times it loses connection and doesn't seem to realize it has lost connection, so sending messages, nick changes, etc, give a '404' error 'can not send to channel'.

    When I get the 404 error message, I find there is nothing I can do to get the chat card to spawn except restart the phone. Other peoples channel log shows me as having quit (which I did not do).

    Attempts to make this bug report useful:

    If I click the connect/disconnect button, the log shows the connect and disconnect happening, but does not open a card to the channel I (normally) join. Even when I manually try to join the channel, I can not.

    If I type /join #SomeRandomChannel it will spawn a new card for that channel, and it looks legit (I'm the only one there, but I assume all is normal), but I can not join the channel I was on.

    A reboot fixes the problem, but closing and opening the app does not.

    Next time it happens I will try to use /quit #MyFavChannel and then try the /join and see if that helps. I'll report back then.

    At this time, I don't know how to cause this to happen, I'll experiment with that also.
  13. #13  
    A '404' error? There is no '404' error.

    If you're getting the 'Not Connected' popup message, It means that it thinks you're disconnected, and isn't sending your command.


    /quit <channel> is not the right command. That will disconnect you from the server with the reason of <channel>.

    /part <channel> is the correct command. But we don't support it (from the server window.)

    We do support /part or /leave, but only from the channel window.

    Tossing the card is normally how you leave a channel in wirc.


    If you can come up with a repeatable steps to get the channel not to spawn, post them. Without that we will have a hard time tracking down if there is a bug there.
    Last edited by oil; 05/14/2010 at 11:11 AM.
  14. #14  
    So I've got some more detail on what I'm seeing regarding post #12 above...

    I'll be on a channel, and notice nothing has happened for a while, I check the connection log, there is nothing unusual, I'll try to chat with the bot to see if I'm still connected, and my message seems to post to the channel, but the chat bot does not reply. I flip over to the connection log and see a message Error 404 - "cannot send".

    I throw the channel card away and then look at the connection log and see Error 442 - "not on that channel".

    I swipe back on the connection card and see that the server connetion is 'green' as if I am still connected to it, and if, on the connection log, I type /join #whatever then a card spawns for that channel. Then I type /join #channelIWasOnBefore and the command disappears as if it is being processed, but nothing happens - no entry in the connection log, no error msg, no card, as if I typed nothing at all.

    Then, I swipe back, I press the green connection button to disconnect, and it turns red and the log shows disconnected. Then I throw away the wIRC card, closing the app entirely.

    I relaunch wIRC and then it reconnects to the original channel no problem.

    Previously I found it necessary to reboot to get back on the channel, but not this time. Not sure what the difference was.

    Anyway, if I learn anymore, I'll let you know.

    But in the connection lag, it is definitely a 404 error, I'll try to post the exact text of it next time I get it...

    Also, to be clear - I have seen the 'not connected' message and I have seen it reconnect me. (Which is quite nice, btw.)
  15.    #15  
    So we are between a rock and a hard place here. Let me try and explain the situation. Connecting over evdo is slower, laggy but stable (it does not drop out often). Wifi is fast but get dropped when u switch AP (if your IP changes). So we can either be aggressive at trying to determine when you lost connection and reconnect as soon as possible. Which will cause you to get disconnected more when not really needed. However you will never be stuck not knowing if u were connected. The lag meter is supposed to start us down this road of detecting when we are not really connected. Combine all this with facts like freenode's timeout is like 10 min so if u get disconnected and signon your nick will still be in use for a while.

    Quote Originally Posted by notcalvin View Post
    So I've got some more detail on what I'm seeing regarding post #12 above...

    I'll be on a channel, and notice nothing has happened for a while, I check the connection log, there is nothing unusual, I'll try to chat with the bot to see if I'm still connected, and my message seems to post to the channel, but the chat bot does not reply. I flip over to the connection log and see a message Error 404 - "cannot send".

    I throw the channel card away and then look at the connection log and see Error 442 - "not on that channel".

    I swipe back on the connection card and see that the server connetion is 'green' as if I am still connected to it, and if, on the connection log, I type /join #whatever then a card spawns for that channel. Then I type /join #channelIWasOnBefore and the command disappears as if it is being processed, but nothing happens - no entry in the connection log, no error msg, no card, as if I typed nothing at all.

    Then, I swipe back, I press the green connection button to disconnect, and it turns red and the log shows disconnected. Then I throw away the wIRC card, closing the app entirely.

    I relaunch wIRC and then it reconnects to the original channel no problem.

    Previously I found it necessary to reboot to get back on the channel, but not this time. Not sure what the difference was.

    Anyway, if I learn anymore, I'll let you know.

    But in the connection lag, it is definitely a 404 error, I'll try to post the exact text of it next time I get it...

    Also, to be clear - I have seen the 'not connected' message and I have seen it reconnect me. (Which is quite nice, btw.)
  16. #16  
    Error was the wrong term for the '404' message I get:

    --- event: 404
    --- origin: irc.server.net
    --- params: nick,#channel,Cannot send to channel
  17.    #17  
    Just a note to all the wIRC users. If you see events formatted like the one below, that is debug output. That means we are not yet handling that event code. If you see these please report them to us. Let us know what you did to get this message and what you expect the normal behavior to be.

    Quote Originally Posted by notcalvin View Post
    Error was the wrong term for the '404' message I get:

    --- event: 404
    --- origin: irc.server.net
    --- params: nick,#channel,Cannot send to channel
  18. #18  
    Glad this is still being worked on

    mode +m (moderated)

    Does not show up next to the other channel mods (next to the channel name on top) and it tells me it is not a known command or something along those lines, but it still applies. (checked via desktop client)

    Having the option to have everything all in one app would be kinda nice instead of separate cards.

    Also not exactly a bug but having nick colors that are hard to see depending on the background. If using the dark palm theme, darker colors become hard to see. And for the normal one, yellow is very hard to see who is talking.


    Keep up the great work guys.
  19.    #19  
    Odd about the modes, oil will check that one out

    Yeah we know we need better color pallets for sender auto coloring.

    And even though its multiple cards it is still one app but I think oil is working on a way to support 1 or multiple cards

    Quote Originally Posted by Banger View Post
    Glad this is still being worked on

    mode +m (moderated)

    Does not show up next to the other channel mods (next to the channel name on top) and it tells me it is not a known command or something along those lines, but it still applies. (checked via desktop client)

    Having the option to have everything all in one app would be kinda nice instead of separate cards.

    Also not exactly a bug but having nick colors that are hard to see depending on the background. If using the dark palm theme, darker colors become hard to see. And for the normal one, yellow is very hard to see who is talking.


    Keep up the great work guys.
  20. #20  
    Thanks for your timely response! I love the app!


    A few more small suggestions, maybe add support for emoticons.

    I am not sure but I think all these extra colors is pretty new, if I recall the older one only had a few. Maybe I am wrong but that brings me to my next point there are SOOOOOOOO many, maybe an option when you click on what you want to change color if you can start typeing, say if I wanted white I could press w and it would bring me down the the w's. Takes a while to scroll :P

    Desktop client shows: (09:43:27) * Prevert sets mode: -m

    Client:


    As you can see it shows that it is being unset, but it is not sure what it is and it still shows that its set on top.

    Time stamps would be great, maybe make a spot where if you press it, it will show/hide time stamps.

    Having the user not have to use # when joining channels would be pretty cool as well, but not needed

    Another thing allowing the user make make small scripts, even if they were as simple as aliases on mIRC such as.

    /j /join #$$1 $2-

    /ns for nickserv would be great

    Small things would be a great irc client even better. I will be anticipating where you guys will bring this app! Even if some people make you feel not appreciated you guys are, you and every other homebrewer/programmer.

    I appreciate what you guys have done!
Page 1 of 3 123 LastLast

Posting Permissions