Page 2 of 86 FirstFirst 1234567 12 52 ... LastLast
Results 21 to 40 of 1706
Like Tree19Likes
  1. Cringer's Avatar
    Posts
    475 Posts
    Global Posts
    483 Global Posts
    #21  
    Quote Originally Posted by rwhitby View Post
    That sounds like a JavaRestart is happening for some reason, which should not happen with Preware 1.0 (the RestartJava flag was present on the Package Manager Service, but is no longer present because that package has been removed from the dependency list).

    What version of WOSQI are you using?

    -- Rod
    WOSQI 3.12, same version I used after the last time I Dr'd my Pre a month ago or so. Didn't have the problem then. Like I said, a reboot seems to have fixed it, haven't had a problem since.
  2. Cringer's Avatar
    Posts
    475 Posts
    Global Posts
    483 Global Posts
    #22  
    Quote Originally Posted by rwhitby View Post
    Thanks - do you have two valid URLs in the webos-internals feed entry?

    Do you have the Diffstat package available in the List of Everything?

    -- Rod
    Seems to have been the later. I don't remember having to get the Diffstat package on it's own before but it seems to have done the trick.

    edit: and now I think I will step away from the phone. I have been fighting with it and my laptop for about 8 hours straight now.
  3. #23  
    Quote Originally Posted by NuttyBunny View Post
    Keeps rebooting Luna on 1.4.0 devices after an app install.

    Happens everytime.
    Quote Originally Posted by rwhitby View Post
    We're working with Palm to try and determine why Luna is crashing as a result of a webOS application -

    Since the problem exists for some people no matter whether they are running Preware 0.9.x or Preware 1.x, and since there are no known solutions to the problem at the moment
    This was 100% reproducible for me, although I haven't verified it happening with Preware 1.0 yet.

    My "solution" or workaround is to simply restart Luna after I install an app. I got so used to doing that, I don't even consider it a problem anymore.

    While I'm sure that the cause and fix will eventually be found, restarting Luna is the simplest and most effective workaround for me.

    Yes, I do realize the problem is not with Preware itself, but installing an app via Preware is the method in which the problem manifests itself...at least on my Pre.
    Last edited by Trekker; 05/10/2010 at 05:27 AM. Reason: added more info
  4. #24  
    Quote Originally Posted by Trekker View Post
    This was 100% reproducible for me, although I haven't verified it happening with Preware 1.0 yet.

    My "solution" or workaround is to simply restart Luna after I install an app. I got so used to doing that, I don't even consider it a problem anymore.

    While I'm sure that the cause and fix will eventually be found, restarting Luna is the simplest and most effective workaround for me.

    Yes, I do realize the problem is not with Preware itself, but installing an app via Preware is the method in which the problem manifests itself...at least on my Pre.
    Exactly the same here, this is a serious bug that needs to be fixed, but it is not Preware-related! I guess it happens whenever an app does some kind of extensive tasks.. the same happened to me once when I started Navit (not everytime though). It happens everytime after I installed anything with Preware.. in the same way it has been described a few posts above.

    Anyway, not Preware related, and I'm glad this is still heavily investigated.. so thanks a lot for Preware 1.0 with an integrated C-service!
    IPK FETCHER <-> An attempt against geo-filtering
  5.    #25  
    Quote Originally Posted by Cringer View Post
    Not letting me install themes from Prethemer.

    ERROR: Cannot satisfy the following dependencies for com.prethemer.themes. 165046f686: org.webosinternals.diffstat


    Has happened for multiple themes.
    OK, it looks like all the package index entries in the PreThemer feed are missing the following line:

    Depends: org.webosinternals.patch, org.webosinternals.diffstat

    I've alerted prethemer.com to the problem.

    The work-around is to install the GNU Patch and Diffstat packages manually.

    Once the missing lines are added to the Packages file on the prethemer.com server, it will all work again as it should.

    -- Rod
    Last edited by rwhitby; 05/10/2010 at 06:16 AM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6. #26  
    thanks
  7. #27  
    Quote Originally Posted by jhoove09 View Post
    I have an issue. I have downloaded Preware 1.0 running on Sprint Pre webOS 1.4.1.1. I am trying to remove my current theme. It gets stuck at the "removing" screen (see attachment). Preware does not freeze and it does not give me any errors. It just spins. It doesn't display actions (underneith the word removing) like usual either. Any idea why this is happening and what I can do to remove the theme?

    Update: The theme will allow me to update... it downloads the IPK then I get an error. This is the IPKG Log from my event.

    prerm
    ** Message: serviceResponse Handling: 2, { "returnValue": false, "errorText": "Some settings could not be saved" }
    remove
    Removing package com.prethemer.themes.54f4af3705 from root...
    (offline root mode: not running com.prethemer.themes.54f4af3705.prerm)
    delete
    Nothing Interesting.
    removed
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    2 1083k 2 29714 0 0 21010 0 0:00:52 0:00:01 0:00:51 21010
    21 1083k 21 228k 0 0 98k 0 0:00:11 0:00:02 0:00:09 218k
    44 1083k 44 478k 0 0 143k 0 0:00:07 0:00:03 0:00:04 234k
    71 1083k 71 779k 0 0 180k 0 0:00:06 0:00:04 0:00:02 257k
    96 1083k 96 1041k 0 0 188k 0 0:00:05 0:00:05 --:--:-- 245k
    100 1083k 100 1083k 0 0 195k 0 0:00:05 0:00:05 --:--:-- 255k
    failed
    -1: Unable to run command: /usr/bin/ipkg -o /media/cryptofs/apps -force-overwrite install /media/internal/.developer/com.prethemer.themes.54f4af3705_1.2.1_all.ipk 2>&1
    Begin installation of com.prethemer.themes.54f4af3705
    Installing com.prethemer.themes.54f4af3705 (1.2.1) to root...
    Begin installation of com.prethemer.themes.54f4af3705
    Installing com.prethemer.themes.54f4af3705 (1.2.1) to root...
    An error ocurred, return value: 1.
    Collected errors:
    ERROR: Cannot satisfy the following dependencies for com.prethemer.themes.54f4af3705:
    org.webosinternals.diffstat
    I am having the same problem. Im wondering if this is from the preware update. I cant remove my theme and i have a simple theme. All I have is the launcher black theme. It stays in the removing screen. I even went into Quick install and it doesnt even find the theme. It says error when i click on themer. Need some help on removing theme.
  8. #28  
    I ran into an issue when I upgraded Preware last week to the latest (.94?). I was hoping it would be fixed with the next update, but after 1.0, I'm still having the problem. After installing .94, it blew away my list of installed apps and patches. Now Preware thinks there are no apps installed (I have about 20) and only two patches (I have about 15). Is there any way to make Preware re-scan for installed apps and patches, or do I have to just re-install each of them?
  9. bill2455's Avatar
    Posts
    65 Posts
    Global Posts
    100 Global Posts
    #29  
    Updated to Preware 1.0. No apparent problems there but Preware 1.0 still shows up in the Package Updates list (under Yesterday). Tried to update again but Preware won't complete the second update. I end up just terminating Preware. All else seems to work OK. Is this an issue?
  10. #30  
    Quote Originally Posted by Admiral Awesome View Post
    I ran into an issue when I upgraded Preware last week to the latest (.94?). I was hoping it would be fixed with the next update, but after 1.0, I'm still having the problem. After installing .94, it blew away my list of installed apps and patches. Now Preware thinks there are no apps installed (I have about 20) and only two patches (I have about 15). Is there any way to make Preware re-scan for installed apps and patches, or do I have to just re-install each of them?

    Fixed. Installed Emergency Reconstruction Utility from Preware (it installs, runs automatically, and then uninstalls itself). After I restarted Preware, my list of installed apps was back.
  11. #31  
    Works great
  12. #32  
    Is Preware 1.0 only installable via webOSQI or is there an OTA update? When i open the Preware app, ver 0.9.38, it doesn't show any available updates as it normally would?

    I'm on O2 UK running version 1.4.1.

    Thanks in advance for your help....


    Updated feeds and downloaded it no problems and everything seems fine...
    Last edited by mykal900; 05/10/2010 at 01:46 PM.
  13. #33  
    New bug...

    Sprint Pre - 1.4.1.1 - in case that matters.

    So... I saw the new version. Already using Preware, so I updated with Preware. All seemed to go well. Gave it a Luna restart.. just for good measure.

    Upon restart, I opened Preware. Available numbers were way down... no biggie.
    Went into Preferences, verified everything was on except "only show free apps". Went into feeds, made sure all were on. I only pull built in feeds, no manual additions. Once i verified everything possible was turned on, I told Preware to Update Feeds. I get the following error:

    Failed during 'update' operation ipkg:invalid compressed data--crc error

    Any ideas? Anyone else getting this?

    BTW - Thanks to Rod and you Devs out there. My Pre wouldn't be "my Pre" without you guys!!
    Tina T
    MCP, MCSE, MCDBA, VCP

    Sharp Zaurus > Cassiopeia A-20 > Casio E-115 > Psion 3 > Phillips VELO 1 > Palm V > Treo 90 > Treo 300 > Treo 600 > Treo 650 > Treo 700p > Centro > Palm Pre > HTC Evo 4G > Samsung Epic 4G > HTC EVO 4G Shift & a rooted Nook Color!! (But still have nothing but love and hope for Palm)
  14. #34  
    I had to hardware swap this morning due to Oreo on the slider, and now I cannot under any circumstances get Preware on my Pre again. I've got current Java, current OSDoctor for Bell, current QuickInstall, it's in developer mode, and nothing. NOTHING. It says it's installing and it's not there. I am about to scream.
  15. #35  
    Quote Originally Posted by mykal900 View Post
    Is Preware 1.0 only installable via webOSQI or is there an OTA update? When i open the Preware app, ver 0.9.38, it doesn't show any available updates as it normally would?

    I'm on O2 UK running version 1.4.1.

    Thanks in advance for your help....
    I just updated it OTA via the old version of Preware without a hitch; I didn't even get the 'vanishing patches' bug that some have been describing. Germany O2 1.4.1 here by the way.

    Check back, it should be there now. Maybe you only need to update your feeds or something
  16. #36  
    Ooooo wait a second, I just remembered I had to OS update the first Pre. I just checked and this one needed an update too...maybe that will fix the issue
  17. #37  
    I'm not having any more apps come up under "Package Updates" and almost none of my previously installed packages under "Installed Packages". I know for sure there were many apps needing updates, but the new Preware 1.x doesn't seem to know what I have installed anymore. I've restarted my phone and all, what do I do?
  18. #38  
    I'd like to report that the App install associated crash is not reproducible on my Pre.

    Updated directly in Preware, tried installing a random app, closed Preware and waited. No crash, all pretty stable.

    I'm on Sprint 1.4.1.1. My advice to NuttyBunny is that I guess this might be an 1.4.0 specific issue as 1.4.0 pretty much crashes on anything, in my experience. I don't know if the 1.4.1 update is available for you yet, but do update as soon as it's available. I know other ways to crash 1.4.1.1, but they do not involve Preware

    And again thank you Preware team for the great work. The speedup is so nice.
  19. #39  
    I ant uninstall 'prebackup' service or my theme. The log shows 'user requested removal...' but it just hangs. Rebooted many times. Sprint, 1.4.1, updated 1.0 through Preware.

    I'm getting a replacement today so it won't matter to me, just thought I would mention it. Was trying prebackup, it wouldn't run, told me to uninstall, reinstall, and reboot but I ant uninstall it.
  20. gryn's Avatar
    Posts
    148 Posts
    Global Posts
    158 Global Posts
    #40  
    Quote Originally Posted by abel_s View Post
    I'm not having any more apps come up under "Package Updates" and almost none of my previously installed packages under "Installed Packages". I know for sure there were many apps needing updates, but the new Preware 1.x doesn't seem to know what I have installed anymore. I've restarted my phone and all, what do I do?
    Run "Emergency Reconstruction Utility" then update feeds when it's done.
Page 2 of 86 FirstFirst 1234567 12 52 ... LastLast

Posting Permissions