Page 6 of 145 FirstFirst 12345678910111656106 ... LastLast
Results 101 to 120 of 2889
Like Tree17Likes
  1. #101  
    I'm running 1.4.1.1 with the Uber Kernel, so this doesn't apply to me, but I'm just curious. I was under the impression that 1.4.1 did not include any kernel changes relative to 1.4.0. In fact, many people have been running what is now called the Super Kernel (a 1.4.0 based kernel) on 1.4.1 distributions successfully. So, aside from packaging restrictions and lack of testing, is there any other reason to believe the 1.4.1 Uber Kernel is not compatible with 1.4.0 which would prevent it from working properly on a 1.4.0 Verizon Pre?
  2. #102  
    Ok. I'm still stuck with the kernel reverting back to stock kernel speeds after a luna restart. But I think I've figured out why others haven't been able to reproduce this problem.

    First things first, I've run WebOS Repair Tool to see if there are any binaries around that aren't what they're supposed to be. Specifically, I was worried that LunaSysMgr (et al) were not properly restored to normal after removing the unixpsycho/caj2008 kernel. But according to WORT, everything is correct.

    So, eliminating that, I discovered that the CPU speed reverts back to 500MHz only when the userspace governor is in use and the cpu is fixed to 800MHz. Under these conditions, a luna restart reverts the cpu frequency back to 500MHz.

    However, if I set it to scale: using the ondemand governor, then the settings persist across a luna restart.

    Can anyone else reproduce these results with the Uber Kernel?

    Thanks.
    Twitter: dullgeek
  3.    #103  
    Quote Originally Posted by meandmypre View Post
    I'm running 1.4.1.1 with the Uber Kernel, so this doesn't apply to me, but I'm just curious. I was under the impression that 1.4.1 did not include any kernel changes relative to 1.4.0. In fact, many people have been running what is now called the Super Kernel (a 1.4.0 based kernel) on 1.4.1 distributions successfully. So, aside from packaging restrictions and lack of testing, is there any other reason to believe the 1.4.1 Uber Kernel is not compatible with 1.4.0 which would prevent it from working properly on a 1.4.0 Verizon Pre?
    Before we got the kernel source code for 1.4.1, we thought the same. But a diff of the 1.4.0 and 1.4.1 kernel source from Palm says differently.

    In particular, there is a /dev/discsock change that we simply do not understand, and therefore do not want to risk it.

    -- Rod
  4. #104  
    Hey Rod, could consider adding a CPU temp patch to the top bar? And possibly a F vs C option for the US vs (rest of the world) option?
    - Jeff
    Palm Pre- and a 32 GB TouchPad.
  5.    #105  
    Quote Originally Posted by pastorrich1 View Post
    Rod, I have looked but haven't found anything.

    I installed Govnah... temp monitoring is working well. I have CPUscalerultimate installed and it has been working fine, but I can't seem to figure out how to get governor options going in govnah.

    I had been running 500-800 and switched to 250-800 after installing uber kernel. I have noticed that my time in state at 250 and 500 isn't as much as it was previously.

    So... where do I find the governor options you have mentioned in this thread?

    Thanks in advance.

    BTW... did you ever get the new server board up and running?
    Govnah does not have control functionality yet - we expect that in the next few days.

    The server mainboard replacement was successfully installed, thanks. All systems are operating smoothly.
  6.    #106  
    Quote Originally Posted by Meltedwire View Post
    Hey Rod, could consider adding a CPU temp patch to the top bar? And possibly a F vs C option for the US vs (rest of the world) option?
    I believe Jason is working on just that.

    -- Rod
  7. #107  
    Cool, thank you and Jason!
    - Jeff
    Palm Pre- and a 32 GB TouchPad.
  8. #108  
    I have final exams and graduation ceremony this week, however after all of that is out of the way I intend on working with whomever I should be consulting with to bring the cpu temp into Battery Monitor as well. It currently polls for battery temp as originally coded by neville who designed the app. It is still his app but I have volunteered to work on taking it beyond. Hopefully the listing I made for the updates will go through the approval process soon the precentral feed so people can download it from preware et al installers. I figured that was the best way to offer the updates and retain neville's original work.
    As requested: for my works on webOS patches and apps. Twitter: @larryboytw Patches: Small icons browser start page, 5x5 launcher. I have an AAS CIS Programming degree. I enjoy working on open source projects and alpha and beta testing.
    http://install.preware.org/ for easy to get up and running for patches and apps.
  9.    #109  
    Quote Originally Posted by StoneRyno View Post
    I have final exams and graduation ceremony this week, however after all of that is out of the way I intend on working with whomever I should be consulting with to bring the cpu temp into Battery Monitor as well.
    Excellent. The service installed with the Govnah application supplies the internal temperature, and I believe that Jason is updating his SysToolsMgr service to do the same. We encourage any developers to use the information supplied by the new code we have added to the Uber-Kernel.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10. #110  
    I am glad to see the freq shown in the app now. I won't have to run the cli to check anymore...however, with background processing coming from what I read, it would be cool to have the freq displayed in the top bar maybe or else where visible since the app (govnah) would be running in the background? Possible?

    Keep up the great work. I'll be donating soon!
  11. #111  
    I'm manually issuing the following commands via wOSQI:

    echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo 800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo 500000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

    Watching the Govnah screen, after issuing the last command I can briefly see the CPU frequency go up to 500 MHz, and then after a few seconds it drops to 125 MHz. (If I use "conservative" for scaling_governor, it never goes below 500 MHz.) Is this supposed to happen when using "ondemand" ???

    EDIT: After doing some other searching, I created the script file needed to make my settings "stick" in the /etc/event.d directory and restarted my Pre. Now, in Govnah, the speed never drops below 250 MHz. I wonder why it was doing that during my first set of steps above???
    Last edited by SilvrDrgn; 04/23/2010 at 09:47 AM.
  12.    #112  
    Quote Originally Posted by orsapps View Post
    I am glad to see the freq shown in the app now. I won't have to run the cli to check anymore...however, with background processing coming from what I read, it would be cool to have the freq displayed in the top bar maybe or else where visible since the app (govnah) would be running in the background? Possible?
    Absolutely, we've written the service specifically so that others can create patches that read the information and display it in all sorts of interesting ways.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  13. #113  
    Would there be any reason that with the conservative governor, and a scaling_min_freq of 125000 (also tried 250000) that the CPU frequency never drops below 500Mhz?
    Attached Images Attached Images
  14. rmbwebs's Avatar
    Posts
    129 Posts
    Global Posts
    145 Global Posts
    #114  
    Quote Originally Posted by ukabu View Post
    Would there be any reason that with the conservative governor, and a scaling_min_freq of 125000 (also tried 250000) that the CPU frequency never drops below 500Mhz?
    I came into this thread to post that EXACT question. I also have zero time_in_state for 250 and 125 MHz, with conservative governor and min set to 125 and max set to 800.

    Code:
    root@palm-webos-device:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_min_freq
    125000
    root@palm-webos-device:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_max_freq
    800000
    root@palm-webos-device:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_governor
    conservative
    root@palm-webos-device:/sys/devices/system/cpu/cpu0/cpufreq# cat stats/time_in_state
    800000 376668
    720000 800
    600000 5766
    550000 4281
    500000 2366085
    250000 0
    125000 0
    root@palm-webos-device:/sys/devices/system/cpu/cpu0/cpufreq#
  15. #115  
    Some reading on various governors such as ondemand and conservative.

    CPU frequency scaling in Linux with cpufreq
    Linux Kernel Documentation :: cpu-freq : governors.txt

    It could be something to do with the up_threshold and down_threshold settings? I don't know really, just thinking "out-loud". Or typing at least.
  16. #116  
    Weird, like I said, I used the default settings and had no problem for it going to the lowest CPU speed.
  17. pomokey's Avatar
    Posts
    526 Posts
    Global Posts
    540 Global Posts
    #117  
    Quote Originally Posted by ukabu View Post
    Would there be any reason that with the conservative governor, and a scaling_min_freq of 125000 (also tried 250000) that the CPU frequency never drops below 500Mhz?
    When I first tried conservative (using commandline in WOSQI), it was scaling fine from 125 to 800. I then used the cpuscaler app, and I think after that it wouldn't drop below 500. are you doing it manually, or are you using the app, or have you used the app before?

    you might need to try and set things back to defaults. this is what teh cpuscaler app changes

    Code used for “scale on”:
    echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo 500000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo 11 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    echo 1000000 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate
    echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/powersave_bias
    I have since reverted back to the stock kernel, so I can't test anything right now.

    Quote Originally Posted by supercluver View Post
    It could be something to do with the up_threshold and down_threshold settings? I don't know really, just thinking "out-loud". Or typing at least.
    I recall messing with the up_threshold and it was still stopping at 500. according http://www.webos-internals.org/wiki/Application:Govnah, it says that conservative also uses a down_threshold. perhaps this is what needs to be messed with? I have no idea what the powersave_bias is though, or what it ishould be.
    Last edited by pomokey; 04/23/2010 at 01:25 PM.
  18. #118  
    I made the change manually. I did not just changed the governor though... I set the scaling_max_freq, then scaling_min_freq, theb scaling_governor

    ok, when I just set the scaling_governor (after a reboot), it does scales down to 125MHz.
  19. #119  
    juste a few minute after setting the conservative governor, I got a crash... Black screen... Need battery pull to recover.

    note that I did nothing else but put conservative in scaling_governor

    before the crash, it was scaling up and down depending on the load... A bit sluggish when it was at 125 or 250 until the cpu is scaled up.
  20. #120  
    Quote Originally Posted by mu7efcer View Post
    I discovered that the CPU speed reverts back to 500MHz only when the userspace governor is in use and the cpu is fixed to 800MHz. Under these conditions, a luna restart reverts the cpu frequency back to 500MHz.
    After some experimenting today, I've been able to get set the CPU to 800MHz and to stick by using the ondemand governor and setting both the max and min frequencies to 800000. These settings now can survive both a luna restart and a reboot.

    It appears that Luna tries to reset the kernel speed to 500MHz. Which is consistent with what I recall back from the 1.0 and 1.1 days. The CPU starts up at 600MHz, but then gets scaled down later in the process. I'm guessing this is done by Luna.

    But Luna assumes that the userspace governor is running. My guess is that it tries to write to scaling_setspeed, but when ondemand governor is in use, that "file" is not available.

    Two questions:
    1. Is this already documented somewhere else, and I'm just way behind the curve? If so, reference please?
    2. If this isn't documented elsewhere, does this seem right?
    Last edited by mu7efcer; 04/23/2010 at 03:19 PM.
    Twitter: dullgeek

Tags for this Thread

Posting Permissions