Page 15 of 145 FirstFirst ... 510111213141516171819202565115 ... LastLast
Results 281 to 300 of 2889
Like Tree17Likes
  1. circuitjc's Avatar
    Posts
    71 Posts
    Global Posts
    78 Global Posts
    #281  
    I am still running the conservative govenor with the setting in my previous post. I don't get studdering and it shifts up and down perfectly. My temps are well in control.

    It is true that the radios in these are the worst for heat generation. Playing audio stays relatively cool where as streaming causes temps to stay in the 40's.

    For my usage patterns my settings seem to be almost perfect. Ondemand bounces around too much which seems to cause stability issues with minor pauses and sluggish response.

    Battery life is simular to stock speeds. Probably since it spends most of its time at 500MHz.

    I must have been lucky since I have never had any issues with installing this or any other kernal.

    I love my Pre and believe I made the right choice in smart phones. I am a tinkerer and love tweaking all my things. Even my F-150 is "overclocked" with a programmer.
  2. Queueyou's Avatar
    Posts
    80 Posts
    Global Posts
    126 Global Posts
    #282  
    I've been using the uber kernel for about a week now. I love it. Before using it however, I "Rarely" (read once a month or so) had a crash. It's basically a once a day thing now (from the first day to now) that it's done this. It only happens if I have the speeds set to any kind of overclocking (temp 25-30 per Govnah). If set to just '500mhz' I have no issues, however, when I set to 125-720, 125-800, 250-800 and 500-800 it happens once a day.

    Overall, the issue I see is when I try to hit the power button to 'wake' the Pre, it does nothing for about 5 seconds or so, after that, it comes up as if I had already 'unlocked' it and after a second (no response to touch during this), it will go black and display the palm boot logo. After that I go immediately into Govnah and check the temps and see they are sitting at a nice calm 25-30 range. I have ONCE seen temps above 40, and only once, they were 48 today while charging / two apps open / on speaker-phone for 7 minutes / on my lap in a car in sunlight. Beyond that, I usually see something like 35-37 immediately after 'heavy' use and the 25-30 at 'idle'.

    I have NOT changed anything but to go between ondemand and conservative. The other settings are at defaults besides mhz. I have never previously ran anything kernel-wise. Are there any suggestions as to settings I should use?

    If there is any troubleshooting details I've left out that I could help provide, please let me know. (I'm on a Sprint Pre, fully updated OS)
  3. #283  
    Quote Originally Posted by Queueyou View Post
    I've been using the uber kernel for about a week now. I love it. Before using it however, I "Rarely" (read once a month or so) had a crash. It's basically a once a day thing now (from the first day to now) that it's done this. It only happens if I have the speeds set to any kind of overclocking (temp 25-30 per Govnah). If set to just '500mhz' I have no issues, however, when I set to 125-720, 125-800, 250-800 and 500-800 it happens once a day.

    Overall, the issue I see is when I try to hit the power button to 'wake' the Pre, it does nothing for about 5 seconds or so, after that, it comes up as if I had already 'unlocked' it and after a second (no response to touch during this), it will go black and display the palm boot logo. After that I go immediately into Govnah and check the temps and see they are sitting at a nice calm 25-30 range. I have ONCE seen temps above 40, and only once, they were 48 today while charging / two apps open / on speaker-phone for 7 minutes / on my lap in a car in sunlight. Beyond that, I usually see something like 35-37 immediately after 'heavy' use and the 25-30 at 'idle'.

    I have NOT changed anything but to go between ondemand and conservative. The other settings are at defaults besides mhz. I have never previously ran anything kernel-wise. Are there any suggestions as to settings I should use?

    If there is any troubleshooting details I've left out that I could help provide, please let me know. (I'm on a Sprint Pre, fully updated OS)
    How often are you installing/uninstalling things with Preware? There have been a thread or two (can't find one at the moment...durrrr) in which people are reporting that they need to restart after installing things with Preware or they will have a lock-and-freeze when waking the phone similar to what you're describing. I have had many of these experiences and it does some to be the case, at least on my phone. I have not yet noticed any freezes using Govnah that I couldn't attribute directly either to what I just described or to using ondemand as I described earlier in this thread.
  4. #284  
    Queueyou,

    The crash circumstances you describe it is had to say for sure the root cause. I believe it to be some sort of underlying triggered thing which can be triggered by one or more apps. I personally haven't experienced the described crash linked to preware or preware alpha. I have however experienced it in the past post 1.4 update with and without a custom kernel. Prior to 1.4 I had never had my pre crash ever. Without a custom kernel installed I have experienced the crash you describe using several different apps but not all of them prior to the crash. This indicates to me it isn't a specific app or even a group of apps but rather something underlying that may or may not have something to do with a specific action performed by certain apps that more than one app has in common. Also I have not experience the crash for some time now maybe going on a week or more.
    As requested: for my works on webOS patches and apps. Twitter: @larryboytw Patches: Small icons browser start page, 5x5 launcher. I have an AAS CIS Programming degree. I enjoy working on open source projects and alpha and beta testing.
    http://install.preware.org/ for easy to get up and running for patches and apps.
  5.    #285  
    Quote Originally Posted by StoneRyno View Post
    Queueyou,

    The crash circumstances you describe it is had to say for sure the root cause. I believe it to be some sort of underlying triggered thing which can be triggered by one or more apps. I personally haven't experienced the described crash linked to preware or preware alpha. I have however experienced it in the past post 1.4 update with and without a custom kernel. Prior to 1.4 I had never had my pre crash ever. Without a custom kernel installed I have experienced the crash you describe using several different apps but not all of them prior to the crash. This indicates to me it isn't a specific app or even a group of apps but rather something underlying that may or may not have something to do with a specific action performed by certain apps that more than one app has in common.
    That is correct.

    We are working with Palm engineers to try and help them track down the problem.

    -- Rod
  6. #286  
    Still running conservative with min pegged @ 550 and max @ 720. No stuttering or crashes in the 72 hours with the uberkernel.

    re: queueyou's last post
    Performing any tasks while on the touchstone sends the cpu temp rocketing upwards very quickly. I have seen my pre jump from low 30s to high 40s just sending two emails while charging.

    From my experience my battery is draining faster but that is to be expected since my min CPU speed is set to higher than stock.
  7. #287  
    Quote Originally Posted by rwhitby View Post
    That is correct.

    We are working with Palm engineers to try and help them track down the problem.

    -- Rod
    I'm pretty happy with my moderately patched Pre. I only install things via Preware at this point,and I'm pretty conservative because I don't want to have to mess with multiple problems. I've been reading the overclocking posts, realize there are a number of options, but I'd rather stick with Preware-installable items. Rod, is there any rough estimate of when your testing will be complete on this program and it will be ready for general consumption? I'm considering trying it anyway, but would rather not have multiple crashes.....
  8. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #288  
    Quote Originally Posted by davidra View Post
    I'm pretty happy with my moderately patched Pre. I only install things via Preware at this point,and I'm pretty conservative because I don't want to have to mess with multiple problems. I've been reading the overclocking posts, realize there are a number of options, but I'd rather stick with Preware-installable items. Rod, is there any rough estimate of when your testing will be complete on this program and it will be ready for general consumption? I'm considering trying it anyway, but would rather not have multiple crashes.....
    FWIW (and I like to be bleeding-edge at times, my Linux distro is Sabayon/Gentoo and I don't run the "stable" releases), I had lots of crashes/hangs when scaling down below 500mHz. Since I set my min to 500 and max to 800 I have gone from multiple crashes or hangs a day to maybe one every couple of days.

    I am sticking with the preware-installable kernels for now simply because I don't have to dedicate quite as much time to it versus maintaining one outside of Preware.
  9. #289  
    Rod (or anyone else who knows how I can fix this issue)

    Is there anyway to have the default min freq at 500mhz and not 125mhz? I had to reboot my phone and when I went to re-adjust my settings my phone keeps locking up as soon as I go into the 'ondemand' due to the fact that the min. is at 125. My phone doesn't like 125mhz or 250mhz and I'm having bad luck trying to keep the phone busy while I try to readjust the settings
  10. #290  
    Quote Originally Posted by Abyssul View Post
    governor: ondemand
    min freq: 500
    max freq: 800
    sampling rate: 100000
    up threshold: 40%
    ignore nice load: false
    powersave bias: 0
    Quote Originally Posted by bitshifter1001 View Post
    I tried these settings without luck. My screen flickered during video playback. Phone locked up when trying to run Super KO Boxing. I was monitoring temp and it seemed to run steady around 38C.
    Quote Originally Posted by SDash View Post
    Have you tried conservative with the same settings?

    I think video playback doesn't like ondemand's sudden changes in frequency. Conservative would flicker on mine but not during actual playback.
    Haven't tried these with conservative. I will now and report back.
  11. #291  
    Rod,

    I would like to thank you and other developers for your time towards this awesome Kernel. I have had it running but would like to make a few suggestions as to issues that came up.

    Currently I'm fighting an issue that cropped up with my PRE doing a luna restart after going idle so unforuntately I needed to uninstall it but here is some information that you may find useful for development / debug.

    1) When waking from idle my pre would never show the lock icon like it does with the stock kernel. Not sure if it was the ondemand kernel I was using or the Weather Window which would keep it from locking / idling properly. I'm currently debugging which of 3 programs seem to be causing my issues.

    2) ondemand worked fine for me as long as I moved the power conservation setting off of ZERO, otherwise would always drop to 125mHz even though I selected otherwise.

    3) ondemand / conservative or other modes dynamically changing mHz would cause random glitches in processor intensive applications such as Need for Speed, Camera etc. Polling was stock, power saving at 40, minimum freq 250 max at 800. Same problem with min at 500mHz. If I set to performance with 800 / 800, no problems existed. I would recommend that dynamic mHz changes are turned off if the processor is being used over 80% until the program in question causing the CPU usage is shut down.

    I hope to re-install the app after I sort out the cause of my random lockups / luna restarts. It would seem PREWARE is also causing random dropped background programs and issues which I will report elsewhere. Other then that thanks for your good work!

    Mark
  12. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #292  
    1) When waking from idle my pre would never show the lock icon like it does with the stock kernel. Not sure if it was the ondemand kernel I was using or the Weather Window which would keep it from locking / idling properly. I'm currently debugging which of 3 programs seem to be causing my issues.
    I get this every once in awhile, even with the stock kernel. I never figured out if there was a pattern.
  13. #293  
    Quote Originally Posted by angiest View Post
    I get this every once in awhile, even with the stock kernel. I never figured out if there was a pattern.
    It hasn't been long but I have been trying to get my pre to mess up again without using Weather Windows or the Uber Kernel. So far every time I hit the power button the lock icon is prompting me where it usually never did previously. It could also be another issue I found with preware but I'm trying to find which program causes the issue by isolating which ones are used.

    On a different note, I also notice that with the stock kernel my pre is asking me to drag the lock icon up to answer calls but when uber kernel was installed it was merely prompting me to answer or disregard the call, again it may be Weather Windows but want to make sure the issue is resolve before I re-enable one program or the other.

    At this point I'm almost 100% certain it's either the Uber Kernel or Weather Windows. In either case I'll be sad to see and app or the kernel go but I need my phone functional. I'll more then likely re-enable Weather Windows which runs in the background in a couple days if I don't get any lock ups and let everyone know my findings.
  14. #294  
    Quote Originally Posted by Queueyou View Post
    I've been using the uber kernel for about a week now. I love it. Before using it however, I "Rarely" (read once a month or so) had a crash. It's basically a once a day thing now (from the first day to now) that it's done this. It only happens if I have the speeds set to any kind of overclocking (temp 25-30 per Govnah). If set to just '500mhz' I have no issues, however, when I set to 125-720, 125-800, 250-800 and 500-800 it happens once a day.

    Overall, the issue I see is when I try to hit the power button to 'wake' the Pre, it does nothing for about 5 seconds or so, after that, it comes up as if I had already 'unlocked' it and after a second (no response to touch during this), it will go black and display the palm boot logo. After that I go immediately into Govnah and check the temps and see they are sitting at a nice calm 25-30 range. I have ONCE seen temps above 40, and only once, they were 48 today while charging / two apps open / on speaker-phone for 7 minutes / on my lap in a car in sunlight. Beyond that, I usually see something like 35-37 immediately after 'heavy' use and the 25-30 at 'idle'.

    I have NOT changed anything but to go between ondemand and conservative. The other settings are at defaults besides mhz. I have never previously ran anything kernel-wise. Are there any suggestions as to settings I should use?

    If there is any troubleshooting details I've left out that I could help provide, please let me know. (I'm on a Sprint Pre, fully updated OS)
    I initially thought this Luna restart was Uber Kernal as well but I uninstalled it and forced an issue I noticed with Preware and still got the Luna restart with the stock kernel. I did notice the lock issue resolved with the stock kernel.

    Did you install an app from Preware, that was downloaded via Preware (not the Palm catalog) before your Luna restart issue? Whenever I installed an app from preware it would close other open windows and cause the phone to hang during wake causing the Luna restart.

    It could be a combination of both... but sure hope not.
  15. #295  
    [QUOTE=graffix31;2409461]Quote:
    Code used for “scale on”:
    echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo 500000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo 11 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    echo 1000000 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate
    echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/powersave_bias

    I am using the govnah but i am having a problem with scaling sticking under 500mhz. i had used uberscaler with the old kernal and read that it might have something to do with it.
    If i uninstall ubescaler and run the above scripts one at a time will it help make it possible to test different scaling under 500?
    Thanks for the help.



    Edit: I think i read this else where but i notice that when first setting ondemand after a restart the phone will scale to any frequency. I used all of the main apps all at the same time, phone, messaging, email, calander and web. and it would still show in govnah the scale back down to 125 or 250 after closing them. however as soon as i use the camera it will no longer scale lower than 500.

    One more thing i take it back. it will scale down however it will never stick at 250 will always scale down to 125 even if min is set at 250.

    The camera in jstop only shows 39 nodes when the phone restarts. however after running it jumps to 79. dont know if that has anything to do with it but even if you close it with jstop it still wont scale down to anything lower than 500. oh well guess i will leave it at a min of 500.
    Last edited by graffix31; 04/29/2010 at 03:23 PM.
  16. #296  
    What is the difference between the two 1.4.1 kernels in the testing feed? One is labeled Palm webOS 1.4.1 Kernel and the other is Stock Kernel. If I want to install back to default Palm, which would I install?
  17. #297  
    Rob can we run the uberkernel without govnah and if we have a cpu scaling app can that control uberkernel where it sticks with a reboot? I have experimented with the majority of the kernels available and I just want to knowfor my own knowledge.
  18. #298  
    Quote Originally Posted by mamouton View Post
    Rob can we run the uberkernel without govnah and if we have a cpu scaling app can that control uberkernel where it sticks with a reboot? I have experimented with the majority of the kernels available and I just want to knowfor my own knowledge.
    I've been using uber-kernel without Govnah for a while now, using only an /etc/event.d / upstart-based script, with no issue.
  19.    #299  
    Quote Originally Posted by mamouton View Post
    Rob can we run the uberkernel without govnah and if we have a cpu scaling app can that control uberkernel where it sticks with a reboot? I have experimented with the majority of the kernels available and I just want to knowfor my own knowledge.
    Yes, all the kernels have identical control interfaces, so as long as the controlling app uses that interface (and both CPUScaler and Govnah do), then it should work.

    WebOS Internals is all about interoperability between multiple redundant solutions in the ecosystem (e.g. Preware and WOSQI) - we never try and lock anyone out or try and hide information about how to replicate the work we do.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  20.    #300  
    Quote Originally Posted by todivefor View Post
    What is the difference between the two 1.4.1 kernels in the testing feed? One is labeled Palm webOS 1.4.1 Kernel and the other is Stock Kernel. If I want to install back to default Palm, which would I install?
    Take a look at the description for each in Preware.

    The Palm Kernel (which is in the "Recovery" category) is the one you want to use for recovery purposes.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Tags for this Thread

Posting Permissions