Page 121 of 145 FirstFirst ... 2171111116117118119120121122123124125126131 ... LastLast
Results 2,401 to 2,420 of 2889
Like Tree17Likes
  1. #2401  
    Gotchya. Thanks Xanadu. I always see you around and you're always really helpful.
  2. #2402  
    Quote Originally Posted by Psychonaut View Post
    Ha! Thinking and typing. So just the file named "compcache" then? Just throw it any ol' place?

    P.S.
    You should save the script for when you come to the conclusion that trying to
    to run webOS 2.1 n 256M RAM is impossible, you can put it back.


    M.
  3. #2403  
    Quote Originally Posted by rwhitby View Post
    What governor are you running, and what is your normal workload?

    -- Rod

    You'll have to forgive me. I'll barely knowledgeable enough to ASK a question in here, let alone answer any..

    I've always stuck with Screenstate 500/1000 aside from a little tryst with 250/1000.

    As for your second question I'm unsure as to whether my answer should be qualitative or quantitative.

    Currently in Govnah the load average is displaying 0.73 1.92 1.42 and memory/swap at 380/0, but I'm fresh off a reboot if that's relevant.

    Frankly I don't have too clear an understanding of what any of that means, and as such, have not observed any kind of average or what is normal.

    Edit: Were you looking for a more qualitative answer as to what my "normal workload" is?
    Last edited by Psychonaut; 03/29/2011 at 07:53 PM.
  4. #2404  
    Quote Originally Posted by Xanadu73 View Post
    P.S.
    You should save the script for when you come to the conclusion that trying to
    to run webOS 2.1 n 256M RAM is impossible, you can put it back.


    M.
    Ha! I did save it, but I'm on a Sprint Pre Plus sportin' 512. Wo0t wo0t!

    But seriously. The three devices I've enabled compcache on have all become promptly totally unusable. Either mind bogglingly slow or forced reboots...
  5. #2405  
    Quote Originally Posted by Psychonaut View Post
    Ha! I did save it, but I'm on a Sprint Pre Plus sportin' 512. Wo0t wo0t!

    But seriously. The three devices I've enabled compcache on have all become promptly totally unusable. Either mind bogglingly slow or forced reboots...
    I don't know if it is related or not, but i've been trying to pinpoint a memory leak that seems related to playing audio in 2.1 on Pre+ and Pre2 devices. Pre- may not be affected... Check it out: http://forums.precentral.net/general...mory-leak.html

    Sorry for going OT.
  6. #2406  
    Quote Originally Posted by Xanadu73 View Post
    Yes. It's "hard coded" in the OS's startup files since Palm/HP integrated 'Psycho's work into webOS. It's not freely/easily adjustable like it used to be (yet).

    The answer is in the 2.1 Upgrade Wiki, though.

    WebOS 2 Upgrade - WebOS Internals


    M.
    Does anyone know if it's possible to set the compcache to values other than 10240 or 32768? Something more equivalent to the Govnah options of 96 MB or 128 MB?
  7. #2407  
    Quote Originally Posted by capt4chris View Post
    Does anyone know if it's possible to set the compcache to values other than 10240 or 32768? Something more equivalent to the Govnah options of 96 MB or 128 MB?
    What is the purpose of using that much Compcache?
  8. #2408  
    Quote Originally Posted by capt4chris View Post
    Something more equivalent to the Govnah options of 96 MB or 128 MB?

    You're talking about near suicide conditions, but (SIZE) x 1024.

    64 x 1024 = 65,536
    128 x 1024 = 131,072

    Good luck...


    M.
  9. #2409  
    Quote Originally Posted by Xanadu73 View Post
    You're talking about near suicide conditions, but (SIZE) x 1024.

    64 x 1024 = 65,536
    128 x 1024 = 131,072

    Good luck...

    M.
    Hm, Govnah has always had these and I thought they were the preferred options. Are they not ideal to use anymore on a Pre- running 2.1.0 for some reason? Just curious because I want to use what's best.

    -- Sent from my Palm Pre using Forums
  10. #2410  
    Quote Originally Posted by capt4chris View Post
    Hm, Govnah has always had these and I thought they were the preferred options. Are they not ideal to use anymore on a Pre- running 2.1.0 for some reason? Just curious because I want to use what's best.

    -- Sent from my Palm Pre using Forums
    Just because they were there doesn't mean a Pre- can handle it. The Pre- was always suffering for memory even in 1.4.5, and it has barely enough for 2.1.0. So anything above 16M-32M is suicide. A Pre+ on the other hand can handle larger sizes.

    Unless you like the thrashing effect .
    Live free or DIE!
  11. #2411  
    i usually run 32mb with f-105 on a sprint pre- and other than the occasional hang have not had any issues. not a singe reboot. i have had it to 64mb but didnt notice much of a diff so just stick with 32. is everyone saying that going that high is bad? should you stick to the 10mb or 16mb?
  12. #2412  
    Quote Originally Posted by unixpsycho View Post
    Just because they were there doesn't mean a Pre- can handle it. The Pre- was always suffering for memory even in 1.4.5, and it has barely enough for 2.1.0. So anything above 16M-32M is suicide. A Pre+ on the other hand can handle larger sizes.

    Unless you like the thrashing effect .
    LOL, ok I'll keep it @ 32. My Pre just goes through times where its running great, then there are times where it slows WAY down even though I have the muffle system logging patch installed.

    Also, there are times when it seems like the apps & OS are running fine but the phone has a hard time reading databases (searching names for calls/texts, tasks, browser history, other data stored on the phone). The app just sits there meanwhile I can move around through other apps & the OS just fine.

    -- Sent from my Palm Pre using Forums
  13. #2413  
    I would like to discuss Compcache and understand why it would be useful on a Pre Plus or a Pre2 running 1.4.5 or 2.x - Should I start a new thread or is this the place to do this?

    I understand the basics of how compcache works (compressed region of ram) and the tradeoffs (performance of that ram). What's not clear to me is if I have a relatively large amount of free memory why I would set aside some of it to compcache?

    Essentially if I am not seeing any swap activity - is there a purpose to using it?
  14. #2414  
    Quote Originally Posted by Unclevanya View Post
    Essentially if I am not seeing any swap activity - is there a purpose to using it?

    Paste was "free -tm" says...


    M.
  15. #2415  
    Quote Originally Posted by Xanadu73 View Post
    Paste was "free -tm" says...
    I'm evidently uberdense - not getting this response.
  16. #2416  
    Quote Originally Posted by Unclevanya View Post
    I'm evidently uberdense - not getting this response.

    Code:
    novacom -t open tty://
    
    free -tm
    You'll get something like:

    Code:
    root@My Pre:/# free -tm
                 total       used       free     shared    buffers     cached
    Mem:           239        220         19          0          3         55
    -/+ buffers/cache:        160         78
    Swap:          103         56         47
    Total:         343        276         67
    See the swap in use? That's what I'm going to show you from yours. Yours *is* swapping.


    M.
  17. #2417  
    Quote Originally Posted by Xanadu73 View Post
    Code:
    novacom -t open tty://
    
    free -tm
    You'll get something like:

    Code:
    root@My Pre:/# free -tm
                 total       used       free     shared    buffers     cached
    Mem:           239        220         19          0          3         55
    -/+ buffers/cache:        160         78
    Swap:          103         56         47
    Total:         343        276         67
    See the swap in use? That's what I'm going to show you from yours. Yours *is* swapping.


    M.
    Not really...

    root@palm-webos-device: free -tm
    total used free shared buffers cached
    Mem: 492 372 119 0 85 107
    -/+ buffers/cache: 179 313
    Swap: 127 0 127
    Total: 620 372 247
    root@palm-webos-device:

    Note that "used" = 0. I have swap allocated but none used.
    Or am I reading this wrong?
    BTW - this is with Compcache enabled - I didn't realize I had it enabled on this reboot.
  18. #2418  
    Finally took the dive and upgraded my Verizon Pre Plus to 2.1. After upgrading, I mistakenly tried to install Uberkernel through webOSQuickInstall. The install got far enough to show it on the Pre, but Govnah can't take advantage of it. I've tried to delete with Preware and QuickInstall and get a failure message of "unable to locate the tarball". Any suggestions on how I can recover and reinstall UK?
  19. #2419  
    Quote Originally Posted by Unclevanya View Post
    Not really...

    root@palm-webos-device: free -tm
    total used free shared buffers cached
    Mem: 492 372 119 0 85 107
    -/+ buffers/cache: 179 313
    Swap:
    Total:
    root@palm-webos-device:

    Note that "used" = 0. I have swap allocated but none used.
    Or am I reading this wrong?
    BTW - this is with Compcache enabled - I didn't realize I had it enabled on this reboot.

    Out of curiosity, how long before checking that had you rebooted?


    M.
  20. #2420  
    Quote Originally Posted by Xanadu73 View Post
    Out of curiosity, how long before checking that had you rebooted?
    Several hours but I didn't check so I cannot say for sure how many. I just checked uptime from terminal and currently it's at 16+ hours. Running "free -tm" gives the same basic results for swap 127 total, 0 used, 127 free.

    The reason I have only 16 hours uptime is that I finally crashed my Pre running at 250mhz (250/720 screenstate). It is not clear yet if this is repeatable. I did not have to pull battery - it was dead and I was able to start with the power button.

    Today was spent mainly looking at a few emails, talking on a few calls, and using Verizon Navigator app while running UK at Default 500mhz due to navigation app and charging in the car.

    So I'm back to my basic question - why would I want to use Compcache if I don't appear to be using SWAP?

Tags for this Thread

Posting Permissions