Page 12 of 26 FirstFirst ... 2789101112131415161722 ... LastLast
Results 221 to 240 of 519
Like Tree19Likes
  1. #221  
    Thanks for updating the X package Rod, it's extremely useful!
  2. gfdos.sys's Avatar
    Posts
    69 Posts
    Global Posts
    77 Global Posts
    #222  
    Any update on how to get arrow keys.... kinda hard to vi with out them
  3.    #223  
    Quote Originally Posted by gfdos.sys View Post
    Any update on how to get arrow keys.... kinda hard to vi with out them
    No arrow key support yet:

    Application:X - WebOS Internals

    This is mostly because no one's sat down and come up with a reasonable configuration for the keyboard, the implementation is fairly straightforward.

    However, in your case you can just use the traditional vi navigation keys 'hjkl' which work fine
    Quake
    thread
    VisualBoyAdvance
    thread App Cat
    X11/XServer/Xterm
    thread
    SuperNES
    thread App Cat


    If you like my work, please consider donating or buying VBA!
  4. #224  
    Quote Originally Posted by rwhitby View Post
    Back on 19th December last year I published a method on our wiki of how to get homebrew services and PDK apps to run outside of the jail - yes, well before the front-page story on PreCentral of someone else supposedly working that out first

    I updated the X11 packages with that technique very early this morning when I woke up with jet lag at 4am.

    -- Rod
    Would it be possible to update the Qt packages as well? The same modification should work for the Qt packages too.
  5. #225  
    Quote Originally Posted by rsanchez1 View Post
    Would it be possible to update the Qt packages as well? The same modification should work for the Qt packages too.
    Which ones do you use?

    -- Rod
  6. #226  
    Quote Originally Posted by rwhitby View Post
    Which ones do you use?

    -- Rod
    I have all of them installed. I guess the changes could be applied to all of them except Qt Framework which doesn't really launch anything and Qt OpenGL Demo which doesn't work either way.

    -- Sent from my Palm Pre using Forums
  7. #227  
    Tried nano in xterm. Works fine. But can't be exited. Most of the Ctrl sequences work well, but C-X (^X) doesn't. How to get a Ctrl-X in xterm? Swiping up and restarting xterm is a workaround. But doesn't come in handy.

    Regards

    Carsten
  8. #228  
    Quote Originally Posted by dtzWill View Post
    No arrow key support yet
    Don't know about vi, but in nano C-p (previous line), C-n (next line), C-b (backwards one character), and C-f (forwards one character) all work as expected. Using Gesture as the Ctrl modifier.
  9. #229  
    Well, incredible work! XServer and xterm are working like a charm on a german O2 Palm Pre with 2.1

    Small caveats: Your howto talks about exporting DISPLAY=:0.0
    Ummm... Maybe I am blind, but I don't see a "=" on my keyboard. Not on the keys and not in the "Special keys" mentioned at the X-Server Page. Is this already there or needs to be implemented? I am seeing a lot of command lines including a "=" so it might come handy...
    Neither C-c nor C-x are working for me. Where I can live without C-x (nano only...), having no Ctrl-C for Cancel is kinda... not optimal. Funny thing is: C-o for example works. Weird. :-/

    Anyway... keep up the good work!

    Regards, Bigfoot29
  10. #230  
    Quote Originally Posted by Bigfoot29 View Post
    Well, incredible work! XServer and xterm are working like a charm on a german O2 Palm Pre with 2.1

    Small caveats: Your howto talks about exporting DISPLAY=:0.0
    Ummm... Maybe I am blind, but I don't see a "=" on my keyboard. Not on the keys and not in the "Special keys" mentioned at the X-Server Page. Is this already there or needs to be implemented? I am seeing a lot of command lines including a "=" so it might come handy...
    Neither C-c nor C-x are working for me. Where I can live without C-x (nano only...), having no Ctrl-C for Cancel is kinda... not optimal. Funny thing is: C-o for example works. Weird. :-/

    Anyway... keep up the good work!

    Regards, Bigfoot29

    I am not sure about the Germany keyboard but my = sign is above the p key. top right of the keyboard.
  11. yroc1234's Avatar
    Posts
    14 Posts
    Global Posts
    19 Global Posts
    #231  
    I have gotten everything to work perfectly together, I also wanted to make things easier by creating .sh scrips to do all the mounting, unmounting, and chroot entering for me so stole the following scripts from dbtrade:

    Code:
    #!/bin/sh
    mount -o loop /media/internal/debsmall.img /media/cf
    mount --bind /dev /media/cf/dev
    mount -t devpts none /media/cf/dev/pts
    mount -t proc none /media/cf/proc
    mount -o bind /tmp /media/cf/tmp
    Code:
    #!/bin/sh
    export DISPLAY=:0.0
    /usr/sbin/chroot /media/cf

    Code:
    #!/bin/sh
    umount /media/cf/dev/pts
    umount /media/cf/dev
    umount /media/cf/proc
    umount /media/cf/tmp
    umount /media/cf
    The issue is, when I run the mount script I get a error saying:

    Failed: No such file or directoryia/cf
    Failed: No such file or directorydev
    Failed: No such file or directorydev/pts
    Failed: No such file or directoryproc
    Failed: No such file or directorytemp

    Any idea on how I can fix the scripts?
  12. Misaki Ki's Avatar
    Posts
    51 Posts
    Global Posts
    52 Global Posts
    #232  
    ^ I believe it has to do with how Windows and Linux does it's line breaks. Did you copy/paste those into notepad?



    Anyway, has anyone experienced a problem with partial loss of web access for various applications? Ping and such works in the Debian environment, as does Preware, but the Browser and Google Maps aren't able to access anything. The email client can receive new emails, but is unable to properly open and read them.

    Sprint Pre-, running 2.1. Happened twice, doctoring does correct it, but looking to see if there's anything much less drastic to work with.
    Last edited by Misaki Ki; 03/23/2011 at 04:30 PM.
    Gitah~
  13. #233  
    Hmm, are you saying that the problem is that chrooting into the debian environment causes the browser and google maps apps on your Pre to stop working?

    -- Sent from my Palm Pre using Forums
    Last edited by rsanchez1; 03/26/2011 at 07:33 PM.
  14. Misaki Ki's Avatar
    Posts
    51 Posts
    Global Posts
    52 Global Posts
    #234  
    Not really, was just wondering if anyone else experienced it. For me I had minimal stuff at the time, (Preware, Xterm/Server Packages.) Happened when my phone crashed trying to install some of the larger packages (with apt-get) so it might just be related to the crash itself. Experienced it twice, but hasn't happened again lately.
    Gitah~
  15. #235  
    Well, you have to remember your Pre- only has 256MB memory. I would recommend installing any necessary packages first through your computer (if you're running Linux or can get VirtualBox set up). You can chroot the same way you would on your pre (except you would use /media/mnt instead of /media/cf).

    Also, when you experienced it before, rebooting your phone didn't help? I've had chrooting give me problems before, but they resolved themselves after a reboot.
  16. Misaki Ki's Avatar
    Posts
    51 Posts
    Global Posts
    52 Global Posts
    #236  
    Yeah, I'm aware. Just wanted to see what I could get running on the phone, using the phone, since I won't always be able to access linux all the time.

    Rebooting didn't help, webaccess just stayed dead.

    Also when I went back into Debian (this happens at any crash, unrelated to the webloss oddity when installing) I had the dkpg interrupted error when trying to use apt-get again. The command it tells you to run "dpkg --configure -a" wouldn't work and I had to do a manual delete of a few of the trouble folders and files in "/var/lib/dpkg/updates" followed by an "apt-get update".

    Took much longer than restoring a backup of the image, so I'll just stick to those.

    Was right click ever added? Arrow keys were mentioned on this page, so no need to mention those, but it's been almost a year since the last mention of right click I think.

    ...Yeah, I'm late to the party.
    Last edited by Misaki Ki; 03/26/2011 at 09:30 PM.
    Gitah~
  17. #237  
    I'm not sure about right-clicking. I think it wasn't added. I've never used it and I haven't seen instructions on how to do right-clicking.

    It hasn't been updated in a year. The last update on Preware was just a change to allow it to run from the Launcher.
  18. #238  
    Is possible to run an Android system image using a similar method?
  19. #239  
    I just saw Rod's tweet on Xecutah and it got me very excited. I'm interested in what Xecutah has to offer over the X server/xterm combo already available (besides one package for both).
  20. #240  
    Quote Originally Posted by dtzWill View Post
    No arrow key support yet:

    Application:X - WebOS Internals

    This is mostly because no one's sat down and come up with a reasonable configuration for the keyboard, the implementation is fairly straightforward.

    However, in your case you can just use the traditional vi navigation keys 'hjkl' which work fine

    Sorry will.. perhaps i should jump in and figure out a good key combo with you like we did for quake. Just off the top of my head what about meta-tap WASD for the phones. as for touchpad... i dunno yet.
    MatterOfFactJack

Posting Permissions