Page 11 of 26 FirstFirst ... 67891011121314151621 ... LastLast
Results 201 to 220 of 519
Like Tree19Likes
  1. #201  
    Here's something interesting to try with X server. You could get an Ubuntu rootfs and try to get Unity 2D running on your Pre. A while back I tried to get an Ubuntu rootfs set up, had limited success, and decided to stop when I realized the Unity desktop was not available for ARM, but it looks like Unity 2D is made for low-powered ARM devices.

    http://bfiller.wordpress.com/2011/01/13/unity-2d/

    EDIT: I was able to get an Ubuntu Maverick rootfs set up with Unity 2D installed, but could barely get Unity running. I could get unity-2d-panel up, and it showed the panel from where you would launch apps, but it only had a trash icon, although I could drag that icon smoothly. Maybe if someone else could try it and share their experience we could make progress. I'll share details on how I got it set up probably this weekend.

    Makes me wonder how touchscreen-friendly the rest of it is...
    Last edited by rsanchez1; 01/27/2011 at 12:55 AM.
  2. #202  
    I've added the testing feeds but I can't find Xterm or X Server. I'm on a Pixi + if that helps. Is this even able to run on a pixi?
  3. #203  
    I didn't find any xterm in Preware testing feeds for ARMv6, so it means - no Xterm for Pixi or Pixi+, sorry.
  4. #204  
    Quote Originally Posted by Unclevanya View Post
    Quick question - in theory could you use the pre to forward the video of X enabled apps from the Pre to a larger video screen on a PC or Unix box running an X11 server?
    It seems like you could run a remote desktop server on your device and display/interact with it via lan/wan.

    Thanks for the X port guys -- works great!
  5. #205  
    I am having some issue with launching xterm. I have it all install but when I launch it, it highlights then it goes away and nothing is opened. should something popup or do I need to use the terminal app for ssh and x11 commands? I didnt install openssh because I already have ssh installed from the sdk.
  6. #206  
    You can't launch xterm from the launcher. You have to launch it from a terminal, either from the Terminal app or by using novaterm.
  7. #207  
    I am going to start over from the beginning. If I have any issues I will be back.
    Last edited by elpollodiablo1; 03/03/2011 at 08:18 AM.
  8. #208  
    is xterm still broken on 1.4.5? I am trying to get it to work and I noticed a few pages earlier that said it was not working on 1.4.5. is there any update on this? do the install instruction at the beginning still hold true?
  9. #209  
    I have updated XTerm to work on my Pre 2 running webOS 2.1.0

    Please test it and tell me what other devices and webOS versions it now runs on successfully.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10. #210  
    Quote Originally Posted by rsanchez1 View Post
    You can't launch xterm from the launcher. You have to launch it from a terminal, either from the Terminal app or by using novaterm.
    Hopefully this is no longer true. Please test the latest version. It now works for me on a Pre 2 running webOS 2.1.0 ... I fixed the jail issue.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. #211  
    I have updated XTerm to work on my Pre 2 running webOS 2.1.0

    Please test it and tell me what other devices and webOS versions it now runs on successfully.

    -- Rod
    I am able to launch Xterm, and am able to type commands, but neither the option key nor the shift key seems to work, so only able to type lowercase letters. No symbols or uppercase....

    Is there a way to run this through novaterm, to get console output or is there a log I can post?

    Using 1.4.5 on a Sprint (Verizon w/Sprint com board) Palm Pre Plus, modified with old meta_doctor method, using tokens: http://forums.precentral.net/palm-pr...ion-guide.html
  12. #212  
    Quote Originally Posted by deerewright View Post
    I am able to launch Xterm, and am able to type commands, but neither the option key nor the shift key seems to work, so only able to type lowercase letters. No symbols or uppercase....

    Is there a way to run this through novaterm, to get console output or is there a log I can post?

    Using 1.4.5 on a Sprint (Verizon w/Sprint com board) Palm Pre Plus, modified with old meta_doctor method, using tokens: http://forums.precentral.net/palm-pr...ion-guide.html
    Hold the modifier key down.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  13. #213  
    Hold the modifier key down.
    Uh DUHHHHH, thought I tried that, guess not . Works now. So far so good!

    Off topic: Rod, would there by any advantage of using the new metadoctor scripts to redoctor? (to 1.4.5). I am planning on eventually trying the upgrade to 2--just not quite ready to take the leap....
    Last edited by deerewright; 03/15/2011 at 09:31 AM.
  14. Tigrao's Avatar
    Posts
    110 Posts
    Global Posts
    111 Global Posts
    #214  
    Quote Originally Posted by rwhitby View Post
    I have updated XTerm to work on my Pre 2 running webOS 2.1.0

    Please test it and tell me what other devices and webOS versions it now runs on successfully.

    -- Rod
    Wow! This is awesome! XTerm is working flawlessly for me. I've really been missing not having Terminal on my 2.1.0 Pre Plus. I tried Secureshell to get by, but XTerm is just so much better! Thanks Rod!
  15. #215  
    Just installed this, I missed the terminal as well.
    Quick dumb question though. Earlier on in this thread there are pictures of desktop Linux running on a Pre but this must be run in conjunction with a Unix box, right? So practically the effect is just a VNC?
  16. #216  
    Quote Originally Posted by innocentbystander View Post
    Just installed this, I missed the terminal as well.
    Quick dumb question though. Earlier on in this thread there are pictures of desktop Linux running on a Pre but this must be run in conjunction with a Unix box, right? So practically the effect is just a VNC?
    No, the packages get installed on your device and everything runs on a X server inside a card
  17. #217  
    I have Xterm now running on my pre 2 v2.1 and Pre- v1.4.5 both stock. I am also able to launch xterm from the launcher and do not need terminal or novaterm.

    Thanks a lot Rod, What exactly did you do to get it working? I was looking through the git repository for it and was thinking about trying to get it working on my own, but I couldnt tell if it was a recompiling that needed to be done or a code change.

    Thanks again!
  18. #218  
    Quote Originally Posted by NuttyBunny View Post
    No, the packages get installed on your device and everything runs on a X server inside a card
    I believe it can be both ways cant it? they can run it from the Pre but if they ssh with X11 forwarding arn't they also able to display the desktop that way similar to VNC?

    atleast that is my understanding.
  19. #219  
    it doesn't seem like the ssh -X option works on my Pre. should this option work in dropbear? I am trying to forward an x application from a remote server.

    I am using the ssh from the PDK
    Last edited by elpollodiablo1; 03/15/2011 at 09:00 PM.
  20. #220  
    Quote Originally Posted by elpollodiablo1 View Post
    I have Xterm now running on my pre 2 v2.1 and Pre- v1.4.5 both stock. I am also able to launch xterm from the launcher and do not need terminal or novaterm.

    Thanks a lot Rod, What exactly did you do to get it working? I was looking through the git repository for it and was thinking about trying to get it working on my own, but I couldnt tell if it was a recompiling that needed to be done or a code change.

    Thanks again!
    Back on 19th December last year I published a method on our wiki of how to get homebrew services and PDK apps to run outside of the jail - yes, well before the front-page story on PreCentral of someone else supposedly working that out first

    I updated the X11 packages with that technique very early this morning when I woke up with jet lag at 4am.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Posting Permissions