Page 4 of 12 FirstFirst 123456789 ... LastLast
Results 61 to 80 of 229
  1.    #61  
    Quote Originally Posted by Audemars02 View Post
    Rod -- I am getting a lot of freeze-ups during the "scanning unknown packages" process. This applies to the regular Preware as well, but it seems to happen more with the preware Alpha... Any idea why this would happen (it seems to be a different package every time)? Also, any way to add a "skip package" if it hangs up on a specific one?
    Do you see any pattern to it? We know that it's happening to a number of people, but have not been able to detect what the cause is yet. We'd rather not put a work-around in until we can work out why it is happening, in case it's a sign of a more serious underlying problem.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2.    #62  
    Quote Originally Posted by plee3 View Post
    There appears to be a bug in the new Preware Alpha.

    After installing Preware Alpha and rebooting, I get the following error when I try to use "Restart Luna" in Luna Manager (the app, not from the Preware menu):

    Method "restartluna" with signature "ss" on interface "org.json" doesn't exist.

    When I remove Preware Alpha, reinstall Preware, and reboot, I no longer get this message and Luna restarts as expected.

    Please let me know if you need more information on how to reproduce this problem.

    Thanks... plee3
    Fixed in Luna Manager 0.0.4 (it was using very old deprecated names for the service calls).

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3. #63  
    Quote Originally Posted by rwhitby View Post
    Do you see any pattern to it? We know that it's happening to a number of people, but have not been able to detect what the cause is yet. We'd rather not put a work-around in until we can work out why it is happening, in case it's a sign of a more serious underlying problem.

    -- Rod
    no idea why..it just happens... and its usually a different package, and its sometimes at the beginning, sometimes in the middle, and sometimes towards the end of the list. so, seems to be totally random. when it happens, i select "update feeds" again and it runs through the whole process again, and i just hope it works!
  4. #64  
    While i apreciate your work, i think you could have picked better words while talking about webos quick install...

    While palm's software, might allow me to install preware, which might do all the same things, it will not replace web-os quick install..

    First off, the last time i installed palm's software, it was a pain. quick install on the other hand is fairly simple, even on 64 bit, windows 7. Also, browsing through a list of patches, and reading descriptions, is much more plesent on a 22 inch monitor than a 3 inch one...


    Again, I appreciate all the work, that you guys are doing, but please be respectful to the work of other devs, Especially if they are Canadian! (the last part was a joke...)

    anyways, does the c version run faster?
  5. #65  
    I have just installed the test app Preware-Alpha. I noticed that it runs much faster than the original Preware. After loading the feeds, it takes less than half as long to scan your installed apps. Very sweet WebOS internals team!!
  6.    #66  
    Quote Originally Posted by nimer55 View Post
    While i apreciate your work, i think you could have picked better words while talking about webos quick install...

    While palm's software, might allow me to install preware, which might do all the same things, it will not replace web-os quick install..

    First off, the last time i installed palm's software, it was a pain. quick install on the other hand is fairly simple, even on 64 bit, windows 7. Also, browsing through a list of patches, and reading descriptions, is much more plesent on a 22 inch monitor than a 3 inch one...


    Again, I appreciate all the work, that you guys are doing, but please be respectful to the work of other devs, Especially if they are Canadian! (the last part was a joke...)
    Wow, it seems that the "wink" emoticon just doesn't cut it these days ... I've removed the comment since it's causing such controversy.

    anyways, does the c version run faster?
    Sure does. Uses less memory too.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  7. #67  
    Rod - YOU ARE THE MAN!
  8. #68  
    I'm getting these two bugs when I run Preware Alpha


    Update: Right after posting this, Preware Alpha loads fine. Thanks for looking though.
    Attached Images Attached Images
  9.    #69  
    Quote Originally Posted by gollyzila View Post
    I'm getting these two bugs when I run Preware Alpha

    Update: Right after posting this, Preware Alpha loads fine. Thanks for looking though.
    Thanks - that does expose an error case that is not handled properly. If all the feeds fail to download (due to a disconnected network or DNS resolver failure), the mv command returns an error. I think I'll replace that mv command with some C code.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10. #70  
    In process of trying to restore right now. Preware Alpha appears hung on trying to restore "Temp w/battery in Device menu" patch.

    How long should I let it sit on that cycle before simply closing out/restarting?
    --Steve

    Visor-->Treo 600-->Treo 650-->Treo 700P-->Treo 800W-->Palm Pre-->HP Touchpad

    My DVD Collection
    My Media Room
    GovTwit Directory
    Twitter: @dslunceford
  11. #71  
    OK, hang was because diff versions (I had orig. ipk version vs feed version saved). Would be nice if it runs into that type of restore error that it would skip over vs hang.

    The only other thing I noticed was that apps from Palm Beta and Palm Web feeds aren't saved (unless I screwed something up). Those aren't restored via the Palm Profile restore, so would be nice to have that option to include them in Saved Package List (especially when many are using the beta/web versions of FaceBook and FourSquare apps due to rapid release of changes).

    With those two nits, it looks like we are nearing a darn-near perfect backup/restore solution like the types we were used to on POS and WinMob Treos (though there would still be drag/drop/sorting of apps and pages).

    Thanks so much for this; cut my Doctor/restore time by more than half.
    --Steve

    Visor-->Treo 600-->Treo 650-->Treo 700P-->Treo 800W-->Palm Pre-->HP Touchpad

    My DVD Collection
    My Media Room
    GovTwit Directory
    Twitter: @dslunceford
  12. #72  
    works great excellent work everybody
    THE CHAMP IS HERE!!
  13. #73  
    I don't know if this fits here or not, but this is probably the first place it would get implemented, so sorry if this belongs somewhere else. Also, sorry if this has been requested before. I also looked on the Wiki, and did not find any place for feature requests.

    Is there a possibility of a on-device installation of .ipk, through preware? Currently the only way to install stuff stored on-device, is through command line (if one is not near a computer). Preware can already handle installation of .ipk through the feeds, is it possible to have preware be able to scan the devices storage to find .ipk, then have a option of installing them?

    Also, I have been using Preware Alpha, it has been working flawlessly for me. Great work.
    Last edited by fallen3712; 04/05/2010 at 04:56 PM.
    Shalom
  14. #74  
    Everything is working great, i have not had any hang up and it loads so much faster, great work. Just noticed though that when trying to install the update for geocaching homebrew it brings me to the precentral page instead of running the update.
    Thanks
  15. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #75  
    I came across a problem I'm having. If I delete package manager and Preware from my Pre, when I run Preware Alpha, it doesn't list the themes, patches, precentral feeds, etc. even if I go to feeds manager to enable them, they are not there. When I install package manager and Preware, they appear again. I was under the impression Alpha, runs without package manager. Am I mistaken? Thanks.
  16.    #76  
    Quote Originally Posted by PreGk View Post
    I came across a problem I'm having. If I delete package manager and Preware from my Pre, when I run Preware Alpha, it doesn't list the themes, patches, precentral feeds, etc. even if I go to feeds manager to enable them, they are not there. When I install package manager and Preware, they appear again. I was under the impression Alpha, runs without package manager. Am I mistaken? Thanks.
    You're not mistaken. Uninstalling the Package Manager Service deletes the feeds. If you reinstall Preware Alpha afterwards, they will return.

    I'll be updating the Package Manager Service so that it doesn't do that.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. 8phooka8's Avatar
    Posts
    13 Posts
    Global Posts
    16 Global Posts
    #77  
    Hats off to all who made this happen!

    I just finished installing and testing preware alpha in conjunction with save/restore. So far, everything has worked flawlessly for me.

    Extra thanks for all the work put into the clearly, well thought out, installation instructions and guides. From WOSQI to this.. It's awesome.

    Thank you
    Sprint|Palm Pre|1.4.1.1
  18.    #78  
    Quote Originally Posted by 8phooka8 View Post
    From WOSQI to this.. It's awesome.
    Just a note of clarification:

    WOSQI (an application from Canuck Software) is not related to Preware (a application from WebOS Internals) in any way other than both groups happen to collaborate in an open webOS homebrew ecosystem.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  19. 8phooka8's Avatar
    Posts
    13 Posts
    Global Posts
    16 Global Posts
    #79  
    Quote Originally Posted by rwhitby View Post
    Just a note of clarification:

    WOSQI (an application from Canuck Software) is not related to Preware (a application from WebOS Internals) in any way other than both groups happen to collaborate in an open webOS homebrew ecosystem.

    -- Rod
    Sorry, I'm aware of this. It seems the issue is a little sticky..

    I used wosqi to get here, so was just spreading the thanks.
    Sprint|Palm Pre|1.4.1.1
  20.    #80  
    Quote Originally Posted by 8phooka8 View Post
    Sorry, I'm aware of this. It seems the issue is a little sticky..

    I used wosqi to get here, so was just spreading the thanks.
    Oh, don't get me wrong, there's no animosity involved between the two groups (in fact I'm chatting with Jason in another window right now), but we both just want to keep the identity of the two groups separate.

    There's plenty of work (and corresponding thanks I guess) to go around for many different groups in an open homebrew ecosystem

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
Page 4 of 12 FirstFirst 123456789 ... LastLast

Tags for this Thread

Posting Permissions