Page 60 of 93 FirstFirst ... 1050555657585960616263646570 ... LastLast
Results 1,181 to 1,200 of 1848
Like Tree18Likes
  1. #1181  
    Sure. Attached below.

    So far I had only done ACAL.... I hadn't yet pulled the script posted above for ACSP into the Save Restore directory.

    Not sure if the file maintains it's executable permission status (but you probably know whether or not it does).
    Attached Files Attached Files
  2. #1182  
    Save/Restore 1.0.11 should be in the testing feed shortly (can take some time before it shows up). just a few updates here:

    - Updated the srf.app.directory script to fix an "override" prompt when restoring (as identified by djgardn2)
    - Added the following files to the /media/cryptofs/apps/usr/palm/applications/org.webosinternals.saverestore/contrib directory:
    1. com.palm.app.photos -- This will ZIP up all the files in your /media/internal/DCIM/100PALM directory. This directory contains all the photos you have taken with your Camera and all the videos from your camcorder. This can be used to create backups of these directories for uploading to a cloud-storage app while not near a computer. Note, if the directory your files are saved differs from 100PALM (e.g. 101PALM), you will need to edit the script. Also, this does NOT restore, just saves. This builds on a script that StoneRyno initially created
    2. sr-acal -- This is a simple executable to be able to initiate the script for the Advanced Config for App Launcher patch. Thanks to greenawayj for providing this. See the readme.txt file below on how to use this
    3. readme.txt -- This provides all the info on how to access and use these scripts. Here is a link to the file
    NOTE 1: Anyone interested in getting access to the testing feed, follow the instructions here: Testing Feeds - WebOS Internals ... Please be sure to add the "-all" testing feed and the feed the relates to your device (pre/pixi/emulator)

    NOTE 2: Don't see an app supported in Save/Restore? Request them here! Remember the bounty system that is referenced on the first post. For any paid applications, the "standard rate" is to offer 2x the value of the App.
    Last edited by Audemars02; 10/07/2010 at 08:44 PM.
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  3. #1183  
    Quote Originally Posted by greenawayj View Post
    Sure. Attached below.

    So far I had only done ACAL.... I hadn't yet pulled the script posted above for ACSP into the Save Restore directory.

    Not sure if the file maintains it's executable permission status (but you probably know whether or not it does).
    This is what I used for ACSP (sorry, don't know how to embed), but it didn't seem to work like for ACAL. Is this because my path is incorrect?

    sh -x /var/svc/org.webosinternals.saverestore/org.webosinternals.patches.advanced-configuration-for-system-preferences save

    Thanks...
  4. #1184  
    No, it's because you need to have the script I posted on the previous page in the /var/svc/org.webosinternals.saverestore/ directory and made executable. You can do it yourself or wait until Audemars adds it to S/R.

    Just changing the name of the command doesn't help. The script is what tells S/R which database keys to store.
  5. #1185  
    Reply to Audemars02

    Just to verify for you, the Nes script in post #1165 is in 100% working order now with the newest update. Feel free to add it anytime, no rush.

    Have a good one...
  6. #1186  
    Quote Originally Posted by tobias funke View Post
    No, it's because you need to have the script I posted on the previous page in the /var/svc/org.webosinternals.saverestore/ directory and made executable. You can do it yourself or wait until Audemars adds it to S/R.

    Just changing the name of the command doesn't help. The script is what tells S/R which database keys to store.
    oops...missed that script. I will add that in tomorrow, as well as the sr-acsp executable
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  7. #1187  
    Save/Restore 1.0.12 should be in the testing feed shortly (can take some time before it shows up). just a few updates here:

    - Application NesEm (courtesy of djgardn2)
    - Patch: Advanced Config for System Preferences (courtesy of tobias funke)',
    - Added executable sr-acsp to run Advanced Config for System Preferences to the /media/cryptofs/apps/usr/palm/applications/org.webosinternals.saverestore/contrib directory. See the readme file (link here) for details

    NOTE 1: Anyone interested in getting access to the testing feed, follow the instructions here: Testing Feeds - WebOS Internals ... Please be sure to add the "-all" testing feed and the feed the relates to your device (pre/pixi/emulator)

    NOTE 2: Don't see an app supported in Save/Restore? Request them here! Remember the bounty system that is referenced on the first post. For any paid applications, the "standard rate" is to offer 2x the value of the App.
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  8. #1188  
    Quote Originally Posted by Audemars02 View Post
    Save/Restore 1.0.12 should be in the testing feed shortly (can take some time before it shows up). just a few updates here:

    - Application NesEm (courtesy of djgardn2)
    - Patch: Advanced Config for System Preferences (courtesy of tobias funke)',
    - Added executable sr-acsp to run Advanced Config for System Preferences to the /media/cryptofs/apps/usr/palm/applications/org.webosinternals.saverestore/contrib directory. See the readme file (link here) for details

    NOTE 1: Anyone interested in getting access to the testing feed, follow the instructions here: Testing Feeds - WebOS Internals ... Please be sure to add the "-all" testing feed and the feed the relates to your device (pre/pixi/emulator)

    NOTE 2: Don't see an app supported in Save/Restore? Request them here! Remember the bounty system that is referenced on the first post. For any paid applications, the "standard rate" is to offer 2x the value of the App.
    Edit -- Shoot. I just looked and realized you've already put them there as part of the build. Sorry. I presumed these would be like the other 4 -- that if we are planning to use them, we move them ourselves to the save / restore scripts folder. Sorry for assuming you missed that. I should know by now that you're on top of your game.

    I was going do delete my post, but figured it might be helpful for others to know that the two scripts are pre-installed in the right place, it's just the executable / command line is needed to run them.

    ------

    Hey Adam. I think you might also want to put TobiasFunke's actual S/R scripts for ACAL ACCP into the next build's /contrib directory along with the sr-acal and sr-acsp executables... otherwise, the executables aren't of any value and ppl will have to go find the right scripts in this thread and manually get them to the /var/svc/org.webosinternals.saverestore directory?
    Last edited by greenawayj; 10/08/2010 at 09:10 AM.
  9. #1189  
    Quote Originally Posted by greenawayj View Post
    Edit -- Shoot. I just looked and realized you've already put them there as part of the build. Sorry. I presumed these would be like the other 4 -- that if we are planning to use them, we move them ourselves to the save / restore scripts folder. Sorry for assuming you missed that. I should know by now that you're on top of your game.

    I was going do delete my post, but figured it might be helpful for others to know that the two scripts are pre-installed in the right place, it's just the executable / command line is needed to run them.

    ------

    Hey Adam. I think you might also want to put TobiasFunke's actual S/R scripts for ACAL ACCP into the next build's /contrib directory along with the sr-acal and sr-acsp executables... otherwise, the executables aren't of any value and ppl will have to go find the right scripts in this thread and manually get them to the /var/svc/org.webosinternals.saverestore directory?
    HA! No worries... and I tend to miss things all the time (after all, i didn't even see the script for ACSP the first go-around)! either way, we can put the scripts for ACSP and ACAL in the scripts directory because they do not affect anything (unless u manually run the files, they are invisible). I only use the contrib directory for things that I do not want to automatically show up!
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  10. #1190  
    I have a new script to add to the collection. It is for my app FitTrack which is currently in beta.

    The tutorial was pretty easy to follow. I had some trouble when testing on the emulator. For some reason the Databases.db file was not with the cookies.db so it would not save that data. When I did the same thing on my device it worked fine.

    Thanks
    -Troy
    Attached Files Attached Files
  11. #1191  
    I see you added my script for putki to Save/Restore in the testing feeds.

    The new script I sended in has had the following source:
    Code:
    #!/bin/sh
    
    APPID=`basename $0`
    APPNAME="putki"
    
    source `dirname $0`/srf.app.info
    
    mkdir -p /media/internal/appdata/com.alphapolygon.putki/Saves
    
    SRCDIR="/media/internal/appdata/com.alphapolygon.putki/Saves"
    FILES="tunneli.sts"
    
    source `dirname $0`/srf.app.files
    
    exit 0
    That one in the testing feeds hasn't the mkdir-line:
    Code:
    #!/bin/sh
    
    APPID=`basename $0`
    APPNAME="putki"
    
    source `dirname $0`/srf.app.info
    
    SRCDIR="/media/internal/appdata/com.alphapolygon.putki/Saves"
    DSTSUB="Saves"
    FILES="tunneli.sts"
    
    source `dirname $0`/srf.app.files
    
    exit 0
    So restoring won't work if the directory "/media/internal/appdata/com.alphapolygon.putki/" doesn't exist (see attachment).
    Would be nice if you could fix this in the next version.
    Attached Images Attached Images
  12. #1192  
    Quote Originally Posted by rwhitby View Post
    Syntax error in your additional scripts. Post them for review.

    -- Rod
    Sorry for my late answer... I don't think that the problem is a syntax error.
    I have an error like this with all my own scripts, but on command line with info/save/restore parameters it works fine.
    This is the way how I do it:
    I send my script with WebOS Quick Install to "/var/svc/org.webosinternals.saverestore/".
    Then:
    Code:
    cd /var/svc/org.webosinternals.saverestore/
    chmod ugo+x ./com.example.myscript
    sh -x ./com.example.myscript info # output ends with "exit 0"
    Then I start the Save/Restore GUI and I get those error messages in "tail -f /var/log/messages" and not all scripts are shown in the GUI, my script isn't shown too.

    (Sorry for my bad English...)
  13.    #1193  
    Quote Originally Posted by pcworld View Post
    Sorry for my late answer... I don't think that the problem is a syntax error.
    I have an error like this with all my own scripts, but on command line with info/save/restore parameters it works fine.
    This is the way how I do it:
    I send my script with WebOS Quick Install to "/var/svc/org.webosinternals.saverestore/".
    Then:
    Code:
    cd /var/svc/org.webosinternals.saverestore/
    chmod ugo+x ./com.example.myscript
    sh -x ./com.example.myscript info # output ends with "exit 0"
    Then I start the Save/Restore GUI and I get those error messages in "tail -f /var/log/messages" and not all scripts are shown in the GUI, my script isn't shown too.

    (Sorry for my bad English...)
    Post your scripts for review.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  14. #1194  
    With the latest update it seems that some of the scripts are missing. I can go to /var/svc/org.webosinternals.saverestore on the Pre and it says 329 scripts are there but when I go to save a script some are missing( the ones I can't see now are messaging, launcher, Sconix's advance patches to name a few) I know you couldn't restore but it was there. I am trying to save my launcher configuration and that is not found. If I go to restore Sconix's advance patches are in the restore menu but how do I get them in the save menu? Am I missing something?
  15. #1195  
    Quote Originally Posted by mamouton View Post
    With the latest update it seems that some of the scripts are missing. I can go to /var/svc/org.webosinternals.saverestore on the Pre and it says 329 scripts are there but when I go to save a script some are missing( the ones I can't see now are messaging, launcher, Sconix's advance patches to name a few) I know you couldn't restore but it was there. I am trying to save my launcher configuration and that is not found. If I go to restore Sconix's advance patches are in the restore menu but how do I get them in the save menu? Am I missing something?
    Hmmm... a few things:
    1) Until the app gets updated to recognize installed patches, Sconix's patches will NOT show up in the SAVE screen. You need to manually run these scripts. However, once a backup is made, you will need that script on the restore page.
    2) not sure about the launcher or messaging app. I am running the latest version and i see launcher and Messaging app in there. Have you been adding scripts manually to the saverestore folder? You may have added a script that is not executable which can cause a hangup with recognizing all of the scripts in the app. You can try to remove the save/restore app, manually delete the var/svc/org.webosinternals/saverestore directory, and then reinstall save/restore and see if that fixes the problem. If it does, then don't forget to move any of my scripts from the /contrib directory or any manual scripts you might have added back to the main scripts directory.
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  16. #1196  
    Quote Originally Posted by pcworld View Post
    I see you added my script for putki to Save/Restore in the testing feeds.

    The new script I sended in has had the following source:

    So restoring won't work if the directory "/media/internal/appdata/com.alphapolygon.putki/" doesn't exist (see attachment).
    Would be nice if you could fix this in the next version.
    What version of Save/Restore are you using?

    In 1.1.10, I added a line to the srf.app.files line to:
    Code:
    [ -d "${SRCDIR}" ] || { mkdir ${SRCDIR} ; }
    in case the directory does not exist.. so not sure why the problem is happening... will look into it

    EDIT: Actually, i just realized that i do not add the "-p" option to the mkdir, and it looks like you are trying to create multiple levels of directories. let me fix that and i will push out an update shortly
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  17. #1197  
    Quote Originally Posted by Audemars02 View Post
    EDIT: Actually, i just realized that i do not add the "-p" option to the mkdir, and it looks like you are trying to create multiple levels of directories. let me fix that and i will push out an update shortly
    Thank you!

    Quote Originally Posted by rwhitby View Post
    Post your scripts for review.

    -- Rod
    See attachment (script for RadioTime).
    (Do not include this script yet!)

    Error message:
    Code:
    2010-10-12T15:20:55.868408Z [29280] ipod user.crit LunaSysMgr: {LunaSysMgrJS}: org.webosinternals.saverestore: Error: ERROR: native parser didn't like '{"scripts": [{ "id": "ca.canucksoftware.internalz", "title": "Internalz", "saved": true, "timestamp": "20101011T153646+0200" }, { "id": "ca.canucksoftware.ledtorch", "title": "LED Torch", "saved": false }, { "id": "ca.canucksoftware.presetreset", "title": "Preset Reset", "saved": false }, { "id": "ch.zorg.rnatau.stc", "title": "ShareTheCosts (STC)", "saved": false }, { "id": "com.10tons.app.sparkle", "title": "Sparkle", "saved": true, "timestamp": "20101011T153738+0200" }, { "id": "com.10tons.app.sparkle-lite", "title": "Sparkle Lite", "saved": false }, { "id": "com.185vfx.paratrooper", "title": "Paratrooper", "saved": true, "timestamp": "20100904T194700+0200" }, { "id": "com.8bitdevelopment.speeddiallite", "title": "Speed Dial Lite", "saved": false }, { "id": "com.8bitdevelopment.speeddialplus", "title": "Speed Dial Plus", "saved": false }, { "id": "com.8bitdevelopment.speeddialpro", "titl
    2010-10-12T15:20:55.908203Z [29280] ipod user.crit LunaSysMgr: {LunaSysMgrJS}: org.webosinternals.saverestore: Error: EXCEPTION [JSON.parse], (SyntaxError): "Unexpected token :", palmInitFramework347:2527
    Edit: Removed attachment
    Last edited by pcworld; 10/12/2010 at 01:11 PM.
  18. #1198  
    Quote Originally Posted by pcworld View Post
    Thank you!


    See attachment (script for RadioTime).
    (Do not include this script yet!)

    Error message:
    Code:
    2010-10-12T15:20:55.868408Z [29280] ipod user.crit LunaSysMgr: {LunaSysMgrJS}: org.webosinternals.saverestore: Error: ERROR: native parser didn't like '{"scripts": [{ "id": "ca.canucksoftware.internalz", "title": "Internalz", "saved": true, "timestamp": "20101011T153646+0200" }, { "id": "ca.canucksoftware.ledtorch", "title": "LED Torch", "saved": false }, { "id": "ca.canucksoftware.presetreset", "title": "Preset Reset", "saved": false }, { "id": "ch.zorg.rnatau.stc", "title": "ShareTheCosts (STC)", "saved": false }, { "id": "com.10tons.app.sparkle", "title": "Sparkle", "saved": true, "timestamp": "20101011T153738+0200" }, { "id": "com.10tons.app.sparkle-lite", "title": "Sparkle Lite", "saved": false }, { "id": "com.185vfx.paratrooper", "title": "Paratrooper", "saved": true, "timestamp": "20100904T194700+0200" }, { "id": "com.8bitdevelopment.speeddiallite", "title": "Speed Dial Lite", "saved": false }, { "id": "com.8bitdevelopment.speeddialplus", "title": "Speed Dial Plus", "saved": false }, { "id": "com.8bitdevelopment.speeddialpro", "titl
    2010-10-12T15:20:55.908203Z [29280] ipod user.crit LunaSysMgr: {LunaSysMgrJS}: org.webosinternals.saverestore: Error: EXCEPTION [JSON.parse], (SyntaxError): "Unexpected token :", palmInitFramework347:2527
    OK..i loaded your app onto the emulator and when i looked at the file in Internalz... take a look at the screenshot. it looks like there is an extra character or something at the beginning of the first line. once i deleted that, it seemed to work just fine. any idea how that happened?
    Attached Images Attached Images
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  19. #1199  
    Quote Originally Posted by Audemars02 View Post
    OK..i loaded your app onto the emulator and when i looked at the file in Internalz... take a look at the screenshot. it looks like there is an extra character or something at the beginning of the first line. once i deleted that, it seemed to work just fine. any idea how that happened?
    Thank you for your help!
    I noticed that you have to select "UTF-8 without BOM" in your editor. I downloaded Geany for Ubuntu which can do that. Notepad++ on Windows should be able to do that too.
  20. #1200  
    Attached below is the updated version of the ACSP script for the upcoming update. The only change is that it will now backup the new Unknown/Blocked contact prefs that are included in the update.

    I regret to inform you guys that Per Contact ringtone settings will only be able to be saved, because they're stored in the PalmDatabase.db3 file along with the contacts themselves. So soon I will post an updated script that saves this info to an .html file like Messaging/Memos, but that's the best we're going to get.

Tags for this Thread

Posting Permissions