Page 35 of 93 FirstFirst ... 2530313233343536373839404585 ... LastLast
Results 681 to 700 of 1848
Like Tree18Likes
  1. proudfrog's Avatar
    Posts
    43 Posts
    Global Posts
    63 Global Posts
    #681  
    I just replace my Pre and followed all the instructions to install Preware and Save/Restore. I copied back to the phone all the files I copied from my phone. When I try to restore the app data for Preware, the Restore Application Data shows empty yet I know the files exist because I transferred them!
  2. #682  
    Quote Originally Posted by pip smith View Post
    Apologise for my noobness but here it goes.

    If I copy the code you pasted to a notepad and rename srf.app.database. Will I need to run fromdos on this as I'm using windows?

    Then from commandline I need to type (Probably make a copy first)

    I will then need to send the new copy to

    And then I can test? Any steps I am missing?
    I would suggest the following:
    1) copy that text into notepad. Save it as "srf.app.database"
    2) run fromdos on it
    3) use webOS Quick Install, send file, and send to "/var/svc/org.webosinternals.saverestore/"

    You had written "svc.app.databases " but it should be "srf.app.databases "...also, i would use webOS QI and not command line for this, otherwise you have to also run the chmod command, too.. either way, webOS QI makes it easy
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  3. #683  
    Quote Originally Posted by rwhitby View Post
    The latest change to srf.app.databases will need some exhaustive testing to make sure it doesn't break anything.

    -- Rod
    I was going to create it with the OLD database file first, and then create a TESTING version once 1.0 went into production... sound good?
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  4. #684  
    Quote Originally Posted by Audemars02 View Post
    I would suggest the following:
    1) copy that text into notepad. Save it as "srf.app.database"
    2) run fromdos on it
    3) use webOS Quick Install, send file, and send to "/var/svc/org.webosinternals.saverestore/"

    You had written "svc.app.databases " but it should be "srf.app.databases "...also, i would use webOS QI and not command line for this, otherwise you have to also run the chmod command, too.. either way, webOS QI makes it easy
    Thanks. I was planning on using wosqi to send it, I just wasn't sure whether I should rm the original file first.

    And my bad, I had actually got it right on the notpad I saved to. Must have just been typing to quick on here.
  5. #685  
    Quote Originally Posted by proudfrog View Post
    I just replace my Pre and followed all the instructions to install Preware and Save/Restore. I copied back to the phone all the files I copied from my phone. When I try to restore the app data for Preware, the Restore Application Data shows empty yet I know the files exist because I transferred them!
    Checked your usb to see if there is a saverestore folder on there?
  6. proudfrog's Avatar
    Posts
    43 Posts
    Global Posts
    63 Global Posts
    #686  
    Quote Originally Posted by pip smith View Post
    Checked your usb to see if there is a saverestore folder on there?
    No there isnt. Should I create on and what should I call it?
  7. #687  
    Quote Originally Posted by proudfrog View Post
    No there isnt. Should I create on and what should I call it?
    This is the folder that you should have copied from your old pre to your new one. Did you copy your full usb from your old pre?
  8. zinvestor's Avatar
    Posts
    13 Posts
    Global Posts
    36 Global Posts
    #688  
    Quote Originally Posted by pip smith View Post
    How are you installing? You should install using Preware.
    What device have you got and what version of webOS are you running?
    Installing with preware, Palm Pre Plus from AT&T, WebOS 1.4.2

    Installed Apps, Kernels, Linux Apps, Patchs, Services and Themes

    preware
    uberkernel
    govnah
    internalz
    terminal
    pRingtones
    LED Torch
    GNU patch
    Lsdiff
    UnZip
    Zip
    4x4 icons v5
    Add Date - MM/DD
    Advanced Reset Options
    All Day Events in Month View
    Battery Percent and Icon White Red Teal
    Call Duration in Call Log
    Default to Week View
    Device Menu Megamix
    Dialpad Tones Off
    Enable Add/Delete Pages
    Enable Hidden Clock
    Faster Card Animations HYPER Version
    Gesture Tap for Info and Delete
    GPS Icon on Top Bar
    Hide Amazon MP3 App
    Hide Twitter Global Search
    Hide You Tube App
    Improved photo naming PRE
    Launch Mode Switcher on Luna Boot
    Launcher Auto Popup
    Match State to Area Code
    Named Pages in the Launcher
    No Auto Refresh After Idle
    No Auto-Off While Charging
    No Autodial from Call Log
    PDF Redux
    Phone No AutoClose
    Reduce Minimum Brightness
    Ringer Switch Icon
    Share Larger Videos Via Email
    Start in Fullscreen
    Unhide Dev Mode Icon
    unknown-notcontact-800-ringtone
    Unthrottle Download Manager
    Wrap Location Field
    File Mgr
    SysToolsMgr
    Glass Effect with 3D Icons Theme
  9. #689  
    Rod.
    Have done some quick testing on the new srf.app.databases. The scripts that I originally had seem to still work, I will further test this tomorrow.

    However when I try to run the My DataBank script I get this
    root@palm-webos-device: sh -x /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank save
    + basename /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank
    + APPID=com.dcapture.mydatabank
    + APPNAME=My DataBank
    + dirname /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank
    + source /var/svc/org.webosinternals.saverestore/srf.app.info
    + [ -n com.dcapture.mydatabank ]
    + [ -n My DataBank ]
    + : /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank
    + : /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank
    + : /media/internal/saverestore/com.dcapture.mydatabank
    + ZIP=/media/cryptofs/apps/usr/bin/zip -q
    + UNZIP=/media/cryptofs/apps/usr/bin/unzip -q
    + MOSTRECENT=
    + TIMESTAMP=
    + [ -d /media/internal/saverestore/com.dcapture.mydatabank ]
    + ls -1 /media/internal/saverestore/com.dcapture.mydatabank
    + egrep ^[0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9]T[0-9][0-9][0-9][0-9][0-9][0-9][+-][0-9][0-9][0-9][0-9].zip$
    + sort -n
    + tail -1
    + MOSTRECENT=
    + ls -1 /media/internal/saverestore/com.dcapture.mydatabank
    + [ -n ]
    + [ save == info ]
    + [ save == save ]
    + date +%Y%m%dT%H%M%S%z
    + TIMESTAMP=20100717T180150+0100
    + DSTDIR=/media/internal/saverestore/com.dcapture.mydatabank/20100717T180150+0100
    + echo 20100717T180150+0100
    20100717T180150+0100
    + dirname /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank
    + source /var/svc/org.webosinternals.saverestore/srf.app.databases
    + [ -n com.dcapture.mydatabank ]
    + [ -n /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank ]
    + [ -n /media/internal/saverestore/com.dcapture.mydatabank/20100717T180150+0100 ]
    + [ -d /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank ]
    + [ -f /var/home/root/html5-databases/Databases.db ]
    + DBSTORE=/var/palm/data
    + PALMDB=/var/palm/data/Databases.db
    + APPSTORE=/media/internal/.app-storage
    + sqlite3 /var/palm/data/Databases.db SELECT origin FROM Origins WHERE origin LIKE "%com.dcapture.mydatabank_0"
    + ORIGIN=file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0
    + [ -n file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0 ]
    + sqlite3 /var/palm/data/Databases.db SELECT name FROM Databases WHERE origin = "file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0"
    + DATABASES=My Data Bank
    + [ -n My Data Bank ]
    + [ save == save ]
    + mkdir -p /media/internal/saverestore/com.dcapture.mydatabank/20100717T180150+0100
    + IFS=
    I'm not sure what the IFS refers to or what is going wrong.
    This is what I had from the original srf.app.databases
    basename /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank
    + APPID=com.dcapture.mydatabank
    + APPNAME=My DataBank
    + dirname /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank
    + source /var/svc/org.webosinternals.saverestore/srf.app.info
    + [ -n com.dcapture.mydatabank ]
    + [ -n My DataBank ]
    + : /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank
    + : /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank
    + : /media/internal/saverestore/com.dcapture.mydatabank
    + ZIP=/media/cryptofs/apps/usr/bin/zip -q
    + UNZIP=/media/cryptofs/apps/usr/bin/unzip -q
    + MOSTRECENT=
    + TIMESTAMP=
    + [ -d /media/internal/saverestore/com.dcapture.mydatabank ]
    + ls -1 /media/internal/saverestore/com.dcapture.mydatabank
    + egrep ^[0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9]T[0-9][0-9][0-9][0-9][0-9][0-9][+-][0-9][0-9][0-9][0-9].zip$
    + sort -n
    + tail -1
    + MOSTRECENT=
    + ls -1 /media/internal/saverestore/com.dcapture.mydatabank
    + [ -n ]
    + [ save == info ]
    + [ save == save ]
    + date +%Y%m%dT%H%M%S%z
    + TIMESTAMP=20100710T000659+0100
    + DSTDIR=/media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100
    + echo20100710T000659+0100
    20100710T000659+0100
    + dirname /var/svc/org.webosinternals.saverestore/com.dcapture.mydatabank
    + source /var/svc/org.webosinternals.saverestore/srf.app.databases
    + [ -n com.dcapture.mydatabank ]
    + [ -n /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank ]
    + [ -n /media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100 ]
    + [ -d /media/cryptofs/apps/usr/palm/applications/com.dcapture.mydatabank ]
    + [ -f /var/home/root/html5-databases/Databases.db ]
    + DBSTORE=/var/palm/data
    + PALMDB=/var/palm/data/Databases.db
    + APPSTORE=/media/internal/.app-storage
    + sqlite3 /var/palm/data/Databases.db SELECT origin FROM Origins WHERE origin LIKE "%com.dcapture.mydatabank_0"
    + ORIGIN=file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0
    + [ -n file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0 ]
    + sqlite3 /var/palm/data/Databases.db SELECT name FROM Databases WHERE origin = "file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0"
    + DATABASES=My Data Bank
    + [ -n My Data Bank ]
    + [ save == save ]
    + mkdir -p /media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100
    + sqlite3 /var/palm/data/Databases.db SELECT path FROM Databases WHERE origin = "file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0" AND name = "My"
    + FILE=
    + expr My : ext:.*
    + LOC=/var/palm/data/file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0/
    + APPID=My
    + cp /var/palm/data/file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0/ /media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100/My
    cp: omitting directory '/var/palm/data/file_.media.cryptofs.apps.usr.palm.applications.com.dcapture.mydatabank_0'
    + cd /media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100
    + ls -1 My
    ls: My: No such file or directory
    + cd /media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100
    + /media/cryptofs/apps/usr/bin/zip -q /media/internal/saverestore/com.dcapture.mydatabank/20100710T000659+0100.zip My
    I will try to take a better look tomorrow as I'm cut for time tonight.
    Thanks
  10. #690  
    Im not sure if Im posting this in the right place so Im sorry if Im not. Is it possible to do a save/restore for games and such and then transfer those saved files to a new device? If I just copy the save/restore over to my comp can I put them back into the new Pre via usb? Im getting my Pre replaced on Monday (its already ordered) as my screen keeps giving out on me. Thanks.

    Melissa
  11. #691  
    Quote Originally Posted by haapala View Post
    Im not sure if Im posting this in the right place so Im sorry if Im not. Is it possible to do a save/restore for games and such and then transfer those saved files to a new device? If I just copy the save/restore over to my comp can I put them back into the new Pre via usb? Im getting my Pre replaced on Monday (its already ordered) as my screen keeps giving out on me. Thanks.

    Melissa
    First no this is not the right place best answers will be provided if you post in the save/restore thread. But I'm sure a mod will merge it anyway so don't worry.
    Anyway the answer to the actual question is yes. Quick instructions.
    0)Open Preware, go to saved package list and update said list.
    1) Make a save of all apps you want in save/restore on current phone.
    2) Put phone in usb mode and copy the folder "saverestore" to your pc.
    3)Get new phone
    4)Load palm profile and redownload all apps.
    5)Install Preware, then from Preware isntall save/restore.
    6)go to usb mode, copy save/restore folder to phone.
    7) Unplug phone, Open save/restore, just restore the preware data to restore.
    8) Open preware, go to saved package list, your list will be back. Check said list, swipe if you don't want anything, then hit instal all.
    9) After installing do a luna restart.
    10) systematically go through the apps that you are restoring data to and open and close them to create the databases.
    11) open save/restore and slect to restore the rest of your apps.
    12) Do a luna restart.

    For more info see the save/restore thread.

    Edit: I see that we got moved to the thread
    Last edited by pip smith; 07/17/2010 at 08:37 PM.
  12. #692  
    Here's an updated script for Guitar Hero 5. I realized I wasn't backing up hs.dat, which is a file used by other Glu Mobile games and backed up for them, so I figured I'd better back it up here, too.
    Attached Files Attached Files
  13. #693  
    Quote Originally Posted by Audemars02 View Post
    When you did the save, did you make sure that is said it successfully backed up your messages (and moved the switch from YES to NO)? sometimes it may say "database is locked" and can not make a copy. otherwise, it should be a zip file in your saverestore/com.palm.app.messaging folder
    No, it gives me a long text code which ends with zip:not found. What did I do wrong along the way?
  14. #694  
    Quote Originally Posted by jcren001 View Post
    No, it gives me a long text code which ends with zip:not found. What did I do wrong along the way?
    Is this when you run the save from the save/restore app? How did you install save/restore? Check that you have the dependency services: zip and unzip also installed.
  15. #695  
    Quote Originally Posted by pip smith View Post
    Is this when you run the save from the save/restore app? How did you install save/restore? Check that you have the dependency services: zip and unzip also installed.
    That worked! Thanks, I didn't see anywhere before that I needed those dependency services, now I installed them and have the back up, thanks!
  16.    #696  
    Quote Originally Posted by jcren001 View Post
    That worked! Thanks, I didn't see anywhere before that I needed those dependency services, now I installed them and have the back up, thanks!
    In future, you should stop using WebOS Quick Install for installing things until it supports dependencies. Use Preware, which automatically installs dependencies.

    -- Rod
  17.    #697  
    Quote Originally Posted by pip smith View Post
    Rod.
    Have done some quick testing on the new srf.app.databases. The scripts that I originally had seem to still work, I will further test this tomorrow.

    However when I try to run the My DataBank script I get this


    I'm not sure what the IFS refers to or what is going wrong.
    This is what I had from the original srf.app.databases


    I will try to take a better look tomorrow as I'm cut for time tonight.
    Thanks
    You've corrupted the file somewhere in the transfer. It does not end at the IFS line.

    -- Rod
  18. #698  
    Quote Originally Posted by rwhitby View Post
    You've corrupted the file somewhere in the transfer. It does not end at the IFS line.

    -- Rod
    Adam has emailed me the file with fromdos already run. I will test this now and report back.
  19. #699  
    **EDIT** I'm sorry. I ended up finding the solution to this problem. Thanks anyways.

    I've had to DR my pre 3 times in the past week and I've followed the steps word for word in this link.

    After each dr i could only get to step 6 before having to stop. When I try to restore Preware, it says Archive not restored b/c the DB cannot be found.

    I've looked everywhere, and I don't know what to do.

    I'm about to have to trade my Pre in, therefore I'd like to be able to utilize this app.

    As of right now it's completely useless to me.
    Last edited by loopybandnerd; 07/17/2010 at 11:17 PM. Reason: answered own question
  20. #700  
    Quote Originally Posted by loopybandnerd View Post
    **EDIT** I'm sorry. I ended up finding the solution to this problem. Thanks anyways.

    I've had to DR my pre 3 times in the past week and I've followed the steps word for word in this link.

    After each dr i could only get to step 6 before having to stop. When I try to restore Preware, it says Archive not restored b/c the DB cannot be found.

    I've looked everywhere, and I don't know what to do.

    I'm about to have to trade my Pre in, therefore I'd like to be able to utilize this app.

    As of right now it's completely useless to me.
    OK..i think I need to update that article. try this and let me know if this works.. Between steps 4 and 5 (i.e. after you load Preware on your phone, but BEFORE you copy your saverestore directory back to your phone), go into Preware, go to Saved Package List, and hit "Update". You may just need to create the database one time before you can restore it. let me know if that helps, and I will update the article.

    ** Just notice you had the big "I ended up finding the solution to this problem. "... if i may ask, what was the problem?
    -Adam
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:

Tags for this Thread

Posting Permissions