webOS Nation Forums >  Homebrew >  WebOS Internals > VisualBoyAdvance
VisualBoyAdvance
  Reply
Like Tree12Likes

 
Thread Tools Display Modes
Old 12/12/2012, 03:39 AM   #1121 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by grazzt View Post
Im not the 'programmer' of the app, Im just the one that took it and compiled it, so any emulator problems, like certain games not functioning properly is not really something I can help with.

Although, the emulator does support save states does it not? Can you not just use them instead of using the battery backup the rom expects?
Hey, the domain is in limbo as of late. Could you send me the ipk for the touchpad?
therotarius is offline   Reply With Quote
Old 02/10/2013, 09:39 AM   #1122 (permalink)
Member
 
Posts: 3
Quote:
Originally Posted by therotarius View Post
Hey, the domain is in limbo as of late. Could you send me the ipk for the touchpad?
Yeah, that domain is dead. Can we get a reupload of the Touchpad IPK?

I've got it working on my Touchpad currently but at the Pre 2 resolution. Would be nice if I could have it at full 1024x768 resolution. I also made a skin that includes a turbo button but you have to hold your finger on it to keep the turbo on. Is it possible to turn the turbo button in the apps code into a switch when using the onscreen skin rather than the keyboard?
ZeroInfiniti is offline   Reply With Quote
Old 06/30/2013, 04:00 PM   #1123 (permalink)
Member
 
PixiPlus's Avatar
 
Posts: 2
I can't find VBA on Preware. I'm using a Palm Pixi Plus. Can anyone help?
PixiPlus is offline   Reply With Quote
Old 02/28/2014, 04:29 AM   #1124 (permalink)
Member
 
mrgconflict's Avatar
 
Posts: 2
Pre 3 (webOS 2.2.4) user here, thought I'd document my experience thus far in getting VBA to work.
  1. The App Catalog (as accessed through a browser) claims to have version 1.3.4 up for $5, but whatever official feeds my Pre 3 seem to be pulling from only list v1.3.1 at what appears to be an old sale price of $2.99. Not sure why that is.
  2. So, I went looking for the latest version in Preware, but couldn't find it until I disabled the device compatibility check in Preware's preferences. After doing that, v1.3.4 became visible, so I went ahead and installed it (what's the worst that can happen, right? ) Launching it, however, was a no-go: The app lights up for a bit, then nothing.
  3. Out of curiosity, I tried to launch it from Xecutah/XTerm:

    cd /media/cryptofs/apps/usr/palm/applications/org.webosinternals.visualboyadvance
    ./vba &
    ./vba: error while loading shared libraries: libsrv_um.so: cannot open shared object file: No such file or directory.

    Well, crud. The libraries must have changed between the Pre Plus (my old phone) and the Pre 3...
  4. Found references to grazzt's website at grazzt.ca (archived) , but unfortunately none of the IPKs were archived and all references appear to be long dead.
  5. Went snooping and found http://8.22.203.194/ , also dead.
  6. Found mrxff's recompiled version for the Pre 3, albeit it's not packaged. Downloaded it, extracted it (creating a binary called VisualBoyAdvance), copied it to the USB drive, and then did the following via novacom/novaterm:

    cd /media/cryptofs/apps/usr/palm/applications/org.webosinternals.visualboyadvance
    mv vba vba.bak
    mv /media/internal/VisualBoyAdvance ./vba
  7. Tried running it again from the Launcher. Lo and behold, it works!

I may try my hand at repackaging the app with mrxff's recompiled binary so it's easier to install. Once done, I'll probably post it here. But for now, that should be enough information to get anyone with a Pre 3 who still wants it after all this time up and running again.
mrgconflict is offline   Reply With Quote
Old 07/30/2014, 08:38 AM   #1125 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by mrgconflict View Post
Pre 3 (webOS 2.2.4) user here, thought I'd document my experience thus far in getting VBA to work.
  1. The App Catalog (as accessed through a browser) claims to have version 1.3.4 up for $5, but whatever official feeds my Pre 3 seem to be pulling from only list v1.3.1 at what appears to be an old sale price of $2.99. Not sure why that is.
  2. So, I went looking for the latest version in Preware, but couldn't find it until I disabled the device compatibility check in Preware's preferences. After doing that, v1.3.4 became visible, so I went ahead and installed it (what's the worst that can happen, right? ) Launching it, however, was a no-go: The app lights up for a bit, then nothing.
  3. Out of curiosity, I tried to launch it from Xecutah/XTerm:

    cd /media/cryptofs/apps/usr/palm/applications/org.webosinternals.visualboyadvance
    ./vba &
    ./vba: error while loading shared libraries: libsrv_um.so: cannot open shared object file: No such file or directory.

    Well, crud. The libraries must have changed between the Pre Plus (my old phone) and the Pre 3...
  4. Found references to grazzt's website at grazzt.ca (archived) , but unfortunately none of the IPKs were archived and all references appear to be long dead.
  5. Went snooping and found http://8.22.203.194/ , also dead.
  6. Found mrxff's recompiled version for the Pre 3, albeit it's not packaged. Downloaded it, extracted it (creating a binary called VisualBoyAdvance), copied it to the USB drive, and then did the following via novacom/novaterm:

    cd /media/cryptofs/apps/usr/palm/applications/org.webosinternals.visualboyadvance
    mv vba vba.bak
    mv /media/internal/VisualBoyAdvance ./vba
  7. Tried running it again from the Launcher. Lo and behold, it works!

I may try my hand at repackaging the app with mrxff's recompiled binary so it's easier to install. Once done, I'll probably post it here. But for now, that should be enough information to get anyone with a Pre 3 who still wants it after all this time up and running again.
Great!

That works on my Pre3, but there is no skins.... so i can't play in landscape.

Skins are in the folders cd /media/cryptofs/apps/usr/palm/applications/org.webosinternals.visualboyadvance/skins, but in Menu of the vba there is: skins(0).

Do you know how skins can works on Pre3?

Thanks you!

Last edited by seth2christ; 08/01/2014 at 07:06 AM.
seth2christ is offline   Reply With Quote
Reply

 

Tags
dtzwill, games

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0