Page 22 of 23 FirstFirst ... 1217181920212223 LastLast
Results 421 to 440 of 451
  1. #421  
    it depends on what maps you are using. for whtever reason I cannot get the Navit planet extractor to work so I use the cloudmate maps which are state by state. The Navit app will only recognize one map at a time so I connected my Pre to my computer in USB mode and made an additional folder called "unused maps" and put the maps of surrounding states in the file. I then loaded the homebrew app 'internalz' which is a great file management app from Jason Robitalle. from the internalz app I can move the map programs back and forth at will. This sounds like a pain, but since the nav portion of Navit app works the way it does, if you are traveling from state to state, I would just use one map at a time and then switch at teh state line. If you can get the Navit planet extractor to work, you can extract a map of the entire eastern state reagon and install it and it would eb waaay more convenient.
  2. #422  
    on the newest version with the latest skin ive found my volume has dropped quiet again, anyone help me out how to adjust this?

    thanks
  3. #423  
    There is now a french wiki page for Navit with several screenshots in french:
    Application:Navit-FR - WebOS Internals
  4. #424  
    Is there any way to use the Maps from Google Maps in Navit?
    Nokia 1100 - Alcatel OT156A - Motorola C650 - Motorola v220i - Motorola V555 - The Great Motorola V360 - The Amazing Treo 650 - Treo 750 - Original Palm Pre (1.4.5) - Palm Pre2 (2.1) + Touchpad.
  5. #425  
    Quote Originally Posted by thenyboy View Post
    Is there any way to use the Maps from Google Maps in Navit?
    No its not possible apparently, I cant remember the deatails exactly but its been brought up before and cant be done
  6. #426  
    Is it posible to remove navit on an other way then preware?
    It seems like preware doesn't detect my navit installation( plus a bunch of others also)
    It doesn't navit in unknown :s
  7. #427  
    not sure, my Preware has it in the unknown section.
  8. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #428  
    Quote Originally Posted by yelti View Post
    Is it posible to remove navit on an other way then preware?
    It seems like preware doesn't detect my navit installation( plus a bunch of others also)
    It doesn't navit in unknown :s
    The current version of Navit and Espeak can also be removed like any other Pre application. Only the langugae pack, if you installed one, can only be removed via Preware. Check the Unknown section. There it should be.

    HaPe
  9. #429  
    Is there any way of adding postcode and address searches to the way you find destinations/watpoints for this version of navit?
    Just the problem is sometimes it is quite difficult to find the place you want to be, if you get what I am saying.
    (gotta say this is a cool app port)
  10. #430  
    Quote Originally Posted by boesler View Post
    I love the idea of navit on my pre, but somehow
    webos quick install just won´t let me install it.

    I installed other homebrew things before and it worked.

    I download the ipk´s for espeak , navit and local_de

    It get the message

    Cannot find package org.webosinterals.espeak.
    Cannot find package org.webosinterals.locale.
    Cannot find package org.webosinterals.navit.

    Check spelling or run ´ipkg update´ is added each time

    Could you please lead me to a solution :-)

    best regards

    Joerg Boesler
    Hi, did you get any answers to this? I am having the same problem.

    Thanks
  11. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #431  
    Hi all,

    good and bad news.

    Navit can run without the additional libs in webos 1.4.5 . This mean we can start to get it into Preware.
    The bad news is that we need to make some changes to get it working wiht the changed way that webos 1.4.5 handle PDK apps.

    The packages in this tread only works with webos < 1.4.5

    HaPe
  12. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #432  
    Hi all,

    on trick I found while playining with OSM and M&G maps.

    If you have the m&g and the OSM maps on your USB drive then you can use the street index from the m&g maps for searching and the OSM maps for routing and display. To do this you need to add the mapset this way:
    Code:
     <mapset enabled="yes">
         <map type="mg" enabled="yes" active="no" data="/media/internal/MapsNavit/dem.map/smp3.smp" />
         <map type="mg" enabled="yes" active="no" data="/media/internal/MapsNavit/dem.map" />
         <map type="binfile" enabled="yes" active="yes" data="/media/internal/MapsNavit/osm/*.bin"/>
     </mapset>
    It looks like Navit uses the street index of the first enabled map even if it is not active.

    Wiki is update => Application:Navit - WebOS Internals

    HaPe
  13. #433  
    Quote Originally Posted by muhgatus View Post
    Now find the hfsplus header:

    Code:
    hexdump -C Palm-PDK.img | egrep "48 +2b +00 +04"
    00005bc0  00 00 00 00 00 00 48 2b  00 04 00 00 01 00 31 30  |......H+......10|
    This may fail in future versions of the PDK. If you want to include it into your Makefile, you may use perl/python to find the occourance of this string.
    For 1.4.5 it is:

    Code:
    00005210: 0000 0000 0000 0000 0000 0000 0048 2b00  .............H+.
    00005220: 0400 0001 0031 302e 3000 0000 00c8 3ee8  .....10.0.....>.
    I have added a packages/host/dmg2img/Makefile to cross-compile.git, and I have added a -p option to dmg2img to start at a particular partition.

    If you tell dmg2img to start at partition 4, then the HFS file is output. No offset needed.

    Note that cross-compile.git now unpacks the packages/common/libpdl automatically.

    And libgarmin, espeak and navit have been moved from packages/nonworking/... to packages/apps/...

    -- Rod
    Last edited by rwhitby; 07/02/2010 at 09:45 AM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  14. #434  
    Just to let you guys know, there seems to be a problem with the update to 1.4.5 which fails to update some important data. That is why navit crashes on 1.4.5. To get it working you either have to manually update the file (only for those who know what the do) or doctor their pre.
    For more information, look here:
    Forums webOS &bull; View topic - 1.4.5 Jail Settings and OTA Updates

    Besides all that neither localization (i.e. languages other than english) nor speech are working currently.

    /Malte
  15. PreRunr's Avatar
    Posts
    344 Posts
    Global Posts
    345 Global Posts
    #435  
    Can you clarify? I reinstalled the current NAVIT (Used to work OK) after a webosdoctor install of 1.4.5 and it "runs". GSM Pre from O2 imported to Australia. I pressed on the espeak icon in launcher and no sound occurred. Once inside NAVIT I selected a destination and looked at the Route Description and it was there, but of course no sound. All of my bookmarks were as before the 1.4.5 install.
  16. #436  
    Quote Originally Posted by PreRunr View Post
    Can you clarify? I reinstalled the current NAVIT (Used to work OK) after a webosdoctor install of 1.4.5 and it "runs". GSM Pre from O2 imported to Australia. I pressed on the espeak icon in launcher and no sound occurred. Once inside NAVIT I selected a destination and looked at the Route Description and it was there, but of course no sound. All of my bookmarks were as before the 1.4.5 install.
    OTA update to 1.4.5 and doctor to 1.4.5 end up with different values in /etc/fstab for /media/internal - an error confirmed by Palm (you should follow @webosinternals on twitter, where this was reported).

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. PreRunr's Avatar
    Posts
    344 Posts
    Global Posts
    345 Global Posts
    #437  
    I have no error in /fstab as I did not use the OTA upgrade. Thus I interpret the phone behaviour as "saying" NAVIT is OK but espeak needs fixing. Thus prioritizing what to fix up for 1.4.5 version. I did look at your twitter before my post.
  18. #438  
    Quote Originally Posted by noradtux View Post
    Just to let you guys know, there seems to be a problem with the update to 1.4.5 which fails to update some important data. That is why navit crashes on 1.4.5. To get it working you either have to manually update the file (only for those who know what the do) or doctor their pre.
    For more information, look here:
    Forums webOS &bull; View topic - 1.4.5 Jail Settings and OTA Updates

    Besides all that neither localization (i.e. languages other than english) nor speech are working currently.

    /Malte
    There may be a cheeky work-around for the access to espeak problem:

    Code:
    echo "pardon" > /etc/nojail
    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  19. #439  
    I ... admit ... I have not finished reading the entire thread but I am thrilled to see this port in progress. Additionally ... I haven't the foggiest how to go about installing it. If there is an applicable thread please link me to it ... otherwise any help is welcome. (p.s. talk to me like i'm 4)
  20. #440  
    I have a Verizon Pre+.
    Should I uninstall Navit before I get the 1.4.5 update?

Posting Permissions