Page 21 of 23 FirstFirst ... 111617181920212223 LastLast
Results 401 to 420 of 451
  1. #401  
    I had to Dr. my pre yesterday and now I cannot get the locale ipk to install. The navit and espeak ones install fine, but I get this message upon attempt to install the locale:
    Error: An error occured while attempting to run /tmp/ipkgScript.sh

    ApplicationPath=/usr/lib/luna/applications:/var/luna/applications:var/usr/lib/luna/applications:/usr/palm/applications:/var/usr/Palm/applications:/media/cryptofs/apps/usr/palm/applications
    In:/usr/lib/locale: Operation not permitted

    Any help or ideas? I had this working great before I had to Dr. and am really wanting it back.

    On an aditional note, when I pull up Navit, the maps display correctly, and when I click on tools>show locale, it reads:
    lang=eng_us.utf-8 (not sure what that means. Thanks again!
    Last edited by jakelaw; 06/13/2010 at 10:23 PM.
  2. richof's Avatar
    Posts
    12 Posts
    Global Posts
    16 Global Posts
    #402  
    No maps! I am sure I am missing something simple here. Installed Navit, no problem. Launchs OK. Speech tests OK. GPS finds me on the Actions screen. No maps showing. I downloaded a map for my region. Edited navit.xml for my map name. What am I missing?
  3. #403  
    Quote Originally Posted by richof View Post
    No maps! I am sure I am missing something simple here. Installed Navit, no problem. Launchs OK. Speech tests OK. GPS finds me on the Actions screen. No maps showing. I downloaded a map for my region. Edited navit.xml for my map name. What am I missing?
    From the Op's instructional post on page 7 of this thred:
    "You also need a map. Go to Navit :: Planet Extractor and create one of the part of the world you need or look for created maps here => OpenStreetMap - Navit's Wiki Connect your Pre in USB mode, create a folder named MapsNavit and put the *.bin file into it."

    My emphasis added because I had the same problem you did. The .bin file is the map file. I just conected the Pre in USB mode to my PC and made the new folder (I used the cloudmate maps) the dragged the map and dropped it to the folder. If you live in the US, one of the things I did is created another folder I titled 'unused maps' and put maps for the surounding states to where I live in it. Then with teh 'Internalz' utility, I can access the maps folder and the unused folder and when I cross state lines, just get in and swap the files for the states and instantly have a new map. The main reason I have to do this is for some reason my laptop will not pull up the maps on Navit's "planet extractor" So far I love Navit. It allows me to get turn by turn directions without the need of a data or even a cell connection, just the GPS.
  4. richof's Avatar
    Posts
    12 Posts
    Global Posts
    16 Global Posts
    #404  
    Quote Originally Posted by jakelaw View Post
    From the Op's instructional post on page 7 of this thred:
    "You also need a map. Go to Navit :: Planet Extractor and create one of the part of the world you need or look for created maps here => OpenStreetMap - Navit's Wiki Connect your Pre in USB mode, create a folder named MapsNavit and put the *.bin file into it."

    My emphasis added because I had the same problem you did. The .bin file is the map file. I just conected the Pre in USB mode to my PC and made the new folder (I used the cloudmate maps) the dragged the map and dropped it to the folder. If you live in the US, one of the things I did is created another folder I titled 'unused maps' and put maps for the surounding states to where I live in it. Then with teh 'Internalz' utility, I can access the maps folder and the unused folder and when I cross state lines, just get in and swap the files for the states and instantly have a new map. The main reason I have to do this is for some reason my laptop will not pull up the maps on Navit's "planet extractor" So far I love Navit. It allows me to get turn by turn directions without the need of a data or even a cell connection, just the GPS.
    I understand. I have done this and still no maps. You make no mention of the navit.xml file. Did you edit this to reflect your map name? I wonder if I messed up the xml config file.
  5. richof's Avatar
    Posts
    12 Posts
    Global Posts
    16 Global Posts
    #405  
    Got it! Had the map 1 level too deep. All set.
  6. TimBoch's Avatar
    Posts
    312 Posts
    Global Posts
    318 Global Posts
    #406  
    Quote Originally Posted by jakelaw View Post
    I had to Dr. my pre yesterday and now I cannot get the locale ipk to install. The navit and espeak ones install fine, but I get this message upon attempt to install the locale:
    Error: An error occured while attempting to run /tmp/ipkgScript.sh

    ApplicationPath=/usr/lib/luna/applications:/var/luna/applications:var/usr/lib/luna/applications:/usr/palm/applications:/var/usr/Palm/applications:/media/cryptofs/apps/usr/palm/applications
    In:/usr/lib/locale: Operation not permitted

    Any help or ideas? I had this working great before I had to Dr. and am really wanting it back.

    On an aditional note, when I pull up Navit, the maps display correctly, and when I click on tools>show locale, it reads:
    lang=eng_us.utf-8 (not sure what that means. Thanks again!
    I get this same error when I try to install any locale file.
  7. #407  
    you have to remove a sym-link to the locale folder manually before installing the new locale.
    i saw it somewhere around page 5 i think.
  8. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #408  
    Quote Originally Posted by jakelaw View Post
    I had to Dr. my pre yesterday and now I cannot get the locale ipk to install. The navit and espeak ones install fine, but I get this message upon attempt to install the locale:
    Error: An error occured while attempting to run /tmp/ipkgScript.sh

    ApplicationPath=/usr/lib/luna/applications:/var/luna/applications:var/usr/lib/luna/applications:/usr/palm/applications:/var/usr/Palm/applications:/media/cryptofs/apps/usr/palm/applications
    In:/usr/lib/locale: Operation not permitted

    Any help or ideas? I had this working great before I had to Dr. and am really wanting it back.

    On an aditional note, when I pull up Navit, the maps display correctly, and when I click on tools>show locale, it reads:
    lang=eng_us.utf-8 (not sure what that means. Thanks again!
    I added the information and how to get the Maps&Guid maps to the wiki:
    Application:Navit - WebOS Internals
    By the way you do not need an local ipk if you use the English UI. It is only needed to get a non English UI and speak output.

    Are you sure that you locale if say 'lang=eng_us.utf-8' ? I would expect 'lang=en_us.utf-8'. Can you please check this. Thanks.

    HaPe
  9. #409  
    Quote Originally Posted by HaPe View Post
    I added the information and how to get the Maps&Guid maps to the wiki:
    Application:Navit - WebOS Internals
    By the way you do not need an local ipk if you use the English UI. It is only needed to get a non English UI and speak output.

    Are you sure that you locale if say 'lang=eng_us.utf-8' ? I would expect 'lang=en_us.utf-8'. Can you please check this. Thanks.

    HaPe
    you are correct, it says 'lang=en_us.utf-8' so I do not need a locale file since I am using english. And to richof, I am not aware of any alterations we need to make to the navot.xml file. But looks like it is runnign good, and I am really liking the new skin. I just wish the response to the accelerometer was better when I turn it. That is not a huge deal though. Thansk to all teh folks working on this. Is there a place to donate yet?
  10. #410  
    I'm using mobile atlas creator to creat offline map from google map which is better than maps from Navit :: Planet Extractor, because i lived in china and the chinese charactors cannot be displayed in the navit map.
    so my question is, which format of output map should I choose?
    have anyone tried? thxs.
    the choice of format including:Create offline atlases for a large number of different (mobile) applications and GPS handhelds:

    * TrekBuddy (J2ME, Android)
    * AndNav (Android)
    * RMaps SQLite format (Android)
    * BigPlanetTW SQLite format (Android)
    * Mobile Trail Explorer (J2ME) - single tiles and MTECache file
    * Maverick (Android)
    * OSMtracker (Windows Mobile/Pocket PC)
    * Glopus (Pocket PC)
    * CacheBox (Windows Mobile)
    * Magellan RMP (GPS handhelds) & VantagePoint
    * Garmin Custom Map - KMZ (GPS handhelds)
    * Touratech QV (Windows software, commercial)
    * OziExplorer (single 24bit PNG image with calibration (MAP) file

    thxs
  11. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #411  
    Quote Originally Posted by gangglion View Post
    I'm using mobile atlas creator to creat offline map from google map which is better than maps from Navit :: Planet Extractor, because i lived in china and the chinese charactors cannot be displayed in the navit map.
    so my question is, which format of output map should I choose?
    have anyone tried? thxs.
    the choice of format including:Create offline atlases for a large number of different (mobile) applications and GPS handhelds:

    * TrekBuddy (J2ME, Android)
    * AndNav (Android)
    * RMaps SQLite format (Android)
    * BigPlanetTW SQLite format (Android)
    * Mobile Trail Explorer (J2ME) - single tiles and MTECache file
    * Maverick (Android)
    * OSMtracker (Windows Mobile/Pocket PC)
    * Glopus (Pocket PC)
    * CacheBox (Windows Mobile)
    * Magellan RMP (GPS handhelds) & VantagePoint
    * Garmin Custom Map - KMZ (GPS handhelds)
    * Touratech QV (Windows software, commercial)
    * OziExplorer (single 24bit PNG image with calibration (MAP) file

    thxs
    Navit has it's own Map format. Not sure if this can be created by the program:
    Navit's binary map driver - Navit's Wiki
    Map driver - Navit's Wiki

    HaPe
  12. #412  
    So,
    from the he_IL locale I am guessing that somewhere, someone, is working on hebrew support. Anyone has any info on this?

    Quote Originally Posted by urig View Post
    Hey...
    Thanks for the quick response.
    Looking at the Navit wiki Interactive help - Navit's Wiki , it claims to use Liberation and than Arial.
    Well, i installed a hebrew font as LiberationSerief-Normal.ttf, no go.

    Any suggestions would be REALLY appreciated.

    Also: I noticed a new he_IL locale in the latest package. what would that do?
  13. #413  
    Quote Originally Posted by urig View Post
    So,
    from the he_IL locale I am guessing that somewhere, someone, is working on hebrew support. Anyone has any info on this?
    Hi Uri,

    I tried to add hebrew support with the great help of HaPe.
    I was able to load the hebrew locale, update the xml file and the navit.sh script to export the hebrew locale and the application even showed that it was using the hebrew locale but without any luck.

    instead of hebrew all I got was [][] squares.

    let me know if you have other ideas...
  14. #414  
    Quote Originally Posted by palmpreacher View Post
    Hi Uri,

    I tried to add hebrew support with the great help of HaPe.
    I was able to load the hebrew locale, update the xml file and the navit.sh script to export the hebrew locale and the application even showed that it was using the hebrew locale but without any luck.

    instead of hebrew all I got was [][] squares.

    let me know if you have other ideas...
    Possibly, this is a problem with the map and not the program. There is a Chinese person complaining about what sounds like a similar issue.
    http://forums.precentral.net/webos-i...ml#post2508492

    If we could properly export the maps...
  15. #415  
    Has the volume been turned down on the latest release? Used it last night and it seemed very quiet.
  16. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #416  
    Quote Originally Posted by urig View Post
    Possibly, this is a problem with the map and not the program. There is a Chinese person complaining about what sounds like a similar issue.
    http://forums.precentral.net/webos-i...ml#post2508492

    If we could properly export the maps...
    as said before it is neither a Navit nor a map problem. It is a font problem.
    The font that is selected in the navit.xml do not contain the characters for that language you want to display.
    The only one how can fiy this are persons from that country. There are two possibilities to do that:
    1) select a other font in the navit.xml that contains the characters (I expect you have to try all fonts installed in the Pre to check for a working one)
    2) install a new font the contains the characters and select this in the navit.xml

    HaPe
  17. #417  
    Quote Originally Posted by HaPe View Post
    as said before it is neither a Navit nor a map problem. It is a font problem.

    1) select a other font in the navit.xml that contains the characters (I expect you have to try all fonts installed in the Pre to check for a working one)
    2) install a new font the contains the characters and select this in the navit.xml

    HaPe
    How does one "select a font in navit.xml?" I could not find the relevant setting.
  18. #418  
    I see others are having success with Navit.

    I can get the app running (with the new skin) with the blue dot indicating my location, but it locks up in 10-15 seconds.

    Any troubleshooting tips?
  19. #419  
    None here, maybe HaPe will pipe up. It works great for me. I would make sure the GPS is on and the "use GPS" option is selected not the "use Google services."
  20. #420  
    Quote Originally Posted by jakelaw View Post
    None here, maybe HaPe will pipe up. It works great for me. I would make sure the GPS is on and the "use GPS" option is selected not the "use Google services."
    Those are the settings I have.

    Navit does locate me and move the map as I travel, however it locks up after 10-15 seconds.

    Another question: I'm in New York State, so I loaded the NYS map. If I planned to travel to Florida, how would I load the maps into Navit so I could travel continuously from NY to FL? Is there an entire USA map?

Posting Permissions