Results 1 to 11 of 11
  1.    #1  
    Over the last several days, the battery life on my Pre has been ridiculously bad. According to Battery Monitor I was seeing 20% drain per hour while idle! Normally I see only 3% drain per hour while idle.

    And, in my case, it didn't matter if wifi was on or off. I was still seeing terrible battery performance. So I did an online chat w/Palm and they suggested that the problem is related to homebrew applications that are behaving badly w/1.3.5.x. So, last night I doctored my phone and so far today it appears that palm was right. I have no homebrew on my phone and my battery is still on 100% after having been mostly idle for an hour. Unfortunately, because I have no homebrew, I also don't have Battery Monitor installed to tell me my actual battery performance.

    My question is this: what do you think the likely culprit is?

    Here are some of the things that I had installed:
    • App: Battery Monitor
    • App: Quake
    • App: Keyring
    • App: myFlashlight
    • App: Presteroids
    • App: JsTop
    • App: Preware
    • App: Luna Manager
    • Theme: Buuf
    • Patch: 4x4 v3
    • Patch: Show download counts in app catalog
    • Patch: Show character count in messaging
    • Patch: Clean timestamps in messaging
    • Patch: Confirm delete in email
    • Patch: MM/DD on top bar
    • Patch: Battery as % on top bar
    • Patch: Roam Control in Phone
    • Patch: Call History during call in Phone
    • Patch: Call duration in call log in Phone
    • Patch: Match state to area code in Phone
    • Patch: Close slider to end calls except headset in Phone
    • Patch: Dialpad vibration in Phone
    • Patch: Unthrottle download manager

    My guess is Quake because JsTop frequently showed it running long after I'd quit it.

    Thoughts?
    Twitter: dullgeek
  2. #2  
    Dont confuse Homebrew (Apps) with Patches. Two very different things. Apps can not cause poor battery performance unless they are running and are CPU intensive. 3d apps like Quake are definitely CPU intensive.

    Patches on the other hand can cause battery drain because they change the operating system and can effect the system at all times. Patches are basically hacks. They should be well researched, then used carefully and sparingly.
    Pilot 1000 -> Pilot 5000 ->Palm Pilot Professional -> HP 620LX -> TRG Pro -> Palm V -> Palm Vx -> Palm M505 -> Palm i705 -> Palm Tungsten|T -> Samsung i500 -> Treo 600->Treo 650 -> Treo 600-> Treo 700p ->Centro ->Treo 800w + Redfly C8n -> Palm Pre -> HP Touchpad
    R.I.P Palm 1996-2011
  3.    #3  
    Ok. I kinda think of homebrew as encompassing everything that isn't part of the default install and the app catalog. I understand that there's a distinction between installing a homebrew app and patching existing default apps and the OS.

    My question is which of the above do you think is likely to have caused the battery drain. I'm skeptical that any of the patches would cause battery drain. Quake might cause excessive battery drain when it's running. I was surprised to find it running when I wasn't running it. Which is why I was guessing that possibly it might have been the culprit.

    But I was hoping that others that have more experience with these items might have more insight into which could be causing the problem.
    Twitter: dullgeek
  4. #4  
    The new 3d Home Brew games have all put something in the start-up-at-boot-time directories to make some part of them start at boot. I'm trying to figure out why. If they don't try and start at boot, they don't start when you go to play them.

    Doom, Quake, Classic Invaders, and SuperTux are the ones I have installed and all four have a part of them fire at boot time. I'd really like to know why because they are killing my battery as well. Tomorrow is the test to prove or disprove that. I've removed them from starting at boot and have rebooted my phone.


    M.
  5.    #5  
    @Xanadu73: looking forward to how your results turn out

    As for me, I'm at 16.5 hours on my current charge and at 29% battery. That's 4.3% drain per hour on a doctor'd phone. Significantly better than the 20% drain per hour I was seeing w/the above config.

    If your results are positive, I'll probably being going back to homebrew just w/out Quake, Doom, et al.
    Twitter: dullgeek
  6. snafu2dj's Avatar
    Posts
    43 Posts
    Global Posts
    47 Global Posts
    #6  
    I'm having a similar situation with my Pre that just started today, but I do not have any of those apps you guys are taking about. I, too, am losing about 20% or more per hour at idle and it just started today. I did a restart this morning to see if that helped any and it did not. I did the restart bc I realized that I had no internet connection. As soon as the phone rebooted, I got 2-3 text messages that were sent last night.

    The other thing that I have noticed since using Preware, Homebrew apps, and patches (just started this past weekend) involves my yahoo email. My gf and I both have Pre's and are having the same issue. I noticed that I'm not getting any of my usual yahoo email notifications. When I go into my yahoo email account, it only shows my emails up to the last time I went in. They are not coming in automatically like usual (and I did check, the "get email" option is still set to "as items arrive"). As soon as i go into my yahoo email, that little thing starts spinning at the top loading the new emails that weren't already there. After several seconds, the new emails populate, but those spinning dots do not stop spinning like they would normally do when it is done refreshing, which also normally happens automatically on its own as they arrive unless I click on it to refresh again.

    Just to clarify, my Pre is having the battery issue AND the email issue. My gf's Pre is ONLY having the email issue. Her battery seems to be working fine. I have had my phone "Prewared" since last Friday night, and the battery issue just started today with no other changes made since the past weekend.

    Here are the things that I have installed (w/Preware & with notes and thoughts):

    • Theme: BMW


    1. App: Preware
    2. App: Terminal (says Termplugin is not installed and app unusable w/o it)
    3. App: Show Properties (doesn't seem to do anything that I need)
    4. App: Luna Manager
    5. App: PreFart
    6. App: Teen Repellent Lite (Is there a full)
    7. App: WeatherNow (NOT running in background. turned off)
    8. App: Music (Remix)
    9. App: MyBPM
    10. App: Drag Stats (not sure what dif is between these 2)
    11. App: Drag Stats AS (has some error pop up when loaded)
    12. App: BAC Calculator (won't update)
    13. App: Discount Calculator
    14. App: LoanCalc (won't update
    15. App: MortCalc
    16. App: Dope Wars
    17. App: MetraRailMap
    18. App: GoogyOS
    19. App: WxRad
    20. App: LED Torch (doesn't work)
    21. App: myFlashlight! (does work!)
    22. App: Advanced BAC (only metric units)
    23. App: Pack 'n' Track (won't work bc says version expired)


    1. Patch: 3000 Autoreplace Words (sucks and won't remove when I try)
    2. Patch: 4x4 Icons v3
    3. Patch: Add Select All and New Message
    4. Patch: All-Day Events in Month View
    5. Patch: Battery Icon and Percent
    6. Patch: BypassPINLock
    7. Patch: Call Duration in Call Log
    8. Patch: Call History During Call
    9. Patch: Character Counter
    10. Patch: Enable Add/Delete Pages
    11. Patch: Enable LED Notifications
    12. Patch: Enter Key for New Line
    13. Patch: Match State to Area Code
    14. Patch: Show Download Count (doesn't seem to work or do anything)
    15. Patch: SMS Tone per Contact
    16. Patch: Snooze Duration Selection
    17. Patch: Timestamps - Fancy
    18. Patch: Unhide Dev Mode Icon
    19. Patch: Video Downloads
    20. Patch: Virtual Keyboard


    -Please note that although it may not make sense why I have everything that I have, I am still new to Preware and webOS Quick Install so I am still experimenting.
  7. #7  
    My battery life was excellent before the 1.3.5 and 1.3.5.1 updates and was not affected afterwards. I am running Preware with 25 patches including the SR 500 patch. The only homebrew patches I have is Flashlight and Battery Monitor. With GPS set to off, wifi on and email set to check every 30 min., my Pre uses around 1% per hour of my Mugen 1400 battery at idle.
    Last edited by netwrkr9; 01/12/2010 at 06:26 PM. Reason: typo
  8. snafu2dj's Avatar
    Posts
    43 Posts
    Global Posts
    47 Global Posts
    #8  
    Quote Originally Posted by snafu2dj View Post
    I'm having a similar situation with my Pre that just started today, but I do not have any of those apps you guys are taking about. I, too, am losing about 20% or more per hour at idle and it just started today. I did a restart this morning to see if that helped any and it did not. I did the restart bc I realized that I had no internet connection. As soon as the phone rebooted, I got 2-3 text messages that were sent last night.

    The other thing that I have noticed since using Preware, Homebrew apps, and patches (just started this past weekend) involves my yahoo email. My gf and I both have Pre's and are having the same issue. I noticed that I'm not getting any of my usual yahoo email notifications. When I go into my yahoo email account, it only shows my emails up to the last time I went in. They are not coming in automatically like usual (and I did check, the "get email" option is still set to "as items arrive"). As soon as i go into my yahoo email, that little thing starts spinning at the top loading the new emails that weren't already there. After several seconds, the new emails populate, but those spinning dots do not stop spinning like they would normally do when it is done refreshing, which also normally happens automatically on its own as they arrive unless I click on it to refresh again.

    Just to clarify, my Pre is having the battery issue AND the email issue. My gf's Pre is ONLY having the email issue. Her battery seems to be working fine. I have had my phone "Prewared" since last Friday night, and the battery issue just started today with no other changes made since the past weekend.

    Here are the things that I have installed (w/Preware & with notes and thoughts):

    • Theme: BMW


    1. App: Preware
    2. App: Terminal (says Termplugin is not installed and app unusable w/o it)
    3. App: Show Properties (doesn't seem to do anything that I need)
    4. App: Luna Manager
    5. App: PreFart
    6. App: Teen Repellent Lite (Is there a full)
    7. App: WeatherNow (NOT running in background. turned off)
    8. App: Music (Remix)
    9. App: MyBPM
    10. App: Drag Stats (not sure what dif is between these 2)
    11. App: Drag Stats AS (has some error pop up when loaded)
    12. App: BAC Calculator (won't update)
    13. App: Discount Calculator
    14. App: LoanCalc (won't update
    15. App: MortCalc
    16. App: Dope Wars
    17. App: MetraRailMap
    18. App: GoogyOS
    19. App: WxRad
    20. App: LED Torch (doesn't work)
    21. App: myFlashlight! (does work!)
    22. App: Advanced BAC (only metric units)
    23. App: Pack 'n' Track (won't work bc says version expired)


    1. Patch: 3000 Autoreplace Words (sucks and won't remove when I try)
    2. Patch: 4x4 Icons v3
    3. Patch: Add Select All and New Message
    4. Patch: All-Day Events in Month View
    5. Patch: Battery Icon and Percent
    6. Patch: BypassPINLock
    7. Patch: Call Duration in Call Log
    8. Patch: Call History During Call
    9. Patch: Character Counter
    10. Patch: Enable Add/Delete Pages
    11. Patch: Enable LED Notifications
    12. Patch: Enter Key for New Line
    13. Patch: Match State to Area Code
    14. Patch: Show Download Count (doesn't seem to work or do anything)
    15. Patch: SMS Tone per Contact
    16. Patch: Snooze Duration Selection
    17. Patch: Timestamps - Fancy
    18. Patch: Unhide Dev Mode Icon
    19. Patch: Video Downloads
    20. Patch: Virtual Keyboard


    -Please note that although it may not make sense why I have everything that I have, I am still new to Preware and webOS Quick Install so I am still experimenting.
    Anyone have any insight to these issues, not just the battery problem, but also the email???
  9. #9  
    Quote Originally Posted by Xanadu73 View Post
    The new 3d Home Brew games have all put something in the start-up-at-boot-time directories to make some part of them start at boot. I'm trying to figure out why. If they don't try and start at boot, they don't start when you go to play them.

    Doom, Quake, Classic Invaders, and SuperTux are the ones I have installed and all four have a part of them fire at boot time. I'd really like to know why because they are killing my battery as well. Tomorrow is the test to prove or disprove that. I've removed them from starting at boot and have rebooted my phone.


    M.
    That's incorrect. They place scripts in event.d so that they can be launched through the Upstart Service. While the Upstart Service itself is started on boot, the scripts placed in that directory by apps are not called until the app is launched.
  10. #10  
    Quote Originally Posted by dallashigh
    They place scripts in event.d so that they can be launched through the Upstart Service.
    Cool. That's what I didn't know. I hadn't seen any logicial reason for them to be en event.d, and that's what I looking to find out.


    M.
  11. Robo.308's Avatar
    Posts
    5 Posts
    Global Posts
    6 Global Posts
    #11  
    I had the same Battery prob the last two days and today get the clue, that it was the Patch "Battery as Percent at the top bar".
    After I removed it, the battery drain is at about 2 % an hour, w/o Push, 3G, WLAN or sth else.
    With the patch I had a drain of about 15 % an hour...

    So I think you have to remove the Battery Patches and wait till they get updated...

    Greetz from Germany ;-)

Posting Permissions