Page 1 of 24 12345611 ... LastLast
Results 1 to 20 of 472
  1.    #1  
    WebOS Internals announces DOOM! (courtesy of Zsoc) now in Preware.

    Read the Homepage link in the Preware package description page for more information.

    DOOM Ported To Palm Pre, Is Hardware-Accelerated

    http://www.precentral.net/hardware-a...d-yes-its-true

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. spare's Avatar
    Posts
    662 Posts
    Global Posts
    664 Global Posts
    #2  
    i've been unable to run the third command line. Anyone else?
  3. Habious's Avatar
    Posts
    245 Posts
    Global Posts
    887 Global Posts
    #3  
    OK...installed it from Preware...and the first command doesn't work.

    I type in "cd /media/cryptofs/apps" and I get "-sh: d: not found"

    However, if I do a "cd/"...and then work my way through the directory tree from that point...I got it to work.

    EDIT: Got it...first line should be ""cd /media/cryptofs/apps/" <--note the last "/"



    As for the controls...

    Holding the phone in Landscape...

    "Y" - Turn Left
    "H" - Walk forward
    "G" - Run forward
    "B" - Turn Right
    Screen Tap shoots ("Sym" key does too)


    Haven't figured out how to back up yet.
    Last edited by Habious; 12/31/2009 at 08:31 AM.
  4. #4  
    Awesome.

    Looks like the second link is inaccessible (access denied, even though I'm logged in).
  5. dsei's Avatar
    Posts
    194 Posts
    Global Posts
    196 Global Posts
    #5  
    WebOS Internals, I salute you! You guys do great work. Haven't tried the game yet as I'm at work, but kudos anyway.
  6. andymac85's Avatar
    Posts
    79 Posts
    Global Posts
    80 Global Posts
    #6  
    worked on the first try!
  7. #7  
    Quote Originally Posted by rwhitby View Post
    WebOS Internals announces DOOM! (courtesy of Zsoc) now in Preware.

    Read the Homepage link in the Preware package description page for more information.

    DOOM Ported To Palm Pre, Is Hardware-Accelerated

    http://www.precentral.net/hardware-a...d-yes-its-true

    -- Rod
    The SDL port is awesome news. Loki, for example, used SDL for their ports of things like Unreal Tournament. SWEET! :-)
  8. tc600's Avatar
    Posts
    305 Posts
    Global Posts
    306 Global Posts
    #8  
    not a problem for me!

    still trying to figure out the game keystrokes. So far:

    Y = turn left
    H = walk forward
    B = turn right
    G = run forward
    Sym = shoot
    screen tap = shoot
    - = siderun right?
    . = sidestep right
    enter = last info
    Last edited by tc600; 12/31/2009 at 08:51 AM.
  9. cue79's Avatar
    Posts
    357 Posts
    Global Posts
    366 Global Posts
    #9  
    doh.. I'm the first with a problem:

    could not initalize SDL: unable to open dev/fd1


    thoughts?
  10. #10  
    Doesn't work for me either. Get a message that says something to the effect of not being able to cd to webosinternals......

    On a side note, I was able to access this page by clicking the link in Twitter, but the rest of the forums seem to be messed up and I get this message when I click on forum link: No input file specified.

    Going to reboot my computer, in case it's on my end.
  11. #11  
    Very cool. Nice and smooth.
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  12. #12  
    Quote Originally Posted by cue79 View Post
    doh.. I'm the first with a problem:

    could not initalize SDL: unable to open dev/fd1


    thoughts?
    This requires WebOS 1.3.5. Have you upgraded yet?
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  13. cue79's Avatar
    Posts
    357 Posts
    Global Posts
    366 Global Posts
    #13  
    Yup.. Been upgraded since the night it came out..

    I'm rebooting to see if that helps.. but def 1.3.5
  14. cue79's Avatar
    Posts
    357 Posts
    Global Posts
    366 Global Posts
    #14  
    I am not using a rooted Pre - using a copy of terminal I installed quite a while ago.. That shouldn't matter though.... Should it?
  15. cue79's Avatar
    Posts
    357 Posts
    Global Posts
    366 Global Posts
    #15  
    Ok - same issue after reboot (on a pc now so easier to type)

    Gets thru some initalizations, hits:

    I_Init: Setting up machine state.
    Error:Could not initialize SDL: Unable to open /dev/fb1
  16. ZeroMuch's Avatar
    Posts
    5 Posts
    Global Posts
    7 Global Posts
    #16  
    Same third command line error here. Can't cd org.webosinternals.....
  17. #17  
    If you are getting errors after the third command, reboot your Pre and it will work fine.

    Great work!
  18. cue79's Avatar
    Posts
    357 Posts
    Global Posts
    366 Global Posts
    #18  
    Quote Originally Posted by ZeroMuch View Post
    Same third command line error here. Can't cd org.webosinternals.....
    That sounds like it didn't install properly thru PreWare - type ls and see what comes up. Do you see the doom directory listed?
  19. zoen22's Avatar
    Posts
    42 Posts
    Global Posts
    48 Global Posts
    #19  
    Ooooo boy!
  20. #20  
    webos 1.3.5 :/

    *waits for eu release*
Page 1 of 24 12345611 ... LastLast

Posting Permissions