Page 7 of 9 FirstFirst ... 23456789 LastLast
Results 121 to 140 of 171
  1.    #121  
    Quote Originally Posted by emoney_33 View Post
    Personally I think the default main scene is the easiest to use (and doesn't hide any types), which is simply

    Package Updates
    Available Packages
    Installed Packages
    List of Everything

    I guess database preferences stay across updates so to get back to this main scene you can go to: Preware -> preferences -> set show available types to NO.
    I actually keep mine this way.

    But in the examples for Getting Started: Preware includes showing them how to install themes so during the instructions the simplest way I can think of to explain this is to tell them:

    Setup Preware. Click the Preware menu at the top-left and tap Preferences. Set Update to Every Launch and for now set everything to YES. In particular make sure Installed Is Available is YES. Tap the Preware menu again then Manage Feeds and set everything to ON for now. Swipe back to the main menu and tap the Preware menu again then Update Feeds to see your changes.
    Also, unless we do this, they cannot find Emergency Patch Recovery from the menus. One cardinal rule for instructions is to never tell them to use something that is hidden from the menus.

    One other problem this helps address is the 180 posts I found where users say "My App/Patches are gone!" What really happened was that Preware defaults to hiding content as soon as it is installed. Setting Installed Is Available to YES fixes their vanishing content issues.

    At the end we show them how to Customize Preware to hide Themes and Available Other again.

    Can you think of any other way to address the "My Apps are gone" and "Where is EPR" posts?

    - Craig
  2. #122  
    Quote Originally Posted by milominderbinder View Post
    I actually keep mine this way.
    The way I have listed is the default stock install. Your current pictures will be confusing to new users as they won't see the screen set up that way. Setting it up that way (with Available Applications, Available Themes) is what HIDES things. The "Available Packages" menu as is on a stock Pre install, shows every type that exist in the feeds that are enabled. So Theme, Patch, Linux Application, etc.. are ALL there. The default main scene I believe was changed along the way, but since your database preferences were never wiped you may not see the new main scene default after an update or reinstall.

    Since the instructions say to set everything to yes in the preferences, this is what changes the main scene. Also if the instructions are followed and everything is set to yes, then available other is shown.

    Also, unless we do this, they cannot find Emergency Patch Recovery from the menus. One cardinal rule for instructions is to never tell them to use something that is hidden from the menus.
    Available Packages -> Linux Application -> Utilities -> Emergency Patch Recovery

    One other problem this helps address is the 180 posts I found where users say "My App/Patches are gone!" What really happened was that Preware defaults to hiding content as soon as it is installed. Setting Installed Is Available to YES fixes their vanishing content issues.
    Preware hides nothing by default. There is a logical distinction between the term "Available" and "Installed". When a package is installed it will show up in "Installed Packages". I'm not sure why people would look in "Available Packages" before "Installed Packages" for an installed package.

    However, I am perfectly fine with the instructions saying to set installed is available to YES. It does not harm anything IMO and I personally prefer it anyway as a place to see all packages whether available or installed already.

    I do not have a problem with this in the instructions and like the fact that it is there. This ("Installed is Available") is quite different from my above "Show Available Types"

    At the end we show them how to Customize Preware to hide Themes and Available Other again.

    Can you think of any other way to address the "My Apps are gone" and "Where is EPR" posts?

    - Craig
    Available Other, and Available Themes, etc... are not in the default main scene on a stock install. You must change that in preferences via the "Show Available Types" option.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  3. #123  
    Hi, I just got my new pre and it has 1.3.5 software. Any ideas when we will have update for preware? I have learned alot of interesting ideas for this site, however, when I try to download with 1.3.5 The installers have been removed until they can be updated to work with webOS 1.3.5

    Everyone told me this was a great place for pre apps.

    Thanks, Crawjelly
  4. #124  
    Quote Originally Posted by crawjelly View Post
    Hi, I just got my new pre and it has 1.3.5 software. Any ideas when we will have update for preware? I have learned alot of interesting ideas for this site, however, when I try to download with 1.3.5 The installers have been removed until they can be updated to work with webOS 1.3.5

    Everyone told me this was a great place for pre apps.

    Thanks, Crawjelly
    http://install.preware.org

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  5. #125  
    Hi,
    Preware wrote me that the Package Manager Service was not running.
    I downloaded again the software, but Preware didn't work.
    Then, I deleted the latest version of Preware (I saw at this time, that there were two versions installed) meaning that new newest version should be for the 1.3.5 OS.
    I tried to download again Preware, first it wasn't possible, because of not enough memory; I deleted some apps and downloaded it (via preload) vith the mention "installation successfull" but I don't see Preware in the launcher, any help please?
    ...and excuse my poor english
  6. bkcrown's Avatar
    Posts
    41 Posts
    Global Posts
    42 Global Posts
    #126  
    Quote Originally Posted by jean-roch View Post
    Hi,
    Preware wrote me that the Package Manager Service was not running.
    I downloaded again the software, but Preware didn't work.
    Then, I deleted the latest version of Preware (I saw at this time, that there were two versions installed) meaning that new newest version should be for the 1.3.5 OS.
    I tried to download again Preware, first it wasn't possible, because of not enough memory; I deleted some apps and downloaded it (via preload) vith the mention "installation successfull" but I don't see Preware in the launcher, any help please?
    ...and excuse my poor english
    Try this.

    Finally got the App catalog to fix.

    Turn on Developer Mode - WebOS20090606
    Hook up Pre to computer, select Just Charge
    Remove Package Mgr Server, PreWare and Emerg Migration Helper with WebOS Quick Install (see Preware)
    Add back Package Mgr Server 9.29 FIRST
    Then add PreWare 9.12
    Then add Emergency Migration Helper
    Finally turn off developer mode
  7. #127  
    hey guys can one of u post the page whith the preware forum with the ipk file to download it please
  8. #128  
    @bkcrown: thanks! I'll try this this evening after work.
  9.    #129  
    Quote Originally Posted by bigbakedantonio View Post
    hey guys can one of u post the page whith the preware forum with the ipk file to download it please
    Follow the instructions in the opening post of this thread. That is what this thread is about.

    - Craig
  10. #130  
    can i get the page with the ipk attachment so i can get preware on my phone
  11. #131  
    @bkcrown : It did work fine, thank you
  12. MSchmidt9's Avatar
    Posts
    10 Posts
    Global Posts
    14 Global Posts
    #132  
    I downloaded the update that Palm released and my preware quit working. I reinstalled it and now when I try to add a patch it tells me there is an error on the IPKG log so when I view it it tells me:

    ErrorGenericMethodException: Failure during post-install script execution

    Any ideas?
  13. #133  
    I know I'm waaaay way behind on this, but as much as I hate to admit it, I have yet to use Preware. I heard that they'll be adding automatic update functionality soon (where you can seamlessly remove and add all your preware stuff when there's a webos update). Any news on when thats coming? Trying to decide if I should wait for that or just go ahead and install away.
  14. #134  
    Quote Originally Posted by schnoid View Post
    I know I'm waaaay way behind on this, but as much as I hate to admit it, I have yet to use Preware. I heard that they'll be adding automatic update functionality soon (where you can seamlessly remove and add all your preware stuff when there's a webos update). Any news on when thats coming? Trying to decide if I should wait for that or just go ahead and install away.
    Install now - it will update itself when new versions are ready.

    http://install.preware.org/

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  15. #135  
    I haven't gone over this thread too in depth yet. but 1) I still see that the link Index of / which as you know points me back to this thread.

    I haven't been through each page but page 6 and 7, I was wondering when it would be updated. Apparently I have some more reading to do.

    But is this compatible with 1.3.5.1? not only that but a heads up I was in the Sprint store today picking up my replacement PrPrPr&#$275$; ($keyboard$ $stopped$ $working$ $on$ $the$ $last$ $one$)

    Anyway, we were BSin about the newest update I'm sure a lot are waiting for. The Flash 10.1 update, which he had info that it's getting released next month in February. So if i can get Preware installed (once I re-read page 1) but Just wondering if Preware will be down till it gets updated again.
  16. #136  
    Quote Originally Posted by SirSilvia View Post
    I haven't gone over this thread too in depth yet. but 1) I still see that the link Index of / which as you know points me back to this thread.

    I haven't been through each page but page 6 and 7, I was wondering when it would be updated. Apparently I have some more reading to do.

    But is this compatible with 1.3.5.1? not only that but a heads up I was in the Sprint store today picking up my replacement PrPrPr&#$275$; ($keyboard$ $stopped$ $working$ $on$ $the$ $last$ $one$)

    Anyway, we were BSin about the newest update I'm sure a lot are waiting for. The Flash 10.1 update, which he had info that it's getting released next month in February. So if i can get Preware installed (once I re-read page 1) but Just wondering if Preware will be down till it gets updated again.
    You use WebOS Quick Install to install Preware.

    It is fully compatible with all webOS versions, and has never been down.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. #137  
    Quote Originally Posted by rwhitby View Post
    You use WebOS Quick Install to install Preware.

    It is fully compatible with all webOS versions, and has never been down.

    -- Rod
    oh ok thanks, I should've shut my mouth till I read a little more. I'm beginning to see how it works now.
  18. #138  
    Preware 0.9.16 and Package Manager Service 0.9.30 have been released.

    Recent enhancements:

    0.9.16: Removed the partial app limit fix (obsolete as of webOS 1.3.5)

    0.9.15: Added Palm App Catalog feeds, including price information.

    0.9.14: Added support for installation of signed packages without confirmation.

    0.9.13: Enabled the Update All button, and added support for skipping restart actions (e.g. when installing multiple patches). (Thanks to Oil)

    To install Preware, see http://install.preware.org/

    Preware documentation lives at Application:Preware - WebOS Internals

    The official Preware thread is at http://forums.precentral.net/webos-i...0-preware.html

    Enjoy.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  19. #139  
    new to preware, do I have to leave it on developer mode the entire time using it? and can you link me to webos updates and what to do with preware? thank you
  20. #140  
    I'm really hoping you can help me. I have installed Preware and Package Manager in the past but had to do a partial erase and I reinstalled them but cant get preware to run. It keeps telling me Package manager might not be installed and asks if I forgot to install it. I've been installing and uninstalling for 2 straight days. I used to love my pre but without the patches its pretty much a paper weight to me. Please help if you have time. I'm not sure how to get replies on here so my email addy is brett.martin2@gmail.com I'm sure I'll get all kinds of spam for posting it but if it gets fixed it will be worth it. Oh ya.... I already hit the thank you button. :-)
Page 7 of 9 FirstFirst ... 23456789 LastLast

Posting Permissions