webOS Nation Forums >  Homebrew >  WebOS Internals > wIRC: webOS IRC Client
wIRC: webOS IRC Client
  Reply
Like Tree4Likes

 
Thread Tools Display Modes
Old 08/18/2010, 05:29 PM   #161 (permalink)
Member
 
NachoB's Avatar
 
Posts: 4,927
Besides the jail for the plugin being setup, this is the only entry I see when viewing the messages log:

Code:
Line 6512: 2010-08-18T22:12:39.657562Z [1107] palm-webos-device user.info org.webosinternals.plugin.wirc[2435]: mdns: Couldn't open nss_mdns configuration file /etc/nss_mdns.conf, using default.
I used Notepad++ to view the messages log, found 42 entries for wirc, any reason why Lumberjack reports that there is nothing in the log file for wirc?
__________________
If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

HOW TO: Zip/Unzip via Pre/Pixi using Terminal
HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
Palm Pre wallpapers
NachoB is offline   Reply With Quote
Old 08/18/2010, 06:19 PM   #162 (permalink)
Developer
 
rwhitby's Avatar
 
Posts: 10,553
Quote:
Originally Posted by NachoB View Post
2010-08-18T16:21:00.302764Z [581] palm-webos-device daemon.info upstart: (00581/44482421) com.tntservices.prebkuservice main process (2173) exited normally
2010-08-18T16:21:00.303070Z [581] palm-webos-device daemon.warning upstart: (00581/44787597) com.tntservices.prebkuservice main process ended, respawning
2010-08-18T16:21:00.303222Z [581] palm-webos-device daemon.info upstart: (00581/44909667) com.tntservices.prebkuservice state changed from running to stopping
2010-08-18T16:21:00.303344Z [581] palm-webos-device daemon.info upstart: (00581/45184326) Handling stopping event
2010-08-18T16:21:00.303436Z [581] palm-webos-device daemon.info upstart: (00581/45428466) com.tntservices.prebkuservice state changed from stopping to killed
2010-08-18T16:21:00.303527Z [581] palm-webos-device daemon.info upstart: (00581/45550537) com.tntservices.prebkuservice state changed from killed to post-stop
2010-08-18T16:21:00.303649Z [581] palm-webos-device daemon.info upstart: (00581/45672607) com.tntservices.prebkuservice state changed from post-stop to starting
2010-08-18T16:21:00.303741Z [581] palm-webos-device daemon.info upstart: (00581/45794677) Handling starting event
2010-08-18T16:21:00.303833Z [581] palm-webos-device daemon.info upstart: (00581/45916748) com.tntservices.prebkuservice state changed from starting to pre-start
2010-08-18T16:21:00.303924Z [581] palm-webos-device daemon.info upstart: (00581/46038818) com.tntservices.prebkuservice state changed from pre-start to spawned
2010-08-18T16:21:00.347930Z [581] palm-webos-device daemon.info upstart: (00581/90441894) Active com.tntservices.prebkuservice main process (2185)
2010-08-18T16:21:00.348419Z [581] palm-webos-device daemon.info upstart: (00581/92028808) com.tntservices.prebkuservice state changed from spawned to post-start
2010-08-18T16:21:00.348724Z [581] palm-webos-device daemon.info upstart: (00581/92364501) com.tntservices.prebkuservice state changed from post-start to running
FYI, this broken service is slowing down the performance of your device. You should remove it.

-- Rod
__________________
WebOS Internals and Preware Founder and Developer
You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
All donations go back into development.
www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
rwhitby is offline   Reply With Quote
Old 08/18/2010, 06:20 PM   #163 (permalink)
Developer
 
rwhitby's Avatar
 
Posts: 10,553
Quote:
Originally Posted by NachoB View Post
Besides the jail for the plugin being setup, this is the only entry I see when viewing the messages log:

Code:
Line 6512: 2010-08-18T22:12:39.657562Z [1107] palm-webos-device user.info org.webosinternals.plugin.wirc[2435]: mdns: Couldn't open nss_mdns configuration file /etc/nss_mdns.conf, using default.
I used Notepad++ to view the messages log, found 42 entries for wirc, any reason why Lumberjack reports that there is nothing in the log file for wirc?
Lumberjack only shows the Mojo errors if you select an application. You'll need to log Everything to see the PDK plugin errors.

-- Rod
__________________
WebOS Internals and Preware Founder and Developer
You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
All donations go back into development.
www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
rwhitby is offline   Reply With Quote
Old 08/18/2010, 06:33 PM   #164 (permalink)
Member
 
NachoB's Avatar
 
Posts: 4,927
Quote:
Originally Posted by rwhitby View Post
FYI, this broken service is slowing down the performance of your device. You should remove it.

-- Rod
Deleted Pre Backup Utility, I'll keep an eye on the log.
__________________
If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

HOW TO: Zip/Unzip via Pre/Pixi using Terminal
HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
Palm Pre wallpapers
NachoB is offline   Reply With Quote
Old 08/20/2010, 05:46 PM   #165 (permalink)
Member
 
Posts: 1
Can someone please help me install wIRC and wIRCd (the old version) and give me links?

for Palm Pre Plus: Verizon please!
Pikula is offline   Reply With Quote
Old 08/20/2010, 08:43 PM   #166 (permalink)
Member
 
NachoB's Avatar
 
Posts: 4,927
Test feed with older wIRC and wIRCd
__________________
If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

HOW TO: Zip/Unzip via Pre/Pixi using Terminal
HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
Palm Pre wallpapers
NachoB is offline   Reply With Quote
Old 08/24/2010, 11:22 AM   #167 (permalink)
Member
 
Posts: 156
Some bug reports/observations:

* I've noticed that on the server channel log scene I occasionally have a problem that seems like the backspace key is held down - every character I type is quickly deleted. I backward swipe to the main scene, then open that channels server log again, and everything is fine. Have not figured out how to do it reproducibly yet. It happened a bit a while back, but has not happened in a few weeks

* Shut down phone for low battery situation, restarted during charge, started wIRC, had 'identity' scene on startup. Shut off IRC, re-installed EFF patch, restarted phone, restarted wIRC, same 'identity' scene as before. Opened webos-internals Save/Restore, restored wIRC backup (which was from 0.2.4) and started wIRC, still 'identity' scene. Entered identities, came to main wIRC screne which had server info on it, connected to server. Previous settings were for Palm Dark Theme, but now had Palm Default theme. Other Global settings were reverted to default. This has happened a second time, and I believe I recently again had a low battery situation, and it is possible that this is my first restart since then

* When people are op'd, etc, it doesn't say who was op'd, only who did the op'ing, it would be nice to see ' +v annoyer by *****'

* When people are op'd by a bot, the users list is no longer accurate about users status - will show people as not op'd when they are. Also seems to be some of this happening when reconnecting to an existing session

* Still sometimes find that I lose connection and the server icon shows connected, but it is clear I am not, but this is MUCH improved (thanks)

* With autoping off, /ping and /ping #channel do not seem to do anything, when typed in the channel card or when typed into the server messages card

* Sometimes when I'm using wIRC people on the channel are annoying
notcalvin is offline   Reply With Quote
Old 08/24/2010, 11:44 AM   #168 (permalink)
oil
Member
 
oil's Avatar
 
Posts: 863
Quote:
Originally Posted by notcalvin View Post
* I've noticed that on the server channel log scene I occasionally have a problem that seems like the backspace key is held down - every character I type is quickly deleted. I backward swipe to the main scene, then open that channels server log again, and everything is fine. Have not figured out how to do it reproducibly yet. It happened a bit a while back, but has not happened in a few weeks
Yeah, we know about this, I have yet to track it down, a good tap on the gesture area will clear it out. (which is why a back-gesture also clears it out.) It's because it thinks you're trying to do a meta+key type action.
http://git.webos-internals.org/trac/wIRC/ticket/95

Quote:
Originally Posted by notcalvin View Post
* Shut down phone for low battery situation, restarted during charge, started wIRC, had 'identity' scene on startup. Shut off IRC, re-installed EFF patch, restarted phone, restarted wIRC, same 'identity' scene as before. Opened webos-internals Save/Restore, restored wIRC backup (which was from 0.2.4) and started wIRC, still 'identity' scene. Entered identities, came to main wIRC screne which had server info on it, connected to server. Previous settings were for Palm Dark Theme, but now had Palm Default theme. Other Global settings were reverted to default. This has happened a second time, and I believe I recently again had a low battery situation, and it is possible that this is my first restart since then
Can you create repeatable steps for this? Starting with a fresh (without restored settings) install of 030?

Quote:
Originally Posted by notcalvin View Post
* When people are op'd, etc, it doesn't say who was op'd, only who did the op'ing, it would be nice to see ' +v annoyer by *****'
* When people are op'd by a bot, the users list is no longer accurate about users status - will show people as not op'd when they are. Also seems to be some of this happening when reconnecting to an existing session
http://git.webos-internals.org/trac/wIRC/ticket/93

Quote:
Originally Posted by notcalvin View Post
* With autoping off, /ping and /ping #channel do not seem to do anything, when typed in the channel card or when typed into the server messages card
http://git.webos-internals.org/trac/wIRC/ticket/94

Quote:
Originally Posted by notcalvin View Post
* Sometimes when I'm using wIRC people on the channel are annoying
Join a different channel.


As you can see, a number of the things you pointed out have already been reported, please be sure to check the trac first, re-reporting things that have already been reported wastes everyones time. But I do appreciate your bug reporting.
oil is offline   Reply With Quote
Old 08/24/2010, 02:08 PM   #169 (permalink)
Member
 
Posts: 156
Hah, you guys are sneaky with that whole publicly hosted bug tracking web site... lol, sorry...

I'll see what I can do about repeating the lost preferences thing. I just bought a new battery, so I can probably figure out a way to do it somewhat conveniently...
notcalvin is offline   Reply With Quote
Old 08/25/2010, 09:07 PM   #170 (permalink)
Member
 
Posts: 4
I am really confused... I updated the app and now I can't figure out how to get it to work again. I am really lost can someone help me out? reneenetrop@aol.com I just want to add shadowfire and have it save in the settings and allow me back into the channels I have been using up until this update.
reneenetrop is offline   Reply With Quote
Old 08/25/2010, 09:08 PM   #171 (permalink)
Member
 
Posts: 4
when i start the app it says waiting for plugin...what have i done wrong
reneenetrop is offline   Reply With Quote
Old 08/25/2010, 09:26 PM   #172 (permalink)
Member
 
Posts: 4
what plug-in am i missing? i cant even access the preloaded networks..argh...i liked it better before i updated, is there a way to go back?
reneenetrop is offline   Reply With Quote
Old 08/25/2010, 09:34 PM   #173 (permalink)
oil
Member
 
oil's Avatar
 
Posts: 863
You either don't have webos 1.4.5, or you have a pixi, and need to go back to wirc 0.2.4. Or maybe you just need the Emergency Fstab Fixer.
oil is offline   Reply With Quote
Old 08/30/2010, 10:22 AM   #174 (permalink)
Member
 
Posts: 156
With 0.3.1, is anyone else having the app lockup when trying to copy a line from the backlog?

Select line, select 'copy' and then frozen.
notcalvin is offline   Reply With Quote
Old 08/30/2010, 08:10 PM   #175 (permalink)
oil
Member
 
oil's Avatar
 
Posts: 863
Quote:
Originally Posted by notcalvin View Post
With 0.3.1, is anyone else having the app lockup when trying to copy a line from the backlog?

Select line, select 'copy' and then frozen.
Fixed in next release.
oil is offline   Reply With Quote
Old 09/05/2010, 11:05 PM   #176 (permalink)
Member
 
Posts: 256
0.3.2 is out with bugfixes and beta SSL support
PuffTheMagic is offline   Reply With Quote
Old 09/05/2010, 11:22 PM   #177 (permalink)
Member
 
NachoB's Avatar
 
Posts: 4,927
Not sure what my issue is, but I still don't connect when first launching WIRC. I see:
~~~ Connecting...
~~~ Disconnected!

Everytime I first launch WIRC after a device restart. Crazy.
NachoB is offline   Reply With Quote
Old 09/06/2010, 07:48 AM   #178 (permalink)
Member
 
Posts: 256
Quote:
Originally Posted by notcalvin View Post
Hah, you guys are sneaky with that whole publicly hosted bug tracking web site... lol, sorry...
We are trying to move from Trac to Redmine for bug tracking which will allow people to make accounts and submit bugs them selves. Right now since the security with Trac is terrible, only us devs and submit bugs.


I wish there was a way to get people to check the bug tracker though
PuffTheMagic is offline   Reply With Quote
Old 09/06/2010, 09:39 AM   #179 (permalink)
Member
 
Posts: 256
Quote:
Originally Posted by notcalvin View Post
* When people are op'd, etc, it doesn't say who was op'd, only who did the op'ing, it would be nice to see ' +v annoyer by *****'
I don't know what you are looking at when someone get op'd but I see:

"~~~ Mode NickOfUser +o by SomeOtherUser"

... so I am marking this bug as invalid in the bug tracker.
PuffTheMagic is offline   Reply With Quote
Old 09/06/2010, 10:17 AM   #180 (permalink)
Member
 
Posts: 256
"Originally Posted by notcalvin
* With autoping off, /ping and /ping #channel do not seem to do anything, when typed in the channel card or when typed into the server messages card"

/ping is remapped to a ctcp-ping and right now requires at least 1 argument, target

/ping with no target in a channel is not allowed because that would flood everyone in the room, if you want to ping the server do it from the server status window or support the server address
PuffTheMagic is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0