Page 4 of 13 FirstFirst 123456789 ... LastLast
Results 61 to 80 of 257
  1. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #61  
    Quote Originally Posted by volcom45 View Post
    Hmm, the new search function doesn't seem to work correctly for me. I had both the Bible Reader Lite and SimpleBible installed and decided to get rid of the SimpleBible. I first removed it from launcher with orange key+d. Then I ran mvapp search bible and it only returned the BibleReaderLite. I then did mvapp listmoved and SimpleBible showed up in that list still. So, I had to manually type mvapp clean com.incrediblylongdomain.simplebible in order to get rid of it. Was I doing anything wrong?
    Thanks,
    ^I'll have to check into the parsing. If the link was gone, the search function won't find it. I don't accept supernatural forces of any kind but if they are out there, perhaps it was divine intervention.
  2. #62  
    In PreWare I don't have mvapp or Terminal. (All types is selected in preferences)
  3. #63  
    Quote Originally Posted by xorg View Post
    ^I'll have to check into the parsing. If the link was gone, the search function won't find it. I don't accept supernatural forces of any kind but if they are out there, perhaps it was divine intervention.
    Ah, so your saying if we truly want to delete an App we've moved to the media side, don'ttry to delete first from launcher with orange button + d? Instead, do the search for a key word in file name and then hit C for clean? That will remove the App from media side and from launcher? Sorry, I was confused as the wiki webpage says to try deleting normally first from launcher.
  4. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #64  
    ^I'll test a few more apps and check it out. The clean function worked, but the way it searches might need to be more thorough to look in both /var and /media.
  5. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #65  
    Quote Originally Posted by BlazerDogs View Post
    In PreWare I don't have mvapp or Terminal. (All types is selected in preferences)
    Hmm... might check you have latest version. Otherwise might ask in the PreWare support thread.
  6. jeffbengr's Avatar
    Posts
    12 Posts
    Global Posts
    20 Global Posts
    #66  
    Quote Originally Posted by BlazerDogs View Post
    In PreWare I don't have mvapp or Terminal. (All types is selected in preferences)
    Maybe check in preferences to see what your "Update Feeds" is set to? I had changed this to "manual" when stuck in a 3G dead zone a couple of weeks ago and hadn't changed it back, and thus was not getting the latest and greatest.
  7. 02589's Avatar
    Posts
    242 Posts
    Global Posts
    248 Global Posts
    #67  
    Regarding the huge amount of data that I thought was emptied from my email and attachments, it was advised that I delete the email accts and start over. I planned to do this but first I deleted the buckets of info. I think there were exactly 20 buckets in the mail and 20 for attachments. This left the e-mail and attachment folders bare empty. No buckets, no files, no nothing. Just before I was ready to delete the accts, I let a few emails come in, and everything worked. The buckets seemed to repopulate as needed. Not 20 at once, but a few here and there. I think buckets are expendable and might be a part of periodic maintenance to keep the Pre working like new.

    It was mvapps that got me going on this project and I appreciate the program and the advice. I hope this message helps. There was a message on the WebOS forum that was asking about buckets and I gave a longer example of what I had done.

    Thanks WebOS internals.
  8. #68  
    Has anyone tried Mvapp on the Messaging (MSN, Yahoo, ICQ, IRC, etc.) plugins by Greg_Roll? Just curious if that still works if moved, it is now like 13megs of /VAR..
  9. #69  
    I'm curious....would it be possible to attach some type of GUI to all this in order to make it more user friendly for those that aren't comfortable using terminal commands? I was just thinking how great something like that would appeal to the masses.
  10. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #70  
    Quote Originally Posted by Trekker View Post
    I'm curious....would it be possible to attach some type of GUI to all this in order to make it more user friendly for those that aren't comfortable using terminal commands? I was just thinking how great something like that would appeal to the masses.
    Ideally 'mvapp' functions would be added to homebrew installers like PreWare so that as you install apps, it would automatically be moved to media drive. I haven't had a specific discussion yet with the PreWare guys but am heading that direction. It looks like Palm isn't planning to solve this with 1.3 and because it would probably take a significant architectural change to deal with the issue, they probably won't do anything until webOS 2.0 if even then. So it's probably time to take 'mvapp' to the next step, make it a service and allow homebrew installer apps use this.
  11. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #71  
    Quote Originally Posted by volcom45 View Post
    Has anyone tried Mvapp on the Messaging (MSN, Yahoo, ICQ, IRC, etc.) plugins by Greg_Roll? Just curious if that still works if moved, it is now like 13megs of /VAR..
    I don't think it has a json file, so mvapp won't move it. I may add a 'force' move option, or if an app with no json file is attempted, mvapp will ask if you want to move anyway with a note that if the app doesn't work, remove, clean and reinstall.

    Many apps with no json file might still work fine, but I intended to avoid those as they are more likely to be specialty apps that could have file attributes not supported by media drive (FAT fs). Originally I was intentionally overly cautious but with the stability of the link method, I could probably refine mvapp to open up to more app types.
  12. #72  
    Is it possible to use the mvapp to remove apps that I have removed but still seem to show up on the mvapp list(possibly having some orphaned files and wasting space) Every time I try a clean it says "link does not exist".
  13. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #73  
    ^I believe this was a webOS issue in previous webOS version. I also think PreWare doesn't always fully clear out the app folder when the app is deleted within PreWare (better to delete from Launcher). mvapp exposes the issue but doesn't resolve it. I could open up the 'clean' function to remove apps even if there is no link. Might consider it for next version, but it might open up can of worms for other issues.

    You could likely do a 'mvapp link' to the orphaned app and then do a 'mvapp clean'.

    In the next version, the 'doctor' will remove any abandoned apps sitting in the media drive that do not have links.
  14. #74  
    Quote Originally Posted by xorg View Post
    ^I believe this was a webOS issue in previous webOS version. I also think PreWare doesn't always fully clear out the app folder when the app is deleted within PreWare (better to delete from Launcher). mvapp exposes the issue but doesn't resolve it. I could open up the 'clean' function to remove apps even if there is no link. Might consider it for next version, but it might open up can of worms for other issues.

    You could likely do a 'mvapp link' to the orphaned app and then do a 'mvapp clean'.
    Actually some of these were deleted via both the launcher and preware. But a long while ago. I will try your suggestion and report any problems. Thanks.

    -----------Edit after trying xorg's suggestion---------------

    No luck on linking and then cleaning because it won't move the app because it can't find the json file for the app.
    Last edited by Kyusaku; 11/13/2009 at 05:52 PM.
  15. #75  
    Quote Originally Posted by xorg View Post
    Ideally 'mvapp' functions would be added to homebrew installers like PreWare so that as you install apps, it would automatically be moved to media drive.
    That would be great for homebrew apps. Is there a similar solution for apps downloaded from Palm's official app catalog?
  16. #76  
    Quote Originally Posted by Trekker View Post
    That would be great for homebrew apps. Is there a similar solution for apps downloaded from Palm's official app catalog?
    Such functionality incorporated into Preware should be able to handle those two. That's one reason why we recently (0.9.8, just released) added the "Fix Unknown Types" functionality, which is usually packages from the app catalog.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #77  
    After the webOS 1.3.1 update, all apps and email moved and linked via mvapp WORK FINE. As expected, the update did not disrupt any of the links.

    There is no need to do anything to prepare for the 1.3.1 update. You do not need to restore any apps or email before the update.
  18. #78  
    Hey Xorg,

    I'm having trouble upgrading the Pre OS. I'm still stuck at version 1.2.0 and Palm 1.8.

    So I'm considering using the Docter to reset the device. I'd like to try and use mvapp to archive my homebrew apps. I've moved all that I could to my media drive and will be backing that up.

    Anything you could suggest to help make a restore of these apps using mvapp work?
  19. ferchope's Avatar
    Posts
    92 Posts
    Global Posts
    105 Global Posts
    #79  
    any fix to app limit with 1.3.1?
  20. try0625's Avatar
    Posts
    57 Posts
    Global Posts
    59 Global Posts
    #80  
    Quote Originally Posted by ferchope View Post
    any fix to app limit with 1.3.1?
    yeah, same question
Page 4 of 13 FirstFirst 123456789 ... LastLast

Posting Permissions