Page 12 of 13 FirstFirst ... 278910111213 LastLast
Results 221 to 240 of 257
  1. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #221  
    Attention mvapp users:

    Doing a 'mvapp postupd' will allow any lost linked apps to be found again but they will not show up in PreWare or update to future releases. I'm working on a fix for this, which is simple in concept but I need to test thoroughly. It's OK if you use 'mvapp postupd' for now to get the apps working. I'll be releasing a new version of mvapp in next day or two that will fix the issue.

    Bummer that Palm released this during the holidays as I'm out of town (Chile/Florida) and not back (in KC) till the New Year. But I hope to get this minor issue fixed by tomorrow or Friday. If you have already run 'mvapp postupd' and want to be able to update an app, simply remove it from the Launcher (with Orange app select) and then reinstall. Apologies for the inconvenience.
    xorg tools - power tools for power users
  2. navinag's Avatar
    Posts
    455 Posts
    Global Posts
    489 Global Posts
    #222  
    Hey xorg,

    I was able to sucessfully fix the migration issue whith my previoulsy linked apps.

    I created a dummy directory in /var for the apps that were moved and a dummy appinfo.json for each. than I restarted luna... Everything migrated ...then I ran mvapp postupd

    now i am gonna run cleanup to make sure i nuked all the junk lying around.

    Just wanted to let you know what i ended up do ing to fix the issue...
  3. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #223  
    ^Yup, that is the approach I'm taking. Thanks for confirming this works. I'm working on it tonight and hope to release tomorrow but I'm flying back home later tomorrow. Might be released on Friday.
    xorg tools - power tools for power users
  4. #224  
    Quote Originally Posted by xorg View Post
    It appears you need to use EMH if you are not able to install apps from the App Catalog. If you use EMH, then you also need to do 'mvapp postupd' as EMH breaks the mvapp links.
    OK. Since I couldn't download from the App Catalog I used EMH. Now I'm getting a "mvapp not found" error when I try to do anything (such as the postupd) from mvapp! Is it time to chuck this thing and get an iPhone? Other than that, what do I do now?
  5. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #225  
    ^Use 'mvappd' a backup command or go into PreWare, remove mvapp and reinstall. Command will then work.
    xorg tools - power tools for power users
  6. #226  
    xorg - thank you for all your work. I'll be looking for the next version of mvapp to come out b4 I update to webOS 1.3.5. Blessed new year!
  7. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #227  
    Attention mvapp users:

    I've posted a new version of mvapp 0.4.3 on PreWare that has two new commands to migrate linked apps, recover any lost linked apps and properly setup ipkg lists that allow apps to showup in Preware. Only use this AFTER applying the webOS 1.3.5 update.

    If mvapp 0.4.3 doesn't show up in PreWare Updates. Remove mvapp and reinstall in PreWare.

    If you want to backup your media .apps folder before migrating, you can do this (may take a very long time depending on number of apps linked, be sure battery is charged or charge while performing backup)...

    mvapp backup

    Only use these commands AFTER webOS 1.3.5 patch is applied. All users should run this, including those who may have run 'mvapp postupd'.

    To migrate apps and fix loose ends, use this...

    mvapp migrate

    If it gives a message that .apps no longer exists (this might happen if you ran postupd/clean earlier), use this command...

    mvapp postupd2 (only if above command tells you to run this)

    Apps that didn't appear in Preware should now show up and the ipkg manifest should be properly updated. If not, try rebooting phone. Please report your experiences.

    When you are comfortable that everything is working OK, you can run 'mvapp cleanup' and it will remove the .apps folder in media drive and all backups. Might want to wait a week or two unless you are tight on media space.
    Last edited by xorg; 01/02/2010 at 02:32 PM.
    xorg tools - power tools for power users
  8. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #228  
    If you have linked email, it will still be linked to media drive after the 'migrate' command. Palm still keeps email on /var even in latest release. You may want to keep email linked if you have very large email/attachments. If you'd like to unlink email, use 'mvapp ue'.

    I'm working on 'xorg tools' (xt command) that will still allow managing email links. It will also have system level configuration like scheduled reboots and other things that might not make it as an app. When the first xt is released, mvapp will be retired... might be a couple weeks.
    xorg tools - power tools for power users
  9. #229  
    xorg,
    should we use the mvapp migrate command before or after using the EMH? I updated to 1.3.5 already but did not use EMH or the postupd command yet. Also to be clear, will i need to use EMH after this new mvapp command? Thanks in advance
  10. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #230  
    'mvapp migrate' can be used before or after EMH. EMH will likely still be needed. mvapp doesn't perform the same function as it only deals with linked apps that mvapp created. If you have a PreWare app installed that was never linked with mvapp, EMH will likely be needed.
    xorg tools - power tools for power users
  11. #231  
    Solution worked great. Used mvapp migrate then used EMH. My phone is very snappy now and I am able to download from the official app catalog again. Thanks for your help. Gonna wait a few days and use your cleanup function.
  12. #232  
    xorg,
    I'm seeing MvApp v0.4.2 in Preware. Not 0.4.3. I updated to 0.4.2 when it showed up in Preware (yesterday morning I think - didn't run it though). I don't see 0.4.3. in preware now so I removed 0.4.2, but still no 0.4.3. Is there something else I need to do?

    Thanks for all of you work.
  13. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #233  
    It's actually 0.4.3 that is posted in PreWare. There must've been a problem with the description tag. If you download it and run mvapp, it will show as 0.4.3. Go ahead and use it. I'll check into fixing the description.
    xorg tools - power tools for power users
  14. xorg's Avatar
    Posts
    633 Posts
    Global Posts
    1,010 Global Posts
       #234  
    Quote Originally Posted by alexlevy117 View Post
    Solution worked great. Used mvapp migrate then used EMH. My phone is very snappy now and I am able to download from the official app catalog again. Thanks for your help. Gonna wait a few days and use your cleanup function.
    Good to hear. All mvapp users should run the 'migrate' command, including those who ran 'postupd' within the last week. The migrate command can also be run multiple times with no issues in case you don't remember which commands you ran.

    After comfortable with the migration, you can run 'mvapp cleanup' to remove the .apps folder and any backups. Might want to a wait a week or two to cleanup.
    xorg tools - power tools for power users
  15. #235  
    Worked like a charm. Thank you.
  16. #236  
    Worked fantastically well, thanks! Mvapp is one of the primary things that has made using the Pre such a joy. I wish xorg worked for Palm, then maybe we wouldn't have had the app storage limit to begin with.
  17. #237  
    Worked perfectly for me as for as I can tell, many MANY thanks! (Now, if Palm would only fix EAS in 1.3.5, grrrrr.)
  18. #238  
    Thanks, xorg. You made it very easy to update this time around, and I really appreciate the time and effort it has taken for you to do these wonderful things.
    I ♥ my Pre.
  19. #239  
    I have a question:

    The update to 1.3.5.1 went very smoothly, and I used mvapp according to all the instructions. I migrated and then ran the EMH. Everything looks great, except that I lost all the data associated with my shopping list program. Is there a way for me to get it back? I did a complete backup to my computer before the update, and I also wonder if the file(s) are still on the Pre. Any help would be appreciated. Thanks!
    I ♥ my Pre.
  20. #240  
    xorg,
    i ran the mvapp migrate command already and everything works well. I never used the mvapp postupd command. I was running the mvapp cleanup command and it asked me to only run if i used postupd? is it ok to continue and use the cleanup if i used migrate and not postupd?
    Sorry if the answer is obvious, i just want to be sure before i hit 'y'
    Thanks for all of your help
Page 12 of 13 FirstFirst ... 278910111213 LastLast

Posting Permissions