Page 19 of 37 FirstFirst ... 9141516171819202122232429 ... LastLast
Results 361 to 380 of 724
Like Tree5Likes
  1.    #361  
    Quote Originally Posted by lu View Post
    I was following meta-doctor guide an bassicly used the same settings that are used there
    So you used a setting without understanding what it did or why you are using it?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. lu
    lu is offline
    lu's Avatar
    Posts
    9 Posts
    #362  
    Quote Originally Posted by rwhitby View Post
    So you used a setting without understanding what it did or why you are using it?

    -- Rod
    Actually i read what it does, but it didn't seemed that i could have any problem because of this setting
  3. #363  
    I believe it's best not to enable that feature if possible.
  4. #364  
    Will the disable_upload_daemon feature resist after updating to a new rom version OTA?
  5.    #365  
    Quote Originally Posted by wiiwaker View Post
    Will the disable_upload_daemon feature resist after updating to a new rom version OTA?
    If Palm updates the package that contains the upstart script, it will not.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6. #366  
    The WebOS Internals people are geniuses. I have been a Bell CDMA Pre user since the first week of it's release. Recently I purchased an unlocked AT&T Pre Plus to use on their new HSPA network that runs on the same frequencies as AT&T. I put an activated Bell SIM card in it. Of course, no data connection, so no way by the Palm activation screen. There is an option to enter APN settings manually, but the device refuses to write the settings when you do that. The root of the problem is that the Pre depends on a Palm database file for the data and mms connection settings (APN, mms gateway, etc). This file does not contain data for many carriers. There is an entry for Bell, but it is incomplete and incorrect.

    I extracted the CarrierNetworkSettings.db3 file from the AT&T webosdoctor jar file, and edited it according to instructions here:

    forums.precentral.net/gsm-pre/211728-modifying-webos-carrier-network-settings.html#post2002079

    and here:

    forums.precentral.net/palm-pre/209222-few-questions-about-german-palm-pre-6.html

    If you don't have your carriers network settings, there is a list here which is maintained for unlocked android users:

    code.google.com/p/cyanogenmod/wiki/APNlist

    I then made a meta-doctor jar for AT&T following the instructions here:

    Application:MetaDoctor - WebOS Internals

    Everything worked perfectly, the meta-doctored phone allowed me to connect to my wifi connection. Also, once I used the WebOS Quickinstall utility to move the modified CarrierNetworkSettings.db3 file to the phone, and rebooted, I had a 3G connection. Then I ran the First Use App which was on the first page of the Launcher, signed into my previous palm profile, and was all set with all my old apps.

    I have access to the US app catalog, including paid apps, even though I signed in from Canada, to a profile previously created from Canada. App access seems to be a function of the phone version, not the country of activation.

    I then wanted to use my old cdma pre as an mp3 player. To get by carrier activation, I thought I would just do the same thing, using a bell webos meta-doctor. Everything worked well, including getting by the initial activation screen, and connecting to wi-fi. Then the interesting problem. Similar to a previous post in this thread, I started the First use app, and after selecting language, it hung and then triggered a luna restart. After the restart the First Use App had disappeared from the Launcher. I used preware to install the show first use app patch, but it still did not appear. I rebuilt the meta-doctor, and did everything over again, same thing. I then built a sprint meta-doctor (chose sprint because it is a cdma plain pre) using the bypass carrier check option in the Makefile, installed it, was able to sign in to wi-fi. The first use app again hung on language selection, and triggered a luna restart. After the restart, the first use app was still there, and using it a second time allowed me to created a new palm profile. I have access to an app a catalog which only contains free apps.

    Just to be sure, I meta-doctored again with a bell version, same result, and again with a sprint version, again first app hung the first time but ran the second time.

    So, there seems to be something in the bell hardware/software which makes the first use app hang, trigger a luna restart, and then be missing, even when the patch to show it is installed.

    Anyway, thanks very much to all the posts above, or I would not have my AT&T Pre Plus running on Bell.

    The best solution to all of this would be for Palm to either keep an accurate CarrierNetworkSetting.db3 file, or to allow manual entry during the first app use. Well, you say, you are using it on an unsupported carrier, and I agree. However, each pre used in this way is another pre sold, and if I want to spend my money this way to have an unlocked phone that is not tied to a contract, it is my money. Also, by doing some adjustments in my data package, I will come out ahead over 48 months or so. How about it Palm?
  7.    #367  
    Quote Originally Posted by mthillis View Post
    The WebOS Internals people are geniuses. I have been a Bell CDMA Pre user since the first week of it's release. Recently I purchased an unlocked AT&T Pre Plus to use on their new HSPA network that runs on the same frequencies as AT&T. I put an activated Bell SIM card in it. Of course, no data connection, so no way by the Palm activation screen. There is an option to enter APN settings manually, but the device refuses to write the settings when you do that. The root of the problem is that the Pre depends on a Palm database file for the data and mms connection settings (APN, mms gateway, etc). This file does not contain data for many carriers. There is an entry for Bell, but it is incomplete and incorrect.

    I extracted the CarrierNetworkSettings.db3 file from the AT&T webosdoctor jar file, and edited it according to instructions here:

    forums.precentral.net/gsm-pre/211728-modifying-webos-carrier-network-settings.html#post2002079

    and here:

    forums.precentral.net/palm-pre/209222-few-questions-about-german-palm-pre-6.html

    If you don't have your carriers network settings, there is a list here which is maintained for unlocked android users:

    code.google.com/p/cyanogenmod/wiki/APNlist

    I then made a meta-doctor jar for AT&T following the instructions here:

    Application:MetaDoctor - WebOS Internals

    Everything worked perfectly, the meta-doctored phone allowed me to connect to my wifi connection. Also, once I used the WebOS Quickinstall utility to move the modified CarrierNetworkSettings.db3 file to the phone, and rebooted, I had a 3G connection. Then I ran the First Use App which was on the first page of the Launcher, signed into my previous palm profile, and was all set with all my old apps.

    I have access to the US app catalog, including paid apps, even though I signed in from Canada, to a profile previously created from Canada. App access seems to be a function of the phone version, not the country of activation.

    I then wanted to use my old cdma pre as an mp3 player. To get by carrier activation, I thought I would just do the same thing, using a bell webos meta-doctor. Everything worked well, including getting by the initial activation screen, and connecting to wi-fi. Then the interesting problem. Similar to a previous post in this thread, I started the First use app, and after selecting language, it hung and then triggered a luna restart. After the restart the First Use App had disappeared from the Launcher. I used preware to install the show first use app patch, but it still did not appear. I rebuilt the meta-doctor, and did everything over again, same thing. I then built a sprint meta-doctor (chose sprint because it is a cdma plain pre) using the bypass carrier check option in the Makefile, installed it, was able to sign in to wi-fi. The first use app again hung on language selection, and triggered a luna restart. After the restart, the first use app was still there, and using it a second time allowed me to created a new palm profile. I have access to an app a catalog which only contains free apps.

    Just to be sure, I meta-doctored again with a bell version, same result, and again with a sprint version, again first app hung the first time but ran the second time.

    So, there seems to be something in the bell hardware/software which makes the first use app hang, trigger a luna restart, and then be missing, even when the patch to show it is installed.

    Anyway, thanks very much to all the posts above, or I would not have my AT&T Pre Plus running on Bell.

    The best solution to all of this would be for Palm to either keep an accurate CarrierNetworkSetting.db3 file, or to allow manual entry during the first app use. Well, you say, you are using it on an unsupported carrier, and I agree. However, each pre used in this way is another pre sold, and if I want to spend my money this way to have an unlocked phone that is not tied to a contract, it is my money. Also, by doing some adjustments in my data package, I will come out ahead over 48 months or so. How about it Palm?
    There's a known problem with First Use not being visible after changing the language.

    Do all the setup in English/US and then change the language it's all done.

    Or use palm-launch to launch com.palm.app.firstuse

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  8. #368  
    Thanks. The bell first use app has two options for language - English and French - no US English. We are Canadian, eh. I used the English option.

    How do I run palm-launch to launch com.palm.app.firstuse?

    Thanks.
  9.    #369  
    The Meta-Doctor now takes DEVICE values for pre, preplus, pixi and pixiplus

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10. #370  
    Sorry guys, I am a noob. I am not that experienced with terminal and code. I have a pre plus that I want to badly use, but unfortunately, its locked and unactivated. I need help, I don't want this phone to stay on the shelf. Can anyone offer me help unlocking and activating. I am in Canada, on Rogers. I would like to be able to use this phone. Please help.
    Aobberry
  11.    #371  
    Quote Originally Posted by aobberry View Post
    Sorry guys, I am a noob. I am not that experienced with terminal and code. I have a pre plus that I want to badly use, but unfortunately, its locked and unactivated. I need help, I don't want this phone to stay on the shelf. Can anyone offer me help unlocking and activating. I am in Canada, on Rogers. I would like to be able to use this phone. Please help.
    Sorry, but this thread is not about unlocking phones. You should talk to the carrier to which the phone is locked about that, or buy an unlocked phone.

    The WebOS Internals Meta-Doctor will not unlock phones.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  12. #372  
    Thanks Rwhitby, I am aware, I need to bypass activation in order for me to unlock.
    Aobberry
  13. #373  
    Quote Originally Posted by aobberry View Post
    Thanks Rwhitby, I am aware, I need to bypass activation in order for me to unlock.
    If you want to bypass the first use app... then just enable the bypass_first_use_app feature. And go from there.
  14. #374  
    Can the meta doctor be used to change the GSM 3g Band? so att GSM can be used in europe with 3g and visa versa? or is it a hardware thing?
    Chris
  15.    #375  
    Quote Originally Posted by chrislo View Post
    Can the meta doctor be used to change the GSM 3g Band? so att GSM can be used in europe with 3g and visa versa? or is it a hardware thing?
    Chris
    Hardware, as far as we know.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  16. #376  
    I don't know anything about programming or code modification, yet I need to install the first-use patch so I can create a palm profile. I'm in Costa Rica and my phone is unlocked. I tried to follow the instructions by Confusedvorlon on page two of this thread, but I can't get Java to install on my ubuntu virtualbox (Oracle VM Virtualbox, Ubuntu (Lucid Lynx) 10.04 LTS.

    Any complete-*****'s-guide-type instructions for me? I've been working on this for three days now and it's getting really frustrating. Any help would be greatly appreciated.

    Thanks.
  17. #378  
    For anyone not able to see the first use app, just try going to the regional settings to change your language to US English. Worked for me, twice now. I originally had selected Canadian English and the first use app would disappear (even after the patch shows it is installed.)
  18. #379  
    Thanks, grndslm!
  19. mhous33's Avatar
    Posts
    99 Posts
    Global Posts
    108 Global Posts
    #380  
    @Rod

    anything new on the meta-doctor genetics front? I'm willing to help

Posting Permissions