webOS Nation Forums >  Homebrew >  WebOS Internals > Preware
Preware
  Closed Thread
 
Thread Tools Display Modes
Old 02/20/2010, 10:55 AM   #5201 (permalink)
Member
 
Posts: 103
I may have missed this in the thread and if so I apologize. Running Preware 9.26. The other morning (2/17) I ran Preware and ALL of my patches said they needed to be updated. Were changes actually made to every patch or is something borked?

Thanks.
ocard is offline  
Old 02/20/2010, 11:25 AM   #5202 (permalink)
Member
 
Blaize19's Avatar
 
Posts: 1,377
Quote:
Originally Posted by ocard View Post
I may have missed this in the thread and if so I apologize. Running Preware 9.26. The other morning (2/17) I ran Preware and ALL of my patches said they needed to be updated. Were changes actually made to every patch or is something borked?

Thanks.
All patches were updated to AUPT-3. Just go ahead and update all. Also check out the AUPT thread.
__________________
Blaize, Mistress of Verbosity



Quote:
Be nice until it's time to not be nice.--Dalton, "Roadhouse"
Blaize19 is offline  
Thanked By: sudoer
Old 02/20/2010, 12:45 PM   #5203 (permalink)
Member
 
Posts: 103
Thanks!
ocard is offline  
Old 02/20/2010, 03:15 PM   #5204 (permalink)
Member
 
OnePalmAddict's Avatar
 
Posts: 408
Quote:
Originally Posted by ocard View Post
I may have missed this in the thread and if so I apologize. Running Preware 9.26. The other morning (2/17) I ran Preware and ALL of my patches said they needed to be updated. Were changes actually made to every patch or is something borked?

Thanks.
Aupt: Important message (from webOS Internals developer)
__________________
Mark A. Einersen
HTC Evo 4G w/Seidio Innocase Active Limited Edition Case < Palm Pre < Palm Pixi (wife) < Palm Treo 755p < Palm Centro (wife) < pa1mOne Treo 650 < Palm Tungsten|E (wife) < Palm Tungsten|T3 w/Sena Case < Sony Clie NR70 < Palm m505 < Palm m105 (wife) < Palm Vx < Palm Pilot Professional w/2 MB upgrade < Palm Pilot Professional < Sharp Zaurus ZR-3500 < Casio Digital Diary SF-4000 < Casio Digital Diary SF-1000
OnePalmAddict is offline  
Old 02/22/2010, 12:54 AM   #5205 (permalink)
Member
 
Posts: 266
patches aren't showing up in my preware. I 'd search more but i'm not at home and on my pre posting this.
Forever92 is offline  
Old 02/22/2010, 08:16 AM   #5206 (permalink)
Member
 
Posts: 23
Patches are not showing up on Preware for me also. Does anyone have any ideas as to why the patches feed it not showing? I have it selected to show but it is not. Thanks for any insight anyone can provide.
cencom14 is offline  
Old 02/22/2010, 08:53 AM   #5207 (permalink)
Member
 
27scoob's Avatar
 
Posts: 169
I will be the third post asking why patches are not showing up in available packages in preware. And yes the feed is set to on. I have also unistalled and reinstalled it on the phone using preload. I have also tried it over wifi.
27scoob is offline  
Old 02/22/2010, 09:21 AM   #5208 (permalink)
Member
 
supercluver's Avatar
 
Posts: 303
I'm having the same problem, patches are not showing up in preware anymore. Haven't changed things in many days, and suddenly they are gone now. When I look at the feed list, nothing is listed under patches as far as a location for the patches feed. no "ipkg.preware.org/feeds/........ " but it still shows up on the preware.org website.... whats up? do we need to reinstall preware and the package manager service? if so how and why did this get messed up?
supercluver is offline  
Old 02/22/2010, 09:46 AM   #5209 (permalink)
Member
 
27scoob's Avatar
 
Posts: 169
All good questions...
27scoob is offline  
Old 02/22/2010, 02:46 PM   #5210 (permalink)
Developer
 
rwhitby's Avatar
 
Posts: 10,553
Quote:
Originally Posted by 27scoob View Post
I will be the third post asking why patches are not showing up in available packages in preware. And yes the feed is set to on. I have also unistalled and reinstalled it on the phone using preload. I have also tried it over wifi.
You cannot use PreLoad to install the Package Manager Service (which is what needs to be reinstalled to fix this problem). You need to use WebOS Quick Install 3.01 or later.

For some reason we don't know, the feed config file for patches is being clobbered on some people's devices. There is an alpha testing version of the Package Manager Service in the testing feed which should be able to recover from this automatically on each boot.

-- Rod
rwhitby is online now  
Old 02/22/2010, 03:07 PM   #5211 (permalink)
Member
 
vza33's Avatar
 
Posts: 2,176
@ Rod, I currently don't have access to WEBOSQI. I have one patch that won't verify.

I managed to fix three of the four patches that came up in EFV. The only one left is the No Alert During Call patch. When I try to install it I get: (I skipped to post installation as Install was normal.)


Quote:
Postinst
Reversed (or previously applied) patch detected! Assume -R? [n]
Apply anyway? [n]
3 out of 3 hunks ignored -- saving rejects to file usr/palm/applications/com.palm.app.phone/app/models/FormattedCall.js.rej
Reversed (or prevously applied) patch detected! Assume -R? [n]
Apply anyway/ [n]
1 out of 1 hunk ignored -- saving rejects to file usr/palm/applications/com.palm.app.phone/source.json.rej

Lock
Nothing Interesting

Status
Nothing Interesting

Remove
Removing package org.webosinternals.patches.phone-no-alert-during-call from root...

Failed
ErrorGenericMethodException
:Failure during post install script execution
Once I fix this one I'll be all set. Thanks in advance.
__________________
"Patience, use the force, think." Obi-Wan


Ready to try Preware? Get this first: Preware Homebrew Documentation
vza33 is offline  
Old 02/22/2010, 03:20 PM   #5212 (permalink)
Member
 
Posts: 101
[QUOTE=rwhitby;2240056]You cannot use PreLoad to install the Package Manager Service (which is what needs to be reinstalled to fix this problem). You need to use WebOS Quick Install 3.01 or later.

For some reason we don't know, the feed config file for patches is being clobbered on some people's devices. There is an alpha testing version of the Package Manager Service in the testing feed which should be able to recover from this automatically on each boot.




I'm having the exact same problem. I didn't want to ***** about it. I'm glad to know I'm not the only one with this problem. Preware rocks...
stashu11 is offline  
Old 02/22/2010, 04:44 PM   #5213 (permalink)
Developer
 
rwhitby's Avatar
 
Posts: 10,553
Quote:
Originally Posted by stashu11 View Post
Quote:
Originally Posted by rwhitby View Post
You cannot use PreLoad to install the Package Manager Service (which is what needs to be reinstalled to fix this problem). You need to use WebOS Quick Install 3.01 or later.

For some reason we don't know, the feed config file for patches is being clobbered on some people's devices. There is an alpha testing version of the Package Manager Service in the testing feed which should be able to recover from this automatically on each boot.
I'm having the exact same problem. I didn't want to ***** about it. I'm glad to know I'm not the only one with this problem. Preware rocks...
Reinstall Package Manager Service 0.9.35 or later using WebOS Quick Install 3.01 or later.

Version 0.9.36 (probably to be released today) will make the Package Manager Service automatically recover from this rare unknown cause problem on each reboot.

-- Rod
__________________
WebOS Internals and Preware Founder and Developer
You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
All donations go back into development.
www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Last edited by rwhitby; 02/22/2010 at 10:24 PM.
rwhitby is online now  
Old 02/22/2010, 10:23 PM   #5214 (permalink)
Developer
 
rwhitby's Avatar
 
Posts: 10,553
Preware 0.9.27 and Package Manager Service 0.9.36 have been released - you *really* *should* update to these versions soon.

To quell any rumours, the Preware and Package Manager Service updates are not related to the installation or removal of AUPT patches, and the bugs that were fixed and improvements that were made are relevant to the current webOS version.

The main reason for the haste is that there was a bug in the update routine where if Javascript garbage collection happened at just the wrong time, the package feed update functionality would hang. With lots of people updating lots of packages for a webOS version update happening sometime in the future, the slight chance of that hitting people increases due to the large number of people involved, so we want to reduce that chance to as close to zero as we can before that happens. We believe this update fixes that bug.

The other major improvement moves the temporary area used when installing a package to the larger /media/cryptofs/apps partition, which means we can now use Preware to install very large packages (like a new game that we're releasing soon).

Other improvements include hiding the price sort option when none of the loaded packages have any prices associated with them, and the addition of new feeds which only show the updates from the last 48 hours for the official Palm feeds.

-- Rod
__________________
WebOS Internals and Preware Founder and Developer
You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
All donations go back into development.
www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Last edited by rwhitby; 02/22/2010 at 10:32 PM.
rwhitby is online now  
Old 02/22/2010, 10:45 PM   #5215 (permalink)
Member
 
spudland's Avatar
 
Posts: 807
Quote:
Originally Posted by rwhitby View Post
Reinstall Package Manager Service 0.9.35 or later using WebOS Quick Install 3.01 or later.

Version 0.9.36 (probably to be released today) will make the Package Manager Service automatically recover from this rare unknown cause problem on each reboot.

-- Rod
I used Preware to install PMS first and then used Preware to install Preware update. Am I good to go or do I need to repeat with WOSQI?
__________________
If "If's" and "But's" were candy and nuts we'd all have a Merry Christmas!


spudland is offline  
Old 02/22/2010, 10:49 PM   #5216 (permalink)
Developer
 
rwhitby's Avatar
 
Posts: 10,553
Quote:
Originally Posted by spudland View Post
I used Preware to install PMS first and then used Preware to install Preware update. Am I good to go or do I need to repeat with WOSQI?
Any time you are able to use Preware to update Preware or the Package Manager Service, you should do so

WebOS Quick Install is handy for when Preware can't update itself for some reason (and for the very initial installation).

-- Rod
__________________
WebOS Internals and Preware Founder and Developer
You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
All donations go back into development.
www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
rwhitby is online now  
Thanked By: spudland
Old 02/23/2010, 12:24 AM   #5217 (permalink)
Member
 
vbockius's Avatar
 
Posts: 290
upon updating i'm getting the critical memory too many cards notification with no cards open, uninstalled preware and the package mgr service through web os qi, error goes away, but when i try to reinstall package mgr service, i get the error again before i can even reinstall preware, even did an epr to remove all patches though web os qi and still got the error when i installed the package mgr service... doctoring now...
__________________
"The union forces me to allow you to go to lunch in spite of the way you've played. Those of you with consciences will not be able to eat. And those of you whose consciences match your talents... go stuff yourselves. I hope you choke".....Maestro, The Money Pit
vbockius is offline  
Old 02/23/2010, 12:45 AM   #5218 (permalink)
Member
 
maxima2k53's Avatar
 
Posts: 3,585
after updating to the latest preware and package manager service...when i opem preware and i tap on w.e (e.g: list everything) it takes 2-3 seconds for it to go into the list...is that normal bc i got all feeds except precentral themes enabled?
__________________
Juan

2010-2011 Champions!

maxima2k53 is offline  
Old 02/23/2010, 02:19 AM   #5219 (permalink)
Member
 
Posts: 76
just updated, working good so far...what's this new game?
nodforce is offline  
Old 02/23/2010, 02:20 AM   #5220 (permalink)
Member
 
Posts: 116
HELP, after update to 9.27/9.36 (OTA), I get an error after launching PREWARE.
It says "Failure during update operation, ipkg: Invalid gzip magic".

I can click the error msg away, and PREWARE continues to load.

I also just realized that I cannot install apps from the official APP Cat anymore (leo dict). Apparently App Cat is not up and running / dead again for non-US?

Any ideas/suggestions?

UPDATE: It is still the same error after I uninstalled PMS and PREWARE through WOSQI

Last edited by mullern; 02/23/2010 at 03:20 AM.
mullern is offline  
Closed Thread

 

Tags
1.3.5 upgrade, error, feeds, freeze, grey, install, issues, lockup, novacom, package manager service, patch, pms, preware, preware crash, preware fair dinkum, preware install, preware issues, program manager, quick install, reinstalling preware, text message problem, themes, virtual keyboard, webos quick install, webosquickintall

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0